Задвоились предопределенные элементы справочников? Выход есть!

Публикация № 559262 02.11.16

Администрирование БД - Чистка данных

Дублирование предопределенных элементов справочников может произойти как по причине того, что при обмене данными в режиме загрузки уникальность предопределенного элемента в пределах области информационной базы не проверяется, так и при объединении/обновлении конфигураций. При попытке переименовать, или, например, пометить на удаление 1С показывает сообщение «Предопределенный элемент не уникален». В этой статье мы напишем обработку, которая позволит избавиться от дублей предопределенных элементов справочника.

Задвоились предопределенные элементы справочников? Выход есть!

Дублирование предопределенных элементов справочников может произойти как по причине того, что при обмене данными в режиме загрузки уникальность предопределенного элемента в пределах области информационной базы не проверяется, так и при объединении/обновлении конфигураций.

При попытке переименовать, или, например, пометить на удаление 1С показывает сообщение «Предопределенный элемент не уникален».

В этой статье мы напишем обработку, которая позволит избавиться от дублей предопределенных элементов справочника.

Алгоритм следующий:

  • Первым делом мы найдем задвоенные (затроенные и т.д.) предопределенные элементы всех справочников.
  • Затем определим на какие элементы больше всего ссылаются другие объекты базы.
  • С учетом количества ссылок, определим как «правильные» те, на которые меньше всего других ссылок.
  • Оставим эти элементы предопределенными, а дубликаты сделаем непредопределенными (наименование сделаем как у предопределенных, для возможности дальнейшей замены всех ссылок на «правильный» соответствующий предопределенный элемент справочника).
  • Дальше можно заменить все ссылки объектов к этим дубликатам ссылками на те элементы, которые мы решили оставить предопределенными и при необходимости удалить дубликаты. Мы просто предложим пометить дубликаты на удаление.

Создадим новую обработку, и добавим табличную часть «ЗадублированныеСправочники»:

tablichnaya_chast_obrabotki.PNG

Реквизиты табличной части «ИмяСправочника», «СинонимСправочника» и «ИмяПредопределенныхДанных» - переменная строка неограниченной длины;

«КоличествоДублей» и «КоличествоСсылок» - неотрицательное число;

«ОставитьПредопределенным» - булево;

«ЭлементСправочника» тип «Справочник».

Создадим основную форму и разместим на ней табличную часть и кнопки «1. Заполнить», «2. Подсказать правильные», «3. Оставить предопределенными только отмеченные»:

forma_obrabotki.PNG

В теле процедуры обработчика нажатия кнопки «1. Заполнить» будем вызывать процедуру ЗадублированныеСправочникиЗаполнить()

Процедура ЗадублированныеСправочникиЗаполнить()
	
	//Очистим табличную часть, так как после выполнения конечного этапа
	//проконтролируем, что дубликаты исчезли
	ЗадублированныеСправочники.Очистить();
	
	//Построим текст запроса, для определения дубликатов
	//предопределенных элементов справочника #ИмяСправочника
	ТекстЗапроса = "ВЫБРАТЬ
	               |	#ИмяСправочника.Ссылка КАК Ссылка,
	               |	#ИмяСправочника.ИмяПредопределенныхДанных КАК ИмяПредопределенныхДанных
	               |ПОМЕСТИТЬ ВремТЗ
	               |ИЗ
	               |	Справочник.#ИмяСправочника КАК #ИмяСправочника
	               |ГДЕ
	               |	#ИмяСправочника.Предопределенный
	               |;
	               |
	               |////////////////////////////////////////////////////////////////////////////////
	               |ВЫБРАТЬ
	               |	ВремТЗ.ИмяПредопределенныхДанных,
	               |	КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ВремТЗ.Ссылка) КАК КоличествоДублей
	               |ПОМЕСТИТЬ Дубли
	               |ИЗ
	               |	ВремТЗ КАК ВремТЗ
	               |
	               |СГРУППИРОВАТЬ ПО
	               |	ВремТЗ.ИмяПредопределенныхДанных
	               |;
	               |
	               |////////////////////////////////////////////////////////////////////////////////
	               |ВЫБРАТЬ
	               |	Дубли.ИмяПредопределенныхДанных КАК ИмяПредопределенныхДанных,
	               |	Дубли.КоличествоДублей КАК КоличествоДублей,
				   |	""#ИмяСправочника"" КАК ИмяСправочника,
				   |	""#СинонимСправочника"" КАК СинонимСправочника,
				   |	ЛОЖЬ КАК ОставитьПредопределенным,
	               |	ВремТЗ.Ссылка КАК ЭлементСправочника
	               |ИЗ
	               |	Дубли КАК Дубли
	               |		ЛЕВОЕ СОЕДИНЕНИЕ ВремТЗ КАК ВремТЗ
	               |		ПО Дубли.ИмяПредопределенныхДанных = ВремТЗ.ИмяПредопределенныхДанных
	               |ГДЕ
	               |	Дубли.КоличествоДублей > 1";
	
	Запрос = Новый Запрос;
	
	//Предупреждая замечания читателей и вопреки всем рекомендациям, будем выполнять запрос в цикле
	//для каждого справочника -
	//это читабельней и не приводит к существенной нагрузке на информационную базу,
	//нежели одним запросом охватывать все справочники 
	//(что, при определенных ограничениях на количество объединений может и вовсе не представлятся возможным)
	Для Каждого Стр Из Метаданные.Справочники Цикл
		
		ИмяСправочника = Стр.Имя;
		СинонимСправочника = Стр.Синоним;
		
		ПоказатьОповещениеПользователя("Поиск по справочнику " + СинонимСправочника);
		
		Запрос.Текст = ТекстЗапроса;
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "#ИмяСправочника", ИмяСправочника);
		Запрос.Текст = СтрЗаменить(Запрос.Текст, "#СинонимСправочника", СинонимСправочника);
		
		Результат = Запрос.Выполнить();
		
		//В этом цикле добавляем строки в табличную часть
		Если Не Результат.Пустой() Тогда
			
			Выборка = Результат.Выбрать();
			
			Пока Выборка.Следующий() Цикл
				НовСтр = ЗадублированныеСправочники.Добавить();
				ЗаполнитьЗначенияСвойств(НовСтр, Выборка);
			КонецЦикла;
			
		КонецЕсли;
		
	КонецЦикла;
	
	//Отстортируем табличную часть и скроем колонку, в которой отображается
	//количество ссылок на предопределенный элемент справочника
	//(по количеству ссылок на объект, пользователю будет легче определить "правильный" объект)
	ЗадублированныеСправочники.Сортировать("ИмяСправочника, ИмяПредопределенныхДанных");
	ЭлементыФормы.ЗадублированныеСправочники.Колонки.КоличествоСсылок.Видимость = Ложь;
	
КонецПроцедуры

В процессе работы данной процедуры мы будем следить за тем, какие справочники проверяются на дубли в специальном окне:

knopka 1 sostoyanie.PNG

Это окно реализовано функцией глобального контекста ПоказатьОповещениеПользователя()

При окончании процедуры мы получим заполненную дубликатами табличную часть, в колонке «Правильные» указывается предопределенный элемент справочника, который необходимо оставить:

zapolnenaya_dublikatami.PNG

Теперь пользователь может либо сам определить «правильные» предопределенные, либо воспользоваться подсказкой по кнопке «2. Подсказать правильные».

В теле процедуры обработчика нажатия этой кнопки будем вызывать процедуру ПодсказатьПравильные() – как уже было сказано, подсказка заключается в определении количества ссылающихся объектов информационной базы на предопределенный элемент справочника – чем больше ссылок на элемент, тем он «правильнее» (меньше ссылок придется заменять в дальнейшем):

Процедура ПодсказатьПравильные()
	
	//Находим ссылки на дубликаты
	ТаблицаСсылок = НайтиПоСсылкам(ЗадублированныеСправочники.ВыгрузитьКолонку("ЭлементСправочника"));
	ТаблицаСсылок.Колонки.Добавить("Количество", Новый ОписаниеТипов("Число"));
	ТаблицаСсылок.ЗаполнитьЗначения(1,"Количество");
	
	//считаем количество ссылок на каждый дубликат
	ТаблицаСсылок.Свернуть("Ссылка", "Количество");
	
	//Заполняем колонку "Количество ссылок"
	Для Каждого СтрТаблицаСсылок Из ТаблицаСсылок Цикл
		
		НайденныеСтроки = ЗадублированныеСправочники.НайтиСтроки(Новый Структура("ЭлементСправочника, КоличествоСсылок", СтрТаблицаСсылок.Ссылка, 0));
		Если НайденныеСтроки.Количество() > 0 Тогда
			НайденныеСтроки[0].КоличествоСсылок = СтрТаблицаСсылок.Количество;
		КонецЕсли;
		
	КонецЦикла;
	
	//Пусть максимальное количество каждого предопределенного элемента
	//будет наверху в группе каждого типа справочника
	ЗадублированныеСправочники.Сортировать("ИмяСправочника, ИмяПредопределенныхДанных, КоличествоСсылок Убыв");
	//Покажем эту колонку пользователю
	ЭлементыФормы.ЗадублированныеСправочники.Колонки.КоличествоСсылок.Видимость = Истина;
	
КонецПроцедуры

Данная операция будет довольно длительной – производится поиск всех ссылающихся объектов, по окончании мы получим рекомендации:

rekomendacii.PNG

Теперь пользователь может определить «правильный» элемент, руководствуясь данными о количестве ссылающихся объектов базы на конкретный элемент предопределенного справочника:

pravilnii.PNG

В теле процедуры обработчика нажатия кнопки «3. Оставить предопределенными только отмеченные» будем вызывать процедуру ОставитьТолькоОдинПредопределенный(). Кстати, спросим – помечать ли на удаление «неправильные».

vopros.PNG

Процедура ОставитьТолькоОдинПредопределенный()
	
	ПометкаУдаления = Ложь;
	
	ВыполненоУспешно = Ложь;
	
	//спросим – помечать ли на удаление «неправильные»
	Режим = РежимДиалогаВопрос.ДаНет;
	Ответ = Вопрос("Пометить на удаление дубли элементов?", Режим, 0);
	
	Если Ответ = КодВозвратаДиалога.Да Тогда
		
	    ПометкаУдаления = Истина;
		
	КонецЕсли; 
	
	ОставитьПредопределеннымКонтроль = ЗадублированныеСправочники.Выгрузить();
	ОставитьПредопределеннымКонтроль.Свернуть("ИмяСправочника, ИмяПредопределенныхДанных", "ОставитьПредопределенным");
	
	Для Каждого Стр Из ЗадублированныеСправочники Цикл
		
		ОтборНеУказанОставитьПредопределенным = Новый Структура("ИмяСправочника, ИмяПредопределенныхДанных, ОставитьПредопределенным", Стр.ИмяСправочника, Стр.ИмяПредопределенныхДанных, Ложь);
		
		Если НЕ Стр.ОставитьПредопределенным И ОставитьПредопределеннымКонтроль.НайтиСтроки(ОтборНеУказанОставитьПредопределенным).Количество() = 0 Тогда
			
			ЭлементОбъект = Стр.ЭлементСправочника.ПолучитьОбъект();
			Если ЭлементОбъект <> Неопределено Тогда
				
				Если Не ЗначениеЗаполнено(ЭлементОбъект.Наименование) Тогда
					ЭлементОбъект.Наименование = ЭлементОбъект.ИмяПредопределенныхДанных;
				КонецЕсли;
				
				ЭлементОбъект.ИмяПредопределенныхДанных = "";//Именно в этом месте мы избавляемся от предопределенности
				ЭлементОбъект.ПометкаУдаления = ПометкаУдаления;
				ЭлементОбъект.Записать();
				ВыполненоУспешно = Истина;
				
				Сообщить("Элемент" + ЭлементОбъект.Наименование + " справочника " + Стр.СинонимСправочника + " сделан непредопределенным.");
				
			КонецЕсли;
			
		КонецЕсли;
		
	КонецЦикла;
	
	//Проконтролируем результат, а также, возможно пользователь "работал" только с определенными справочниками
	Если ВыполненоУспешно Тогда
		ЗадублированныеСправочникиЗаполнить();
	КонецЕсли;
	
КонецПроцедуры

Ну, и по традиции - во вложении исходная обработка.

Скачать файлы

Наименование Файл Версия Размер
Обработка избавление от дублей предопределенных элементов справочника

.epf 11,47Kb
114
.epf 11,47Kb 114 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Рейтинг всех уровней
2. Luchik 626 09.11.16 09:44 Сейчас в теме
(1) Но в указанной Вами публикации можно только скачать обработку. А пользуясь этой статьей читатель может написать обработку под свои задачи.
Romario_; Swetlana; +2 Ответить
1. vakula28 14 09.11.16 09:10 Сейчас в теме
Как, минимум, есть уже вот это. Достаточно удобный инструмент и на УФ.
http://infostart.ru/public/305892/
5. WellMaster 104 14.11.18 13:58 Сейчас в теме
Есть нюанс, отметил на рисунке.
Прикрепленные файлы:
3. chmv 09.11.16 11:52 Сейчас в теме
да и писать ничего не надо. делаешь заменой реквизитов один элемент непредопределенным, помечаешь на удаление, перебрасываешь ссылки
У нас делал делал продвинутый пользователь
4. Michael0507 22.08.18 09:10 Сейчас в теме
Тем не менее держать под руками такую обработку очень удобно. Полный автомат. Спасибо.
6. Luchik 626 14.11.18 14:12 Сейчас в теме
7. Улыбайка 7 16.01.19 16:22 Сейчас в теме
Скачала обработку, не открывается в упр форах, обидно, не обратила внимания что в описании ничего не сказано в каких форах работает обработка
8. Поручик 4545 27.05.19 13:44 Сейчас в теме
Вот и пригодилось. Будем делать обработку на УФ. Эта мне больше понравилась.
Оставьте свое сообщение

См. также

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Обработка документов Загрузка и выгрузка в Excel Обработка справочников v8 1cv8.cf Абонемент ($m)

Это перепиленная вдоль и поперек версия всем известной обработки "Загрузка из табличного документа" с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

9 стартмани

25.06.2014    9968    16    Дмитрий74Чел    4    

Оптимизация размера изображений из присоединенных файлов УТ 11.4

Инструменты администратора БД Обработка справочников Управление торговлей v8 УТ11 Россия Абонемент ($m)

У нас часто возникала ситуация, когда необходимо настроить обмен с сайтом или с внешней системой, но выгружаемые изображения слишком сильно увеличивали объем сообщений обмена, обмен происходил медленно. Да и для самой базы, операции с не оптимизированными изображениями требуют большего количество ресурсов и места на диске. Потому мы собрали свои наработки в одно расширение.

5 стартмани

10.07.2020    8904    6    Neti    4    

Свертка БД 1С: обрезка до выбранной даты средствами MS SQL

Свертка базы Чистка данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Внешняя обработка, позволяющая произвести анализ размера БД и грубую обрезку данных до выбранной даты средствами MS SQL. Управляемые формы, 1С:Предприятие 8.3 (8.3.9.1818).

1 стартмани

15.11.2019    23395    272    dmitrydemenew    44    

Обработки для 1С: Розница по работе с ЕГАИС

Розничная торговля Обработка документов Обработка справочников Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Несколько простых и нужных обработок для упрощения работы с ЕГАИС в 1С Розница версий 2.2.10.ХХХ и выше.

1 стартмани

25.02.2019    26564    56    independ    15    

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек. Промо

Чистка данных Сервисные утилиты Инструменты администратора БД v8 1cv8.cf Россия Абонемент ($m)

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    54361    535    Eugen-S    35    

1С: Розница/УТ 10.3. ЕГАИС, загрузка акцизных марок в справочник Штрихкоды и Упаковки, регистр Акцизные марки из XML-сообщений входящих ТТН ЕГАИС + Печать акцизных марок

Розничная торговля Обработка справочников Обмен через XML Ценники Розничная торговля v8 Розница Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пакетная загрузка/обновление списка акцизных марок ЕГАИС из входящих ТТН ЕГАИС. Для 1С Розница 2.2.9.ХХХ/2.2.10.ХХХ//2.2.11.ХХХ/2.2.12.ХХХ/Управление торговлей 10.3.49.ХХХХ и выше с возможностью печати

1 стартмани

31.01.2019    34969    226    independ    140    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка данных v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    35815    439    morozov.sv    56    

Очистка замеров производительности - даешь больше места на диске (= меньше хлама в базе)

Чистка данных v8 Розница УНФ БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Вы могли и не знать, но у Вас в базе может быть несколько сотен тысяч записей о производительности системы. А появились они там благодаря встроенной в БСП подсистеме "Оценка производительности". И думаю что далеко не каждый из Вас реально собирается оценивать производительность своей системы. Специально для тех кто, как и я считает, что ему абсолютно не нужны все эти записи в базах и была создана эта обработка.

1 стартмани

31.10.2018    27306    258    1c.pro.fun    27    

Пометка на удаление неиспользуемых элементов справочников и документов Промо

Чистка данных Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

В ходе работы в программе в ней зачастую накапливается "мусор". Данная разработка может помочь убрать его... (обычные или управляемые формы)

1 стартмани

02.02.2010    41569    726    AnryMc    53    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    48017    154    json    44    

Очистка периодических регистров посредством T-SQL (удаление записей, кроме среза последних)

Чистка данных v8 Абонемент ($m)

Обработка для ленивых. Составит вместо Вас запрос для SQL, который удалит все не актуальные записи (т.е все, кроме среза последних)

5 стартмани

22.06.2018    21009    21    Alexander.Shvets    9    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    47824    5    taurus__    23    

Встраиваемая подсистема "Универсальные шаблоны объектов"

Обработка документов Обработка справочников v8 v8::СПР v8::УФ ЗУП3.x Абонемент ($m)

Очень часто бывает так, что пользователь каждый месяц делает какие-либо "одинаковые" операции, например, заводит одни и те же документы, каждый раз меняя в них только значения нескольких реквизитов. Также во многих системах набирают популярность так называемые многофункциональные документы, т.е. документы, отвечающие за несколько разных участков автоматизации и в зависимости от вида операции, заполняющихся по разному. Для автоматизации подобных процессов была реализована данная подсистема.

1 стартмани

17.05.2018    22386    34    Skin123    14    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    32556    20    notserioussam    2    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    38973    83    charivnick    4    

Очистка регистрации обмена Промо

Чистка данных v8 v8::ОУ УТ10 Абонемент ($m)

Данная обработка предназначена для очистки узла. Для очистки необходимо указать период,организацию.

1 стартмани

19.09.2017    21727    9    serg-lom89    0    

2 в 1: Проверить действительность паспорта / Получить ИНН по паспорту

Обработка справочников WEB Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::УФ ERP2 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Представляю вашему вниманию внешнюю обработку заполнения элемента справочника "Физические лица". Обработка выполнена с использованием API (для работы необходим доступ в интернет), содержит полностью открытый код и 2 команды: Проверка документа, удостоверяющего личность, в списке недействительных паспортов и Заполнение ИНН по паспортным данным.

1 стартмани

27.02.2018    29224    184    VladimirElohov    40    

[РАСШИРЕНИЕ] Заполнение данных контрагента по ИНН в 1С: Бухгалтерия и 1С: УНФ

Обработка справочников v8 УНФ БП3.0 Абонемент ($m)

Бесплатное заполнение реквизитов контрагентов в 1С: Бухгалтерия, 1С: УНФ на базе сервиса dadata.ru. Добавляет кнопку заполнения по ИНН в карточку нового контрагента, не требует подписки на ИТС.

1 стартмани

09.01.2018    51929    289    Anton64    90    

Удаление помеченных объектов, замена ссылок. Обычное и управляемое приложение. Не монопольно, включая рекурсивные ссылки, с отбором по метаданным и произвольным запросом Промо

Чистка данных v8 1cv8.cf Абонемент ($m)

Обработка удаления помеченных объектов с расширенным функционалом. Работает в обычном и управляемом приложении. Монопольный и разделенный режим работы. Отображение и отбор по структуре метаданных. Отборы данных произвольными запросами. Копирование и сохранение отборов. Удаление циклических ссылок (рекурсия). Представление циклических в виде дерева с отображением ключевых ссылок, не позволяющих удалить текущий объект информационной базы. Удаление записей связанных независимых регистров сведений. Групповая замена ссылок. Индикатор прогресса при поиске и контроле ссылочности.

10 стартмани

31.10.2016    63582    766    m..adm    232    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    53856    343    Windyhead    45    

Удаление данных напрямую в SQL

Сервисные утилиты Чистка данных v8 v8::СКД 1cv8.cf Абонемент ($m)

Порой так и хочется грохнуть что нить в скуле, но наталкиваешься на отсутствие понятных и функциональный инструментов. Вроде как что то и есть, но явно писанное для каких то конкретных простых целей. И так очередное творение в данной тематике. Особенности: удаление порциями, отображение готового текста запроса, отбор данных с помощью СКД (в отборе учитываются составные типы и обращения через точку).

1 стартмани

08.07.2017    20871    130    denacid    32    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    74765    365    Tatitutu    50    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    79749    52    Indgo    34    

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Управление бизнес-процессами (BPM) Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf БП3.0 КА2 УУ Абонемент ($m)

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    71756    324    BlizD    269    

Удаление документов по организациям для 1С:Бухгалтерия Предприятия 3.0 и 2.0 (управляемые и простые формы)

Чистка данных v8 v8::БУ БП2.0 БП3.0 Россия Абонемент ($m)

Обработка удаляет документы по выбранной организации, либо по всем, кроме выбранной. UPD. Добавлена обработка для управляемых форм с возможностью подбора организаций в список. Условия остаются теми же - удалить по организациям из списка, или по всем, кроме подобранных в списке.

3 стартмани

31.07.2016    33902    385    Krasnyj    52    

Изменение реквизитов справочников, документов, табличных частей, движений (Обычные и Управляемые формы) Промо

Обработка документов Обработка справочников v8 v8::УФ 1cv8.cf Казахстан Абонемент ($m)

Обработка позволяет редактировать реквизиты справочника, документа, его табличные части и движения.

1 стартмани

15.10.2012    56627    491    Exit_in    42    

Многопоточное удаление объектов

Чистка данных v8 1cv8.cf Абонемент ($m)

Обработка предназначена для ускорения процедуры удаления объектов

2 стартмани

02.06.2016    29833    56    zzz_natali    20    

Шифрование и расшифровка строковых полей справочников методом Виженера (с улучшениями)

Защита и шифрование Обработка справочников v8 1cv8.cf Абонемент ($m)

Обработка по шифрованию и расшифровке строковых полей справочников модифицированным методом Виженера - реализация без внешних компонент, без com-объектов, чистый 1С.

1 стартмани

27.04.2016    40284    49    NikitaXa    22    

Удаление помеченных объектов с отбором по метаданным

Чистка данных v8 1cv8.cf Абонемент ($m)

Это доработанная обработка с отбором по метаданным. По итогу общее время в сравнении со стандартной обработкой сокращено, если необходимо очистить только несколько типов документов/справочников.

1 стартмани

06.04.2016    28502    137    endym    7    

Отключение доступа уволенным пользователям Промо

Информационная безопасность Обработка справочников Инструменты администратора БД v8 v8::Права БП2.0 УПП1 Абонемент ($m)

Давно хотели навести порядок в пользователях? Надоело, что в списке мешаются давно уволенные сотрудники? Тогда эта обработка для Вас!

3 стартмани

15.10.2013    55607    109    VBod    17    

Номенклатура (Расширенная форма списка) и Корзина [Расширение]

Рабочее место Обработка справочников Учет ТМЦ Учет ТМЦ v8 БП3.0 Абонемент ($m)

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    44803    124    mrXoxot    69    

Чистка регистров накопления {остатки и обороты} по закрытым движениям (обычные формы)

Чистка данных v8 1cv8.cf Абонемент ($m)

Обработка предназначена помочь очистить регистры накопления от ненужных записей. Иначе говоря, для удаления строк по измерениям регистра накопления, остатки по которым закрылись в 0.

1 стартмани

22.02.2016    33222    47    endym    14    

Автозаполнение реквизитов контрагентов по ИНН для БП3.0, ERP2.4, УТ11.4, КА2.4, Розница 2.2, Документооборот 2.1

Обработка справочников v8 КА1 ERP2 БП3.0 УТ11 Абонемент ($m)

Расширение для конфигурации 1С: БП 3.0, ERP 2.4, УТ 11.4, КА 2.4, Розница 2.3, Документооборот 2.1

3 стартмани

22.01.2016    72165    757    oslokot    404    

Контрагенты (расширенная форма списка) [Расширение]

Обработка справочников v8 БП3.0 Абонемент ($m)

Красивая и удобная форма списка контрагентов. Добавлено быстрое создание документов из списка и оперативная информация по контрагенту.

5 стартмани

22.12.2015    35040    96    mrXoxot    22    

1С:Интеграция ЕГАИС + Инвентаризация на ТСД

Обработка справочников Обмен через XML Оптовая торговля Оптовая торговля v8 1cv8.cf Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Интеграция ЕГАИС модуля для 1С: 8.3 + модуль WMS контура для инвентаризации алкогольных марок на ТСД.

1 стартмани

10.12.2015    41883    27    JetBrain    5    

Сброс неверной нумерации объектов

Обработка документов Обработка справочников v8 1cv8.cf Абонемент ($m)

Кратко о выправлении нумерации объектов

1 стартмани

07.11.2015    119744    989    magobato    43    

Загрузка изображений с поисковых сайтов сети Интернет в 1С

Обработка справочников WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 v8::ОУ v8::УФ УТ10 УТ11 Абонемент ($m)

Обработка загрузки изображений из интернета в 1С:Предприятие. Платформа 1С:Предприятие версий 8.2 и 8.3.

10 стартмани

13.10.2015    49755    178    premierex    157    

Удаление организации из 1С. Чистка базы 1С. Удаление "не удаляемых" объектов

Чистка данных v8 1cv8.cf Абонемент ($m)

Удалить все документы, чтобы в базе осталась только одна организация со своими документами? Удалить всю информацию в регистрах, не связанную с указанной фирмой? Удалить "неудаляемую" номенклатуру? Легко! Используйте эту обработку.

10 стартмани

02.10.2015    63535    330    spy-83    83    

Автоматическая загрузка классификатора адресов КЛАДР

Обработка справочников WEB v8 УТ10 Россия Абонемент ($m)

Обработка автоматически загружает классификатор с сайта www.gnivc.ru, распаковывает и загружает все регионы в информационную базу.

1 стартмани

02.09.2015    29044    41    kolos    1    

Подсистема автоматического удаления дублей в справочниках (управляемые формы, любая конфигурация)

Чистка данных Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Подсистема позволяет проводить автоматическое удаление дублей справочников в соответствии с заданными настройками. Возможно встраивание в любую конфигурацию на управляемых формах. Позволяет задать настройки справочников, в которых ищутся дубли и также поля поиска совпадений. Есть регламентное задание для запуска проверки с заданным периодом. Если в базе найдены ссылки на тот элемент, который будет удален, то они заменяются на тот элемент, который остается. Дублем считается элемент справочника, у которого больше значение кода.

1 стартмани

31.07.2015    41467    101    primat    12    

Конфигурация ФИАС для 1С 8.1 и 8.2

Обработка справочников v8 1cv8.cf Россия Абонемент ($m)

Конфигурации, которые позволяют интегрировать ФИАС (Федеральная информационная адресная система) в любую конфигурацию 1С 8.1 и 1С 8.2, работающую на НЕ управляемых формах.

1 стартмани

30.07.2015    72671    740    dgonson    55