Интеграция ДБО BS-Client (Белагропромбанк) и БП 1.6 (не используемая обработка "КлиентБанк")

Публикация № 563992

Учет и отчетность - Банковские операции

клиент банка интеграция dbf бухгалтерия предприятия

3
Как можно сделать рабочую интеграцию с клиентом банка за два часа? Привожу пример из личного опыта.

Доработка влючает следующие шаги:

1) добавить процедуру модуля формы обработки "КлиентБанк" следующего содержания:

// Процедура сборка из DBF
Процедура ЗаполнитьДокументыНаИмпортDBF(ДокументыДляИмпорта,таблица) Экспорт
	
	Перем СтрокаРССчетов;
	
	// Проверка каталога загрузки
	Путь = Новый Файл(ФайлЗагрузки);
	
	Если Не Путь.Существует() Тогда
		Сообщить("Каталог не существует!", СтатусСообщения.Важное);
		Возврат;
	ИначеЕсли Не Путь.ЭтоКаталог() Тогда
		Сообщить("Выбран файл загрзуки. Ожидается каталог", СтатусСообщения.Важное);
		Возврат;
	КонецЕсли;
	
	// Подготавливаем структуры обработки данных
	Импорт_ПризнакОбмена = Ложь;
	ЗагрРасчетныеСчета   = Новый СписокЗначений;
	СписокДокументов     = Новый СписокЗначений;
	ЗагрВидыДокументов   = Новый СписокЗначений;
	
	Импорт_РасчетныеСчета.Очистить();
	
	ДокументыДляИмпорта.Очистить();
	
	Файлы = НайтиФайлы(ФайлЗагрузки, "??_??*.dbf", Ложь);
	ЧтениеФайла = Новый XBase;
	ЧтениеФайла.Кодировка = КодировкаXBase.OEM;
	
	Для каждого Файл Из Файлы Цикл
	
		ЧтениеФайла.ОткрытьФайл(Файл.ПолноеИмя,, Истина);
		
		СодержитДокументы = ( ЧтениеФайла.поля.Найти("TYPE_DOC") <> Неопределено );
		
		Пока Не ЧтениеФайла.ВКонце() Цикл
			
			Если Не СодержитДокументы Тогда
				
				СчетОрганизации = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("SCHETKL"));
				ВалютаСтр = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("VALKL"));
				//счет 
				ВыборкаСчета = СчетПринадлежитОрганизации(СчетОрганизации).Выбрать();
				Если ВыборкаСчета.Следующий() Тогда
					СтрокаРССчетов = Импорт_РасчетныеСчета.Найти(СчетОрганизации, "РасчСчет");
					СчетОрганизацииСсылка = ВыборкаСчета.Ссылка;
					ВалютаСтр             = ВыборкаСчета.Ссылка.ВалютаДенежныхСредств;
					ОрганизацияСсылка     = ВыборкаСчета.Владелец;
                    КодВалютыДокумента    = ВыборкаСчета.Ссылка.ВалютаДенежныхСредств;
					Если СтрокаРССчетов = Неопределено Тогда
						СтрокаРССчетов = Импорт_РасчетныеСчета.Добавить();
						СтрокаРССчетов.РасчСчет = СчетОрганизации;
						// добавим информацию о выписке
						СтрокаРССчетов.РасчетныйСчет = СчетОрганизацииСсылка;
						СтрокаРССчетов.ДатаНачала = Формат(ЧтениеФайла.ПолучитьЗначениеПоля("DATEVIP"), "ДФ=дд.ММ.гггг");
						СтрокаРССчетов.ДатаКонца = Формат(ЧтениеФайла.ПолучитьЗначениеПоля("DATEVIP"), "ДФ=дд.ММ.гггг");
						СтрокаРССчетов.Начало = ЧтениеФайла.ПолучитьЗначениеПоля("DATEVIP");
						СтрокаРССчетов.Конец = ЧтениеФайла.ПолучитьЗначениеПоля("DATEVIP");
						СтрокаРССчетов.НачальныйОстаток = Формат(ЧтениеФайла.ПолучитьЗначениеПоля("VH_OSTR"), "ЧДЦ=2; ЧРД=.; ЧГ=0");
						СтрокаРССчетов.КонечныйОстаток = Формат(ЧтениеФайла.ПолучитьЗначениеПоля("ISH_OSTR"), "ЧДЦ=2; ЧРД=.; ЧГ=0");
						СтрокаРССчетов.НачальнаяСумма = ЧтениеФайла.ПолучитьЗначениеПоля("VH_OSTR");
						СтрокаРССчетов.КонечнаяСумма = ЧтениеФайла.ПолучитьЗначениеПоля("ISH_OSTR");
						СтрокаРССчетов.Поступило = 0;
						СтрокаРССчетов.Списано = 0;
					Иначе
						ДатаВ = ЧтениеФайла.ПолучитьЗначениеПоля("DATEVIP");
						Если ДатаВ < СтрокаРССчетов.Начало Тогда
							СтрокаРССчетов.ДатаНачала = Формат(ДатаВ, "ДФ=дд.ММ.гггг");
							СтрокаРССчетов.Начало = ДатаВ;
							СтрокаРССчетов.НачальныйОстаток = Формат(ЧтениеФайла.ПолучитьЗначениеПоля("VH_OSTR"), "ЧДЦ=2; ЧРД=.; ЧГ=0");
							СтрокаРССчетов.НачальнаяСумма = ЧтениеФайла.ПолучитьЗначениеПоля("VH_OSTR");
						Иначе
							СтрокаРССчетов.ДатаКонца = Формат(ДатаВ, "ДФ=дд.ММ.гггг");
							СтрокаРССчетов.Конец = ДатаВ;
							СтрокаРССчетов.КонечныйОстаток = Формат(ЧтениеФайла.ПолучитьЗначениеПоля("ISH_OSTR"), "ЧДЦ=2; ЧРД=.; ЧГ=0");
							СтрокаРССчетов.КонечнаяСумма = ЧтениеФайла.ПолучитьЗначениеПоля("ISH_OSTR");
						КонецЕсли;
					КонецЕсли;
					Если СчетОрганизации <> БанковскийСчет.НомерСчета Тогда
						Сообщить("В заголовке файла импорта указан счет, принадлежащий организации: " + СчетОрганизации + "," + Символы.ПС + "но он отличается от счета, выбранного в настройках! (" + БанковскийСчет.НомерСчета + ")" , СтатусСообщения.ОченьВажное);
                    КонецЕсли;
				Иначе
					Сообщить("В заголовке файла импорта указан счет, не принадлежащий организации: " + СчетОрганизации + " !", СтатусСообщения.ОченьВажное);
					Возврат;
				КонецЕсли;
				
				ДатаВыписки = ЧтениеФайла.ПолучитьЗначениеПоля("DATEVIP");
				
				Прервать;
				
			КонецЕсли;
			
			НоваяСтрокаДокументов = ДокументыДляИмпорта.Добавить();
			НоваяСтрокаДокументов.НОМЕР = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("N_DOC"));
			НоваяСтрокаДокументов.ОПЕРАЦИЯ = Строка(ЧтениеФайла.ПолучитьЗначениеПоля("PR_DK"));
			//НоваяСтрокаДокументов.Дата = Значение;
			НоваяСтрокаДокументов.ДАТА = ЧтениеФайла.ПолучитьЗначениеПоля("DATEPR");
			НоваяСтрокаДокументов.КОНТРАГЕНТИНН = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("UNP"));
			НоваяСтрокаДокументов.КОНТРАГЕНТ = "";//ЧтениеФайла.ПолучитьЗначениеПоля("UNP");
			НоваяСтрокаДокументов.КОДПЛАТЕЖАВБЮДЖЕТ = "";
			НоваяСтрокаДокументов.СЧЕТКОНТРАГЕНТА = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("SCHETKORR"));
			Если НоваяСтрокаДокументов.ОПЕРАЦИЯ = "1" Тогда//"0" Тогда
				НоваяСтрокаДокументов.Операция  = "ПЛАТЕЖНОЕПОРУЧЕНИЕ";
				НоваяСтрокаДокументов.СУММАСПИСАНО = 0;
				НоваяСтрокаДокументов.СУММАПОСТУПИЛО = Строка(ЧтениеФайла.ПолучитьЗначениеПоля("SUMMRUB"));
				СтрокаРССчетов.Поступило = СтрокаРССчетов.Поступило + ЧтениеФайла.ПолучитьЗначениеПоля("SUMMRUB");
			Иначе
				НоваяСтрокаДокументов.Операция  = "ПЛАТЕЖНОЕТРЕБОВАНИЕ";
				НоваяСтрокаДокументов.СУММАСПИСАНО = Строка(ЧтениеФайла.ПолучитьЗначениеПоля("SUMMRUB"));
				НоваяСтрокаДокументов.СУММАПОСТУПИЛО = 0;
				СтрокаРССчетов.Списано = СтрокаРССчетов.Списано + ЧтениеФайла.ПолучитьЗначениеПоля("SUMMRUB");
			КонецЕсли;
			НоваяСтрокаДокументов.НАЗНАЧЕНИЕПЛАТЕЖА = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("NAZNPLAT"));
			НоваяСтрокаДокументов.ВидПлатежа               = "электронно";
			НоваяСтрокаДокументов.ВалютаДокумента          = КодВалютыДокумента;
			НоваяСтрокаДокументов.ДатаДок                  = НоваяСтрокаДокументов.Дата; //ДатаВыписки;
			НоваяСтрокаДокументов.Поступило                = НоваяСтрокаДокументов.Дата;
			НоваяСтрокаДокументов.Списано                  = НоваяСтрокаДокументов.Дата;
			НоваяСтрокаДокументов.СчетОрганизации          = СчетОрганизацииСсылка;//СчетОрганизации;
			НоваяСтрокаДокументов.СчетОрганизацииСсылка    = СчетОрганизацииСсылка;
			НоваяСтрокаДокументов.ОрганизацияСсылка        = ОрганизацияСсылка; 
			НоваяСтрокаДокументов.Организация              = ОрганизацияСсылка; 
			НоваяСтрокаДокументов.КодВалютыДокумента       = КодВалютыДокумента; 
			НоваяСтрокаДокументов.КодВалютыДокументаСсылка = КодВалютыДокумента; 
			НоваяСтрокаДокументов.НомерДок                 = СокрЛП(ЧтениеФайла.ПолучитьЗначениеПоля("N_DOC"));//НоваяСтрокаДокументов.Номер;
			НоваяСтрокаДокументов.ДатаПроведения           = НоваяСтрокаДокументов.Дата;
			НоваяСтрокаДокументов.КонтрагентИНН            = Сред(Врег(СокрЛП(НоваяСтрокаДокументов.КонтрагентИНН)),20, 10);
			НоваяСтрокаДокументов.ПОЛУЧАТЕЛЬИНН            = НоваяСтрокаДокументов.КОНТРАГЕНТИНН;
			НоваяСтрокаДокументов.ПОЛУЧАТЕЛЬСЧЕТ           = НоваяСтрокаДокументов.СЧЕТКОНТРАГЕНТА;
			
			ЧтениеФайла.Следующая();
			
		КонецЦикла;
		
		ЧтениеФайла.ЗакрытьФайл();
		
	КонецЦикла;
	
	Если ЗначениеЗаполнено(СтрокаРССчетов) Тогда
		СтрокаРССчетов.ВсегоПоступило = Формат(СтрокаРССчетов.Поступило, "ЧДЦ=2; ЧРД=.; ЧГ=0");
		СтрокаРССчетов.ВсегоСписано = Формат(СтрокаРССчетов.Списано, "ЧДЦ=2; ЧРД=.; ЧГ=0");
	КонецЕсли;
	
	УдалитьФайлы(ФайлЗагрузки, "??_??*.dbf");
	
	НомерСтроки = 0;
	Для Каждого СтрокаДокумента Из ДокументыДляИмпорта Цикл
		// Последовательно обрабатываем каждую загруженную строку
		РаспознатьДанныеВСтрокеДокумента1(СтрокаДокумента, "СчетКонтрагента");
		РаспознатьДанныеВСтрокеДокумента1(СтрокаДокумента, "Сумма");
		РаспознатьДанныеВСтрокеДокумента1(СтрокаДокумента, "Документ");
		//Распознаем реквизиты
		НомерСтроки = НомерСтроки + 1;
		СтрокаДокумента.НомерСтроки = НомерСтроки;
		Если ТипЗнч(СтрокаДокумента.Контрагент)=Тип("Строка") ИЛИ
			ТипЗнч(СтрокаДокумента.СчетКонтрагента)=Тип("Строка") ИЛИ
			ТипЗнч(СтрокаДокумента.Договор)=Тип("Строка") Тогда
			
			//добавляем реквизиты в табличну часть для дальнейнего использования
			СписокНенайденных(СтрокаДокумента);
		КонецЕсли;
	КонецЦикла;

КонецПроцедуры

2) в процедуре "ПрочитатьДанныеИзФайла" модуля формы внести изменения:

//ЗаполнитьДокументыНаИмпорт(ДокументыКИмпорту,ЭлементыФормы.ДокументыКИмпорту);
ЗаполнитьДокументыНаИмпортDBF(ДокументыКИмпорту,ЭлементыФормы.ДокументыКИмпорту);

Далее требуется настроить пути загрузки в 1С, а в программе клиент банка зайти "Входящие-Выписки", выделить все нужные документы, выбрать пункт контекстного меню "Экспорт в DBF". После чего в обрабоке "Клиент банка" нажимаем "Прочитать данные из файла" (это произведёт загрузку всех выгруженных документов в таблицу).

3

Специальные предложения

Автор запретил комментарии

См. также

Загрузка платежей из Сбербанк Онлайн по картам физических лиц 7

Статья Программист Нет файла v8 1cv8.cf Россия Банковские операции Бесплатно (free) Обмен с банком

Код для загрузки выписки по карте из Сбербанк.Онлайн НЕ Сбербанк Бизнес Онлайн.

27.09.2018    3645    compguru    0       

Многофакторная авторизация. Шаблон проектирования для «1С:Предприятие 8». На примере API «Приватбанка» для юр. лиц 10

Статья Программист Нет файла v8 Бесплатно (free) Информационная безопасность Обмен с банком

Многим из читателей знакомы понятия стандартов разработки и шаблонов проектирования. Для платформы «1С:Предприятие 8» на сайте its.1c.ru описаны базовые стандарты оформления кода и некоторые полезные примеры, но отсутствует информация об высокоуровневых абстракциях. Почти у каждого банка есть реализация обмена с конфигурациями «1С:Предприятие 8», но анализировать код, а тем более реализацию без слёз невозможно. Данная статья предлагает использовать некий шаблон оформления кода для многофакторной авторизации.

11.09.2017    10170    pbazeliuk    6       

Оплата банковскими картами в "Управлении торговлей для Украины" 12

Статья Бухгалтер Руководитель проекта Нет файла v8 1cv8.cf Украина УУ Банковские операции Розничная торговля Бесплатно (free) Пользователю системы

Доля безналичных оплат в торговле неуклонно растет, и сегодня уже существует законодательное требование к торговым точкам, согласно которому наличие POS-терминала является обязательным требованием. Процесс оплаты банковскими картами называется «Эквайринг». Для организации оплаты картами в своем магазине необходимо обратиться в банк и заключить с ним договор эквайринга. Существуют различные условия этого договора, но, по сути, они отличаются лишь процентной ставкой. В данной статье описывается порядок работы для конфигурации «Управление торговлей для Украины», если оплата производится с помощью платежных карт.

23.05.2017    17927    pbazeliuk    1       

Печать QR кодов для 1С:Бухгалтерия 2.0 для платежек Сбербанка 29

Статья Программист Нет файла v8 БП2.0 Россия Банковские операции Бесплатно (free) Практика программирования

Печать QR кодов оффлайн в 1С:Бухгалтерия 2.0 с помощью бесплатной ActiveX компоненты для платежек Сбербанка

30.03.2017    26379    Chaotic    33       

Работа с 1С:ДиректБанк в системе ДБО iBank 2 18

Инструменты и обработки Бухгалтер Архив с данными v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ ERP2 Россия Windows Банковские операции Бесплатно (free) Обмен с банком Бухгалтерский учет

В современных типовых конфигурациях фирмы "1С" есть возможность работать с системой ДБО iBank 2 напрямую из 1С:Предприятия. Пользователям доступны такие функции, как подпись и отправка платежа в банк, подтверждение платежа по SMS и получение выписки. Промышленная система ДБО iBank 2 установлена в более чем трети российских банков, и многие из них уже начали предоставление сервиса прямого обмена. В статье вкратце описан порядок подключения услуги и настройки DirectBank с системой ДБО iBank 2.

26.05.2016    22501    ph_1984    29       

Из клиент-банка в 1С загружается не вся информация 5

Статья Программист Нет файла v8 УТ10 Банковские операции Бесплатно (free) Практика программирования

Столкнулся в проблемой - банк нашего поставщика вернул перечисленные нами деньги обратно на наш расчетный счет (по причине неправильного заполнения поля Наименование получателя). Но при загрузке из программы Сбербанка в 1С УТ 10.3 этот возврат никак не отображался. Пришлось разбираться, почему...

21.04.2016    8559    CXY    1       

Загрузка выписки из Банк - клиента в 1С: Бухгалтерию - настройка 5

Статья Бухгалтер Нет файла v8 БП2.0 БУ Windows Банковские операции Бесплатно (free) Обмен с банком

Регулярно приходится объяснять бухгалтерам как формировать платежные поручения в банк-клиенте, а также еще раз заносить их в программы 1С. Чтобы избежать двойной нудной работы достаточно настроить простой перенос загрузку выписок из банк в программу. Сложность данной операции не велика для любого бухгалтера и он способен справиться с этим самостоятельно, разобраемся.

23.03.2016    32245    Bylka    2       

Клиент банк из 1С 36

Статья Системный администратор Программист Бухгалтер Нет файла v8 КА1 БП2.0 УТ10 УНФ ERP2 БУ УУ Windows Банковские операции Бесплатно (free) Обмен с банком

Хочу рассказать про отличную возможность 1с Бухгалтерии 3.0 (и некоторых других конфигураций) использования клиент банка прямо из 1С. Теперь не надо делать выгрузку в файлик и загружать выписки из файлика. Достаточно нажать кнопку Обмен с банком в 1С и получить необходимые документы. А для платежек нажать кнопку Создать и отправить электронные документы.

12.02.2016    46998    ameli-130412    64       

Варианты отражения факторинговых операций в УТ 10.3 5

Статья Бухгалтер Нет файла v8 УТ10 Россия УУ Windows Банковские операции Бесплатно (free) Бухгалтерский учет

У нас возникла необходимость отражения факторинговых операций в 1С:Управление торговлей 10.3 без доработок самой конфигурации. В статье приводится 2 варианта, не противоречащих законодательству.

16.10.2015    8840    irina_shick    3       

Чтение dbf-файла через ODBC Foxpro драйвер 26

Статья Программист Нет файла v8 Windows Бесплатно (free) Файловые протоколы обмена, FTP

Иногда возникает потребность прочитать dbf-файл, который xbase не понимает.

11.07.2013    30570    zels    18       

Корректировка заголовка DBF-файла, сформированного в 1С, для его связи с индексным файлом для дальнейшей работы с ним из внешних приложений (FoxPro 2.6, Visual FoxPro и пр.) 9

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Файловые протоколы обмена, FTP

Программный код, корректирующий заголовок DBF-файла, сформированного в 1С, для его связи с индексным файлом для далнейшей работы с ним из внешних приложений (FoxPro 2.6, Visual FoxPro и пр.)

18.03.2013    11923    iRounder    19       

Внешняя выгрузка КлиентБанк 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия БУ Windows Банковские операции Бесплатно (free) Обмен с банком

Внешняя обработка для выгрузки документов в банки. Для нетиповых и сильно переработанных конфигураций.

24.01.2013    4772    34    GoroStyle    2       

Подсистема "COMExchange": прямой доступ к EXCEL через ADO 8

Статья Системный администратор Программист Нет файла v8 1cv8.cf УТ10 УПП1 Россия Windows Бесплатно (free) Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel Внешние источники данных

На примере этой, очень популярной, темы наглядно продемонстрированы нетривиальные возможности консоли запросов в составе подсистемы: 1. использование событий выполнения запроса (в том числе для запуска на выполнение других запросов) 2. запуск на выполнение запроса в цикле с подстановкой значений параметров из таблицы значений.

20.01.2013    21172    yuraos    7       

Счета-фактуры на аванс, БП 2.0 как есть 29

Статья no Нет файла v8 БП2.0 БУ НУ Банковские операции Кассовые операции Оптовая торговля НДС Бесплатно (free) Пользователю системы Бухгалтерский учет

Формирование авансовых счетов-фактур, вычет НДС с полученных авансов, как работает и от чего зависит в Бухгалтерии предприятия 2.0, в том числе и про 5 дней.

30.03.2012    27163    Yury1001    10       

Экспорт платежных поручений в казначейство г. Москвы 4

Статья no Нет файла v8 БГУ Государственные, бюджетные структуры Россия Госбюджет Банковские операции Бесплатно (free) Обработка документов Обмен с банком Обмен через XML

Устанавливая конфигурацию "1С: Бухгалтерия государственного учреждения" (1С:БГУ) в одном из детских садиков г. Москвы, столкнулся с проблемой - казначейство не принимает платежные поручения (платежки), выгруженные из 1С:БГУ стандартной обработкой обмена.

09.02.2012    14296    AVK_Alex    1       

Функция загрузки из dbf 98

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Файловые протоколы обмена, FTP Универсальные функции

Универсальная функция чтения данных из dbf файлов и создания таблицы значений.

26.12.2011    37267    Kuzja_R    18       

Банковские дни запросом 14

Статья Программист Нет файла v8 1cv8.cf Россия БУ Банковские операции Бесплатно (free) Практика программирования

Часто в отчетах требуется получить дату через N банковских дней, данный запрос на выходе дает таблицу: Дата | Дата_Через_N_Банковских дней. Параметр (&КоличествоБанковскиДней*1.5 + 20) не случаен 20 - максимальное количество не банковских дней подряд (примерно) 1,5 - отношение количества банковских дней к календарным дням, чем он меньше тем быстрее выполняется запрос, но если он слишком мал, не все даты могут попасть в результат, поэтому взял с запасом.

24.11.2011    8073    sm0123    13       

Загрузка курсов валют с сайта Национального Банка Азербайджана. 1С8 2

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Банковские операции Бесплатно (free) Обработка справочников WEB

Обработка, позволяющая загружать курсы валют с сайта Национального Банка Азербайджана, www.cbar.az. 1С8

22.04.2011    21439    71    PaRaDoX    4       

Формирование списка сотрудников на оформление банковских карт для Сбербанка 4

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия Банковские операции Зарплата Бесплатно (free) Обработка документов Универсальные печатные формы Обмен с банком

Внешняя обработка для 1С:8.1 ЗУП 2.5. Формирует список сотрудников (только работающих), на которых необходимо сделать банковские карты Сбербанка. Формирование списка возможно с отбором по периоду даты приема сотрудников.

10.11.2010    12684    124    pavel_pss    3       

Получение курса валюты по списку дат 38

Статья no Нет файла v8 1cv8.cf Россия БУ Windows Банковские операции Бесплатно (free) Практика программирования

Иногда у меня возникала необходимость в запросе получить значение курсов валют на разные даты, причем заранее список дат неизвестен. Естественно было желание сделать все одним запросом. Буквально вчера нашел я оптимальное решение задачи. Т.к. подобные задачи могут возникать и у других, то решил результат здесь.

20.03.2010    15865    Nikola23    17       

Выгрузка на ПК в СберБанк для ЗБУ 8.1 11

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 ЗКБУ Банковские операции Зарплата Бесплатно (free) Обработка документов Обмен с банком

Столкнулся с удивительной, для меня, вещью: в "Зарплате и кадры для бюджетного учреждения" нет выгрузки данных о перечислениях зарплаты на пластик в СберБанк. И это при том, что значительная часть бюджетных учреждений открыли зарплатные счета именно в этом банке. Мнение 1С по этому поводу, если коротко: "Функциональность планируется реализовывать в конфигурации ББУ". А что же делать тем, у кого нет ББУ? Вот и сделал свою обработку на базе обработки из ЗУП 8, а точнее немного подправил типовую:

16.02.2010    10796    253    smooth    13       

Один из вариантов переноса данных из 1С 7.7 в 1С 8.Х 24

Инструменты и обработки Системный администратор Программист Архив с данными v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Перенос данных из 1С7.7 в 1C8.X Файловые протоколы обмена, FTP

Перенос данных — это почти всегда индивидуальный подход. И крайне важно выбрать наиболее подходящий инструмент из множества доступных. Я в этой статье опишу один из вариантов.

30.11.2009    15946    266    awk    29       

Загрузка должностей из DBF 5

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия Управление персоналом (HRM) Бесплатно (free) Обработка справочников Файловые протоколы обмена, FTP

Написанная обработка использовалась при переносе данных в 1С 8.1 Зарплата и Управление Персоналом, но она универсальна и подойдет я думаю для любой конфигурации..

23.10.2009    6243    108    netuser    8       

Выгрузка зарплаты на пластиковые карточки Девон, Ак Барс банк 7

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 Россия БУ Банковские операции Зарплата Бесплатно (free) Обмен с банком

Позволяет формировать файлы выгрузки зарплаты на пластиковые карты для банков "Ак Барс Банк" и "Девон Кредит" на основании документов "Зарплата к выплате", "Платежное поручение" в ЗУП 2.5.

10.06.2009    11483    194    alexey85    5       

Выгрузка зарплатного реестра для Сбербанка из 1С ЗУП 2.5 и Бухгалтерии Предприятия 2.0 в формате .txt 32

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 ЗУП2.5 Россия БУ Банковские операции Зарплата Бесплатно (free) Обработка документов Обмен с банком

Выгрузка зарплатного реестра для Сбербанка из 1С ЗУП 2.5, Бухгалтерия Предприятия 2.0 в формате .txt Добавлена загрузка лицевых счетов из файла, присланного Сбербанком.

05.01.2009    30632    582    goalkeeper    8       

Навеяно кризисом 138

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Банковские операции Бесплатно (free) Универсальные обработки WEB Работа с интерфейсом

Используя эту обработку Вы всегда будете знать состояние кризиса на данный момент :)

11.11.2008    16604    773    ValeriVP    27       

Квитанция на оплату (для Сбербанка) 15

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Россия БУ Банковские операции Кассовые операции Бесплатно (free) Обработка документов

Обработка позволяет напечатать квитанцию на оплату, опирается на справочник контрагентов. Маленько недоделанная, так что хотелось бы услышать советы более опытных людей, чем я!

06.08.2008    4553    129    SolovieFF    1       

DBFViewer 115

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Инструментарий разработчика Файловые протоколы обмена, FTP

На новой работе пришлось заниматься экспортом из дремучих DOS-DBF. Пригодилась старая разработка. Может, кому понадобится. Интерфейс, надеюсь, интуитивно-понятный Добавлен облегченный вариант для 8.1

18.02.2007    19155    1191    Abadonna    31       

Генератор отчетов GenRep 31

Инструменты и обработки Программист Приложение (exe) v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Инструментарий разработчика Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel

GenRep - Генератор отчетов в Word, Excel, Нtml, TXT. Шаблон отчета разрабатывается в самом Word'е, Excel. Подробная документация на русском языке и пример для 1С есть внутри архива.

26.07.2006    16176    813    kudenzov    8