IE2017

Фильтр на таблицу значений системой компоновки данных

Программирование - Практика программирования

Часто здесь проскакивает вопрос, а как установить фильтр на таблицу значений в управляемых формах. На самом деле, есть только один способ - залить старую таблицу значений в новую, отфильтровав или отсортировав по каким-либо правилам. Здесь реализуем на компоновке данных.

Итак, что делает обработка. Обработка собирает из текущей конфигурации перечень объектов метаданных. Причем делает она это нестандартно, используя функцию ПолучитьСтруктуруХраненияБазыДанных(). Обычно структуру метаданных собирают циклами по списку документов, справочников, и т.д. Способ не факт, что быстрее, но для учебных целей он может быть интересен.

Далее, часто задают вопрос, а как сделать автоподбор при вводе символов в поле ввода. 1С говорит, что с заходом на сервер этого делать нельзя. На самом деле, если немного обмануть систему, то можно. Делается это в процедуре автоподбора через грязный хак:

&НаКлиенте
Процедура ОбъектМетаданныхАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)
	Если Не ПустаяСтрока(Текст) Тогда
		СтандартнаяОбработка = Ложь;
		ОбъектМетаданных = Текст;
		ДанныеВыбора = ПолучитьПереченьОбъектов(Текст);
	КонецЕсли;
КонецПроцедуры

Смысл в том, чтобы присвоить набранное значение в реквизит, к которому привязано поле формы, а затем уже уходить на сервер. Есть правда минус, поле начинает некорректно отображать курсор. То-есть сам курсор ввода остаётся на своем месте, но поле показывает его в начале строки.

И да. Не рекомендую это решение в продакшн на продажу. Вдруг 1С закроет эту багофичу?

На смешении этих двух идей в обработке построен инкрементальный поиск в таблице значений. При открытии подбора метаданного из таблицы значений можно отфильтровать отдельно как по типу метаданного, так и по части строки имени метаданного.

Скачать файлы

Наименование Файл Версия Размер
кпнФильтрНаТаблицуЗначений.epf
.epf 12,84Kb
14.12.16
1
.epf 12,84Kb 1 Скачать

См. также

Комментарии
1. Sergey Andreev (starik-2005) 1041 14.12.16 22:33 Сейчас в теме
Что-то странное твориццо, ибо как минимум два утверждения в статье неверны.

Часто здесь проскакивает вопрос, а как установить фильтр на таблицу значений в управляемых формах. На самом деле, есть только один способ - залить старую таблицу значений в новую, отфильтровав или отсортировав по каким-либо правилам.


Это не так. Для фильтра таблицы значений в управляемых формах есть ОтборСтрок. Фактически это работает так:
&НаКлиенте
Процедура ФильтрПриИзменении(Элемент)
	Элементы.Таблица.ОтборСтрок = Новый ФиксированнаяСтруктура(Новый Структура("ИмяТаблицыХранения", Фильтр));
КонецПроцедуры
...Показать Скрыть


Фильтруется на вхождение (по подстроке, т.е. [ПОДОБНО "%"+фильтр+"%"].

Далее, часто задают вопрос, а как сделать автоподбор при вводе символов в поле ввода. 1С говорит, что с заходом на сервер этого делать нельзя. На самом деле, если немного обмануть систему, то можно. Делается это в процедуре автоподбора через грязный хак:


В действительности при изменении реквизита формы и происходит неладное (курсор туды-сюды и прочая). Но если попытаться создать событие "АвтоПодбор" для поля, то мы удивимся диалогу от 1С, предлагающему создать процедуру на клиенте или !ВНИМАНИЕ! на сервере без контекста. Т.е. такой код замечательно работает:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	Таб = ПолучитьСтруктуруХраненияБазыДанных();
	Таб.Индексы.Добавить("ИмяТаблицыХранения, ИмяТаблицы, Метаданные, Назначение");
	Адрес = ПоместитьВоВременноеХранилище(Таб, УникальныйИдентификатор);
	Таблица.Загрузить(Таб);
КонецПроцедуры

&НаКлиенте
Процедура ФильтрАвтоПодбор(Элемент, Текст, ДанныеВыбора, ПараметрыПолученияДанных, Ожидание, СтандартнаяОбработка)
	Если Ожидание > 0 Тогда 
		ДанныеВыбора = ФильтрАвтоПодборНаСервере(Адрес, Текст);
		СтандартнаяОбработка = Ложь
	КонецЕсли;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФильтрАвтоПодборНаСервере(Адрес, Текст)
	// Вставить содержимое обработчика.
	ДВ = Новый СписокЗначений;
	Запрос = Новый Запрос(
	"ВЫБРАТЬ ИмяТаблицыХранения, ИмяТаблицы, Метаданные, Назначение ПОМЕСТИТЬ ВТТаб ИЗ &Таб КАК Таб;
	|ВЫБРАТЬ ИмяТаблицыХранения ИЗ ВТТаб ГДЕ ИмяТаблицыХранения ПОДОБНО ""%"+текст+"%"" ИЛИ ИмяТаблицы ПОДОБНО ""%"+текст+"%"" ИЛИ Метаданные ПОДОБНО ""%"+текст+"%"" ИЛИ Назначение ПОДОБНО ""%"+текст+"%""");
	Запрос.УстановитьПараметр("таб", ПолучитьИзВременногоХранилища(Адрес));
	Для Каждого Ст ИЗ Запрос.Выполнить().Выгрузить() Цикл 
		ДВ.Добавить(Ст.ИмяТаблицыХранения)
	КонецЦикла;
	Возврат ДВ;
КонецФункции
...Показать Скрыть
zoikins; bulpi; Ганс; ardn; headMade; pm74; +6 Ответить
2. Павел Кручинин (igel9780) 139 15.12.16 10:12 Сейчас в теме
1. Да согласен. Значит, отбор по СКД стоит использовать для более сложных случаев.
2. И тоже согласен. Только если все данные находятся в таблице значений, а в базе данных их нет, то такой вариант с НаСервереБезКонтекста не подходит.

Ну, собственно, в том и смысл форума, что бы оппонировать. Спасибо.
Alien_job; +1 Ответить
Оставьте свое сообщение