Единый семинар «1С» для бухгалтеров и руководителей

Экран покупателя. Передача данных по локальной сети. Воспроизведение видео.

Обработки - Рабочее место

Программа предназначена для вывода информации о текущем заказе покупателя на любой дисплей (может быть как локальный второй монитор, так и удаленный). Вывод информации производится через HTTP-запросы (не требует настройки общих папок). На экране покупателя помимо текущего заказа покупателя ротируются картинки из папки. Также можно выводить полноэкранное видео плейлистом из папки например при пустом заказе.

Для воспроизведения видео на экране необходимо отправить на адрес http://ip-адрес-компьютера-с-запущенной-программой/main  JSON следующего вида:

{
"method":"video",
"op":"start"
}

для остановки:

{
"method":"video",
"op":"stop"
}

Для вывода списка товаров на дисплей:

{"method":"set_screen",
"sum"":"1234.56",
"Items":[
{
"name":"Оливье",
"num":"2",
"sum":"29",
"cost":"14,5"
}
]
}

Пример интеграции с 1С:Управление торговлей 11:

При отсутствии товаров в заказе на экране воспроизводится видео. При добавлении товаров переключается на вывод списка покупок.

Процедура ОбновитьИнформациюНаТабло()
		Товары = Объект.Товары;
		HTTPСоединение = Новый HTTPСоединение("localhost","14001");
                HTTPЗапрос = Новый HTTPЗапрос("main");

		 
		Если Товары.Количество()>0 Тогда
			request = "{""method"":""video"",""op"":""stop""}";
			Текст = Новый ТекстовыйДокумент;
         	        Текст.ДобавитьСтроку(request);
         	        HTTPЗапрос.УстановитьТелоИзСтроки(request, "UTF-8", ИспользованиеByteOrderMark.НеИспользовать);
         	        HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
		ИНАЧЕ
			request = "{""method"":""video"",""op"":""start""}";
			Текст = Новый ТекстовыйДокумент;
         	        Текст.ДобавитьСтроку(request);
         	        HTTPЗапрос.УстановитьТелоИзСтроки(request, "UTF-8", ИспользованиеByteOrderMark.НеИспользовать);
         	        HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
                КонецЕсли;

		СуммаВсего = Товары.Итог("Сумма");       
	        СписокТоваров = Новый ТаблицаЗначений;   
	        СписокТоваров = Объект.Товары.Выгрузить();  
	        Кол = СписокТоваров.Количество();
		request = "{""method"":""set_screen"",""sum"":"""+СуммаВсего+""",""Items"":[";
	        Пока Кол >0 Цикл       
	    	    Колво = СписокТоваров[ном-1].Количество;   
	            ТекЦена = СписокТоваров[ном-1].Цена;
	            ТекТовар = СписокТоваров[ном-1].Номенклатура.Наименование;
		    ТекСумма = СписокТоваров[ном-1].Сумма;
		    request = request + "{""name"":"""+Строка(ТекТовар)+""","+"""num"":"""+ Формат(Колво,"ЧЦ=10; ЧДЦ=3")+""","+"""sum"":"""+ Формат(ТекСумма,"ЧЦ=10; ЧДЦ=3")+""","+"""cost"":"""+Формат(ТекЦена,"ЧЦ=10; ЧДЦ=2; ЧН=")+"""}";
		    Если Кол> 1 Тогда
			request = request+",";	 
		    КонецЕсли;	 
	        Кол = Кол-1;
		КонецЦикла;
		request = request + "]}";
		Текст = Новый ТекстовыйДокумент;
		Текст.ДобавитьСтроку(request);
	        HTTPЗапрос.УстановитьТелоИзСтроки(request, "UTF-8", ИспользованиеByteOrderMark.НеИспользовать);
		HTTPСоединение.ОтправитьДляОбработки(HTTPЗапрос);
 КонецПроцедуры

Данную процедуру необходимо вызвать в процедуре ВывестиИнформациюНаДисплейПокупателя() в форме ФормаДокументаРМК в документе ЧекККМ.

По Вашим пожеланиям готовы внести любые доработки.

Также по вашему запросу можем интегрировать с любой учетной системой.

Установка и настройка программы:

  1. Распаковать архив
  2. Запустить конфигуратор (configurator.exe)
  3. Ввести ключ активации
  4. Активировать программу
  5. В папку images положить картинки для ротации (поддерживаемые форматы: *.jpg, *.jpeg, *.png)
  6. Установить актуальную версию плеера VLC
  7. В папку videos положить ролики для воспроизведения (поддерживаемые контейнеры *.mkv, *.avi, *.mp4, *.webm; кодеки поддерживаются те, которые может открыть установленный в системе VLC)
  8. Открыть TCP порт указанный в конфигураторе (стандартно 14001)
  9. Запустить webserver.exe

Для получения программы для GNU/Linux или RaspberryPI после покупки необходимо связаться с разработчиками и сообщить название и версию используемого дистрибутива GNU/Linux.

UPD: версия для x86 Linux включена в поставку

 

Лицензирование осуществляется путем передачи ключа активации клиенту.  Программа имеет закрытый исходный код.  Лицензия на одно рабочее место действует бессрочно, при условии запуска на одной установке ОС. При переустановке ОС пользователь может сделать запрос на получение нового ключа, который будет выслан в течение 3 рабочих дней, старый ключ деактивируется.

Получение обновлений бесплатное. Обновление можно плучить как с данного сайта, так и через прямой запрос на e-mail технической поддержки.

Техническая поддержка по общим вопросам использования програмного продукта предоставляется бесплатно в течение 6 месяцев. Также возможно заказать платную поддержку, в рамках которой с Вами свяжется специалист и поможет в установке/настройке.

 

Причины купить

  • Удобство клиента
  • Отображение видеорекламы

Достоинства

  • Работает по HTTP (не требует дисковых операций)
  • Мгновенное обновления состояния (Воспроизведение видео, остановка видео, отображение чека)
  • Легковесность (использует <30 Мб оперативной памяти)
  • Кроссплатформенность (возможен запуск на Windows, GNU/Linux, RaspberryPI 1/2/3)

Все

Наименование Файл Версия Размер
Демонстрационная версия Экран покупателя
.zip 29,52Mb
25.12.16
21
.zip 1.0 29,52Mb 21 Скачать бесплатно

Лицензии

Наименование Файл Версия Размер
Экран покупателя. Передача данных по локальной сети. Воспроизведение видео. : Экран покупателя 1 рабочее место
28.12.2016
1.0 4500 руб.

Моментальная
доставка

Техническая поддержка

Наименование Файл Версия Размер
Экран покупателя. Передача данных по локальной сети. Воспроизведение видео. : Техническая поддержка (1 час)
28.12.2016
1000 руб.


Новый вопрос

E-mail*
Тема (вопрос)*

См. также