Заполнение ОГРН с использованием Инструментов разработчика

Публикация № 610851

Администрирование - Администрирование данных 1С - Обработка справочников

загрузка ОГРН ИР Инструменты разработчика

9
Вот и до нашей организации добралось требование указывать в отчетности для ГлавКонтроля ОГРН контрагента. Как всегда, задача возникла внезапно, и решить ее нужно было "вчера".

Обозрев просторы интернетов, стало понятно, что владельцы информации сделали все, чтобы максимально затруднить массовое получение такой информации. К счастью, добрый человек  Sirruf, опубликовал обработку, позволяющую получать ОГРН с разных сайтов, в том числе,  fedresurs.ru.

Так как задача была срочная и одноразовая, было решено не городить огородов, а написать алгоритм для Инструментов разработчика уважаемого Сергея Старых (tormozit), позаимствовав процедуру получения данных из обработки ВводКонтрагентовПоДаннымФНС_ОбычныеФормы.

Опубликую это здесь, может кому-то пригодится.

Итак:

В конце концов, я решил использовать инструмент Консоль запросов (ИР).

В справочник Контрагенты был добавлен реквизит ахОГРН, который и требовалось заполнить актуальными данными.

Почему реквизит справочника?

Конечно, в соответствии с 1CZen, правильнее было бы добавить в конфигурацию новую таблицу, например РС:ОГРНКонтрагентов, раз уж не предусмотрено в типовой конфигурации УПП реквизита ОГРН в справочнике Контрагенты. но мы решили, что ОГРН - это у контрагента раз и навсегда, поэтому все-таки добавили именно реквизит справочника.

Запросом отобрал необходимых контрагентов и заявил дополнительные реквизиты, которые будут заполняться на последующем шаге:

ВЫБРАТЬ
	Контрагенты.Родитель КАК Родитель,
	Контрагенты.Код КАК КонтрагентКод,
	Контрагенты.Ссылка КАК КонтрагентСсылка,
	Контрагенты.НаименованиеПолное КАК ПолноеНаименование,
	Контрагенты.ИНН КАК СпрИНН,
	Контрагенты.КПП КАК СпрКПП,
	выразить("" как Строка(300)) КАК Наименование,
	выразить("" как Строка(15)) КАК ИНН,
	выразить("" как Строка(15)) КАК КПП,
	выразить("" как Строка(30))  КАК ОГРН,
	выразить("" как Строка(300))  КАК Адрес,
	выразить("" как Строка(300))  КАК url
ИЗ
	Справочник.Контрагенты КАК Контрагенты
ГДЕ  Истина
	И Контрагенты.Родитель = &РодительПапкаСбыт
	И НЕ Контрагенты.ЭтоГруппа
	И Контрагенты.ЮрФизЛицо = &ЮрФизЛицоЮрЛицо

Далее, заполнил текст модуля "Обработка строки результата" процедурой получения данных. Сервис fedresurs.ru был выбран из-за отсутствия необходимости ввода капчи на каждый запрос. Хотя, боюсь, что это скоро прикроют и капчу все-таки навесят. Сегодня, 14.04.2017, я этим алгоритмом загружал данные в копию информационной базы - капчи не было.

К тексту модуля небольшое пояснение:

Действие выполняется в два этапа: на первом этапе получаются данные от вебсервиса для контрагента (по ИНН) текущей строки набора данных и их запись в ячейки строки таблицы данных. На втором этапе получается объект справочника Контрагенты из ссылки в текущей строке набора данных и полученные данные записываются в объект. Так как в модуле Обработка результата Консоли запросов (ИР) результирующий набор данных (внезапно!)  а переносить получение данных в процедуру Обработка результата мне было лениво, оба этапа реализованы в одном модуле Обработка строки результата, а этап выбирается значением переменной ПолучениеИзInternet. Когда она равна правде - происходить загрузка данных, если ее установить в неправду - данные из набора данных записываются в справочник.

Кроме кода ОГРН, вебсервис возвращает еще правильное наименование контрагента и его юридический адрес. Посчитав, что это важные для выверки данные, я решил сохранить их в неиспользуемом у нас реквизите справочника ДополнительноеОписание. Туда же дописывается ссылка, по которой можно открыть страницу с данными этого контрагента на fedresurs.ru.

// Заполнение Адрес, ОГРН, url и правильного Наименования в Результат-коллекция
// данные для заполнения берутся с сайта http://www.fedresurs.ru
// алгоритм чтения страницы и разбора параметров взят из //infostart.ru/public/281276/

ФР = "http://se.fedresurs.ru";
ПолучениеИзInternet = ложь;
Состояние(СтрокаРезультата.ПолноеНаименование);

Если Не ПолучениеИзInternet Тогда
	КонтрагентОбъект = Справочники.Контрагенты.НайтиПоКоду(СтрокаРезультата.КонтрагентКод).ПолучитьОбъект();
	КонтрагентОбъект.ахОГРН = СтрокаРезультата.ОГРН;
	КонтрагентОбъект.ДополнительноеОписание = 
		 СтрокаРезультата.Наименование+Символы.ПС
		+"---***---"+Символы.ПС
		+СтрокаРезультата.Адрес+Символы.ПС
		+"---***---"+Символы.ПС
		+СтрокаРезультата.url;
	КонтрагентОбъект.Записать();
Иначе
	
	зИНН = СокрЛП(СтрокаРезультата.СпрИНН);
	Если СтрДлина(зИНН) <> 10 Тогда
		СтрокаРезультата.ИНН = "***UNKNOWN INN***";
		
	ИначеЕсли ПустаяСтрока(СтрокаРезультата.Адрес) тогда
		
		ГетЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
		ГетЗапрос.SetTimeouts(10000, 10000, 10000, 10000);
		СтрокаЗапроса = ФР+"/companies?filter=" + зИНН;
		ГетЗапрос.Open("GET", СтрокаЗапроса, 0); 
		
		Попытка
			ГетЗапрос.Send();
			ГетЗапрос.WaitForResponse();
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;
		
		ResponseText = ГетЗапрос.ResponseText();
		
		ResponseText = СтрЗаменить(ResponseText, Символы.ВК + Символы.ПС, "");
		
		Шаблон = "<div class=""vcard listItem""(.*?)</div>\s*</div>";
		
		СтрокаПоиска = ResponseText;
		//=====================>>>[НайтиВхожденияШаблона]
		//	ВхожденияШаблона = НайтиВхожденияШаблона(ResponseText, ШаблонПоиска);
		МассивСтрок = Новый Массив;
		RegExp = Новый COMОбъект("VBScript.RegExp");
		RegExp.IgnoreCase = Истина; //Игнорировать регистр
		RegExp.Global = Истина; //Поиск всех вхождений шаблона
		RegExp.MultiLine = Ложь; //Многострочный режим
		
		RegExp.Pattern = Шаблон; 
		Matches=RegExp.Execute(СтрокаПоиска);
		ЧислоВхождений=Matches.Count();
		Если ЧислоВхождений>0 Тогда 
			Для к = 0 По ЧислоВхождений-1 Цикл
				Match = Matches.Item(к);
				
				SubMatches = Match.SubMatches;
				ЧислоПодвыражений=SubMatches.Count();
				
				МассивПодстрок = Новый Массив;
				
				Для н = 0 По ЧислоПодвыражений-1 Цикл
					SubMatch=SubMatches.Item(н);
					Если SubMatch="" Тогда
						Продолжить;
					КонецЕсли;    
					
					МассивПодстрок.Добавить(SubMatch);
					
				КонецЦикла;    
				
				Если МассивПодстрок.Количество() > 0 тогда
					МассивСтрок.Добавить(МассивПодстрок);
				КонецЕсли;
				
			КонецЦикла;
		КонецЕсли;
		
		//=====================<<<[НайтиВхожденияШаблона]
		ВхожденияШаблона = МассивСтрок;	
		
		МассивСтрок = Новый Массив;
		Для каждого ТекВхождение из ВхожденияШаблона цикл
			РезПоискаСтр = ТекВхождение[0];
			//=====================>>>[РазобратьЭлементРезультатаПоискаФР]
			Результат = Новый Соответствие;
			
			ШаблонПоискаНаименования = "onclick="" window.location.assign\('(.*?)'.*<span class=""fn org"".*?>(.*?)<";
			
			
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаНаименования;
			//=====================>>>[НайтиВхожденияШаблона]
			//	ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаНаименования);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				Результат.Вставить("url", ВхожденияШаблона[0][0]);
				СтрокаРезультата.url = ФР + СокрЛП(ВхожденияШаблона[0][0]);
				
				Наим = СокрЛП(ВхожденияШаблона[0][1]);
				Наим = СтрЗаменить(Наим, "&quot;", "");
				СтрокаРезультата.Наименование = Наим;
				Результат.Вставить("NAME", Наим);
			КонецЕсли;
			
			
			ШаблонПоискаИНН = "ИНН&nbsp;(\d+)";
			
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаИНН;
			//=====================>>>[НайтиВхожденияШаблона]
			//	ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаИНН);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				//				Результат.Вставить("INN", ЗаменитьКривыеСимволы(СокрЛП(ВхожденияШаблона[0][0])));
				Результат.Вставить("INN", СокрЛП(ВхожденияШаблона[0][0]));
				СтрокаРезультата.ИНН = СокрЛП(ВхожденияШаблона[0][0]);
			КонецЕсли;
			
			ШаблонПоискаОГРН = "ОГРН&nbsp;(\d+)";
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаОГРН;
			//=====================>>>[НайтиВхожденияШаблона]
			// ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаОГРН);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				//				Результат.Вставить("OGRN", ЗаменитьКривыеСимволы(СокрЛП(ВхожденияШаблона[0][0])));
				Результат.Вставить("OGRN", СокрЛП(ВхожденияШаблона[0][0]));
				СтрокаРезультата.ОГРН = СокрЛП(ВхожденияШаблона[0][0]);
			КонецЕсли;
			
			ШаблонПоискаАдреса = "Адрес:&nbsp;(.*?)<";
			СтрокаПоиска = РезПоискаСтр;
			Шаблон = ШаблонПоискаАдреса;
			//=====================>>>[НайтиВхожденияШаблона]
			// ВхожденияШаблона = НайтиВхожденияШаблона(РезПоискаСтр, ШаблонПоискаАдреса);
			МассивСтрок = Новый Массив;
			RegExp = Новый COMОбъект("VBScript.RegExp");
			RegExp.IgnoreCase = Истина; //Игнорировать регистр
			RegExp.Global = Истина; //Поиск всех вхождений шаблона
			RegExp.MultiLine = Ложь; //Многострочный режим
			
			RegExp.Pattern = Шаблон; 
			Matches=RegExp.Execute(СтрокаПоиска);
			ЧислоВхождений=Matches.Count();
			Если ЧислоВхождений>0 Тогда 
				Для к = 0 По ЧислоВхождений-1 Цикл
					Match = Matches.Item(к);
					
					SubMatches = Match.SubMatches;
					ЧислоПодвыражений=SubMatches.Count();
					
					МассивПодстрок = Новый Массив;
					
					Для н = 0 По ЧислоПодвыражений-1 Цикл
						SubMatch=SubMatches.Item(н);
						Если SubMatch="" Тогда
							Продолжить;
						КонецЕсли;    
						
						МассивПодстрок.Добавить(SubMatch);
						
					КонецЦикла;    
					
					Если МассивПодстрок.Количество() > 0 тогда
						МассивСтрок.Добавить(МассивПодстрок);
					КонецЕсли;
					
				КонецЦикла;
			КонецЕсли;
			
			//=====================<<<[НайтиВхожденияШаблона]
			ВхожденияШаблона = МассивСтрок;	
			
			
			Если ВхожденияШаблона.Количество() > 0 тогда
				//				Результат.Вставить("ADRESTEXT", ЗаменитьКривыеСимволы(СокрЛП(ВхожденияШаблона[0][0])));
				Результат.Вставить("ADRESTEXT", СокрЛП(ВхожденияШаблона[0][0]));
				СтрокаРезультата.Адрес = СокрЛП(ВхожденияШаблона[0][0]);
			КонецЕсли;
			
			
			//=====================<<<[РазобратьЭлементРезультатаПоискаФР]
			//		МассивСтрок.Добавить(РазобратьЭлементРезультатаПоискаФР(РезПоиска));
			МассивСтрок.Добавить(Результат);
		КонецЦикла;
	КонецЕсли;
КонецЕсли;

заполнение таблицы для 4848 строк прошло за 14 минут

Выполнение завершено, обработано 4 848 элементов за 0:13:57 (837 сек). Грубое среднее время обработки элемента - 172,65 мс

Готовый файл для Консоли запросов (ИР) можно скачать ниже.

9

Скачать файлы

Наименование Файл Версия Размер
Заполнение ОГРН с использованием инструментов разработчика:
.sel 23,31Kb
21.04.17
4
.sel 23,31Kb 4 Скачать

Специальные предложения

Избранное Подписка Сортировка: Рейтинг
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Использование HTTP-сервиса для создания "фронтенда" HTML/CSS/jQuery с кэшированием 94

Статья Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) WEB

В статье описан способ создания "фронтенда" на HTML/CSS/jQuery и скрипт кеширования AJAX запросов на PHP.

1 стартмани

06.08.2019    4786    6    Sedaiko    22       

Шаблон http-сервиса для вашего проекта 70

Инструменты и обработки Программист Архив с данными v8 v8::Mobile 1cv8.cf Абонемент ($m) Внешние источники данных WEB Мобильная разработка

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

2 стартмани

04.05.2019    5989    46    MarkoSokolov    47       

1C + Python + Django Rest Framework + Vue.js. Опыт несложной full-stack разработки 121

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Обмен через XML WEB Разработка

В этой статье мы рассмотрим путь и основные моменты создания небольшого вэб-сервиса, который мы называем "Онлайн Прайс-лист". Выгрузка из 1С, бэкенд, фронтенд, получение заказов в 1С.

1 стартмани

22.04.2019    15927    14    riposte    63       

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet 74

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m) WEB

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    8987    51    Ditron    15       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 512

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    25252    243    bonv    108       

Проверка VAT номеров 2

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    3704    wtlz    0       

Работа с публикациями "Инфостарт" 13

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    8234    10    RocKeR_13    12       

SOAP для чайников 86

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Обмен через XML WEB

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    18473    25    dusha0020    18       

HTTP Сервисы: Путь к своему сервису. Часть 1 258

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    35156    15    dsdred    22       

Пример использования REST API Яндекс Диска 33

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    12395    23    MKFreeUser    12       

Обмен файловыми базами данных через Yandex диск 7

Инструменты и обработки no Приложение (exe) v8 Россия Windows Абонемент ($m) WEB

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    9864    6    slimper    1       

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза 69

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    8039    45    Malfarion    14       

Конфигурация для просмотра публичных телеграм каналов 10

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) WEB

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    9912    7    DO_WHILE_LOOP    7       

Автоматическое заполнение графиков в ЗУП 3.1 6

Инструменты и обработки Бухгалтер Архив с данными v8 v8::СПР ЗУП3.x Россия БУ Зарплата Учет рабочего времени Абонемент ($m) Обработка справочников

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    8059    14    notserioussam    1       

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности) 80

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Внешние источники данных WEB

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    16822    113    Ko1t    63       

Простая и пошаговая интеграция Яндекс-Алисы и 1С 76

Инструменты и обработки Программист Конфигурация (md, cf) v8 Windows Абонемент ($m) WEB

Интеграция Алисы и 1С через http сервис на платформе 8.3.9. Используем виртуальный сервер, сертификат от letsencrypt, и делаем простые запросы к базе из Алисы.

1 стартмани

09.04.2018    14868    15    kiv1c    33       

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы) 148

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Внешние источники данных WEB

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    21228    164    Ko1t    50       

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1) 17

Инструменты и обработки Бухгалтер Расширение (cfe) v8 v8::СПР ЗУП3.x БУ Управление персоналом (HRM) Абонемент ($m) Обработка справочников

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    14621    45    charivnick    3       

Внешняя компонента для работы по Web-socket протоколу 21

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент WEB

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

6 стартмани

30.03.2018    12929    9    Ditron    50       

Построение маршрута доставки с расчётом расстояния для любой базы УФ 56

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Оптовая торговля Абонемент ($m) Универсальные обработки WEB

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    18460    36    KorotkovRV    16       

А чё это вы здесь делаете, а? 142

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) WEB

Разработчикам тиражных обработок близка и понятна проблема обратной связи с пользователем. Много важного и полезного можно почерпнуть, зная, что делает бухгалтер, который запустил обработку. В большом мире вэба сбор статистики на сайте дело привычное и даже обязательное. Эта статья покажет практику применения инструментов сбора статистики из мира веба для обработок на платформе 1С:Предприятие.

1 стартмани

21.01.2018    16561    28    infosoft-v    42       

Пример заполнения/создания файла XML из XSD схемы, используя XDTO 128

Статья Программист Документ XML v8 1cv8.cf Абонемент ($m) Обмен через XML WEB

Добрый день, коллеги! Наконец-то дошли руки написать сию статью. Хочу поделиться своим опытом по разбору xsd схемы используя Фабрику XDTO, а также связанным с этим XML файлом. Думаю, наверняка кому-то понадобится.

1 стартмани

21.12.2017    28581    40    sandybaev    23       

Сервер push сообщений “Push0k“ 18.05 12

Инструменты и обработки no Архив с данными v8 1cv8.cf Абонемент ($m) WEB

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    10404    11    PloAl    20       

Проверка орфографии средствами Yandex Speller 77

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Проверка орфографии средствами Yandex Speller с опциями и коррекцией ошибок. Возможность вызова как с сервера, так и с клиента (с последующим исправлением).

1 стартмани

09.11.2017    13065    49    🅵🅾️🆇    38       

Ведение локального каталога обработок с Инфостарт 67

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Обработка наводит порядок в ваших скачанных и локально хранимых обработках с Инфостарта. Это особенно удобно тем коллегам, которые уже скачали немалый объем обработок и хотят получить удобный инструмент навигации по списку.

1 стартмани

06.10.2017    18283    55    rpgshnik    48       

Подсистема Вики - интеграция 1С и сайта под управлением MediaWiki 90

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) WEB

Редактирование статей сайта Mediawiki из 1С. Формирование функционального описания конфигурации на сайте Вики.

1 стартмани

19.09.2017    20516    31    shmalevoz    18       

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2 99

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Оптовая торговля Розничная торговля Ценообразование, анализ цен Абонемент ($m) Обработка справочников Ценообразование, прайсы

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    40068    49    myALKleon    37       

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9 109

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Практика программирования WEB

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    18396    16    Anton64    22       

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации 128

Инструменты и обработки Пользователь Руководитель проекта Архив с данными v8 1cv8.cf БП3.0 КА2 УУ Документооборот и делопроизводство Абонемент ($m) Управление бизнес-процессами (BPM) Обработка документов Обработка справочников

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    36919    218    BlizD    179       

Конструктор-тестер http запросов в 1С 215

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) WEB Инструментарий разработчика

Данная обработка позволяет в несколько кликов конструировать http запросы на языке 1С и просматривать результаты их выполнения.

3 стартмани

19.08.2016    33739    299    hlopik    16       

Легкий интернет-магазин из УТ 11.2 67

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 УТ10 УУ Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка создания интернет-магазина из УТ 11. Создается единственный файл html, который содержит все выгруженные товары. Клиент составляет и отправляет заказ вам на e-mail прямо из браузера, не прибегая к использованию стороннего ПО.

11.08.2016    21814    482    hlopik    36       

Hello world на metadata.js 249

Статья Программист Архив с данными v8 1cv8.cf Абонемент ($m) Инструментарий разработчика WEB Мобильная разработка

Про браузерные offline-first приложения можно написать миллионы слов. Сэкономлю своё и ваше время и перейду сразу к делу. В статье не будет рекламы и агитации за новые технологии, не будет критики традиционных или попсовых решений. Рассмотрим по шагам разработку простейшей программы на metadata.js. Постараюсь сделать акцент не на том «как это сделано», а «почему сделано именно так»

1 стартмани

11.08.2016    47589    115    unpete    205       

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен) 7

Инструменты и обработки Системный администратор Программист Бухгалтер Конфигурация (md, cf) v8 1cv8.cf Беларусь БУ НДС Абонемент ($m) Инструментарий разработчика Внешние источники данных WEB

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    25746    28    c1nil    4       

Работа с Яндекс.Диском (обычная и управляемая форма) 78

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки WEB

Возникла необходимость хранить картинки, а может и другие файлы в Яндекс.Диске? Нет ничего проще, работай с Ядекс.Диском прямо из 1С!

1 стартмани

10.07.2016    20782    145    Xershi    55       

Просмотр данных системы Платон на картах Google 10

Инструменты и обработки Руководитель проекта Внешняя обработка (ert,epf) v8 1cv8.cf Автомобили, автосервисы Транспорт, автопарки, такси Windows Абонемент ($m) Универсальные обработки WEB

Обработка для просмотра предполагаемых треков движения транспортного средства на карте Google согласно данным, предоставляемым системой Платон в формате CSV. Работает под 8.2 и 8.3, обычное и управляемое приложение, может подключаться к типовым конфигурациям в качестве внешней обработки.

1 стартмани

15.04.2016    22882    21    anig99    8       

Трекинг номеров РПО в Почте России 14

Инструменты и обработки Пользователь Архив с данными v8 Оптовая торговля, дистрибуция, логистика Windows Оптовая торговля Абонемент ($m) WEB

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    16586    37    Smaylukk    3       

Номенклатура (Расширенная форма списка) и Корзина [Расширение] 80

Инструменты и обработки Бухгалтер Пользователь Расширение (cfe) v8 БП3.0 Windows Учет ТМЦ Абонемент ($m) Обработка справочников Рабочее место

Красивая, удобная и эргономичная форма списка номенклатуры. В общем списке номенклатуры отображаются и остатки, и цены. А еще есть возможность быстро создать документы по выбранным позициям через корзину.

5 стартмани

29.02.2016    26520    118    mrXoxot    45       

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами 57

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Абонемент ($m) Внешние источники данных WEB Интеграция

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    33191    84    lunjio    15       

Облачный каталог товаров на 1C 40

Инструменты и обработки Программист Архив с данными v8 УТ10 Розница Windows Оптовая торговля Розничная торговля Абонемент ($m) WEB

Поднимите руки те, кто занимается разработкой на 1С. Спасибо, опустите. Поднимите руки те, кто хоть раз писал загрузку прайса из экселя. Я смотрю, все те же. Ладно, а теперь поднимите руки те, кто хоть раз задумывался о каком-то каталоге мастер-данных по товарам. Чуть меньше. А признайтесь, кто из вас свято убежден, что делать этот каталог должен кто-то другой, например, веб-разработчики? Об этом и пойдет речь.

1 стартмани

28.12.2015    20209    31    skif47    42       

Инструмент для создания веб приложений на основе 1С REST сервиса 67

Инструменты и обработки Программист Пользователь Приложение (exe) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика WEB Работа с интерфейсом

Обзор платформы-конструктора для создания веб-приложений, использующих в качестве источника базы данных 1С

1 стартмани

13.10.2015    21378    82    dmzubr    23       

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) 184

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Обработка документов Обработка справочников Загрузка и выгрузка в Excel

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    49902    373    Tatitutu    49