Зябликов Дмитрий | Senior ios developer | ЦРПТ

«Разработка на 1С VS нативная разработка под iOS»

- а такое возможно?:) - плюсы и есть ли минусы - нюансы разработки - путь от начала до публикации приложения

Переработки сотрудников

Отчеты - Бухгалтерские

Отчет предназначен для расчета переработок сотрудников. Наполнение отчета реализовано как в документе "Регистрация переработок".

Отчет Переработки - аналог документа "Регистрация переработок" (Зарплата- Регистрация переработок)  для расчета переработок сотрудников.

 

Удобно использовать для контроля за переработками для сотрудников с суммированным учетом времени. Отчет имеет два параметра - Период, за который рассчитываются переработки и Организация

 

 

Реализован в виде внешнего отчета, который можно подключать как дополнительный отчет в конфигурацию.

 

Отчет формируется программно, функционал отчета создан адаптацией функционала документа "Регистрация переработок".

Учтено возможное использование в рассылке отчетов.

 

Ниже часть кода, в котором можно увидеть, как реализуется  "неотправка" пустого отчета при использовании рассылки отчетов.

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь; 
	Настройки = КомпоновщикНастроек.ПолучитьНастройки(); // настройки отчета 
	ПериодОтчета = 
	КомпоновщикНастроек.ПолучитьНастройки().ПараметрыДанных.Элементы.Найти("ПериодОтчета").Значение;
	
	Организация = 
	КомпоновщикНастроек.ПолучитьНастройки().ПараметрыДанных.Элементы.Найти("Организация").Значение;
	
	ТЗ = Новый ТаблицаЗначений;
	
	Если ЗначениеЗаполнено(Организация) Тогда
		// Получаем список сотрудников, работавших на суммированном учете в этот период.
		
		МассивСотрудников = ЗаполнитьСотрудниковНовый(Организация,ПериодОтчета.ДатаНачала,ПериодОтчета.ДатаОкончания);
		
		ТЗ=РассчитатьСотрудниковНовый(МассивСотрудников,ПериодОтчета.ДатаНачала,ПериодОтчета.ДатаОкончания);
		
	КонецЕсли;		 
	
	Если ТЗ.Количество()>0 Тогда
		
		ДанныеРасшифровки = Новый ДанныеРасшифровкиКомпоновкиДанных;  
		КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;  
		// Инициализирую макет компоновки используя схему компоновки данных 
		// и созданные ранее настройки и данные расшифровки
		СхемаКомпоновкиДанных = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
		МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, 
		Настройки, ДанныеРасшифровки);
		
		// компоновка результата
		ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
		
		ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,
		Новый Структура("Данные", ТЗ), 
		ДанныеРасшифровки);
		
		ДокументРезультат.Очистить();
		
		// Вывод в табличный документ
		ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
		ПроцессорВывода.УстановитьДокумент(ДокументРезультат);	
		ПроцессорВывода.Вывести(ПроцессорКомпоновки);
		
	Иначе
		ДопСвойства=КомпоновщикНастроек.ПользовательскиеНастройки.ДополнительныеСвойства;
		ДопСвойства.Вставить("ОтчетПустой",Истина);
	КонецЕсли;
	
КонецПроцедуры

 

  Проверялась на редакции конфигурации ЗУП 3.1.2.238. Платформа 8.3.9.2170

Скачать файлы

Наименование Файл Версия Размер
Отчет Переработки:
.erf 9,22Kb
19.06.18
25
.erf 9,22Kb 25 Скачать

См. также

Комментарии
1. Dragon Ago (DragonAgo) 8 15.06.18 23:49 Сейчас в теме
Добрый вечер. Формирую отчет, а он пустой. Документом Регистрация переработок пользуемся.
2. Виктор Петрянкин (ВикторП) 108 16.06.18 14:33 Сейчас в теме
За год , как был сделан отчёт, конфигурация поменялась. На следующей неделе выложу отчёт под последний ЗУП.
3. Виктор Петрянкин (ВикторП) 108 19.06.18 09:58 Сейчас в теме
Файл отчета изменил, но, он отличается от файла, который был только итоговой суммой по колонкам.

Тестировался отчет на ЗУП 3.1.6.54. Отличий в данных от документа нет.

Если у вас отчет формирует не те данные, просьба - выложите данные для проверки.
Оставьте свое сообщение