ЭВОТОР: выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ (54ФЗ). 1С: 7.7 ТиС

Публикация № 636217

Разработка - Обмен данными 1С - Загрузка и выгрузка в Excel

Обработка ЭВОТОР выгрузка загрузка 1C:7.7 Торговля и Склад тиС онлайн касса 54 ФЗ

Выгрузка из 1C версии 7.7 ТиС (Торговля и Склад) в EXCEL для дальнейшей загрузки в кассы ЭВОТОР, с помощью обработки обмен через EXCEL ( которая выбирается на сайте ЭВОТОР в магазине приложений). Полная версия без ограничений. Демоверсия позволяет выгружать только 5 строк номенклатуры(группы товаров). Демоверсия обладает такими же характеристиками что и полная за исключением того, что выгружает 5 строк неважно чего группы или номенклатуры (текст обработки зашифрован). Если у вас одна позиция номенклатуры или 5 позиций без групп, тогда Демоверсия для Вас. Если вдруг выскакивает ошибка по запуску обработки попробуйте запустить 1с с правами администратора

Все говорят,  что для работы с новыми кассами система 1C:7.7 не подходит, однако это не так.

Чтобы избежать расходов по переходу на  версию 1С:8.2 или 8.3 , можно по-прежнему оставаться на  1C:7.7 , для этого покупается касса ЭВОТОР  https://evotor.ru/ ,а также выгрузка из 1C:7.7 Торговля и Склад   и при этом не требуется связки 1C:7.7 и кассы.

Касса сама автономно работает в течении дня со сканером штрих кода, а загрузка товара в кассу осуществляется  с помощью выгруженного файла из 7.7 .

Обновление  цен и номенклатуры делается по средством  загрузки файла через web приложение обмен через excel которое доступно первый месяц бесплатно. ( выбирается наш выгруженный файл Excel).

Итого расходы разовые:

 Стоимость кассы ЭВОТОР ( 30 000 р) + Стоимость моей обработки 1C:7.7 2500 р (полная версия) и стоимость приложения (загрузка файлов из Excel) 0 р( первый месяц) = 32750 р.

Ежемесячные расходы за стоимость приложения загрузки файлов=250 рублей( данное приложение доступно в магазине ЭВОТОР).

Возможно внедрение и в другие конфигурации 1C:7.7 за дополнительную плату.

При покупке модуля техническая поддержка 1 месяц  бесплатно.

Гарантированно работает на релизе ТиС 7.70.988( 957)

Причины купить

1) Экономия времени при заливке товаров в кассу особенно если позиций номенклатуры достаточно много.

2) Возможность выбора любого типа цен ( Розничных или других) для этого достаточно выбрать в диалоге.

3) Данная версия обработки успешно протестирована на  действующем предприятии (релиз в ТиС 7.70.988)  ( 957) позиций более 35000 номенклатуры. 

4) Есть возможность протестировать обработку перед покупкой  ( для этого можно скачать демо версию  и компоненты ) и выгрузить  на примере 5 товаров.

Достоинства

Позволяет Вам выгружать номенклатуру, а также  любые цены (розничные или мелкооптовые) в формате Excel для онлайн касс ЭВОТОР.

Для этого выберите тип цены в  диалоге

 

При покупке продукта вы высылаете запрос на почту gevicer.e@mail.ru на получение лицензии.

ВАЖНО . ПЕРЕД ТЕМ КАК СТАРТОВАТЬ ОБРАБОТКУ  НЕОБХОДИМО  ДОБАВИТЬ В ПРОЦЕДУРУ ГЛОБАЛЬНОГО МОДУЛЯ В  Процедура ПриНачалеРаботыСистемы()

СЛЕДУЩИЕ СТРОКИ (выделены жирным и курсивом)

  

Процедура ПриНачалеРаботыСистемы()
    Перем Спр;


    // Выполняется при старте
    // При старте проверяем наличие компоненты "Оперативный учет" 1С:Предприятия

    //Добавляемые строки

   Если ЗагрузитьВнешнююКомпоненту(каталогиб()+"decoder.dll") = 0 Тогда
        Предупреждение("Недоступна компонента ""decoder.dll"".");
    Иначе
    
    КонецЕсли;

//КонецДобавляемыхстрок

Иначе будут сыпаться ошибки что процедура не обнаружена итп.

 

Затем вводите эту лицензию в форму и нажимаете кнопку отправить, а затем кнопку активировать .

После этого вы можете работать с обработкой 

Гарантия возврата денег

ООО "Инфостарт" гарантирует Вам 100% возврат оплаты, если программа не соответствует заявленному функционалу из описания. Деньги можно вернуть в полном объеме, если вы заявите об этом в течение 14-ти дней со дня поступления денег на наш счет.

Программа настолько проверена в работе, что мы с полной уверенностью можем дать такую гарантию. Мы хотим, чтобы все наши покупатели оставались довольны покупкой.

Для возврата оплаты просто свяжитесь с нами.

Скачать файлы

Наименование Файл Версия Размер
ЭВОТОР выгрузка и загрузка в онлайн кассу в соответствии с требованием 54-ФЗ ( 54ФЗ) 1С 7.7 ТиС: демо

.ert 225,85Kb
121
.ert 1.1.1 225,85Kb 121 Скачать бесплатно
Компоненты для работы файла , просто добавить в основной каталог базы

.zip 468,68Kb
87
.zip 468,68Kb 87 Скачать бесплатно

5.1 5 2500 руб.

Моментальная
доставка


0 1000 руб.

0 2000 руб.

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Техподдержка 19.06.17 17:11
Качаем выгрузку в excel файл для кассы Эвотор из 1с 7.7 , она также является полноценной для организаций с небольшим количеством номенклатуры ( до 5 позиций если в корне справочника номенклатуры)
2. Sergant 51 20.06.17 11:13 Сейчас в теме
В Эвоторе есть возможность локальной загрузки файла формата АТОЛ. (Формат простой, выгрузка пишется быстро)
3. Техподдержка 20.06.17 12:06
(2) Для 8ки возможно, никто не спорит, попробуйте для 7.7 и для номенклатуры с 30 тыс позиций
5. 00tv 23.06.17 15:38 Сейчас в теме
Можно ссылку на документацию эвотора ? Искал решение в свое время.
У них ни слова о локальном обмене. Только через облако, REST API. Для 7-ки вообще нету.
Сергей если не трудно, подскажите ? Конкретный пруф можно, а то до дыр их доки зачитал.
Пока данной обработкой пользуемся. Если есть локальный вариант, это сильно выручило бы.
Но даже Эвоторовская Техподдержка сказала, что нет такой возможности. Обманывают наверное.
4. 00tv 23.06.17 15:34 Сейчас в теме
Выручила, 45000 в семерке в торговле. Пара точек. Руками не вариант.
6. Техподдержка 28.06.17 14:38
ВАЖНО . ПЕРЕД ТЕМ КАК СТАРТОВАТЬ ОБРАБОТКУ НЕОБХОДИМО ДОБАВИТЬ В ПРОЦЕДУРУ ГЛОБАЛЬНОГО МОДУЛЯ

Процедура ПриНачалеРаботыСистемы()

СЛЕДУЩИЕ СТРОКИ (выделены жирным и курсивом)

Процедура ПриНачалеРаботыСистемы()
Перем Спр;
// Выполняется при старте
// При старте проверяем наличие компоненты "Оперативный учет" 1С:Предприятия

//Добавляемые строки

Если ЗагрузитьВнешнююКомпоненту(каталогиб()+"decoder.dll") = 0 Тогда
Предупреждение("Недоступна компонента ""decoder.dll"".");
Иначе

КонецЕсли;


//КонецДобавляемыхстрок
7. Oblomovo 12.09.17 10:22 Сейчас в теме
Доброго! Не могу с сайта скачать бесплатно демку. Поддержка сказала звонить на горячую линию, они типа соединят с Вами. Если оффлайн не случиться... Вопросов 2. Как всё таки заполучить демку? Какая обработка из магазина ЭВОТОР работает с Вашей обработкой? У меня 7.7 самописка(((

По обработке ЭВОТОР разобрался, недосмотрел в описании. Вопрос остался по демке, и если всё будет нормально, по покупке
9. Техподдержка 12.09.17 12:40
Добрый день Олег , теперь демо- версия бесплатна, можете ее скачать , если будут вопросы по работе пишите , обработка может работать в любых конфигурациях где есть справочники номенклатуры и типы цен
10. Oblomovo 12.09.17 12:41 Сейчас в теме
Спасибо за оперативность, увидел
12. Oblomovo 12.09.17 13:27 Сейчас в теме
Ну вот где-то так получилось. Куда идти?
Далее, у меня нет мелкооптовых и розничных. Есть только учётная в номенклатуре. На всякий переименовал ее в розничную
Прикрепленные файлы:
13. Техподдержка 12.09.17 18:07
Олег скорее всего у вас нет глобальных функций которые есть в типовой конфигурации ТиС (Торговли и Склад) необходимо их внести в глобальный модуль вашей конфигурации, пишите мне в личку я помогу их внедрить по удаленке , либо поправлю под вашу конфу свою выгрузку

вот что нужно ставить в глобальный модуль

//
//******************************************************************************
//  глПересчет(Сумма,ВалютаНач,ПоКурсуВалютыНач,ВалютаКон,ПоКурсуВалютыКон,ПоКратностиВалютыНач,ПоКратностиВалютыКон)
//
// Параметры:      
//	Сумма                - сумма, которую следует пересчитать
// 	ВалютаНач            - валюта (элемент справочника "Валюты"), из которой считаем
// 	ВалютаКон            - валюта (элемент справочника "Валюты"), в которую считаем
// 	ПоКурсуВалютыНач     - курс или дата курса валюты нач
// 	ПоКурсуВалютыКон     - курс или дата курса валюты кон
// 	ПоКратностиВалютыНач - кратность валюты нач
// 	ПоКратностиВалютыКон - кратность валюты кон
//
// Возвращаемое значение: 
//  Сумма, пересчитанная в другую валюту
//
// Описание: 
// 	Эта функция пересчитывает сумму из ВалютаНач и возвращает значение Сумма в 
// 	ВалютаКон в параметрах ПоКурсуВалютыНач и ПоКурсуВалютыКон могут передаваться
// 	либо сами курсы либо даты
//
Функция глПересчет(Сумма,ВалютаНач,ПоКурсуВалютыНач,ВалютаКон,ПоКурсуВалютыКон,ПоКратностиВалютыНач = 1,ПоКратностиВалютыКон = 1) Экспорт
	
	Если ВалютаНач = ВалютаКон Тогда
		// ну, тут и считать нечего...
		Возврат Сумма;
	КонецЕсли;

	ТипЗн=ТипЗначенияСтр(ПоКурсуВалютыНач);
	
	Если ТипЗн = "Число" Тогда
		КурсВалютыНач      = ПоКурсуВалютыНач;
		КратностьВалютыНач = ПоКратностиВалютыНач;
		КратностьВалютыНач = ?(КратностьВалютыНач = 0,1,КратностьВалютыНач);
		
	ИначеЕсли ТипЗн = "Дата" Тогда
		КурсВалютыНач      = глКурсДляВалюты(ВалютаНач,ПоКурсуВалютыНач);
		КратностьВалютыНач = глКратностьДляВалюты(ВалютаНач,ПоКурсуВалютыНач);
		
	Иначе
		Сообщить("глПересчет():Неверный тип параметра ПоКурсуВалютыНач!");
		Возврат Сумма;
		
	КонецЕсли;

	ТипЗн = ТипЗначенияСтр(ПоКурсуВалютыКон);
	
	Если ТипЗн = "Число" Тогда
		КурсВалютыКон      = ПоКурсуВалютыКон;
		КратностьВалютыКон = ПоКратностиВалютыКон;
		КратностьВалютыКон = ?(КратностьВалютыКон = 0,1,КратностьВалютыКон);
		
	ИначеЕсли ТипЗн = "Дата" Тогда
		КурсВалютыКон      = глКурсДляВалюты(ВалютаКон,ПоКурсуВалютыКон);
		КратностьВалютыКон = глКратностьДляВалюты(ВалютаКон,ПоКурсуВалютыКон);
		
	Иначе
		Сообщить("глПересчет():Неверный тип параметра ПоКурсуВалютыКон!");
		Возврат Сумма;
		
	КонецЕсли;

	Если (КурсВалютыНач = 0) 
	 ИЛИ (КурсВалютыКон = 0) Тогда
		Сообщить("При пересчете валюты обнаружен нулевой курс валюты "
		+?(КурсВалютыНач = 0,ВалютаНач,ВалютаКон));
		Возврат Сумма;
	КонецЕсли;

	Возврат Сумма * ((КурсВалютыНач / КратностьВалютыНач) / (КурсВалютыКон / КратностьВалютыКон));
	
КонецФункции // глПересчет()

//2 фунция

//******************************************************************************
// глОкруглить(Числ, ПорядокОкругления)
//
// Параметры:
//  Числ              - исходное число
//  ПорядокОкругления - элемент перечисления Порядки окгугления: 
//  "шаг" округления (0.01 (арифметическое), 0.01, 0.05, 0.1, 0.5, 1, 5, 10, 50, 100)
//
// Возвращаемое значение:
//  Округленное по заданному порядку значение
//
// Описание:
//  Округляет число вверх по заданному порядку. Т.е число 123.37 при порядке
//  округление 0.5 превратиться в 123.50, а число 0.1 при порядке округления
//  5 станет равным 5.
//  Если значение перечисления ОкрТочно, то округляет арифметически до 0.01
//
Функция глОкруглить(Числ, ПорядокОкругления) Экспорт
	Перем Рез;
	
	Если ПорядокОкругления = Перечисление.ПорядкиОкругления.ОкрТочно Тогда
		
		// арифметическое округление до 2-х знаков после запятой
		Рез = Окр(Числ, 2);
	Иначе
		// округление к верхней границе по заданному порядку
		
		// преобразуем порядок округления число
		Порядок			= Число(Строка(ПорядокОкругления));
		
		// вычислим количество интервалов, входящих в число
		КолвоИнтервал	= Числ / Порядок;
		
		// вычислим целое количество интервалов.
		КолвоИнтервалЦел= Цел(КолвоИнтервал);
		
		Если КолвоИнтервал = КолвоИнтервалЦел Тогда
			// Числа поделились нацело. Округлять не нужно.
			Рез	= Числ;
		Иначе
			Рез	= Порядок * (КолвоИнтервалЦел + 1);
		КонецЕсли;
		
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глОкруглить()

//3 функция


// глВернутьЦену1(Номенклатура, ТипЦены, ДатаЦены, ЦенаЦены, ЕдЦены, ВалЦены, НаценкаЦены, НайденнаяЦена) 
//
// Параметры: 
//  Номенклатура  - элемент справочника "Номенклатура"
//  ТипЦены       - элемент справочника "ТипыЦен"
//  ДатаЦены      - дата, на которую надо получить цену
//  ЦенаЦены      - переменная, которую надо заполнитиь значением (число) полученной цены
//  ЕдЦены        - переменная, которую надо заполнитиь значением 
//                  (элемент справочника Единицы) единицы, за которую дается цена
//  ВалЦены       - переменная, которую надо заполнитиь значением валюты, в которой выражена цена 
//  НайденнаяЦена - переменная, которую надо заполнить найденным элементом справочника цен
//
// Возвращаемое значение:
//  1 - если есть такая цена, пераметры цены заполнены
//  0 - нет такой цены
// -1 - есть только цены, помеченные на удаление
//
// Описание:
//  Формирует ценовые характеристики номенклатурной единицы по заданному типу цен. 
//
Функция глВернутьЦену(Номенклатура, ТипЦены, ДатаЦены = 0, ЦенаЦены = 0, ЕдЦены = 0, ВалЦены = 0, НаценкаЦены = 0, НайденнаяЦена = 0) Экспорт
	Перем ЦеныНоменклатуры;
	Перем Рассчетная;
	Перем НужныйТипЦен;
	Перем ЕстьУдаленные;
	
	
	Рез = 1;
	НайденнаяЦена = ПолучитьПустоеЗначение("Справочник.Цены");
	
	Если ПустоеЗначение(ДатаЦены) = 1 Тогда
		ДатаЦены = РабочаяДата();
	КонецЕсли;
	
	// Найдет или нужную цену в справочнике
	// если она рассчитывается, то найдем базовую цену 
	Рассчетная		= ТипЦены.Рассчитывается;
	НужныйТипЦен	= ?(ПустоеЗначение(Рассчетная) = 1, ТипЦены, ТипЦены.БазовыйТипЦен);
	
	ЦеныНоменклатуры= СоздатьОбъект("Справочник.Цены");
	ЦеныНоменклатуры.ИспользоватьВладельца(Номенклатура); 
	ЦеныНоменклатуры.ВыбратьЭлементы();
	
	Пока ЦеныНоменклатуры.ПолучитьЭлемент()  = 1 Цикл    
		Если ЦеныНоменклатуры.ТипЦен <> НужныйТипЦен Тогда
			Продолжить;
		КонецЕсли;
		
		НайденнаяЦена = ЦеныНоменклатуры.ТекущийЭлемент();
		
		Если ЦеныНоменклатуры.ПометкаУдаления() = 1 Тогда
			Рез = - 1; // Цена есть, но помечена на удаление
			Продолжить;
		Иначе
			Прервать;
		КонецЕсли;
		
	КонецЦикла;       
	
	Если ПустоеЗначение(НайденнаяЦена) = 1 Тогда
		
		// Нет такой цены
		Возврат 0;
	КонецЕсли;
	
	// Заполним все ценовые характериситики 
	
	// если не задана единица цены на эту дату, то потом придется обрабатывать случай нулевого коэффициента у  пустой единицы
	ЕдЦены		= НайденнаяЦена.Единица.Получить(ДатаЦены); 
	
	Если ПустоеЗначение(Рассчетная) = 1 Тогда 
		
		//Если цена не рассчитывается
		ЦенаЦены	= НайденнаяЦена.Цена.Получить(ДатаЦены);
	    //Рез=ЦенаЦены;
		// элемент справочника существует Валюту и Наценку возьмем из него
		ВалЦены		= НайденнаяЦена.Валюта;
		НаценкаЦены	= НайденнаяЦена.Процент;
	Иначе
		//Если цена рассчитывается
		БазоваяЦена 	= НайденнаяЦена.Цена.Получить(ДатаЦены);
		БазоваяВалюта	= НайденнаяЦена.Валюта;
		
		// Цены у базового типа могут отличаться
		ЦенаЦены    = глПересчет(БазоваяЦена, БазоваяВалюта, ДатаЦены, ТипЦены.Валюта, ДатаЦены);
		ЦенаЦены    = глОкруглить(ЦенаЦены * (100 + ТипЦены.Процент) / 100, ТипЦены.ПорядокОкругления);
	    
		// элемент справочника Цены не существует (расчетный). Валюту и Наценку возьмем из типа цены
		ВалЦены		= ТипЦены.Валюта;
		НаценкаЦены	= ТипЦены.Процент;
	КонецЕсли;
	
	Возврат Рез;
КонецФункции // глВернутьЦену()
Показать
Oblomovo; +1 Ответить
14. Oblomovo 25.09.17 09:27 Сейчас в теме
Спасибо огромное!!! За сутки адаптировать свою обработку к нашей "самописке" - громадный респект. Выгрузили уже несколько раз, всё прекрасно работает. Но.. есть и пожелания - выдать дерево номенклатуры, хотя бы первого уровня, есть группы, которые не участвуют в рознице, приходится удалять их вручную из Excel файла
15. Техподдержка 25.09.17 09:43
(14) Олег обращайтесь, рад что вам помог, в следующем релизе выпущу с деревом номенклатуры
16. user943592 27.03.18 09:13 Сейчас в теме
Добрый день! Выгрузка справочника номенклатура из 1С в Эвотор есть, это понятно. Непонятно есть ли загрузка продаж за день в 1С: ТиС 7.7 9.2 ?
17. user945894 29.03.18 23:34 Сейчас в теме
Добрый день! Насколько я понял информация из 1с переносится в эвотор. а именно? Количество и наименование товара по каждому складу и фирме? Справочник контрагенты ? И можно ли потом автоматически залить продажи с эвотора в 1с при наличии 2 фирм и 3 магазинов?
18. Техподдержка 18.04.18 09:21
(17)
я понял информация из 1с переносится в эвотор. а именно? Количество и наименование товара по каждому складу и фирме? Справочник контрагенты ? И можно ли потом автоматически залить продажи с эвотора в 1с при наличии 2 фирм и 3 магазинов?

Добрый день , в данный момент , реализована только выгрузка справочника номенклатуры с ценой , без учета складов и фирмы, если нужен такой функционал то добавим в следующей версии, загрузка будет реализована в другой обработке.
19. oops! 18.05.18 12:46 Сейчас в теме
(18) На счет необходимости складов и фирмы в самом Эвоторе - вопрос спорный. А вот есть ли возможность выгрузить туда остатки по конкретному складу/фирме, и осуществлять реализацию с контролем остатков? Кроме того, безусловно, без загрузки продаж из Эвотора в 1С в конце дня вся эта автоматизация не имеет никакого смысла, и в связи с этим, вопрос: когда ждать? По срокам - запуститься надо не позже 01.07.2018...
20. Техподдержка 19.05.18 00:13
(19) Егор , следущий релиз планирую выпустить после 25 мая , с учетом выгрузки остатков по складам, вы конечно понимаете что формируется файл эксель с готовыми остатками а затем его подгружаем через обмен через эксель в облаке эвотора, загружать продажи так же, выгрузка из облака в файл эксель и дальше уже загрузка реализаций в 1с, но тут встает вопрос грузить реализацию одну за 1 день или создавать множество в зависимости от количества продаж

Также планирую выпустить выгрузку под 8ку , конфигурации 1с Розница версия 1.0 ( уже опробована на 1 магазине выгружено более 140 тыс номенклатурных позиций) если кому интересно. ( постараюсь выпустить побыстрее) и по Управление торговлей 10.3 ( опробована также на предприятии)
21. oops! 20.05.18 01:08 Сейчас в теме
(20) Что ж, тогда ждём 25 мая. Я со 2-го июня в отпуске, до 29-го июня, - надеюсь, мне хватит времени на обкатку ;). Здесь сразу же вопрос - повлияют ли доработки функционала на стоимость решения?
На счёт в каком варианте грузить реализацию - тут ответ, на мой взгляд, вполне очевиден - загрузка реализации происходит в конце смены, и, по сути, грузится "Отчет ККМ", который в случае режима работы типа "фискальный регистратор" формируется с помощью обработки "Закрытие смены", которая все "чеки ККМ" удаляет, перенося данные из них в "Отчет ККМ".
Единственный здесь нюанс я вижу, так это то, что стандартная версия ТиС 9.2 не поддерживает работу с эквайринговыми терминалами, но сейчас практически не осталось розничных точек, где бы не было этих терминалов, и, к Эвотору, pin-pad также подключается. К примеру, Сбербанк сейчас вообще продаёт свои комплекты - касса Эвотор 7.3 + их pin-pad, и на обоих устройствах логотипы Сбербанка. В связи с этим очень бы хотелось хотелось, чтобы все продажи за наличный расчёт собирались в документ "Отчет ККМ", а все остальные продажи (варианты оплаты по платежной карте, кредиту) отдельно собирались в один документ "Реализация (розница)".
22. user1006119 29.06.18 08:37 Сейчас в теме
Доброе утро, ситуация следующая: работаем в унф облачной, продажи оптом но физ лицам, оплачивают по банку по счетам, но обязали на эти продажи пробивать чеки, ассортимент огромный в счете может быть и 100 позиций, есть ли возможность не дублировать продажу из 1с в эвотор, а выгрузить только ее в эвотор и пробить чек? Спасибо заранее за ответ.
23. Техподдержка 02.07.18 16:23
(22)
плачивают по банку по счетам, но обязали на эти продажи пробивать чеки, ассортимент огромный в счете может быть и 100 позиций, есть ли возможность не дублировать продажу из 1с в эвотор, а выгрузить только ее в эвотор и пробить чек? Спасибо заранее за ответ.

Людмила читайте внимательно, что делает обработка, она делает выгрузку из 1с товаров с ценами в эксель для того чтобы вы загрузив этот файл, работали с эвотором отдельно, выгрузить можно продажи из 1с , но вот загрузить в кассу)) вряд ли , смысл онлайн кассы тогда в чем
24. CheBurator 3440 29.05.20 00:06 Сейчас в теме
Еще бы в самом Эвоторе чтобы была возможность как-нибудь сканером прощелкать-проверить поступление товара на точку...
Попробовал с Эвотором поработать - как автономная касса на автономном месте где ничего более как 1.загрузить товары в кассу. 2. пробивать товар по кассе - норм. Чуть более расширенный вариант - надо искать приложения, они все мутные... без головняка на базе Эвотор вменяемой автоматизации мелкой торговой точки не сделать. ну, может Эвотор для этого и не предназначен... ва вот.. если мобильное приложение бы...
25. user1041091 04.02.21 10:57 Сейчас в теме
Ошибка при создании объекта из компоненты C:\1С_Bases\ComplexKIT\mxl_doctor.dll (отсутствует CLSID)

Отстутствует ВК (внешняя компонента) <MXL_DOCTOR>, необходимая для работы программы!
ВК <MXL_DOCTOR> можно скачать здесь: http://www.infostart.ru/projects/323/download.php?file=808

библиотека в корне базы есть!
26. user1041091 04.02.21 11:13 Сейчас в теме
Ошибка при создании объекта из компоненты C:\1С_Bases\ComplexKIT\mxl_doctor.dll (отсутствует CLSID)

Отстутствует ВК (внешняя компонента) <MXL_DOCTOR>, необходимая для работы программы!
ВК <MXL_DOCTOR> можно скачать здесь: http://www.infostart.ru/projects/323/download.php?file=808
Оставьте свое сообщение

См. также

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями в ФЗ от 01/07/19 Промо

Инструментарий разработчика Разработка внешних компонент WEB Кассовые операции ККМ Кассовые операции Фискальный регистратор Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия БУ УУ Платные (руб)

FR_ATOL_SHTRIH.EXE встраивается в SYSTRAY (в правом нижнем углу, там где часы) и следит за появлением обычного текстового файла, в котором перечислено, какие операции необходимо осуществить с ККТ - напечатать чек (нал/безнал), снять Z-отчет, осуществить выемку денег, сделать возврат и т.д. Такой механизм позволяет использовать комплект для WEB сайтов, для нетиповых или сильно измененных 1с7 или 1с8. Для любых программ, которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые к использованию обработки для 1с8: УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1С7.7:ТиС документ Реализация ТМЦ,Печать из ПКО, Бух4.5, Бух1.3 . Код на 1с открыт - используйте обработки комплекта, как шаблоны для своих программ. Подключать ККМ к 1С не надо! Более 300 внедрений на ККМ Штрих и Атол. Некоторые из покупателей реализовали работу с ККМ даже из Excel и Axapta.

1500 руб.

31.07.2017    72539    268    489    

Обработка обслуживания ККТ АТОЛ, платформа 5.0 с драйверами v10 для 1С:Торговля и Склад 9.2 (частичные оплаты по ОФД 1.1, эквайринг Сбербанк)

Розничная торговля ККМ Оптовая торговля Эквайринг v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия УУ Платные (руб)

Данная обработка предназначена для работы с ККТ АТОЛ на платформе 5.0 с драйверами АТОЛ версии 10.7.0.0 и выше для 1С:Торговля и Склад 9.2. Проста в установке и настройке. В поставку включена поддержка эквайринга на уровне драйверов (в данный момент – Сбербанк), реализован учет частичных оплат по ОФД 1.1, добавлены эмуляторы кассы и эквайрингового терминала.

1000 руб.

20.08.2020    4530    19    23    

Контроль онлайн ККМ (онлайн ККТ) (для платформы 7.7)

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md Платные (руб)

Обработка позволяет проверить, что в данный момент передано онлайн ККМ оператору фискальных данных и ИФНС, если ваш ОФД - ofd.ru (Общество с ограниченной ответственностью «ПЕТЕР-СЕРВИС Спецтехнологии»). Удобно использовать для контроля торговых точек оснащенных онлайн ККМ, особенно, если их несколько. В любой момент времени можно получить текущее состояние продаж по кассе, вплоть до состава последнего чека (при условии устойчивой связи ККМ с ОФД).

1000 руб.

27.06.2017    14173    0    6    

Работа с онлайн-кассой Википринт Viki Print 57Ф из 7.7

ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия БУ УУ Платные (руб)

Работа с кассами Википринт (производитель DreamKas) и Пирит из конфигураций под платформу 1С 7.7

3500 руб.

24.04.2017    33527    135    139    

Подключаем онлайн кассу Атол к 1С 7.7 Для драйвера DTO-8 (не 10!)

ККМ Кассовые операции Кассовые операции v7.7 1cv7.md Россия Платные (руб)

Для тех, у кого остались не типовые конфигурации или сильно доработанные. Не все заказчики согласны платить за перенос конфигурации c V1С 7.7  на V1С 8 в связи с новым применением ККМ нового поколения ( 54-ФЗ ). Код обработки полностью открыт, поэтому разработчику не составит труда использовать методы данной обработки для привязки фискального регистратора Атол любых моделей к конфигурации Заказчика.

1000 руб.

31.03.2017    38063    29    36    

Загрузка документов "Поступление", "Отгрузка", "Счет на оплату" из Excel в Бухгалтерию 7.7

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля Оптовая торговля v77::БУ 1С7:Бух БУ Платные (руб)

Обработка загружает из файла Excel документы "Поступление", "Отгрузка", "Счет на оплату". Возможно сохранение настройки соответствия полей. Есть демоверсия. Есть интересная функция загрузки сразу и поступления, и отгрузки (цены в отгрузке будут установлены больше на выбранный процент). Элементы номенклатуры ищутся по полям поиска и могут создаваться новые, если не найдены.

7800 руб.

02.06.2015    30695    3    5    

Загрузка номенклатуры в справочник и документ из файла Excel и CSV, обновление цен и реквизитов (адаптируется под разные конфигурации 1С: 7.7)

Загрузка и выгрузка в Excel Обработка справочников Обработка документов Внешние источники данных Оптовая торговля Розничная торговля Ценообразование, анализ цен Оптовая торговля Розничная торговля Ценообразование, анализ цен v7.7 1cv7.md УУ Платные (руб)

Загрузка номенклатуры в справочник и документ, обновление цен, реквизитов, подчинённых справочников из файла Excel и CSV в 1С7.7. Формирует структуру групп (иерархию), создаёт полностью готовый справочник. Выгружает товары прайс-листа в документы Поступление, Реализация, Заказ, Оприходование, Отчет ККМ и другие. Автоматически адаптируется под разные конфигурации 1С7.7, в которых есть справочник номенклатуры.

1500 руб.

04.12.2014    61412    32    56    

Консолидация, анализ данных в учетных системах.

Загрузка и выгрузка в Excel Обмен через XML v77::ОУ v77::БУ 1cv7.md Россия УУ Платные (руб)

Программа предназначена для консолидации в единой программе данных из других базы данных 1С (7.Х / 8.Х), EXCEL, XML. Бизнес - процессы - как в текущей базе, так и встраиваемые во внешние учетные системы. Анализ данных в различных разрезах.

6000 руб.

09.08.2012    15244    0    3    

Загрузка справочников в 1С (7.7) из Excel, OpenOffice, 1C (обработка)

Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel 1С7.7<->1C7.7 v7.7 1cv7.md Платные (руб)

Универсальная обработка, предназначенная для загрузки справочной информации в программу 1С:Предприятие 7.7 из файлов различных типов: Excel, OpenOffice, 1C. Позволяет загрузить объемную информацию о товарах, материалах, контрагентах, а также заполнить прочие справочники системы. Не ограничена какой-то конкретной конфигурацией и может быть использована на любой платформе 1С (7.7) c использованием имеющихся приложений: 1С, Excel, OpenOffice.

1500 руб.

09.09.2010    62020    17    27    

Загрузка документов в 1С (7.7) из табличных файлов Excel,OpenOffice,1C,DBF,TXT (обработка)

Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel 1С7.7<->1C7.7 v7.7 1cv7.md Платные (руб)

Обработка решает поставленную задачу по вводу документов, а кроме того обладает важной функцией: настраивается на ассортимент конкретного поставщика, запоминая соответствие между его номенклатурой и «нашей». Т.е. фактически – является самообучающейся системой ввода накладных. У разных поставщиков могут быть накладные различного типа, с разным количеством полей, поэтому для каждого из них может быть сохранена своя собственная настройка диалоговой формы так, что любая поступающая накладная может быть обработана. По отношению к программе "1С:Предприятие 7.7" данное решение является внешними файлами. Для использования данного продукта не требуется вносить изменения в алгоритм существующих программ или используемых конфигураций.

1500 руб.

10.12.2009    66183    53    93    

Прайс-органайзер 7.7: Загрузка прайс-листов и документов произвольного формата из Excel в 1С

Оптовая торговля Учет ТМЦ Ценообразование, анализ цен Загрузка и выгрузка в Excel Оптовая торговля Учет ТМЦ Ценообразование, анализ цен v77::ОУ 1С7:ТиС Россия Платные (руб)

Комплекс «Прайс-органайзер» позволяет прочитать и занести в базу программы 1С:Торговля и склад 7.7 прайс-листы, приходные накладные произвольного формата от поставщиков. Инструмент прост в использовании и позволяет очень эффективно повысить производительность труда товароведов, менеджеров, операторов склада. Работа с «Прайс-органайзером» построена в форме диалога, поэтому настройка и использование не вызовет трудностей. Программа снабжена подробным, иллюстрированным описанием. На фирмах, где используется в работе прайс-органайзер, операторы сообщали, что он позволял обрабатывать список товаров в несколько тысяч наименований в течение одного часа. Победителями бесплатного розыгрыша двух комплектов программы "Прайс-органайзер" стали Konditer и chaus. отчет о прохождении акции - здесь: http://infostart.ru/blogs/1099/

2000 руб.

01.06.2009    29956    4    117    

RayCon ® Financial Reporter - Генератор отчетов из 1C 7.7 в MS Excel в режиме онлайн

Загрузка и выгрузка в Excel Учет доходов и расходов Учет доходов и расходов v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ Россия БУ УУ Платные (руб)

Генератор отчетов RayCon ® Financial Reporter предназначен для построения бухгалтерской отчетности в MS Excel по любому плану счетов. Например, это может быть корпоративный план счетов (МСФО, US GAAP, управленческий) или же изменённый российский план счетов. Отчеты формируются в режиме реального времени на основании данных, получаемых из программы «1С:Бухгалтерия 7.7» в соответствии с формулами языка «1С 7.7».

5000 руб.

18.02.2009    17749    0    7