Доработка Розницы 1 ред. под использование онлайн-касс

Оборудование - ККМ

Для тех, кто использует первую редакцию Розницы, не существует типовой возможности подключения онлайн-касс, и это прискорбно! На сайте ИТС указаны рекомендации по доработке конфигураций. В соответствии с этими рекомендациями и выполнена данная работа.

Использовался актуальный на момент публикации релиз розницы - 1.0.19.16. Все изменения в тексте выделены комментариями вида "//++ок". Изменений в диалоговых частях почти нет - исключение обработка "ТОНастройка". Новые объекты префиксами не выделены, считаю так удобнее.  

Доработка размещена в виде файла "CF" и устанавливается через стандартное "Сравнить объединить с конфигурацией из файла" в режиме конфигуратор. Для корректной работы требуется установить кассу через помощник подключения ТО, где добавлены соответствующие разделы. Каждый день требуется создавать документ Кассовая смена и в конце дня закрывать его. Открытие/закрытие кассовой смены доступно как из списка документа "Кассовая смена", так и из меню РМК.

Работа тестировалась только на одном магазине,  так что в теории могут быть и косяки. Если кто-нибудь обнаружит проблемы, постараюсь оперативно исправить.

upd. Исправлены ошибки.

Скачать файлы

Наименование Файл Версия Размер
Доработка Розницы 1 ред. под использование онлайн-касс:
.cf 27,22Mb
04.07.17
16
.cf 27,22Mb 16 Скачать

См. также

Комментарии
1. Seva __ (seva1405) 25 09.07.17 20:38 Сейчас в теме
Не работает. При попытке запустить РМК пишет
{ОбщийМодуль.РаботаСТорговымОборудованием.Модуль(861)}: Метод объекта не обнаружен (ДополнитьМассив)
ОбщегоНазначенияКлиентСервер.ДополнитьМассив(МассивТО, МассивПоВиду);

Функция ПолучитьЭлементТО(ВидТО, ТекстЗаголовкаВыбора, СообщениеНеПодключен, Отбор = Неопределено)  Экспорт
	
//++ок
//заменено
	//МассивТО = ПолучитьСерверТО().ПолучитьСписокУстройств(ВидТО);

	//Если МассивТО.Количество() = 0 Тогда
	//	ЭлементТО = Неопределено;
	//	Если Не ТихийРежим Тогда
	//		Предупреждение(СообщениеНеПодключен);
	//	КонецЕсли;
	//ИначеЕсли МассивТО.Количество() = 1 Тогда
	//	ЭлементТО = МассивТО[0];
	//Иначе
	//	ЭлементТО = ПолучитьСписокУстройствТОДляВыбора(МассивТО).ВыбратьЭлемент(ТекстЗаголовкаВыбора);
	//	Если ЭлементТО <> Неопределено Тогда
	//		ЭлементТО = ЭлементТО.Значение;
	//	КонецЕсли;
	//КонецЕсли;
//на	
	Если ТипЗнч(ВидТО) = Тип("Массив") И ВидТО.Количество() > 1 Тогда
		МассивТО = Новый Массив();
		Для Каждого Элемент Из ВидТО Цикл
			МассивПоВиду = ПолучитьСерверТО().ПолучитьСписокУстройств(Элемент, Отбор);
			ОбщегоНазначенияКлиентСервер.ДополнитьМассив(МассивТО, МассивПоВиду);
		КонецЦикла;
	Иначе
		МассивТО = ПолучитьСерверТО().ПолучитьСписокУстройств(ВидТО, Отбор);
	КонецЕсли;

	Если МассивТО.Количество() = 0 Тогда
		ЭлементТО = Неопределено;
		Предупреждение(СообщениеНеПодключен);
	ИначеЕсли МассивТО.Количество() = 1 Тогда
		ЭлементТО = МассивТО[0];
	Иначе
		ЭлементТО = ПолучитьСписокУстройствТОДляВыбора(МассивТО).ВыбратьЭлемент(ТекстЗаголовкаВыбора);
		Если ЭлементТО <> Неопределено Тогда
			ЭлементТО = ЭлементТО.Значение;
		КонецЕсли;
	КонецЕсли;
//--ок	

	Возврат ЭлементТО;

КонецФункции // ПолучитьТО()
Показать


Автор, подскажи как исправить ошибку?
2. Seva __ (seva1405) 25 09.07.17 20:39 Сейчас в теме
В "ОбщегоНазначенияКлиентСервер" нет функции "ДополнитьМассив", у вас действительно работает?
3. Виталий Дульцев (bestsader) 27 09.07.17 22:19 Сейчас в теме
В рабочей базе были свои доработки и их я снес, попутно снес и функцию "Дополнить массив" которую я добавил из УТ 10.3. Извините, так получилось. Попутно исправил еще несколько косяков. Файл исправлен и заменен.
4. Seva __ (seva1405) 25 09.07.17 22:43 Сейчас в теме
5. Федор Шиморин (fvshimorin) 17.07.17 12:37 Сейчас в теме
Какое решение мне взять

"ФЗ-54. Обработки для ККТ Он-лайн. Подключение фискальных регистраторов "АТОЛ: Драйвер ККМ v.8.12", "ШТРИХ-М: Драйвер ККМ v 4.13", "ВИКИ: Драйвер CSI v 1.0" для "УТ 10.3", "КА 1.1", "УПП 1.3", "Розница 1.0", "Ресторан 2.2"."

или

Доработка Розницы 1 ред. под использование онлайн-касс

У нас розница 1.0 19.16
6. Федор Шиморин (fvshimorin) 17.07.17 12:39 Сейчас в теме
Забыл сказать ККТ Атол 30ф
7. Федор Шиморин (fvshimorin) 17.07.17 13:39 Сейчас в теме
8. Виталий Дульцев (bestsader) 27 17.07.17 15:53 Сейчас в теме
(7) Достаточно чего то одного. У меня весь код, по возможности, скопирован из УТ 10.3. Соответственно и работать будет также как и в 10.3. Про перечисленные обработки ничего сказать не могу, пока не использовал.
9. Федор Шиморин (fvshimorin) 18.07.17 14:23 Сейчас в теме
При открытии обработки AtoKKm выскакивает ошибка отправить отчет и закрывается 1с
10. Федор Шиморин (fvshimorin) 18.07.17 16:19 Сейчас в теме
Ошибка выскакивает при открытии параметры или параметры фискализации
Устанавливал драйвера Атола 8.14.0.0 и 8.14.2.2 куда только не регистрировал FprnM1C82_54FZ.dll и все равно тоже самое
11. Федор Шиморин (fvshimorin) 18.07.17 16:21 Сейчас в теме
Вот ошибка
Прикрепленные файлы:
12. Виталий Дульцев (bestsader) 27 18.07.17 22:51 Сейчас в теме
Я так понимаю, дело не в обработке. Скорее проблема в компоненте или правах пользователя ОС. Попробуйте платформу переставить, кэш почистить. Для чистоты эксперимента, можно еще УТ 10.3 поставить демо-базу и в ней проверить.

Тест драйвера запускается?
13. Федор Шиморин (fvshimorin) 19.07.17 13:16 Сейчас в теме
(12)Тест проходит продажа из теста чек печатает норм. Какую лучше платформу поставить?
14. Федор Шиморин (fvshimorin) 19.07.17 13:54 Сейчас в теме
Кеш почистил, платформу поставил последнюю и все равно такая ошибка
15. Виталий Дульцев (bestsader) 27 19.07.17 20:07 Сейчас в теме
(14)Попробуйте прицепить торговое оборудование как фискальный регистратор, а лучше поставте УТ 10.3 демо базу и попробуйте там прицепить онлайн-кассу. Так мы точно будем знать в каком месте проблема.
16. d (belyavsky) 2 09.08.17 11:55 Сейчас в теме
А какие обработки обслуживания для такой розницы использовать?
17. Виталий Дульцев (bestsader) 27 09.08.17 14:54 Сейчас в теме
(16) Такме же как и для УТ 10.3. Тестировал на атоловских и штрихэмовских драйверах
18. aleksandr S (salexio) 29.08.17 00:49 Сейчас в теме
Автор, Прошу написать все новые объекты, и изменения в Диалогах, так как буду накладывать на РОЗНИЦУ1.0 МАГАЗИН ОДЕЖДЫ И ОБУВИ.если есть возможность также выслать мне типовую конфу розницы с которой вы начинали работать, что бы сравнить. salexio@list.ru
А может кто уже пытался наложить на МАГАЗИН ОДЕЖДЫ И ОБУВИ??
20. Виталий Дульцев (bestsader) 27 29.08.17 06:21 Сейчас в теме
(18)
Можно просто загрузить CF в пустую базу и сравнить с конфигурацией поставщика. CF-ник содержит информацию о конфигурации поставщика.
22. Виталий Дульцев (bestsader) 27 29.08.17 06:38 Сейчас в теме
(18)
А может кто уже пытался наложить на МАГАЗИН ОДЕЖДЫ И ОБУВИ??

Для этой конфигурации придется переделывать много. Мне тоже нужно будет допилить магазин одежды и обуви. Могу помочь это проделать, но только на след. неделе, сейчас аврал.
23. aleksandr S (salexio) 29.08.17 09:19 Сейчас в теме
(22)
Могу помочь это проделать, но только на след. неделе, сейчас аврал.

Спасибо!! попробую начать, но думаю за помощью обращусь..
19. Александр Лаптев (SaschaL) 29.08.17 06:00 Сейчас в теме
А почему бы просто не обновить Розницу до актуального, правда придется делать переход на версию 2, а там у многих пользователей вылазиют ошибки при конвертации, вызванные кривыми настройками и ранее не корректно введенными документами.
21. Виталий Дульцев (bestsader) 27 29.08.17 06:29 Сейчас в теме
(19)Косяки с конвертацией, не такая и проблема. В основном это сделано для тех, у кого свои существенные изменения в рознице имеются. Да и пользователей переучивать не всегда просто. Многих первая редакция устраивает на все 100% и они не хотят менять свои привыччки, просто не видят в этом смысла.
24. aleksandr S (salexio) 30.08.17 20:00 Сейчас в теме
Атол 30ф видит:
Через ручное управление в параметрах фискализации при нажатии на отчет о состоянии выдает:
Номер смены: 3
Номер документа: 12
Статус смены: Открыта
Текущая дата: 30.08.2017 20:42:44
КоличествоНепереданныхФД: 0
НомерПервогоНепереданногоФД:
ДатаПервогоНепереданногоФД:

но при нажатии открыть смену или закрыть или отчет о текущем состоянии расчетов ругается:

Ошибка вызова метода <ОбъектДрайвера.ОтчетОТекущемСостоянииРасчетов>.
Недостаточно фактических параметров
Ошибка вызова метода <ОбъектДрайвера.ОткрытьСмену>.
Недостаточно фактических параметров


и еще вопрос "ПолучитьПарольАдминистратораККМ" от куда??
Прикрепленные файлы:
25. aleksandr S (salexio) 30.08.17 20:24 Сейчас в теме
забыл написать что драйвер 9.11.0.5549
Атол версии 8.15
обработка ATOLkkt.epf
26. Виталий Дульцев (bestsader) 27 30.08.17 20:32 Сейчас в теме
(25) Я так понял, тут проблема с свовместимостью драйвера и обработки. Пароль администратора обычно пустой или 30, точно не помню.
27. aleksandr S (salexio) 30.08.17 21:20 Сейчас в теме
Автор, Что посоветуете?
я конечно ее на магазин одежды наложил, там 19 версий небыло, ложил на 16. много модулей уже не тех. но вроде "добился ".
какой драйвер взять??
28. Дмитрий Тюрин (meps) 54 01.09.17 16:37 Сейчас в теме
не могу выбрать обработку, с сайта обновлений 1с скачал обработку ккт штрих, но он его не воспринимает, при добавлении не видит, где взять обработку?
29. aleksandr S (salexio) 02.09.17 21:11 Сейчас в теме
(28) а справочник ТО обновили?? с сайта или из каталога, с этим вообще проблем не должно быть.
30. Рузэль Чурагулов (kazakkk) 03.10.17 09:58 Сейчас в теме
У кого-нибудь еще, кроме автора, эта доработка заработала?
Оставьте свое сообщение