Проверка ИНН Сотрудников России

Публикация № 65951

Учет и отчетность - Зарплата

0
Проверка ИНН Сотрудников
	 Функция ОстатокОтДеления(Делимое, Делитель);
  
    Возврат Делимое - Делитель * Цел(Делимое / Делитель);
  
КонецФункции

Процедура ПроверкаИНН(ВходИНН)
  
    Перем МассИНН[12];
    Перем ДляРасчета[11];
    Перем Сумма_;
    Перем Остаток;
    Перем Флаг;
    Флаг = 0;
  
    Для Сч = 1 По 12 Цикл
        МассИНН[Сч] = 0;
        Если Сч < 12 Тогда
            ДляРасчета[Сч] = 0;
        КонецЕсли;
        МассИНН[Сч] = Число(Сред(ВходИНН, Сч, 1));
    КонецЦикла;
    ДляРасчета[1]    = МассИНН[1]    * 7;
    ДляРасчета[2]    = МассИНН[2]    * 2;
    ДляРасчета[3]    = МассИНН[3]    * 4;
    ДляРасчета[4]    = МассИНН[4]    * 10;
    ДляРасчета[5]    = МассИНН[5]    * 3;
    ДляРасчета[6]    = МассИНН[6]    * 5;
    ДляРасчета[7]    = МассИНН[7]    * 9;
    ДляРасчета[8]    = МассИНН[8]    * 4;
    ДляРасчета[9]    = МассИНН[9]    * 6;
    ДляРасчета[10]    = МассИНН[10]    * 8;
    Сумма_ = 0;
    Для Сч = 1 По 10 Цикл
        Сумма_ = Сумма_ + ДляРасчета[Сч];
    КонецЦикла;
    Остаток = ОстатокОтДеления(Сумма_, 11);
    Если Остаток = 10 Тогда
        Остаток = 0;
    КонецЕсли;
    Если Остаток = МассИНН[11] Тогда
        Флаг = 1;
    Иначе
        Сообщить("ИНН не верен! Исправьте! (первая контрольная цифра не верна)");
        Возврат ;
    КонецЕсли;
    Если Флаг = 1 Тогда
        ДляРасчета[1]    = МассИНН[1]    * 3;
        ДляРасчета[2]    = МассИНН[2]    * 7;
        ДляРасчета[3]    = МассИНН[3]    * 2;
        ДляРасчета[4]    = МассИНН[4]    * 4;
        ДляРасчета[5]    = МассИНН[5]    * 10;
        ДляРасчета[6]    = МассИНН[6]    * 3;
        ДляРасчета[7]    = МассИНН[7]    * 5;
        ДляРасчета[8]    = МассИНН[8]    * 9;
        ДляРасчета[9]    = МассИНН[9]    * 4;
        ДляРасчета[10]    = МассИНН[10]    * 6;
        ДляРасчета[11]    = МассИНН[11]    * 8;
        Сумма_ = 0;
        Для Сч = 1 По 11 Цикл
            Сумма_ = Сумма_ + ДляРасчета[Сч];
        КонецЦикла;
        Остаток = ОстатокОтДеления(Сумма_, 11);
        Если Остаток = 10 Тогда
            Остаток = 0;
        КонецЕсли;
        Если Остаток = МассИНН[12] Тогда
            Предупреждение("ИНН верен!");
        Иначе
            Сообщить("ИНН не верен! Исправьте! (вторая контрольная цифра не верна)");
        КонецЕсли;
    КонецЕсли;
  
КонецПроцедуры
0

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. wondermaker 24.02.10 10:34 Сейчас в теме
Это Украина или Россия :) ?
2. Andrew_flyer 24.02.10 17:12 Сейчас в теме
3. ArCtic 24.02.10 17:20 Сейчас в теме
4. v_id 94 19.04.10 22:02 Сейчас в теме
Функция ОстатокОтДеления(Делимое, Делитель);

Возврат Делимое - Делитель * Цел(Делимое / Делитель);

КонецФункции


Можно (нужно?) проще. Для примера набери в табло 101%10 - сам поймешь. В типовых часто используется.
Оставьте свое сообщение

См. также

Использование классов .Net в 1С для новичков 147

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    62541    Serginio    104       

Процедура расшифровки ячейки таблицы в отчетах 1С 7.7 11

Статья Программист Нет файла v7.7 1cv7.md Windows Бесплатно (free) Практика программирования Универсальные функции

Хочу поделиться с вами универсальной процедурой для расшифровки ячеек печатной формы отчетов в 1С 7.7.

24.09.2015    13686    Anzhey    13       

Записки на память. Зарплата и кадры 1С 7.7 (ЗиК 7.7 ) 54

Статья Системный администратор Программист Бухгалтер Нет файла v77::Расчет 1С7:ЗиК Россия БУ НУ УУ Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерский учет

ЗиК 7.7 постепенно сходит на нет. Но, возможно, кому-то из нас все-таки когда-либо еще не раз придется столкнуться с этой конфигурацией. Поскольку работы по ней и заказов всё меньше и меньше, знания о ней и опыт постепенно угасают. Мой опыт с ЗиК 7.7 длиной в 14 лет терять просто так неохота. В этой статье я запишу, чтобы не забыть, важные моменты об этой конфигурации, чтобы самому не забыть, и вдруг кто-то получит это в наследство на сопровождение и будет вынужден (иначе не скажешь) это обслуживать. Или еще можно рассматривать эту статью как модное нынче «Письмо самому себе в прошлое».

18.11.2014    35060    Lapitskiy    26       

Получение характеристик и управление текущим процессом 1С на основе WMI 36

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Универсальные функции

Функционал для работы из 1С с текущим процессом класса Win32_Process. Пример получает текущее значение ОЗУ занятое процессом 1С. По описанной методике можно получать значения пиковых нагрузок на ОЗУ, время запуска текущей сессии 1С с точностью до миллисекунд. Определять загрузку активного ядра процессом и даже поменять приоритет самого процесса.

09.07.2012    18913    dusha0020    8       

Как заполнить справку 2-НДФЛ в Бухгалтерии 7.7? 38

Статья Бухгалтер Нет файла v77::БУ 1С7:Бух Россия БУ Зарплата НДФЛ Бесплатно (free) Справки

Многие при попытке сформировать справку 2 НДФЛ сталкиваются с ошибкой «Данных о доходах за 2011 год не обнаружено»

12.12.2011    31149    Myst_    18       

Компенсация отпуска, оплата дней доноров и оплата льготных дней родителей в ЗиК 18

Статья Программист Нет файла v77::Расчет 1cv7.md 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

"Компенсация отпуска"," Оплата дней доноров" и "Оплата льготных дней родителей" - эти виды расчетов должны облагаться страховыми взносами с 01.01.2011 года.

04.10.2011    6553    maxim305    18       

Хитрость. Использование БУЛЕВО при OLE обмене/подключении из 7.7 к 8 17

Статья Системный администратор Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Перенос данных из 1С7.7 в 1C8.X Универсальные функции

Как известно, при OLE обмене доступны только типы СТРОКА, ЧИСЛО, ДАТА. А вот БУЛЕВО (ИСТИНА, ЛОЖЬ) использовать при подключении из 7.7 к 8 не получается. Как же быть? Есть хитрость, как использовать тип булево в семерке при обмене с 1С8! :)

28.09.2011    14001    bsturtle    9       

Расчет сверхурочной работы 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Учет рабочего времени Бесплатно (free) Бухгалтерские

Сверхурочной работой считается работа, производимая работником по инициативе работодателя сверх нормального числа рабочих часов за учетный период (п.1 ч.2 ст. 99 ТК РФ). Данная обработка позволяет автоматически по итогам учетного периода (месяц, квартал, год) расчитать переработку сотрудников и расчитать им доплату за сверхурочную работу.

31.08.2011    18887    151    victuan    29       

Методика расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года (вариант) 32

Статья Программист Нет файла v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

В статье рассмотрен один из возможных вариантов расчета резервов отпусков (счет 96) в 1С Зарплата и Кадры 7.7 с 2011 года.

14.06.2011    19343    vkr    48       

Форма 1-НДФЛ для 2011 года (Зарплата и Кадры 7.7, релиз 310) 29

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Бесплатно (free) Практика программирования

В прежних релизах была возможность из справочника "Сотрудники" сформировать форму 1-НДФЛ по кнопке "Ввод данных" (там была возможность расшифровки сумм). Вернём полезную функцию!

29.04.2011    4323    Q-Q    9       

Заявление о выборе (замене) страховой медицинской организации (компании) 12

Отчеты и формы no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия Управление персоналом (HRM) Бесплатно (free) Справки

Печатная форма "Заявление о выборе (замене) страховой медицинской организации (компании)" (Закон "Об обязательном медицинском страховании в Российской Федерации" от 29.11.2010г. N°326-ФЗ)

14.04.2011    14539    63    TaTaPuH-Magic    6       

Форма 4-ФСС с автозаполнением за 1 кв. 2011 г. + Исправление количества знаков после запятой в Разделе 1 96

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух 1С7:Комплекс 1С7:ПУБ Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Регламентированная отчетность

Форма 4-ФСС с автозаполнением за 1 кв. 2011 г. + Исправление количества знаков после запятой в Разделе 1. Видимы и работоспособны кнопки Заполнить, Расшифровать и Заполняется по внешним данным.

05.04.2011    16019    903    911service    27       

Ошибка в отчетности 1кв. 2011г. Форма-4 ФСС для 1С 7.7 29

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Регламентированная отчетность

Исправление количества знаков после запятой в Форме-4 ФСС Раздела1, Таблицы 1 для 1кв. 2011г. 1С 7.7

31.03.2011    10064    209    vladimir_astapov    12       

Отпуск по уходу за ребенком. Расчет по-новому и по-старому 32

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Управление персоналом (HRM) Бесплатно (free) Практика программирования

По новому законодательству расчет среднего заработка для отпуска по уходу можно производить как по старым правилам, так и по новым, на усмотрение сотрудника. Реализуем это в ЗиК.

11.03.2011    10127    Nicholas    9       

Больничный лист по беременности и родам 44

Статья no Нет файла v77::БУ 1С7:ЗиК Россия Зарплата Бесплатно (free) Бухгалтерский учет

По новому законодательству можно теперь начислять пособия по беременности и родам, как по старым правилам, так и по новым, на усмотрение сотрудника. В ЗиК 306 и выше это не предусмотрено.

18.02.2011    9711    lel4ik    22       

Ошибки формата файла 2-НДФЛ в ЗиК релиз 306 100

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия НУ Зарплата НДФЛ Бесплатно (free) Практика программирования

Ошибки 2НДФЛ в релизе: файл формируется как для ЮЛ, даже если работодатель ИП, опечатка "Отчетсвто", и указание имени файла с расширением. Нужно подправить отчет "СправкиПоНДФЛ".

02.02.2011    17040    1st    6       

ЗиК 305 ЗиК 306 Больничный лист. 107

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Для переходящих больничных листов за счет работодателя оплачивается 2 дня, а не 3. Первоисточник: http://forums.kuban.ru/forum/viewtopi...669&page=2

25.01.2011    12150    Cvetic    26       

Расчетная ведомость для УСН 2011 31

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::БУ 1С7:Бух Россия БУ Зарплата УСН Бесплатно (free) Бухгалтерские

Расчетная ведомость для УСН (7.7), выдающая на печать все начисленные страховые взносы (а не только страховую и накопительную часть ПФР)

23.01.2011    8194    264    lelbraun    10       

Бух 2011 (ставки ФОМС) 51

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::БУ 1С7:Бух Россия БУ НУ Windows Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Обработка справочников

Обработка устанавливает в типовых конфигурациях "1С:Бухгалтерия 7.7" (релиз 521) и "1С:Упрощенная система налогообложения 7.7" (релиз 177) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

11.01.2011    11980    505    Antia    7       

ЗиК 2011 (ставки ФОМС) 90

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ НУ Windows Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Обработка справочников

Обработка устанавливает в типовой конфигурации "Зарплата и Кадры 7.7" (релиз 305) ставки страховых взносов, измененные с 1 января 2011 года Федеральным законом от 16.10.10 № 272-ФЗ.

09.01.2011    11486    588    Antia    11       

ЗиК.300 Загогулина 59

Инструменты и обработки Программист Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

В конфигурации ЗиК.300 при использовании при расчетах любого единовременного пособия из соцстраха (рождение, погребение…) - возможна ошибка в своде проводок...

24.08.2010    12911    UV2    14       

Список сотрудников с особыми условиями труда для ПФР. (Версия от 16.07.2011) 25

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Формирование и выгрузка списка сотрудников с особыми условиями труда в xml-файл под версию 1.9 Отчет переписан почти заново. Обновление 16.07.2011.

23.07.2010    16325    403    rechvladmir    22       

Ускоритель СЗВ 2010 для ЗиК 2.99 30

Статья Системный администратор Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Практика программирования

Ускоряет формирование СЗВ примерно вполовину за счет уменьшения числа запросов. Реально полезно, когда надо часто и много заходить в редактирование форм СЗВ. ЗиК 2.99

20.07.2010    7957    aves    7       

ЗиК 298 Ошибка в исчислении стажа. Отчетность ПФР СЗВ-6. 34

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата Бесплатно (free) Практика программирования

Проблемы у сотрудников, имеющих Больничные листы, у которых либо Начало болезни = конец месяца либо Окончание болезни = начало месяца. В первом случае в СЗВ-6 началом болезни считается начало следующего месяца, во втором окончание болезни - конец месяца.

13.07.2010    11028    Cvetic    19       

Штатное расписание по факту (со всеми надбавками, с оплатой по окладам и тарифам) 23

Отчеты и формы no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

Учитываются не только оклады, но и часовые тарифы сотрудников, а также все постоянные надбавки, введены ли они через справочник "Штатное расписание" или документами.

18.06.2010    8752    312    pr_skm    12       

Отчет для отдела кадров 14

Отчеты и формы no Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия УУ Windows Управление персоналом (HRM) Бесплатно (free) Управленческие

Отделу кадров необходим список работающих женщин, которым 50 и более и мужчин, которым 60 и более.

18.06.2010    8371    159    Hla    6       

Расчетная ведомость с детализацией по месяцам 46

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Бесплатно (free) Универсальные печатные формы Бухгалтерские

Стандартная расчетная ведомость с возможностью формирования за произвольный период. С детализацией по месяцам.

04.05.2010    17473    676    Diamante    14       

Лицевой счет Т-54а для ЗиК 41

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Бухгалтерские

Лицевой счет по форме Т-54а, утвержденой постановлением Госкомстата России от 05.01.2004 года №1. С заполнением кадровых данных, вычетов, взносов и прочего для программы "1С:Зарплата и кадры 7.7".

19.04.2010    19335    374    zaic    25       

Отчет по переходящим отпускам (РБП - 97 счет) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Windows Зарплата Управление персоналом (HRM) Бесплатно (free) Бухгалтерские

То что 100% должно быть в своде проводок для выгрузки в БУ. Просто интересно, кому то еще это может пригодиться или нет. Еще интереснее комментарии если что то еще должно присутствовать в выгрузке РБП. "типа больничных". Сам я как то плохо представляю как можно заболеть в будущем.

07.04.2010    6303    224    try2007    16       

Алгоритм расчета периодов 3

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Универсальные функции

Вычисление периодов в формате ГГММДД. Вычисление дат по формуле Дата + ГГММДД. Примечание: Даты передаем в виде 'ДД.ММ.ГГГГ', периоды - "ГГ-ММ-ДД". Пользуйтесь.

10.03.2010    8242    arithmometr    1       

v7.7 ЗиК. Невыходы списку сотрудников 16

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Управление персоналом (HRM) Учет рабочего времени Бесплатно (free) Обработка документов

Сейчас становится модным вводить сокращенную рабочую неделю. Для формирования большого количества документов Невыходы предназначена эта обработка. По результатам работы формируется таблица-отчет со списком сформированных документов.

10.03.2010    4333    137    vladb50@mail.ru    2       

Справка о доходах за 2009 (ошибка релиза 293) 16

Статья Программист Нет файла v77::Расчет 1С7:ЗиК Россия Зарплата Бесплатно (free) Справки Практика программирования

Исправлена ошибка релиза 293 "Зарплата и кадры 7.7" в части вывода в справку строк с пустыми данными.

15.02.2010    10271    OlegAl    14       

Интервал дат прописью 8

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Windows Бесплатно (free) Универсальные функции

Иногда возникает необходимость подсчитать количество дней, недель, месяцев или лет в интервале дат и вывести результат прописью. Обработка предназначена для демонстрации работы функции ПолучитьИнтервалДат(Дата1,Дата2,Период) Используется стандартный файл прописи для рублей. Специально не оптимизировал функции, чтобы каждый мог настроить их под свои требования.

15.02.2010    7743    143    Vlan    3       

ЗиК 7.7 персонификация месячная! 4

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v7.7 1cv7.md Россия БУ Зарплата Бесплатно (free) Обработка документов

Переписала внешнюю обработку для месячной персонификации.В списке выбрать:Отношения,ИнддаыеБез,Больничные/отпуска-и сдавайте все в срок! Ньюансы-нет модуля для выгрузки в Бест-не знаю кодов полей dbf-ников,если кто в курсе-подскажите....

12.02.2010    5435    82    Jan    5       

Расширенная зарплата для конфигурации "Бухгалтерский учет для Украины" 7.7 24

Инструменты и обработки Бухгалтер Конфигурация (md, cf) v77::БУ 1С7:Бух Украина БУ Зарплата Бесплатно (free) Рабочее место

Расширенная зарплата для конфигурации "Бухгалтерский учет для Украины" ред. 2.77 * Начисление и выплата ЗП в разрезе подразделений (отделов); * Расчет отпускных; * Расчет больничных; * Начисление произвольных доплат фиксированной суммой или % к окладу произвольному количеству сотрудников; * Табель учета рабочего времени

10.02.2010    10627    235    Некто A. Petti    26       

Пояснительная записка к отчету ПФР 17

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК БУ НУ Windows Зарплата Управление персоналом (HRM) ФОМС, ПФ, ФСС Бесплатно (free) Универсальные печатные формы Бухгалтерские

Как выяснилось некоторые пенсионки запрашивают дополнительно к отчетам еще и пояснительные записки. Если много организаций, то это огромная работа. Вот сделала для ЗИК 7.7. Буду рада, если кому-то понадобится.

06.02.2010    7074    235    Ежик    4       

Расчетная ведомость с налогами, свод начислений с налогами (с 2010г.) 83

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Бесплатно (free) Обработка документов

Разработка не моя... Переработана с учетом введения страховых взносов для ЗиК 7.7. Для комплексной 7.7 не работала вообще... Исправил ошибки. Сейчас все в норме..

04.02.2010    11014    1665    and1605    89