Параметры для дополнительных отчетов и обработок БСП

Публикация № 688005

Программирование - Практика программирования

10
Еще один вариант передачи параметров во внешние обработки БСП. Параметры привязываются к командам дополнительной обработки и хранятся в элементе справочника.

Данный подход подойдет для конфигураций с БСП. Реализацию разделим на три этапа.

Этап 1.  Внесение изменений в конфигурацию (неприятный этап). Добавление табличной части в справочник  "ДополнительныеОтчетыИОбработки"

Этап 2. Добавление табличной части на форму Дополнительной обработки с настройкой обработчиков событий для связки параметров с командами. Для этого можно использовать механизм расширений конфигурации и выглядеть например как на картинке.

Этап 3. Использование параметров непосредственно во внешней обработке. Рассмотрю на примере внешней печатной формы.

  1.  Добавим в обработку табличную часть аналогично созданной на  Этапе 1 за исключением реквизита "Идентификатор" (можно скопировать и удалить лишний реквизит)   
  2.   Получение параметров. В ВПФ их можно получить в  экспортной процедуре ПЕЧАТЬ.. Для этого нам нужна ссылка на  дополнительную обработку и имя команды. Ссылку получим из   ПараметрыВывода.ДополнительнаяОбработкаСсылка, а имя команды из КоллекцияПечатныхФорм. Полученные параметры добавим в созданную Табличную часть.. Пример процедуры ПЕЧАТЬ.      
Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
	ДополнительнаяОбработкаСсылка = ПараметрыВывода.ДополнительнаяОбработкаСсылка;
	ПараметрыОтбора = Новый Структура;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетФактураТ") Тогда
		ПараметрыОтбора.Вставить("Идентификатор", "СчетФактураТ");
        НайденныеСтроки = ДополнительнаяОбработкаСсылка.Сити_Параметры.НайтиСтроки(ПараметрыОтбора);
		Если НайденныеСтроки.Количество() > 0 Тогда
			Для Каждого Строка Из НайденныеСтроки Цикл
				НовыйПараметр = Сити_Параметры.Добавить();
				НовыйПараметр.Имя      = Строка.Имя;
				НовыйПараметр.Значение = Строка.Значение;
			КонецЦикла;
		КонецЕсли;	
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм,"СчетФактураТ", "Счет-фактура",
		ПечатьСчетовФактур981(МассивОбъектов, ОбъектыПечати, "ТекстЗапроса"));
	ИначеЕсли УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетФактураД") Тогда
		//
	ИначеЕсли УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетФактура981") Тогда
		//
	КонецЕсли;
	
КонецПроцедуры
  1. Использование параметров в печатной форме.
Процедура ВывестиСчетФактуруВТабличныйДокумент(ТабДокумент, Макет, ВыборкаСФ, ЭтоУниверсальныйПередаточныйДокумент = Ложь)
	
    //.....
    //..... 
	
	ОбластьМакета = Макет.ПолучитьОбласть("Подвал");
	
    //Передача параметров в Табличный документ 
	СтрутураПараметровВПФ = Новый Структура;	
	Для Каждого Строка Из Сити_Параметры Цикл
		СтрутураПараметровВПФ.Вставить(строка.Имя, Строка.Значение);
	КонецЦикла;	
    ОбластьМакета.Параметры.Заполнить(СтрутураПараметровВПФ);
	
	ТабДокумент.Вывести(ОбластьМакета);
	
КонецПроцедуры

 

10

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Дата
1. Bassgood 877 18.10.17 19:30 Сейчас в теме
(0) Вот здесь это реализовано без изменения конфигурации: https://infostart.ru/public/627824/
2. duhh 122 19.10.17 12:19 Сейчас в теме
(1) И правда, надо было сначала поискать, а потом выкладывать статью.
3. duhh 122 19.10.17 12:32 Сейчас в теме
(1)Вот только, судя по описанию, в вашем подходе параметры не привязываются к командам, а мне нужно было, именно для каждой команды обработки свои параметры. Но скорей всего при вашем подходе это тоже можно реализовать, добавив к параметрам еще и идентификатор команды.
4. Bassgood 877 19.10.17 12:55 Сейчас в теме
(2) Да, все верно, указанная мною обработка заточена на установку параметров выполнения регл. задания (как наиболее наболевшее), но в целом ее можно довести до более универсального варианта - реализовать привязку параметров обработки к ее командам (например, в виде табличной части) и использовать ее не только для выполнения серверных команд.
Просто во внешних обработках, предназначенных для выполнения регл. заданий, редко используется несколько команд запуска этих самых заданий, обычно под каждое регл. задание создается отдельная внешняя обработка с одной командной запуска (но в целом, никто не мешает создать в обработке нужное количество параметров под каждую команду, а визуально разграничить их между собой уже в форме установки параметров).
Оставьте свое сообщение