INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Лисенков Владимир | Руководитель отдела разработки | АО МФК "Городская Сберкасса"

«Имитационное моделирование в среде 1С:Предприятие»

- суть имитационного моделирования, как способа определения наиболее оптимального решения - алгоритмы получения случайных значений по заданному закону распределения - построение имитационной модели и проведение имитационных испытаний в среде 1С:Предприятие В основу доклада будет положена выпускная работа по теме "Имитационное моделирование". Теория и практическая часть на платформе 1С. В качестве примера - расчет оценки кредитного риска по методу VAR в финансовых организациях. Платформа 1С будет рассмотрена в качестве аналога такому пакету как Oracle Cristal Ball.

УПД за поставщика для документа "Поступление товаров и услуг" для БП 2.0 (форма 1137, в том числе с приказом 625 и 981)

Печать - Печатные формы документов

2
Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика для БП 2.0.

Реализована форма УПД, рекомендованная к применению с 01.07.2017 г.

Тестировалась и работает на последних релизах БП 2.0 (тестировалось на БП 2.0.66.39)

Регистрируется стандартно, как и любая ВПФ (Сервис - Дополнительные отчеты и обработки - Дополнительные внешние печатные формы - Выбрать этот файл с внешней печатной формой - Записать и закрыть).

25.04.18 Новая версия 1.1 исправлена ошибка - при указанном ответсвенном лице в складе ВПФ не печаталась.

2

Скачать файлы

Наименование Файл Версия Размер
УПД за поставщика для документа "Поступление товаров и услуг" для БП 2.0 (форма 1137, в том числе с приказом 625 и 981:
.epf 40,85Kb
08.05.18
130
.epf v 1.1 40,85Kb 130 Скачать

См. также

Комментарии
Сортировка: Древо
1. Teta 08.12.17 10:51 Сейчас в теме
Добрый день. Скачали, но при печати выдает ошибку:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (ГоловнаяОрганизация)
пробовала и на релизе 66.39 и выше
2. kn 58 08.12.17 12:50 Сейчас в теме
Добрый день, вышлите скрин ошибки(посмотрю в какой строчке)у себя не наблюдаю и головная организация в тексте не нахожу.
3. Teta 11.12.17 09:44 Сейчас в теме
(2)Проблема скорее всего в моей базе данных. Потому как на двух других все работает. Единственное не могу понять в какую строну рыть, ТиИ делала, chdbfl проверяла.
Прикрепленные файлы:
ошибка.doc
4. Teta 11.12.17 09:53 Сейчас в теме
(2)отсылает сюда
Прикрепленные файлы:
Конф.doc
7. lamaker9876 05.02.18 11:37 Сейчас в теме
(4)это решается вытаскиванием функций из модуля ОбщегоНазначения
ДанныеФизЛица и ГоловнаяОрганизация.

в функции ГоловнаяОрганизация должно получиться:

Если ТипЗнч(Организация) = Тип("СправочникСсылка.Контрагенты") Тогда
		
	Если Организация.Пустая() ИЛИ Организация.ГоловнойКонтрагент.Пустая() Тогда

		Возврат Организация;
			
	Иначе

		Возврат Организация.ГоловнойКонтрагент;
			
	КонецЕсли;
		
ИначеЕсли ТипЗнч(Организация) = Тип("СправочникСсылка.Организации") Тогда
		
	Если Организация.Пустая() ИЛИ Организация.ГоловнаяОрганизация.Пустая() Тогда

		Возврат Организация;
			
	Иначе

		Возврат Организация.ГоловнаяОрганизация;
			
	КонецЕсли;
		
КонецЕсли;
Показать
8. user631290_makerplus 5 24.04.18 16:22 Сейчас в теме
(7)
ГоловнаяОрганизация


Предлагаете поменять текст общего модуля?
9. kn 58 24.04.18 16:59 Сейчас в теме
(8)там дело было в самой базе в данных, т.к у нее на других базах работало.
11. user631290_makerplus 5 24.04.18 20:40 Сейчас в теме
(9) дело в том, что ошибка возникает если у Склада указано Ответственное лицо. Вероятно в какой то базе оно и было указано, а в других нет.
Было был не плохо написать что нужно исправить в модуле обработки чтобы ошибка не возникала
12. kn 58 25.04.18 05:19 Сейчас в теме
(11)Да, действительно наблюдаю такую ошибку, исправить можно так
в модуле объекта ВПФ УПД заменить все вызовы функции ОбщегоНазначения.ДанныеФизЛица на просто ДанныеФизЛица
и добавить скопировав из общего модуля ОбщегоНазначения функции ДанныеФизЛица,ПолучитьПредставлениеДокументаФизЛица,ПолучитьФамилиюИмяОтчество. И в скопированной функции ДанныеФизЛица
заменить ЗапросПоЛицам.УстановитьПараметр("Организация", ОбщегоНазначения.ГоловнаяОрганизация(Организация));
на ЗапросПоЛицам.УстановитьПараметр("Организация", ГоловнаяОрганизация(Организация));а и добавить функцию ГоловнаяОрганизация как в пишет 7
10. lamaker9876 24.04.18 19:45 Сейчас в теме
(8)никак нет, написал же : "решается вытаскиванием функций из модуля ОбщегоНазначения". Т.е. не конфигурацию правим, а в обработке чуть дорабатываем
5. lamaker9876 22.12.17 12:14 Сейчас в теме
Добрый день!
контактные лица не подставляет в печать за поставщика, я правильно понял?
6. kn 58 22.12.17 12:44 Сейчас в теме
Добрый день, да. Возможно в следующей версии будет заполнение контактных лиц.
13. kn 58 25.04.18 05:27 Сейчас в теме
Выложена версия 1.1, где исправлена ошибка - при указанном ответсвенном лице в складе ВПФ не печаталась
14. realEvgenius 19.07.18 12:35 Сейчас в теме
Народ, подскажите, форма актуальная? Работает? Или вышла новее?
15. kn 58 19.07.18 13:17 Сейчас в теме
Про эту форму скажу - скачивают, замечаний нет
16. realEvgenius 19.07.18 13:31 Сейчас в теме
Оставьте свое сообщение