УПД за поставщика для документа "Поступление товаров и услуг" для БП 2.0 (форма 1137, в том числе с приказом 625 и 981)

Печать - Печатные формы документов

УПД за поставщика для БП 2.0; УПД для Поступления товаров и услуг; Универсальный передаточный документ за поставщика для БП2.0

2
Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика для БП 2.0.

Реализована форма УПД, рекомендованная к применению с 01.07.2017 г.

Тестировалась и работает на последних релизах БП 2.0 (тестировалось на БП 2.0.66.39)

Регистрируется стандартно, как и любая ВПФ (Сервис - Дополнительные отчеты и обработки - Дополнительные внешние печатные формы - Выбрать этот файл с внешней печатной формой - Записать и закрыть).

25.04.18 Новая версия 1.1 исправлена ошибка - при указанном ответсвенном лице в складе ВПФ не печаталась.

2

Скачать файлы

Наименование Файл Версия Размер
УПД за поставщика для документа "Поступление товаров и услуг" для БП 2.0 (форма 1137, в том числе с приказом 625 и 981:
.epf 40,85Kb
08.05.18
170
.epf v 1.1 40,85Kb 170 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Teta 08.12.17 10:51 Сейчас в теме
Добрый день. Скачали, но при печати выдает ошибку:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (ГоловнаяОрганизация)
пробовала и на релизе 66.39 и выше
2. kn 65 08.12.17 12:50 Сейчас в теме
Добрый день, вышлите скрин ошибки(посмотрю в какой строчке)у себя не наблюдаю и головная организация в тексте не нахожу.
3. Teta 11.12.17 09:44 Сейчас в теме
(2)Проблема скорее всего в моей базе данных. Потому как на двух других все работает. Единственное не могу понять в какую строну рыть, ТиИ делала, chdbfl проверяла.
Прикрепленные файлы:
ошибка.doc
4. Teta 11.12.17 09:53 Сейчас в теме
(2)отсылает сюда
Прикрепленные файлы:
Конф.doc
7. lamaker9876 05.02.18 11:37 Сейчас в теме
(4)это решается вытаскиванием функций из модуля ОбщегоНазначения
ДанныеФизЛица и ГоловнаяОрганизация.

в функции ГоловнаяОрганизация должно получиться:

Если ТипЗнч(Организация) = Тип("СправочникСсылка.Контрагенты") Тогда
		
	Если Организация.Пустая() ИЛИ Организация.ГоловнойКонтрагент.Пустая() Тогда

		Возврат Организация;
			
	Иначе

		Возврат Организация.ГоловнойКонтрагент;
			
	КонецЕсли;
		
ИначеЕсли ТипЗнч(Организация) = Тип("СправочникСсылка.Организации") Тогда
		
	Если Организация.Пустая() ИЛИ Организация.ГоловнаяОрганизация.Пустая() Тогда

		Возврат Организация;
			
	Иначе

		Возврат Организация.ГоловнаяОрганизация;
			
	КонецЕсли;
		
КонецЕсли;
Показать
8. user631290_makerplus 9 24.04.18 16:22 Сейчас в теме
(7)
ГоловнаяОрганизация


Предлагаете поменять текст общего модуля?
9. kn 65 24.04.18 16:59 Сейчас в теме
(8)там дело было в самой базе в данных, т.к у нее на других базах работало.
11. user631290_makerplus 9 24.04.18 20:40 Сейчас в теме
(9) дело в том, что ошибка возникает если у Склада указано Ответственное лицо. Вероятно в какой то базе оно и было указано, а в других нет.
Было был не плохо написать что нужно исправить в модуле обработки чтобы ошибка не возникала
12. kn 65 25.04.18 05:19 Сейчас в теме
(11)Да, действительно наблюдаю такую ошибку, исправить можно так
в модуле объекта ВПФ УПД заменить все вызовы функции ОбщегоНазначения.ДанныеФизЛица на просто ДанныеФизЛица
и добавить скопировав из общего модуля ОбщегоНазначения функции ДанныеФизЛица,ПолучитьПредставлениеДокументаФизЛица,ПолучитьФамилиюИмяОтчество. И в скопированной функции ДанныеФизЛица
заменить ЗапросПоЛицам.УстановитьПараметр("Организация", ОбщегоНазначения.ГоловнаяОрганизация(Организация));
на ЗапросПоЛицам.УстановитьПараметр("Организация", ГоловнаяОрганизация(Организация));а и добавить функцию ГоловнаяОрганизация как в пишет 7
10. lamaker9876 24.04.18 19:45 Сейчас в теме
(8)никак нет, написал же : "решается вытаскиванием функций из модуля ОбщегоНазначения". Т.е. не конфигурацию правим, а в обработке чуть дорабатываем
5. lamaker9876 22.12.17 12:14 Сейчас в теме
Добрый день!
контактные лица не подставляет в печать за поставщика, я правильно понял?
6. kn 65 22.12.17 12:44 Сейчас в теме
Добрый день, да. Возможно в следующей версии будет заполнение контактных лиц.
13. kn 65 25.04.18 05:27 Сейчас в теме
Выложена версия 1.1, где исправлена ошибка - при указанном ответсвенном лице в складе ВПФ не печаталась
14. realEvgenius 19.07.18 12:35 Сейчас в теме
Народ, подскажите, форма актуальная? Работает? Или вышла новее?
15. kn 65 19.07.18 13:17 Сейчас в теме
Про эту форму скажу - скачивают, замечаний нет
16. realEvgenius 19.07.18 13:31 Сейчас в теме
17. taasha25 13 22.08.18 12:39 Сейчас в теме
Здравствуйте! Уже несколько минут жду. Письма с Инфостарта со ссылкой нет.
18. kn 65 22.08.18 12:42 Сейчас в теме
Ждите, может переадресация в ящике.
19. taasha25 13 22.08.18 12:48 Сейчас в теме
Нет переадресации. Уже второй раз заказала и письмо в поддержку написала. Срочно нужно.)
20. taasha25 13 22.08.18 12:52 Сейчас в теме
Можете выслать на почту tania1964@rambler.ru? Как ссылка придет скачаю. Стартмани есть. Спасибо!
21. kn 65 22.08.18 12:55 Сейчас в теме
Напишите в техподдержку, может не в том ящике смотрите.Сегодня вообще-то скачивали.
22. taasha25 13 22.08.18 12:55 Сейчас в теме
Поддержка тоже не отвечает(
23. taasha25 13 22.08.18 12:56 Сейчас в теме
В спаме тоже нет. У меня один ящик. Я его подтвердила при заказе.
24. taasha25 13 22.08.18 13:07 Сейчас в теме
25. taasha25 13 22.08.18 13:35 Сейчас в теме
26. kn 65 22.08.18 13:35 Сейчас в теме
27. Zanoza_1 01.11.18 12:16 Сейчас в теме
В версии БП (2.0.66.64) - выходит ошибка: Метод объекта не обнаружен (ПолучитьПараметрыУчетнойПолитикиНалоговыйУчет)
автор может дать совет - куда смотреть?
31. kn 65 02.11.18 15:08 Сейчас в теме
(27)(30)На указанном релизе ВПФ работает, функции ПолучитьПараметрыУчетнойПолитикиНалоговыйУчет нет в конфигурации и в ВПФ.
Вывод - используемая Вами форма не из этой публикации.
28. kn 65 01.11.18 14:51 Сейчас в теме
Могу подключиться посмотреть,
29. kn 65 01.11.18 14:54 Сейчас в теме
не вижу Вас в числе скачивающих.
30. Zanoza_1 01.11.18 15:25 Сейчас в теме
(29) Я не скачивала с сайта, вообщем пришлось слегка модернизировать. Вопрос снят, спасибо автору что он есть, ну и совет для многих авторов - держите свои доработки в актуальном состоянии к текущим версиям программы, а то поиск выдает вашу ВПФ первой а она пффф...
Оставьте свое сообщение