УПД за поставщика для документа "Поступление товаров и услуг" для БП 2.0 (форма 1137, в том числе с приказом 625 и 981

Печать - Печатные формы документов

Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика для БП 2.0.

Реализована форма УПД, рекомендованная к применению с 01.07.2017 г.

Тестировалась и работает на последних релизах БП 2.0 (тестировалось на БП 2.0.66.39)

Регистрируется стандартно, как и любая ВПФ (Сервис - Дополнительные отчеты и обработки - Дополнительные внешние печатные формы - Выбрать этот файл с внешней печатной формой - Записать и закрыть).

Скачать файлы

Наименование Файл Версия Размер
УПД за поставщика для документа "Поступление товаров и услуг" для БП 2.0 (форма 1137, в том числе с приказом 625 и 981:
.epf 39,57Kb
23.10.17
89
.epf 39,57Kb 89 Скачать

См. также

Комментарии
1. Татьяна Гусарова (Teta) 08.12.17 10:51 Сейчас в теме
Добрый день. Скачали, но при печати выдает ошибку:
Не удалось сформировать внешнюю печатную форму!
Поле объекта не обнаружено (ГоловнаяОрганизация)
пробовала и на релизе 66.39 и выше
2. Ольга Немешева (kn) 49 08.12.17 12:50 Сейчас в теме
Добрый день, вышлите скрин ошибки(посмотрю в какой строчке)у себя не наблюдаю и головная организация в тексте не нахожу.
3. Татьяна Гусарова (Teta) 11.12.17 09:44 Сейчас в теме
(2)Проблема скорее всего в моей базе данных. Потому как на двух других все работает. Единственное не могу понять в какую строну рыть, ТиИ делала, chdbfl проверяла.
Прикрепленные файлы:
ошибка.doc
4. Татьяна Гусарова (Teta) 11.12.17 09:53 Сейчас в теме
(2)отсылает сюда
Прикрепленные файлы:
Конф.doc
7. Артём Туголуков (lamaker9876) 05.02.18 11:37 Сейчас в теме
(4)это решается вытаскиванием функций из модуля ОбщегоНазначения
ДанныеФизЛица и ГоловнаяОрганизация.

в функции ГоловнаяОрганизация должно получиться:

Если ТипЗнч(Организация) = Тип("СправочникСсылка.Контрагенты") Тогда
		
	Если Организация.Пустая() ИЛИ Организация.ГоловнойКонтрагент.Пустая() Тогда

		Возврат Организация;
			
	Иначе

		Возврат Организация.ГоловнойКонтрагент;
			
	КонецЕсли;
		
ИначеЕсли ТипЗнч(Организация) = Тип("СправочникСсылка.Организации") Тогда
		
	Если Организация.Пустая() ИЛИ Организация.ГоловнаяОрганизация.Пустая() Тогда

		Возврат Организация;
			
	Иначе

		Возврат Организация.ГоловнаяОрганизация;
			
	КонецЕсли;
		
КонецЕсли;
Показать
5. Артём Туголуков (lamaker9876) 22.12.17 12:14 Сейчас в теме
Добрый день!
контактные лица не подставляет в печать за поставщика, я правильно понял?
6. Ольга Немешева (kn) 49 22.12.17 12:44 Сейчас в теме
Добрый день, да. Возможно в следующей версии будет заполнение контактных лиц.
Оставьте свое сообщение