Универсальная внешняя печатная форма счета-фактуры и УПД для Бухгалтерии 3.0

Печать - Печатные формы документов

обработка внешняя печатная форма

2
Может быть полезна для разработчиков, которые хотят внести изменения в форму счет-фактуры и УПД, но не хотят добавлять несколько внешних обработок для каждой формы документа.

Внешняя печатная форма счет-фактуры и упд. Сделано на Бухгалтерия предприятия, редакция 3.0 (3.0.52.39). Но должно работать и на других.

Печатает нужную форму в зависимости от даты документа.

Выполнено на БСП.

2

Скачать файлы

Наименование Файл Версия Размер
Внешняя печатная форма счет-фактуры:
.epf 38,08Kb
01.11.17
11
.epf 38,08Kb 11 Скачать
Внешняя печатная форма упд:
.epf 42,35Kb
01.11.17
15
.epf 42,35Kb 15 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. user853896 10.12.17 10:13 Сейчас в теме
Эта Внешняя печатная форма счет-фактуры выводится на печать только из документа "Реализация товаров и услуг". При попытке вывести на печать из документа "Счет-фактура выданный" вылезает ошибка: "В обработчике печати не был сформирован табличный документ для: СчетФактура981. Как можно исправить и устранить эту проблему?
2. aleksdiez 4 12.12.17 15:14 Сейчас в теме
(1) проверил, действительно проблема есть, обязательно исправлю.
Но вас нет в списке скачавших
3. MasI 9 15.01.18 13:36 Сейчас в теме
Добрый день!

проверил для счета-фактуры действительно не печатает, я есть в списке скачавших точно)
4. user659124_s.kostina 04.04.18 09:59 Сейчас в теме
Наткнулась на тот же момент, что и авторы предыдущих комментариев) Но обработка уже скачана, так что вот так доработала самым быстрым образом обработку.
В функции отладочная печать изменила строки:
Функция ОтладочнаяПечать(МассивОбъектов, ОбъектыПечати) Экспорт

	ДокПродажи = МассивОбъектов[0];	
	Если ТипЗнч(ДокПродажи) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
		СчетаФактуры = ПолучитьСчетФактуры(ДокПродажи);
		Иначе Если ТипЗнч(ДокПродажи) = Тип("ДокументСсылка.СчетФактураВыданный") Тогда
			СчетаФактуры = Новый Массив;
			СчетаФактуры.Добавить(ДокПродажи); 
		КонецЕсли;
	КонецЕсли;
				
	ДатаДок = СчетаФактуры[0].Дата;
	ОбъектыПечати = Новый СписокЗначений;
	
	Если ДатаДок < Дата("20170701") тогда	
		ТД = ПечатьСчетовФактур1137До1Июля(СчетаФактуры, ОбъектыПечати, ТекстЗапросаПечатьСчетовФактур(,,Ложь));
	ИначеЕсли ДатаДок >= Дата("20170701") И ДатаДок < Дата("20171001") тогда		
		ТД = ПечатьСчетовФактур1137После1Июля(СчетаФактуры, ОбъектыПечати, ТекстЗапросаПечатьСчетовФактур(,,Ложь));
	ИначеЕсли ДатаДок >= Дата("20171001") тогда	
		ТД = ПечатьСчетовФактур981(СчетаФактуры, ОбъектыПечати, ТекстЗапросаПечатьСчетовФактур(,,Истина));
	КонецЕсли;
	
	Возврат ТД;
	
КонецФункции // ОтладочнаяПечать()
Показать

И на форме у реквизита "Документ" отметила составной тип данных и добавила ДокументСсылка.СчетФактураВыданный.
5. user659124_s.kostina 04.04.18 12:42 Сейчас в теме
Если же хотите, чтобы обработка работала для внешней ПФ из доп. обработок, то меняла функцию:
Функция ПолучитьСчетФактуры(ДокументПродажи)
	
	СчетаФактуры = Новый Массив;
	Запрос = Новый Запрос; 
	
	Если ТипЗнч(ДокументПродажи) = Тип("ДокументСсылка.РеализацияТоваровУслуг") Тогда
		
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	СчетФактураВыданный.Ссылка КАК Ссылка
		|ИЗ
		|	Документ.СчетФактураВыданный КАК СчетФактураВыданный
		|ГДЕ
		|	СчетФактураВыданный.ДокументОснование В(&ДокументОснование)";
		
		Запрос.УстановитьПараметр("ДокументОснование", ДокументПродажи);
		
		РезультатЗапроса = Запрос.Выполнить();
		
		ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
		
		Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
			СчетаФактуры.Добавить(ВыборкаДетальныеЗаписи.Ссылка);
		КонецЦикла; 		
		Возврат СчетаФактуры; 		
		
		Иначе Если ТипЗнч(ДокументПродажи) = Тип("ДокументСсылка.СчетФактураВыданный") Тогда			
			СчетаФактуры.Добавить(ДокументПродажи.Ссылка);  						
			Возврат СчетаФактуры;
		КонецЕсли;
	КонецЕсли;  	
	
КонецФункции // ПолучитьСчетФактуры()
Показать


В функции Печать изменить строку
СчетаФактуры = ПолучитьСчетФактуры(МассивОбъектов);

на
СчетаФактуры = ПолучитьСчетФактуры(МассивОбъектов[0]);


И добавить вид документа, для которого будет отображаться данная внешняя форма:
ПараметрыРегистрации.Назначение.Добавить("Документ.СчетФактураВыданный"); 
Оставьте свое сообщение