Универсальная история изменения документов и справочников

Публикация № 74378

Разработка - Практика программирования

73
Универсальная история изменения документов и справочников, позволяет сохранять изменения только тех реквизитов документов, справочников, а также их табличных частей, которые действительно изменились. Те реквизиты которые не изменились не попадают в историю. Это позволяет отслеживать кто, когда и что именно изменил в документе или справочнике.

Универсальная история изменения документов и справочников, позволяет сохранять изменения только тех реквизитов документов, справочников, а также их табличных частей, которые действительно изменились. Те реквизиты которые не изменились не попадают в историю. Это позволяет отслеживать кто, когда и что именно изменил в документе или справочнике. Не имеет ссылок на объекты метаданных, что позволяет удалять объекты метаданных, помеченных на удаление, через обработку удаление помеченных на удаление, без проверки на ссылание этого объекта в этом справочнике.

Чтобы эту историю внедрить в Вашу конфигурацию, необходимо:

  1. Создать Справочник ИзмененияДокументов со следующими параметрами:
  2. Длина наименования 150, Длина кода 20, Тип Кода Строка.
    Реквизиты Справочника:
               Пользователь - Тип:СправочникСсылка.Пользователи
               GUID_Объекта - Тип:Строка, Длина: 36
               ДатаИзменения - Дата, Состав даты: Дата и время
          Табличная часть "Изменения" справочника, содержит Реквизиты:
               Реквизит - Тип:Строка, Длина:200
               ЗначениеДо - Тип: Строка, неограниченная
               ЗначениеПосле - Тип: Строка, неограниченная

  3. Создать ФормуСписка и ФормуЭлемента Справочника, в форме элемента сделать её только для просмотра.

  4. В общем модуле, который выполняется на клиенте, либо создав новый, разместить экспортируемую процедуру:

	 Процедура ЗаписатьИзмененияДокументаВСправочникИзмененияДокументов(Объект) ЭКСПОРТ

    Если Объект.ЭтоНовый() Тогда
        ID = Новый УникальныйИдентификатор;
        Если Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")-1) = "Документ" Тогда
            Объект.УстановитьСсылкуНового(Документы[Объект.Метаданные().Имя].ПолучитьСсылку(ID));
        ИначеЕсли Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")-1) = "Справочник" Тогда
            Объект.УстановитьСсылкуНового(Справочники[Объект.Метаданные().Имя].ПолучитьСсылку(ID));
        КонецЕсли;
    КонецЕсли;

    Изменения = Истина;
    ДатаИзм = ТекущаяДата();

    //Изменения реквизитов
    ЗапросПроверкаРеквизитов = Новый Запрос;
    ЗапросПроверкаРеквизитов.Текст = "ВЫБРАТЬ
                                     |  *
                                     |ИЗ
                                     |  " + Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")) + Объект.Метаданные().Имя + " КАК ОбъектМетаданных
                                     |ГДЕ
                                     |  ОбъектМетаданных.Ссылка = &Ссылка";

    ЗапросПроверкаРеквизитов.УстановитьПараметр("Ссылка", Объект.Ссылка);
    ВыборкаПроверкаРеквизитов = ЗапросПроверкаРеквизитов.Выполнить().Выбрать();
    Если ВыборкаПроверкаРеквизитов.Следующий() Тогда
        Для Каждого Рек Из Объект.Метаданные().Реквизиты Цикл
            Если Объект[Рек.Имя] <> ВыборкаПроверкаРеквизитов[Рек.Имя] Тогда
                Если Изменения Тогда
                    НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                    НовЭлемент.Наименование = Строка(Объект.Ссылка);
                    НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                    НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                    НовЭлемент.ДатаИзменения = ДатаИзм;
                    Изменения = Ложь;
                КонецЕсли;
                НовСтр = НовЭлемент.Изменения.Добавить();
                НовСтр.Реквизит = Рек.Имя;
                НовСтр.ЗначениеДо = Строка(ВыборкаПроверкаРеквизитов[Рек.Имя]);
                НовСтр.ЗначениеПосле = Строка(Объект[Рек.Имя]);
                Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                    НовЭлемент.Записать();
                    Изменения = Истина;
                КонецЕсли;
            КонецЕсли;
        КонецЦикла;
        Если ВыборкаПроверкаРеквизитов.ПометкаУдаления <> Объект.ПометкаУдаления Тогда
            Если Изменения Тогда
                НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                НовЭлемент.Наименование = Строка(Объект.Ссылка);
                НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                НовЭлемент.ДатаИзменения = ДатаИзм;
                Изменения = Ложь;
            КонецЕсли;
            НовСтр = НовЭлемент.Изменения.Добавить();
            НовСтр.Реквизит = "ПометкаУдаления";
            НовСтр.ЗначениеДо = Строка(ВыборкаПроверкаРеквизитов.ПометкаУдаления);
            НовСтр.ЗначениеПосле = Строка(Объект.ПометкаУдаления);
        КонецЕсли;
    Иначе
        Для Каждого Рек Из Объект.Метаданные().Реквизиты Цикл
            Если Изменения Тогда
                НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                НовЭлемент.Наименование = Строка(Объект.Ссылка);
                НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                НовЭлемент.ДатаИзменения = ДатаИзм;
                Изменения = Ложь;
            КонецЕсли;
            НовСтр = НовЭлемент.Изменения.Добавить();
            НовСтр.Реквизит = Рек.Имя;
            НовСтр.ЗначениеДо = "";
            НовСтр.ЗначениеПосле = Строка(Объект[Рек.Имя]);
            Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                НовЭлемент.Записать();
                Изменения = Истина;
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;

    //Проверка на изменение табличных частей документа
    Для Каждого ТЧ из Объект.Метаданные().ТабличныеЧасти Цикл

        ЗапросПроверкаТЧ = Новый Запрос;

        ЗапросПроверкаТЧ.Текст = "ВЫБРАТЬ
                                     |  *
                                     |ИЗ
                                     |  " + Сред(Объект.Метаданные().ПолноеИмя(), 1, Найти(Объект.Метаданные().ПолноеИмя(), ".")) + Объект.Метаданные().Имя + "." + ТЧ.Имя + " КАК ОбъектМетаданных
                                     |ГДЕ
                                     |  ОбъектМетаданных.Ссылка = &Ссылка
                                     |УПОРЯДОЧИТЬ ПО
                                     |  НомерСтроки";

        ЗапросПроверкаТЧ.УстановитьПараметр("Ссылка", Объект.Ссылка);
        ВыборкаПроверкаТЧ = ЗапросПроверкаТЧ.Выполнить().Выбрать();
        Для Каждого СтрТЧ Из Объект[ТЧ.Имя] Цикл
            Если ВыборкаПроверкаТЧ.Следующий() Тогда
                Для Каждого Рек Из Объект.Метаданные().ТабличныеЧасти[ТЧ.Имя].Реквизиты Цикл
                    Если СтрТЧ[Рек.Имя] <> ВыборкаПроверкаТЧ[Рек.Имя] Тогда
                        Если Изменения Тогда
                            НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                            НовЭлемент.Наименование = Строка(Объект.Ссылка);
                            НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                            НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                            НовЭлемент.ДатаИзменения = ДатаИзм;
                            Изменения = Ложь;
                        КонецЕсли;
                        НовСтр = НовЭлемент.Изменения.Добавить();
                        НовСтр.Реквизит = ТЧ.Имя + ":" + Строка(СтрТЧ.НомерСтроки) + " - " + Рек.Имя;
                        НовСтр.ЗначениеДо = Строка(ВыборкаПроверкаТЧ[Рек.Имя]);
                        НовСтр.ЗначениеПосле = Строка(СтрТЧ[Рек.Имя]);
                        Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                            НовЭлемент.Записать();
                            Изменения = Истина;
                        КонецЕсли;
                    КонецЕсли;
                КонецЦикла;
            Иначе
                Для Каждого Рек Из Объект.Метаданные().ТабличныеЧасти[ТЧ.Имя].Реквизиты Цикл
                    Если Изменения Тогда
                        НовЭлемент = Справочники.ИзмененияДокументов.СоздатьЭлемент();
                        НовЭлемент.Наименование = Строка(Объект.Ссылка);
                        НовЭлемент.GUID_Объекта = Объект.Ссылка.УникальныйИдентификатор();
                        НовЭлемент.Пользователь = ПараметрыСеанса.ТекущийПользователь.Ссылка;
                        НовЭлемент.ДатаИзменения = ДатаИзм;
                        Изменения = Ложь;
                    КонецЕсли;
                    НовСтр = НовЭлемент.Изменения.Добавить();
                    НовСтр.Реквизит = ТЧ.Имя + ":" + Строка(СтрТЧ.НомерСтроки) + " - " + Рек.Имя;
                    НовСтр.ЗначениеДо = "";
                    НовСтр.ЗначениеПосле = Строка(СтрТЧ[Рек.Имя]);
                    Если НовЭлемент.Изменения.Количество() = 99999 Тогда
                        НовЭлемент.Записать();
                        Изменения = Истина;
                    КонецЕсли;
                КонецЦикла;
            КонецЕсли;
        КонецЦикла;
    КонецЦикла;

    Если Не Изменения Тогда
        НовЭлемент.Записать();
    КонецЕсли;

КонецПроцедуры

И в нужном документе/справочнике в модуле объекта вконце процедуры ПередЗаписью() размещаем следующее:

	 #Если Клиент Тогда
Если Не Отказ Тогда
    НашиДороботки.ЗаписатьИзмененияДокументаВСправочникИзмененияДокументов(ЭтотОбъект);
КонецЕсли;
#КонецЕсли

4. На форме документа/Элемента объекта метаданных документа/справочника, для которого необходимо отслеживать историю изменений, можно разместить кнопку "История изменений", которая будет отбирать из справочника только те элементы которые по данному документу/справочнику. Для этого разместим кнопку на командной панели(ну или где Вам угодно) и в обработчике нажатия на кнопку  написать следующее:

	 Процедура ДействияФормыИсторияИзменений(Кнопка)

    ФормаИзменений = Справочники.ИзмененияДокументов.ПолучитьФормуСписка();
    ФормаИзменений.СправочникСписок.Отбор.GUID_Объекта.ВидСравнения = ВидСравнения.Равно;
    ФормаИзменений.СправочникСписок.Отбор.GUID_Объекта.Использование = Истина;
    ФормаИзменений.СправочникСписок.Отбор.GUID_Объекта.Значение = Строка(ЭтотОбъект.Ссылка.УникальныйИдентификатор());

    ФормаИзменений.Открыть();

КонецПроцедуры

Обновляем информационную базу и все. При каждом изменении в справочник добавляются элементы (изменения которые внесли пользователи). Думаю данная история изменений будет кому-то интересна и удобна.

73

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. e.kogan 1849 29.09.10 16:50 Сейчас в теме
Почему не оформлено как подсистема? (О том, что баян - промолчу)
7. RTFM 83 30.09.10 13:41 Сейчас в теме
(1) Извините новичек еще, первая публикация... Сам написал это еще ы 2009 году, решил щас поделиться, может кому пригодиться...

(4) Бывают такие большие документы, где производсится изменений более чем 99999, а ограничение табличной части есть 99999 строк, для этого и есть данная проверка, он записывает один элемент истории и создает другой элемент, где указываются оставшиеся изменения после 99999. Надеюсь внятно разъяснил)) (на практике встретил, пришлось добавить данное условие ибо не дает тогда записать такие большие документы...)

(5) Извиняюсь за орфографическую ошибку)))

(6) а затем чтобы быстро(по одному щелчку мыши) и любой компентентый юзер мог просмотреть историю изменения документов или справочников.

(6) А выполнение на клиенте это и есть гуд! Так как на сервер объект не передашь ибо мутабельное значение, и на сервере не сможешь проверить какие на данный момент времени перед записью значения в объекте, а какие еще пока хранятся в базе, чтобы выявить изменения вносимые текущим юзером.
Для этого предусматривается разграничение прав на данный справочник, всем абсолютно юзерам даются права на добавление, просмотр и ввод по строке. (ни каких изменений в истории никто не сможет сделать, а это уже хорошо).
Если ты имел ввиду про дополнительный обработчик, который на стороне клиента, ну это не 8.2 с тонким клиентом чтоб так беспокоится, на 8.1 он итак очень "толстый" и сильно не "напрягает" клиент.
9. w-divin 30.09.10 15:10 Сейчас в теме
(7) с такими объемами как вы описываете (и с какими я работал) база дохнет довольно быстро... По крайней мере у нас документы правлись по 5-10 раз на дню, и документы и документоооборот немаленькие. Держать эту информацию в базе ИМХО нецелесообразно, хотя бы потому что сам просмотр изменений вызывается крайне редко по отношению к вводу документов и получениям данных из базы...

по поводу сервера - например XML-сериализацию еще никто не отменял... поищи на просторах интернета примеры проведения документов на сервере в привелигированых модулях... у нас в разных базах реализовано 3 схемы хранения истории изменений: XML, отдельная sql-база, отдельная 1С-база, в зависимости от объема рабочей базы и частоты изменений используем одну из них... вся обработка истории проходит на сервере со всеми вытекающими плюсами (с использованием привилегированных модулей)...

опять же - "чтобы быстро(по одному щелчку мыши) и любой компентентый юзер мог просмотреть историю" это совершенно не зависит от расположения данных

плюс: "Бывают такие большие документы, где производсится изменений более чем 99999" 99999 раз получать размер тч, тем более на клиенте - ну не есть это гут... совсем не есть...

"на 8.1 он итак очень "толстый"" во-первых все зависит от конфы, а во-вторых зачем еще утолщать и так очень толстое???
11. RTFM 83 30.09.10 15:34 Сейчас в теме
(9) Я тебя не заставляю пользоваться моим примером реализации, хочешь пиши свой :) . У нас данная история не используется для всех документов и справочников, а для основных, где как раз такая детальная история и необходима. Работает данная история уже довольно долго и база не сдохла... :) и не сдохнет!
Я не заметил сильного "заторможения" работы при записи документов от обычной записи.
Я конечно понял что Вы имели ввиду что это не идеал и далеко это не так, ну я не кого не принуждаю его использовать, просто поделился, меня данный вариант устраивает. При томуж очень просто в кончоле отчетов накидать отчет по изменениям для руководства :-Р
13. w-divin 30.09.10 16:27 Сейчас в теме
(11) Один из смыслов оставлять комменты тут - это как раз указать автору на негативные стороны выставленного решения... а вы как-то неадекватно на конструктивную критику реагируете... по поводу "хочешь - пиши свой" - смотри пост (9) - там сказано что у меня уже написано и работают 3 различных механизма хранения истории изменений.

Заметьте - я не написал что обработка плохая или никому не нужная - я указал на минусы, которые присутствуют в её реализации, потому как тема актуальная еще со времен клюшек... И как всегда в механизмах регистрации изменений хочется задать вопрос (хотя ответ очевиден :D ): берем документ с 5000 строк, удаляем первую строку и имеем 5000 записей об изменении.... верно? или я что-то упустил?

ну и раз уже пошла такая тема, то оригинальностью данная разработка тоже не блещет (навскидку не говоря о платных вариантах):
http://infostart.ru/public/22167/
http://infostart.ru/public/19364/
http://infostart.ru/public/63420/
15. RTFM 83 30.09.10 17:41 Сейчас в теме
(13) Конструктивная критика принята :)

берем документ с 5000 строк, удаляем первую строку и имеем 5000 записей об изменении.... верно? или я что-то упустил?


Почти угадал :)
Один элемент справочника "Изменение документов" и с табличной частью как минимум строк 4999, но и более, все зависит от количества реквизитов в ТЧ измененного документа и как они изменились по отношению к значениям которые хранились в записи на строку выше...)))
17. w-divin 30.09.10 18:36 Сейчас в теме
(15) хех...болезнь... у меня в механизме в xml реализован контроль удаления строк, но он тож далек от идеала и никак не помогает при изменении порядка строк ((( но хоть что-то... уже легше... ... а так хотелось....

в 13 я имел ввиду записи об изменениях - т.е. то что видит пользователь при анализе, а не количество записей в бд...
18. RTFM 83 30.09.10 20:25 Сейчас в теме
(17) ну я же написал, пользователь видит одну строку с одним изменением документа пользователем. (Ну это является элементом справочника) Далее открывает этот элемент справочника и в шапке отображается кто, когда и какой документ/справочник изменил, а ниже табличная часть со строками изменения реквизитов. Вот в ней, табличной части справочника, уже много строк.(показывается в каждой строке реквизит далее значение до, значение после)
23. kasper076 48 15.10.10 08:50 Сейчас в теме
(17) Может стоит пренебречь изменением номера строки? Т.е. исключить этот реквизит из проверки ТЧ.
2. vit1c 29.09.10 17:07 Сейчас в теме
Zупер!!! Пользую. Нравится.
3. Чертеночек 29.09.10 17:37 Сейчас в теме
кому боян, а кому НРАВИТСЯ:)))):{}
4. PowerBoy 2911 30.09.10 09:20 Сейчас в теме
"Если НовЭлемент.Изменения.Количество() = 99999 Тогда"

я хренею от такого кода :o
6. w-divin 30.09.10 10:15 Сейчас в теме
ну йопт... ну зачем все в базу-то пихать???

и выполнение на клиенте - это не есть гуд... можно даже сказать есть бэд...

+(4) тоже понравилось... опять же на клиенте )))
5. Asdam 115 30.09.10 10:13 Сейчас в теме
НашиДороботки
Это от слова робот?
8. zzerro 276 30.09.10 15:08 Сейчас в теме
(7 )... Так как на сервер объект не передашь ...

Это вообще как понимать?
10. RTFM 83 30.09.10 15:21 Сейчас в теме
(8) При попытки передачи объекта на сервер ругается на мутабельное значение!
12. cool.dkf 30.09.10 15:34 Сейчас в теме
(10) Все правильно - напрямую серверу передать такие значения нельзя. Где-то я уже видел что-то подобное, но все равно +
14. rumik007 30.09.10 17:17 Сейчас в теме
И в нужном документе/справочнике в модуле объекта вконце процедуры ПередЗаписью() размещаем следующее:




#Если Клиент Тогда

Если Не Отказ Тогда

НашиДороботки.ЗаписатьИзмененияДокументаВСправочникИзмененияДокументов(ЭтотОбъект);

КонецЕсли;

#КонецЕсли
Показать


:idea: Наверное лучше бы было оформить через подписку на событие.
s.w.a.t.; +1 Ответить
16. RTFM 83 30.09.10 17:46 Сейчас в теме
(14) Идея хорошая... не подумал сразу, спасибо :)
19. Michael_Osipov 10 01.10.10 08:26 Сейчас в теме
Может быть и не идеал, но работает как надо. Для нескольких документов с небольшими изменениями как раз то, что нужно. Моя благодарность автору.
20. K_A_O 522 03.10.10 08:50 Сейчас в теме
Только за Найти(Объект.Метаданные().ПолноеИмя(), ".")-1) = "Документ" хочется минус поставить
21. Djekiss 10.10.10 12:07 Сейчас в теме
Клёво! Всё работает!! оргомное СПАСИБО АВТОРУ!!!!!!!!!!!! :{}
Давно не могла решить эту проблему: как же можно отслеживать кто, когда и что именно изменил в документе или справочнике!? Теперь буду знать кому именно по голове стучать :evil: !!!!) еще раз спасибо! :D
22. Djekiss 10.10.10 12:14 Сейчас в теме
Клёво! Всё работает!! ОГРОМНОЕ СПАСИБО АВТОРУ!!!!!
Давно не знала как решить эту проблему: как же отслеживать кто, когда и что именно изменил в документе или справочнике... Теперь буду знать кому надо по голове стучать!!!)))) Еще раз СПАСИБО! :{}
24. rhtr 72 16.10.10 07:41 Сейчас в теме
ПЛЮСУЮ, а на счет событий это уже каждый дадумает сам)
25. zhleonid8 18.10.11 17:03 Сейчас в теме
автору респекти призыв на 8,2
26. i132 115 06.03.12 12:44 Сейчас в теме
RTFM, инетерсно, почему вы используете запрос а не сравниваете реквизиты ссылки и объекта?

Если построили запрос "выбрать * из ссылка" то мне кажется было бы быстрее быстрее перебирать выборка.Колонки чем перебирать реквизиты метаданных, кроме того в такой запрос попадают и табличные части в виде таблицы значений. Еще в выборку попадут стандртные реквизиты, которые вы пропустили: дата, номер, код, наименование, проведен...

Сравнение табличных частей мне кажется быстрее сравнивать через ЗначениеВстркуВнутр( табЧасть.Выгрузить()) для каждой строки табчасти вызывать Объект.Метаданные() -должно заметно увеличивать время обработки записи.

Перед присвоением ГУИД-ссылки новому объекту стоит проверить была ли уже ему присвоена другая ссылка (ГУИД <> "00000000-0000-0000-0000-000000000000")

Для поиска справочника с изменениями может быть не достаточно одного ГУИД -надо еще искать и по виду - можно создать два справочника разных видов но с одним ГУИД (в вашем случае этого не будет вы каждый раз получаете новый ГУИД)
27. AlekseiLeit 9 09.04.12 09:50 Сейчас в теме
Спасибо автору. Пригодилось
28. WildDancer 3 22.06.12 06:48 Сейчас в теме
Просто и со вкусом, и главное отлично работает. Спасибо
29. WildDancer 3 22.06.12 07:23 Сейчас в теме
Немного поторопился. Конфликтует с моей доработкой)
30. kosb_64 22.06.12 16:42 Сейчас в теме
Уже ставил "+", только он пропал куда-то. Работает отлично. Ставлю ещё раз "+"!!
31. kudim 21.06.16 12:48 Сейчас в теме
А зачем записывать изменения в событии ПередЗаписью? а если в процессе проверки ПриЗаписи формы или Объекта получим отказ и не запишем? история то уже сохранится.
Логичнее тогда уж фиксировать записанные изменения после записи объекта.
32. ukraina 28.11.17 15:32 Сейчас в теме
Понимаю, что запоздало. Установил данный код на Контрагентах и Договорах. После применения данного кода на РИБ, после обмена на филиальной базе все вновь созданные контрагенты остались без привязке к своим договорам. Т.е. договора то в базу перенеслись, но без владельца... В чем дело? почему так получилось?
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 316

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9743    ids79    42       

Три костыля. Сказ про фокусы в коде 121

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    7683    YPermitin    67       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    8090    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 241

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    10147    ids79    24       

Фоновое выполнение кода в 1С - это просто 117

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    9698    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    9108    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8558    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6159    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 192

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17227    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 176

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11441    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17108    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9716    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4751    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7272    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16244    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12625    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12740    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15318    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12620    ids79    27       

Новый подход к обмену данными EnterpriseData 203

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21271    ids79    72       

EnterpriseData - пример доработки правил конвертации без использования КД 3.0 в расширении конфигурации 118

Статья Программист Нет файла v8 v8::УФ БП3.0 УТ11 Россия Windows Бесплатно (free) Практика программирования Обмен через XML

В статье подробно описан реальный пример доработки обмена данными через EnterpriseData (универсальный формат обмена) между конфигурациями УТ 11.4 и Бухгалтерия 3.0

16.11.2018    18790    ids79    20       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 463

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    31532    GeterX    93       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19459    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 126

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20726    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20366    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14503    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21115    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19226    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24246    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21109    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16894    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11284    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24222    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35443    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25761    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21254    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    137155    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22609    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20984    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23949    json    9       

Работа с Excel 288

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24522    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46607    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 127

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    18155    vardeg    31