Загрузка справочника БИК банков с сайта Национального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON

Публикация № 812617

Учет и отчетность - Банковские операции

Загрузка файла из интернет программно 1С 7.7 HTTPСоединение JSON Классификатор банков РБ

Обработка для загрузки справочника БИК банков с сайта Национального банка Республики Беларусь. Пример скачивания файла из интернет из 1С 7.7, пример простого разбора файла JSON из 1С 7.7.

С 4 июля 2017г. в Республике Беларусь осуществлен переход на международный формат номера банковского счета IBAN (International Bank Account Number) и новые банковские идентификационные коды банков BIC (Bank Identifier Code). На сайте Национального банка Республики Беларусь представлен перечень действующих БИК банков, с описанием АPI по справочнику БИК можно ознакомиться по ссылке: http://www.nbrb.by/apihelp/bic. Файл-ответ с сайта содержит файл в формате JSON.

Обработка получает файл-ответ в формате JSON c сайта (используется внешняя компонента v7plus.dll), разбирает файл JSON и записывает новые банки в справочник банков конфигурации 1С 7.7.

Обработка тестировалось на версиях конфигураций 1С 7.7 Юкола. Бухгалтерский учет. Типовая настройка для РБ; Мисофт. Бухгалтерский учет, редакция 4,5.

//Вспомогательная функция
Функция ПреобразоватьСтрокуИзУТФ8(Стр) 
	Длина = СтрДлина(Стр); 
	Итог = ""; 
	Для Н=1 По Длина Цикл 
		Знак = Сред(Стр, Н, 1); 
		Код = КодСимв(Знак); 
		Если Код < 128 Тогда 
			Итог = Итог + Знак; 
		ИначеЕсли (Код >= 128) И (Код < 192) Тогда 
		Иначе 
			Н = Н + 1; 
			Знак2 = Сред(Стр,Н,1); 
			Код2 = КодСимв(Знак2); 
			Если Код = 208 Тогда 
				Итог=Итог + Симв(КодСимв("А")  +Код2 - 144); 
			ИначеЕсли Код = 209 Тогда 
				Итог=Итог + Симв(КодСимв("р") + Код2 - 128); 
			КонецЕсли; 
		КонецЕсли; 
	КонецЦикла; 
	Возврат Итог; 
КонецФункции 

Процедура Сформировать()
	///**** 1 **** Подключить внешнюю компоненту
	Если ЗагрузитьВнешнююКомпоненту("v7plus.dll") <> 1 Тогда
        Сообщить("Компонента v7plus.dll не найдена!");
        Возврат;
    КонецЕсли;
    ///**** 1 ****
	
	///**** 2 **** Скачать файл из интернета средствами 1С 7.7
    HTTPСоединение=СоздатьОбъект("AddIn.V7HttpReader");
    URL ="http://www.nbrb.by/API/BIC"; 
	//Описание API: http://www.nbrb.by/apihelp/bic
    ИмяФ = КаталогВременныхФайлов() + "bic.txt"; 
    Попытка
        HTTPСоединение.ПолучитьКакФайл(URL, ИмяФ);
    Исключение
        Ответ = HTTPСоединение.СтрокаСостоянияОтвета;
        Сообщить(Ответ);
        Возврат;
    КонецПопытки;
	///**** 2 ****
	 
	///**** 3 **** Разобрать файл JSON программно из 1С 7.7, заполнить ТаблицуЗначений
	//Образец описания банка в формате JSON
	//{"typ":"Банк","CDBank":"ABLTBY22","CDHeadBank":"ABLTBY22","NrBank":"898","BICStatus":"0",
	//"NmBankShort":"ЗАО 'АБСОЛЮТБАНК'","AdrBank":"Г.МИНСК","CdControl":null,"DtControl":null,"CdBankSuccessor":null} 
	ТЗ = СоздатьОбъект("ТаблицаЗначений");
	ТЗ.НоваяКолонка("КодБанка"); 
	ТЗ.НоваяКолонка("НомерБанка");
	ТЗ.НоваяКолонка("НазваниеБанка");
	ТЗ.НоваяКолонка("АдресБанка");
	Файл = СоздатьОбъект("Текст");
	Файл.Открыть(ИмяФ);
	Файл.КодоваяСтраница(1);
	Для инд = 1 По Файл.КоличествоСтрок() Цикл
		Стр = Файл.ПолучитьСтроку(инд); 
		Стр = ПреобразоватьСтрокуИзУТФ8(Стр);
		НачалоБанка = Найти(Стр, "{");
		Пока НачалоБанка > 0 Цикл 
			КонецБанка = Найти(Стр, "}");
			СтрокаБанка = Сред(Стр, НачалоБанка, КонецБанка - НачалоБанка + 1);
			Стр = СтрЗаменить(Стр, СтрокаБанка, "");
			НачалоБанка = Найти(Стр, "{");
			
			ТЗ.НоваяСтрока();
			
			Нач = Найти(СтрокаБанка, "CDBank");
			Кон = Найти(СтрокаБанка, "CDHeadBank");
			ТЗ.КодБанка = Сред(СтрокаБанка, Нач + 9, Кон - Нач - 12);  
			
			Нач = Найти(СтрокаБанка, "NrBank");
			Кон = Найти(СтрокаБанка, "BICStatus");
			ТЗ.НомерБанка = Сред(СтрокаБанка, Нач + 9, Кон - Нач - 12);
			
			Нач = Найти(СтрокаБанка, "NmBankShort");
			Кон = Найти(СтрокаБанка, "AdrBank");
			ТЗ.НазваниеБанка = Сред(СтрокаБанка, Нач + 14, Кон - Нач - 17);
			
			Нач = Найти(СтрокаБанка, "AdrBank");
			Кон = Найти(СтрокаБанка, "CdControl");
			ТЗ.АдресБанка = Сред(СтрокаБанка, Нач + 10, Кон - Нач - 13);
			
		КонецЦикла;
	КонецЦикла;
	///**** 3 ****
	
	///**** 4 **** Записать новые банки Республики Беларусь в справочник банков 1С 7.7 (МИСОФТ/ЮКОЛА)
	Банки = СоздатьОбъект("Справочник.Банки");
	ТЗ.ВыбратьСтроки();
	Пока ТЗ.ПолучитьСтроку() = 1 Цикл
		Если Банки.НайтиПоКоду(ТЗ.КодБанка) <> 0 Тогда
			Продолжить; //Банк уже существует в справочнике
		КонецЕсли;                                         
		Банки.Новый();
		Банки.Код = ТЗ.КодБанка;
		Банки.Наименование = ТЗ.НазваниеБанка;
		Банки.Адрес = ТЗ.АдресБанка;
		Банки.Записать();
		Сообщить("Загружен банк " + Тз.НазваниеБанка + " " + ТЗ.КодБанка);
	КонецЦикла;
	///**** 4 ****

	ФС.УдалитьФайл(ИмяФ);

КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
Загрузка справочника БИК банков с сайта Нацонального банка Республики Беларусь http://www.nbrb.by для конфигураций 1С 7.7 используя AddIn.V7HttpReader с разбором файла ответа в формате JSON:

.ert 42,50Kb
07.04.18
3
.ert 42,50Kb 3 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Рейтинг 1-го уровня
2. Dnki 4 03.09.18 01:11 Сейчас в теме
А здорово, когда есть в распоряжении инструменты! Набросал аналог на 8-ке:
Функция Загрузить()
	
	//	Запрос
	Соединение = Новый HTTPСоединение("www.nbrb.by");
	Попытка
	АшТТП_Ответ		= Соединение.Получить(Новый HTTPЗапрос("/API/BIC"));
	Исключение
		Сообщить(ОписаниеОшибки());
		Возврат Ложь;
	КонецПопытки;
	
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.УстановитьСтроку(АшТТП_Ответ.ПолучитьТелоКакСтроку());
	Т_Массив = ПрочитатьJSON(ЧтениеJSON, Ложь);
	
	//	Разбор
	КолНов = 0;
	КолУдл = 0;
	СпрМен = Справочники.Банки;
	Для каждого ТекЭлемент Из Т_Массив Цикл
		Т_Статус= ТекЭлемент.CdControl;
		Т_Удл	= (СтрНайти("ЛИКВ,ЗАКР", Т_Статус) > 0);
		Т_БИК	= ТекЭлемент.CdBank;
		
		//	Поиск
		СпрСылка = СпрМен.НайтиПоКоду(Т_БИК);
		
		//	Есть
		Если ЗначениеЗаполнено(СпрСылка) Тогда
			Если Т_Удл И НЕ СпрСылка.ПометкаУдаления Тогда
				СпрОбъект = СпрСылка.ПолучитьОбъект();
				СпрОбъект.УстановитьПометкуУдаления(Истина);
				Увеличить(КолУдл);
			КонецЕсли;

		//	Нету
		Иначе
			Если НЕ Т_Удл Тогда
				СпрОбъект = СпрМен.СоздатьЭлемент();
				СпрОбъект.Код			= Т_БИК;
				СпрОбъект.Наименование	= ТекЭлемент.NmBankShort;
				СпрОбъект.Адрес			= ТекЭлемент.AdrBank;
				Попытка
				СпрОбъект.Записать();
				Исключение
					Сообщить(ОписаниеОшибки());
				КонецПопытки;
				Увеличить(КолНов);
			КонецЕсли;
		КонецЕсли;	// ЗначениеЗаполнено(СпрСылка)
	КонецЦикла;	// Т_Массив

	Предупреждение("Новых: "+ КолНов+ Символы.ПС+ "Удалено: "+ КолУдл, 10);
	Возврат Истина;
КонецФункции	// Загрузить
Показать
1. Dnki 4 03.09.18 00:57 Сейчас в теме
Благодарю за идею - не знал про API сайта.
Скачиваю в знак благодарности.
Как замечание могу только сказать: из всего списка банков есть несколько со статусом "Закрыт", "Ликвидирован". Вы их обрабатываете как нормальные банки.
Оставьте свое сообщение

См. также

Расширение справочника номенклатуры 1С: 7.7 Промо

Обработка справочников v7.7 1С7:Комплекс 1С7:ТиС 1С7:ПУБ Абонемент ($m)

Подсистема для 1С: 7.7, предназначена для расширения возможностей справочника номенклатуры. Дополнительная альтернативная структура каталога. Привязка одного товара к нескольким группам. Удобный редактор привязок.

10 стартмани

25.02.2016    21691    2    spy-83    5    

Дополнение реквизитов номенклатуры из Эксель в 7.7. Групповое редактирование реквизитов номенклатуры 7.7 в списке

Обработка справочников Загрузка и выгрузка в Excel v7.7 1С7:Комплекс УУ Абонемент ($m)

Обработки группового дополнения данных о номенклатуре. Ввод веса и объема существующих товаров вручную в форму таблицы значений и затем запись в справочник Номенклатуры и Единиц. Закачка весов и объемов существующих товаров из Эксель в справочник Номенклатуры и Единиц. Загрузка внешних кодов товаров из Эксель в справочник Номенклатуры. Редактирование внешних кодов товаров в форме списка. Дозаполнение реквизитов существующих товаров из Эксель (ключевые поля - штрихкод, наименование, внешний код).

1 стартмани

11.10.2019    4562    2    ksnik    2    

Загрузка адресов произвольного формата (КЛАДР и нестандартных "грязных" адресов) в ФИАС современных конфигураций из 1С 7.7

Обработка справочников Перенос данных из 1С7.7 в 1C8.X Загрузка и выгрузка в Excel v7.7 v8 1cv8.cf 1cv7.md ERP2 Абонемент ($m)

Описание технологии загрузки любых адресов из 1С 7.7 с разложением по ФИАС в современные конфигурации 1C 8.3 на примере ERP. Предлагаемый способ просто чудо, он гарантирует результат, он очень простой и качественный! Моя обработка является синтаксическим анализатором, который подставляет в строку грязного адреса выражение "Дом №" и "Корпус", благодаря чему грязные адреса 7.7 сами очень хорошо раскладываются по значимым полям ФИАС - заполняется область, город, улица, дом, корпус.. все раскладывается само с помощью встроенного механизма современных конфигураций 1С 8.3, который написали сами сотрудники фирмы 1С!

1 стартмани

16.08.2019    7146    4    ksnik    12    

Универсальный подбор и обработка объектов для 1С: Предприятия 7.7 "UChoice.ert"

Обработка документов Универсальные обработки Обработка справочников v7.7 1cv7.md Абонемент ($m)

Универсальная обработка 7.7, представленная здесь, до сих пор почему-то по функционалу гораздо беднее, чем общеизвестная типовая "Универсальный подбор и обработка объектов" (UNIREPS82\UniversalSelection) 8.2-8.3", мне не хватило возможности выполнить произвольный код обработчика объектов. Данная обработка "UChoice.ert" является полным аналогом "UniversalSelection", представляет собой консоль выполнения произвольного кода, позволяет делать с объектами информационной базы 1С 7.7 абсолютно все, что угодно, а не узкий, сложно настраиваемый набор команд, на мой взгляд, она существенно превосходит имеющиеся аналоги, поэтому ничем другим кроме нее я не пользуюсь.

1 стартмани

04.04.2019    7111    10    ksnik    9    

Пример QR кода для Сбербанка в квитках ТСЖ (1с77)

Практика программирования Банковские операции Банковские операции v7.7 1cv8.cf Россия Абонемент ($m)

Формирование Штрихкода по ГОСТ 56042-2014 для Сбербанка.

1 стартмани

26.12.2018    6075    11    bob_    1    

Загрузка данных контрагентов по УНП из ЕГР Беларусь для 1С 7.7

Обработка справочников Обмен через XML v7.7 1cv7.md Беларусь Абонемент ($m)

Обработка получает xml-файл c данными контрагента по УНП из Государственного реестра плательщиков Республики Беларусь (http://portal.nalog.gov.by/grp/). Файл xml разбирается средствами 1С 7.7. Для получения и разбора xml используется библиотека "v7plus.dll". По УНП из файла могут быть получены такие реквизиты, как полное наименование контрагента, юридический адрес.

1 стартмани

07.04.2018    11314    2    svilsa    2    

Загрузка курсов валют с сайта НБУ или Приватбанк за период. Для Украины. 7.7

Обработка справочников WEB Банковские операции Банковские операции v7.7 1С7:Бух Украина БУ Абонемент ($m)

Загрузка курсов валют с сайта НБУ или Приватбанк за период. Для Украины. 7.7. Проверялась на "Бухгалтерский учет" для Украины. 7.70.328

2 стартмани

20.03.2018    10087    1    whtblck    0    

Как получить номер и дату договора из наименования справочника договоров? Промо

Обработка справочников Практика программирования v7.7 1cv7.md Абонемент ($m)

В типовых конфигурациях платформы "1С:Предприятие 7.7" часто номер и дата договора указаны в самом наименовании договора. Что создает сложности в тех случаях, когда эти реквизиты надо знать, например, при конвертации данных в конфигурации платформы "1С:Предприятие 8", где номер и дата договора - отдельные реквизиты.

1 стартмани

24.09.2015    20705    2    SiAl    7    

Перенумерация документов и справочников в БП 3.0 и Бух 7.7

Обработка документов Обработка справочников v7.7 v8 1С7:Бух БП3.0 Абонемент ($m)

Обработки позволяют восстановить стандартную нумерацию объектов (справочников и документов) в Бухгалтерии Предприятия 3.0. и Бухгалтерии 7.7

1 стартмани

09.02.2018    13454    119    Ant10    0    

Загрузка классификаторов УКТ ВЭД и ДКПП в базы 1С 7.7

Обработка справочников Внешнеэкономическая деятельность (ВЭД) Оптовая торговля Внешнеэкономическая деятельность (ВЭД) Оптовая торговля v7.7 1cv7.md Украина НУ Абонемент ($m)

Обработка предназначена для выборочного заполнения типового справочника "Коды для налоговых накладных" значениями из классификаторов ДКПП и УКТВЭД (украинские конфигурации)

1 стартмани

17.01.2018    9455    0    skyvixen    0    

Загрузка текущих курсов валют с сайта Национального банка РК

Обработка справочников WEB Банковские операции Банковские операции v7.7 1cv7.md Казахстан БУ Абонемент ($m)

Обработка загружает курсы валют с сайта Нацбанка РК на текущую дату. Для 1С 7.7, Казахстан.

5 стартмани

27.12.2017    8126    0    ikalichkin    0    

Загрузка из клиент банка для Украины в 1с 7.7 бух Промо

Банковские операции Обмен с банком Банковские операции v7.7 1С7:Бух Украина БУ Абонемент ($m)

Для 129 Банков Проверено, работает с текущим Укрсоцбанком. Будьте внимательны, при выгрузке и загрузке выставляйте одну и ту же дату. При старте выбираем файл>открыт обработку ClientBank.ert из папки

1 стартмани

20.12.2012    33840    38    luckardo    7    

Загрузка курсов валют с сайта НБ РБ (API)

Обработка справочников WEB Банковские операции Банковские операции v7.7 1cv7.md Беларусь Абонемент ($m)

C 2017 на сайте www.nbrb.by разработали новую загрузку курсов валют через API функции. Данный функционал сам нацбанк рекомендует использовать как основную загрузку, и сам функционал более расширен.

1 стартмани

19.12.2017    11416    9    brunet    3    

Выгрузка в клиент-банк (Беларусь)

Обмен с банком Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Выгрузка / Загрузка документов в программу Клиент-банк (Беларусь).

1 стартмани

16.12.2017    13351    7    brunet    4    

Заполнение реквизитов контрагентов по ИНН через 1С:Контрагент 1С: 7.7

Обработка справочников v7.7 1cv7.md Россия Абонемент ($m)

Обработка позволяет получить реквизиты контрагента по ИНН при наличии доступа к сервису 1С:Контрагент.

1 стартмани

11.12.2017    8669    26    Andgman    5    

7.7 : Ставки налогов и отчислений. БУХ учет Украина 2014 Промо

Обработка справочников Зарплата Зарплата v77::БУ 1С7:Бух Украина БУ НДФЛ Абонемент ($m)

Просто запустим обработку. Файл "СтавкиНалоговЗарплата2014.ert" - выполнить.

1 стартмани

22.01.2014    21615    0    kompas-dm    1    

Перенос (копирование) договоров с одного контрагента на другого

Обработка справочников v7.7 1cv7.md Абонемент ($m)

Обработка копирует договоры с контрагента-источника на контрагента-приёмника. Работает в большинстве баз данных 1С 7.7. Написана по заказу бухгалтера, которому нужно было периодически выполнять данную однотипную операцию.

1 стартмани

14.11.2017    8018    0    1v7    0    

Загрузка адреса юридического лица из ЕГРЮЛ для 1С 7.7 и 8.3

Обработка справочников v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Обработка позволяет загрузить адрес юридического лица с сайта ЕГРЮЛ (https://egrul.nalog.ru) для платформы 7.7 .Сделана на основе обработки для платформы 8.3 "Загрузка адреса юридического лица из ЕГРЮЛ" от Александра Белякова (https://infostart.ru/public/676211/).

1 стартмани

26.10.2017    7515    25    hvostik    8    

Электронный больничный. Генерация по адресу сотрудника тега ADDR2_KLADR Код адреса из KLADR 1С 7.7 Комплексная автоматизация 4.5 7.70.566

Зарплата Управление персоналом (HRM) Обработка справочников Зарплата Управление персоналом (HRM) v7.7 1С7:Комплекс Россия Абонемент ($m)

Обработка включает в себя все необходимое для генерации тэга ADDR2_KLADR по ЮрАдресу сотрудника в программе 1С 7.7 Комплексная автоматизация 4.5 7.70.566

1 стартмани

21.09.2017    9773    3    webcocon    2    

Актуатор прайс-листов для ТиС, Комплексной 7.7 Промо

Ценообразование, прайсы Обработка справочников Оптовая торговля Ценообразование, анализ цен Оптовая торговля Ценообразование, анализ цен v77::ОУ 1С7:Комплекс 1С7:ТиС Абонемент ($m)

UPD добавлена обновленная обработка, теперь актуатор позволяет копировать прайс-листы на новую дату. Актуатор предназначен для быстрого изменения даты актуальности цен на группу товаров и группу типов цен (прайс-листов) в ТиС 7.7 или комплексной. Типовая обработка позволяет мгновенно рассчитывать цены по определенным условиям, и если даже произошла ошибка в дате - ничего, казалось бы, страшного.... Открыть обработку второй раз, поставить верную дату, и выполнить тот же расчет...

1 стартмани

08.11.2013    20819    15    Krasnyj    2    

Универсальная конвертация для 1C 7.7 Беларусь: счетов/кодов банка в IBAN/BIC через сервис iban.bisc.by

Обработка справочников Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Обработка создана для упрощения перехода расчётных счетов и кодов банка в Беларуси с 4 июля 2017 г. на международный формат IBAN и BIC.

1 стартмани

21.06.2017    15035    11    1v7    6    

v77. Выгрузка и загрузка расчетных счетов в формате XML для сервиса "Калькулятор IBAN" НБ РБ

Обмен через XML Банковские операции Банковские операции v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Выгрузка старых и загрузка новых расчетных счетов в формате XML во взаимодействии с сервисом "Калькулятор IBAN" НБ РБ (http://iban.bisc.by) Представлены две обработки: 1. IBtoIBAN - выгрузка старых номеров расчетных счетов. 2. IBANtoIB - загрузка новых номеров формата IBAN. Назначение: облегчить труд бухгалтера по изменению номеров счетов в справочниках "Банковские счета" предприятия и "Расчетные счета" контрагентов.

1 стартмани

17.06.2017    14297    3    item    0    

Групповая обработка документов и справочников v.7.7

Универсальные обработки Обработка документов Обработка справочников v7.7 1cv7.md Россия Абонемент ($m)

1. Обработка позволяет совершать следующие действия над объектами: а. СПРАВОЧНИКИ: удаление; пометка на удаление; снятие пометки на удаление. б. ДОКУМЕНТЫ: удаление; пометка на удаление; снятие пометки на удаление; проведение; отмена проведения; выключить проводки; включить проводки. 2. Действия могут быть ограничены некоторыми условиями. 3. Существует отбор по видам объектов. 4. Есть возможность обработать подчиненные справочники.

1 стартмани

30.04.2017    11994    42    DUH    0    

Работа с базой штрихкодов https://barcodes.olegon.ru/ из 1C:7.7

Оптовая торговля Розничная торговля Обработка справочников WEB Оптовая торговля Розничная торговля v7.7 1cv7.md Абонемент ($m)

Все очень просто - отсканировали ШК неизвестного для вашей базы товара, и получили один или несколько :) вариантов наименования. Выбрали, которое вам нравится больше всего, скопировали в буфер, и можно создавать карточку товара, не вводя его наименование вручную, с клавиатуры, а просто вставив из буфера.

1 стартмани

07.04.2017    10459    6    M_W_W    0    

Перенос значений реквизитов справочника номенклатуры между разными базами 1С:7.7

Обработка справочников 1С7.7<->1C7.7 v7.7 1cv7.md Абонемент ($m)

Внешняя обработка для выгрузки в текстовый файл значений реквизита справочника номенклатуры базы 1С7.7. Загрузка из сформированного текстового файла значений реквизита в другой базе 1С7.7 для аналогичных элементов номенклатуры (поиск по коду и наименованию).

1 стартмани

08.02.2017    15469    16    etmarket    3    

Производственные нормативы. Групповая обработка Промо

Обработка справочников Производство готовой продукции (работ, услуг) Рабочее место Производство готовой продукции (работ, услуг) v7.7 v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Абонемент ($m)

Групповая обработка нормативов производства/ Обработка позволяет с хирургической точностью изменять затраты на производство. Добавляет, изменяет и удаляет нормы затрат.

1 стартмани

13.04.2012    21434    6    juker    5    

Универсальные обработки документов и справочников для 1С: Предприятие 7.7

Обработка документов Универсальные обработки Обработка справочников v7.7 1cv7.md Россия Абонемент ($m)

Обработки можно использовать в любой конфигурации 1С-Предприятия 7.7. Обработки позволяют просмотреть/изменить значения любого реквизита документов/справочников, существующих в базе. В обработках реализован множественный отбор по значениям реквизитов (для табличной части документов тоже). В обработке документов реализованы следующие действия: Перенумерация; проведение; отмена проведения; пометка на удаление; непосредственное удаление; снятие пометки удаления; изменение реквизитов; очистка реквизитов; удаление строк табличной части; вывод на печать и в файлы *.xls,*.csv,*.dbf,*.xml реквизитов шапки и табличной части. В обработке справочников реализованы следующие действия: Перенумерация; пометка на удаление; непосредственное удаление; снятие пометки удаления; изменение реквизитов; очистка реквизитов; очистка истории значений периодического реквизита; перенос справочника в другую базу подобной конфигурации по OLE; вывод на печать реквизитов и истории значений периодических реквизитов; вывод реквизитов в файлы *.xls,*.csv,*.dbf,*.xml; отчет по структуре справочников, вывод и обработка ссылок на выбранные элементы.

1 стартмани

23.11.2016    23888    149    SanchoD    15    

Сверка справочника контрагентов со списком Перечня лжепредприятий Республики Казахстан

Обработка справочников WEB v7.7 БП2.0 Казахстан Абонемент ($m)

Простая обработка позволяет сверить справочник контрагентов с перечнем лжепредприятий. Обработка предназначена для конфигурации Бухгалтерский учет для Казахстана 7.7

1 стартмани

16.11.2016    8791    2    Filt    0    

Тюнинг Бух.7.7, УСН: Табельный учет Промо

Зарплата Обработка документов Обработка справочников Зарплата v77::БУ 1С7:Бух Россия Абонемент ($m)

Ведем календарь и рабочие графики. Заполняем по ним табели формы Т-13. Формируем документ начисления зарплаты.

1 стартмани

20.04.2011    25594    5    Арчибальд    67    

Перенумерация справочников и документов для 1С: 7.7

Обработка документов Обработка справочников v7.7 1cv7.md Абонемент ($m)

Перенумерация справочников и документов. Поддерживает нумерацию нескольких документов с одним нумератором. Возможен отбор документов по любым реквизитам шапки. Возможно дублирование номеров на подчиненные документы.

1 стартмани

03.08.2016    16544    94    ak_register    8    

Подмена значений в документах и справочниках 7.7

Обработка документов Обработка справочников v7.7 1cv7.md Абонемент ($m)

Обработка Подмена значений в документах и справочниках 7.7, с отборами по справочникам и документам, с возможностью отсеять по периоду

1 стартмани

04.07.2016    9684    7    Turn123    3    

Деноминация в Беларуси. В помощь специалистам и обычным пользователям

Обработка документов Обработка справочников v7.7 1cv7.md Беларусь БУ Абонемент ($m)

Инструмент для деноминации числовых реквизитов справочников, документов и операций в обороте за период.

1 стартмани

14.06.2016    12559    16    ge_ni    3    

Загрузка курсов валют Национального банка республики Беларусь для 1С: 7.7

Обработка справочников WEB Обмен через XML v7.7 1С7:Бух Беларусь Абонемент ($m)

Загрузка с сайта НБРБ. Обновление загрузки курсов для 1С: 7.7.

1 стартмани

16.03.2016    14129    2    vika64    1    

Обмен данными Website X5 Evolution с 1С 7.7 (Выгрузка/загрузка/пересчёт)

Обработка справочников Внешние источники данных v7.7 1cv7.md УУ Абонемент ($m)

Обработка для выгрузки/загрузки/пересчёта в/из файла *.csv, созданного программой Website X5 Evolution в/из 1С 7.7. Проблема кодировки UTF8 - ANSI решается с помощью Recode.exe. Выгрузка в 1С и загрузка обратно Website X5 - корректно срабатывает и без декодирования.

3 стартмани

24.02.2016    10625    0    1v7    1    

Получение лицензий из ЛК ФСРАР

Обработка справочников Универсальные обработки WEB Оптовая торговля Оптовая торговля v7.7 1cv7.md Оптовая торговля, дистрибуция, логистика Абонемент ($m)

При подготовке файлов деклараций необходимо указывать действующие лицензии поставщиков. Данная обработка позволяет запросить, удалить и обновить информацию по выданным лицензиям контрагентов.

2 стартмани

17.02.2016    11175    17    knstanta    14    

Загрузка номенклатуры в 1С: 7.7 из Excel

Обработка справочников Загрузка и выгрузка в Excel v7.7 1С7:Комплекс Россия Абонемент ($m)

Обработка предназначена для автоматической загрузки номенклатуры в справочник из внешнего Excel файла.

1 стартмани

15.02.2016    12515    23    adamych8    1    

Оптимизированная загрузка КЛАДР методами прямых запросов 1С++ для клиент-серверной версии 1C 7.7

Файловые протоколы обмена, FTP Обработка справочников v7.7 1cv7.md Россия Абонемент ($m)

Не нравится, когда загрузка классификатора не заканчивается за ночь? Закачайте весь за 1 час!

1 стартмани

19.01.2016    9599    1    anreko    1    

Очистка справочников

Обработка справочников Чистка базы v7.7 1cv7.md Абонемент ($m)

Помечает на удаление подчиненные элементы у помеченных на удаление элементов справочников. Удаляет все, переносит на дату периодические значения справочников.

1 стартмани

21.12.2015    10497    14    andrey1508    1    

Проверка марок из ЛК ФСРАР

Обработка справочников WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 1cv7.md Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Рестораны, кафе и фаст-фуд Пищевая промышленность Россия Абонемент ($m)

Вашему вниманию предлагается обработка, позволяющая добавить марки на проверку на service.fsrar.ru, а также получить протоколы по проверке. Скорость работы обработки по получению протоколов проверки значительно выше стандартной процедуры работы через ресурс service.fsrar.ru. Для работы требуется действующая учетная запись (ИНН, Пароль). Обработка открыта для редактирования и модернизации.

5 стартмани

13.12.2015    26563    142    knstanta    108    

Обработка для переименования элементов справочников Номенклатура (Товары), Клиенты и других с предварительным просмотром

Обработка справочников v7.7 1cv7.md Абонемент ($m)

Данная обработка позволяет переименовывать элементы таких справочников, как Номенклатура, Товары, Клиенты и других, содержащих текстовые поля. Обработка не привязана к конкретной конфигурации, имеет несколько опций, предварительный просмотр, печать, при сохранении делает запись в журнал регистрации.

1 стартмани

10.12.2015    6760    11    vovaapril    3    

Выгрузка реестра зарплаты в Газпромбанк

Обмен с банком Банковские операции Зарплата Банковские операции Зарплата v7.7 1С7:ЗиК Россия БУ Абонемент ($m)

Выгрузка реестра заработной платы в "Газпромбанк" на основании документа "Заявка на перечисление денежных средств"

1 стартмани

01.12.2015    7893    7    deemko48    1    

Увеличение разрядности справочника

Обработка справочников v7.7 1cv7.md Абонемент ($m)

Установка нового кода после увеличения разрядности справочника

1 стартмани

19.11.2015    4118    0    atr12    1