Получение кода ФИАС для УПП 1.3 через веб-сервис 1С

Публикация № 816807

Разработка - Обработки - Универсальные обработки

обработка ФИАС веб-сервис api.orgaddress.1c.ru

Обработка позволяет получить код ФИАС для адреса в формате КЛАДР через веб-сервис 1С. Может быть полезна кадровикам при заполнении заявлений в ФСС на выплату пособий. Используется в старых конфигурациях на обычных формах - УПП, ЗУП 2.0. Для работы обязательно иметь подписку на ИТС 1С.

Как уже было сказано  в  других публикациях ( например, в //infostart.ru/public/384725/), 1 июля 2014 года вступил в силу Федеральный закон от 28.12.2013 № 443-ФЗ, обязавший использовать Федеральную информационную адресную систему (далее ФИАС) в качестве единой базы адресов для всех государственных и муниципальных организаций.

В указанной публикации предложено решение с переносом всей конструкции в свою конфигурацию. Работа трудоемкая и не всегда оправданная. В случае УПП 1.3 мы пока столкнулись с адресом в формате ФИАС только при оформлении заявлении на выплату пособия. В нём теперь нужно для адресов указывать уникальный номер по ФИАС.

 Для тех, у кого есть доступ к ИТС 1С, код ФИАС можно получить через веб-сервис 1С (https://api.orgaddress.1c.ru/orgaddress/v1?wsdl). Данная внешняя обработка для выбранного адреса конкретного физического лица формирует запрос и возвращает код дома и код улицы по ФИАС (код улицы оставлен просто для проверки). Конечно адрес должен быть заполнен правильно средствами КЛАДР.

Обработка использует обычные формы.

В разделе "Настройки" необходимо указать параметры подключения (логин и пароль) к сайту  https://users.v8.1c.ru/

В общем разделе выбирается сотрудник из справочника "Физические лица". При этом определяется какие виды адресов для выбранного сотрудника занесены в базу. По умолчанию выбирается "Адрес регистрации". Представление адреса отображается на форме.  По нажатию кнопки "Выполнить" обработка преобразует  выбранный адрес в пакет XDTO и запрашивает анализ на веб-сервисе  api.orgaddress.1c.ru. Ответ сервиса отображается в соответствующих окнах. Оттуда его можно скопировать и занести в окно "Уникальный номер по ФИАС" в заявлении на выплату пособий. 

Если код не сформировался или сформировался только код улицы, то адрес нужно проверять на сайте налоговой. Возможно, в базе ФИАС нет такого дома или он неправильно внесён в вашей базе.

Обработка тестировалась на конфигурации УПП 1.3.105.2 на платформах 1С:Предприятие 8.3 (8.3.9.1850) и (8.3.11.2867). 

Скачать файлы

Наименование Файл Версия Размер
Получение кода ФИАС для УПП 1.3 через веб-сервис 1С:
.epf 10,46Kb
13.04.18
148
.epf 10,46Kb 148 Скачать
Получение кода ФИАС для УПП 1.3 через веб-сервис 1С 8.2:
.epf 10,49Kb
08.06.18
30
.epf 10,49Kb 30 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. leon131167 18.04.18 08:12 Сейчас в теме
Добрый день.

Вываливается с ошибкой
{Форма.Форма.Форма(7,32)}: Конструктор не найден
ЗащищенноеСоединение = Новый <<?>>ЗащищенноеСоединениеOpenSSL(Неопределено, Неопределено);
{Форма.Форма.Форма(8,24)}: Конструктор не найден
WSОпределения = Новый <<?>>WSОпределения("https://api.orgaddress.1c.ru/orgaddress/v1?wsdl", Логин, Пароль, ,10, ЗащищенноеСоединение);
{Форма.Форма.Форма(10,17)}: Конструктор не найден
Сервис = Новый <<?>>WSПрокси(WSОпределения, "http://www.v8.1c.ru/ssl/AddressSystem", "AddressSystem", "AddressSystemSoap12",
2. AlekSo 13 18.04.18 11:30 Сейчас в теме
(1) Добрый. А на какой платформе? Такое возможно на платформе 8.2 Там если я не ошибаюсь не было защищенного соединения. Я тестировал хоть и на 8.3, но в режиме совместимости версии 8.2.13. По крайней мере отсюда должно работать.
3. AlekSo 13 18.04.18 11:33 Сейчас в теме
Только-что обнаружил, что возвращается код именно дома! Почему-то не возвращает код помещения. Работаю над этим!
4. deman_ru 20 20.04.18 17:39 Сейчас в теме
5. AlekSo 13 23.04.18 04:53 Сейчас в теме
6. katnevamk 23.04.18 07:27 Сейчас в теме
УПП, редакция 1.3 (1.3.106.2) всё прекрасно работает!!! А то мы замучились бухгалтерам вставлять коды с сайта ФИАС, ожидая когда разработчики сделают. Спасибо!
7. user960210 24.04.18 07:20 Сейчас в теме
Возражу. УПП, редакция 1.3 (1.3.106.2) . по прежнему возвращает код дома. Ждём исправления.
8. androidT1C 73 24.04.18 15:58 Сейчас в теме
Смотрю, какой код ФИАС пишет 1С в реестр больничных (по пилотному проекту ФСС) в ЗУП КОРП 3.0: туда вообще пишется код улицы! Код дома пишется только если НЕ найден (пустой) код ОКТМО по региону.
Поэтому мне для реестров в ФСС кода дома вполне достаточно :)
9. AlekSo 13 25.04.18 04:20 Сейчас в теме
Если бы ещё понимать как этот код используется в ФСС. Возможно им действительно достаточно кода дома.
1С отказывается давать консультации по веб-сервису. Пока пробую разные комбинации вставки номера квартиры в XDTO. Но похоже дело всё же в том, как это обрабатывает веб-сервис. Возможно в их задачи просто не входит определение кода помещения.
10. akitayev 2 25.04.18 09:57 Сейчас в теме
Если зайти на сайт fias.nalog.ru, то для нашего областного центра (Великий Новгород) просто отсутствуют номера помещений (квартир). И до настоящего момента отсылаем реестры в ФСС с пустым кодом ФИАС.
11. AlekSo 13 25.04.18 10:38 Сейчас в теме
(10)С пустым он как-раз не отправляется. По крайней мере в заявлении. Должен быть заполнен хоть чем-то. Хоть всеми единицами. Похоже его никто не проверяет. Вот если стоит признак отправки заказным письмом, то они могут поставить вместо адреса только код, и тогда письмо не дойдёт. Но вряд-ли они уже ввели такую технологию.
12. androidT1C 73 25.04.18 11:34 Сейчас в теме
У нас (Нижний Новгород) пока ФСС принимает с пустым кодом. Сколько это продлится - хз.
13. userGJ 17.05.18 13:24 Сейчас в теме
А есть где-то нормативный документ, в котором регламентировано какой ФИАС нужен в реестрах ФСС: код дома или код поиещения (квартиры)?
14. AlekSo 13 21.05.18 10:59 Сейчас в теме
(13) Я такого пока не нашёл.

Обнаружил интересную весчь!

Создал больничный лист, указал сотрудника. В заявлении в поле адреса встает адрес только до дома! Хотя в контактной информации физлица квартира есть. Похоже всё-таки везде указывается именно дом.
15. arakelyan 371 29.05.18 15:32 Сейчас в теме
ЗУП 2.5 не проходит аутентификацию. (ИТС Проф действующий)
16. AlekSo 13 30.05.18 05:45 Сейчас в теме
(15) Сделал несколько попыток. Действительно пару раз выпадала ошибка на аутентификацию. Но при следующей попытке всё сработало. Попробуйте ещё раз. Возможно сервер был занят.
17. arakelyan 371 30.05.18 22:23 Сейчас в теме
18. ANDRU48DOP 5 04.06.18 16:04 Сейчас в теме
Адаптировал на платформе 8.2.19.130

Проверил также по сайту http://fias.nalog.ru/ExtendedSearchPage.aspx

На сайте бьется мой адрес до квартиры, а в вашей обработке только до дома?
Можно ли изменить, чтобы бился в обработке id до квартиры, как на сайте http://fias.nalog.ru/ExtendedSearchPage.aspx ?
20. sea123 13 06.06.18 20:09 Сейчас в теме
(18) Подскажите, что именно было сделано под платформу 8.2?
Я вроде бы привел параметры в соответствие с платформой, но постоянно получаю вот такую ошибку.
Новый WSОпределения("https://api.orgaddress.1c.ru/orgaddress/v1?wsdl", Логин_, Пароль_,10) {(1)}: Ошибка при вызове конструктора (WSОпределения)
21. ANDRU48DOP 5 07.06.18 09:44 Сейчас в теме
(20)
Подскажите, что именно было сделано под платформу 8.2?
Я вроде бы привел параметры в соответствие с платформой, но постоянно получаю вот такую ошибку.
Новый WSОпределения("https://api.orgaddress.1c.ru/orgaddress/v1?wsdl", Логин_, Пароль_,10) {(1)}: Ошибка при вызове конструктора (WSОпределения)


Оставить вот так WSОпределения("https://api.orgaddress.1c.ru/orgaddress/v1?wsdl", Логин_, Пароль_);

и прокси только три первых параметра

Сервис = Новый <<?>>WSПрокси(WSОпределения, "http://www.v8.1c.ru/ssl/AddressSystem", "AddressSystem", "AddressSystemSoap12")

на 8.2.19.130 взлетело на 19.90 не работает
23. AlekSo 13 08.06.18 05:04 Сейчас в теме
(18)Может, конечно, это от адреса зависит, но у меня и на 8.2 такой же ответ.
19. ANDRU48DOP 5 04.06.18 16:06 Сейчас в теме
При повторном запросе выходит иногда выходит

{ВнешняяОбработка.фиас_ПолучениеКодаФИАС.МодульОбъекта(27)}: Ошибка при вызове метода контекста (Ping)
Результат = Сервис.Ping(КодЯзыка, Метаданные.Имя);
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка вызова операции сервиса: {http://www.v8.1c.ru/ssl/AddressSystem}:AddressSystem:Ping()
по причине:
При вызове веб-сервиса произошла ошибка. Ошибка HTTP: HTTP Status 403.
.

403 Forbidden
nginx
22. AlekSo 13 08.06.18 05:03 Сейчас в теме
Добавил версию для платформы 8.2. Проверял на 8.2.19.130.
24. ANDRU48DOP 5 08.06.18 09:33 Сейчас в теме
(22)
Добавил версию для платформы 8.2. Проверял на 8.2.19.130.


Скажите, идентификатор ФИАС только до дома (от чего это зависит)?
На сайте фиас налог до квартиры бьется.
25. AlekSo 13 08.06.18 09:59 Сейчас в теме
поскольку 1С не даёт никаких описаний своего веб-сервиса, то всё разбирается экспериментальным путём. пакет для запроса разрабатывался по описаниям ФИАС. Почему не возвращается код помещения - определить не могу.
26. SashasDas 27.08.18 16:44 Сейчас в теме
Работало до предыдущей пятницы. Теперь на строке WSОпределения = Новый WSОпределения("https://api.orgaddress.1c.ru/orgaddress/v1?wsdl", Логин, Пароль,10) вылетает с ошибкой "При создании описания сервиса произошла ошибка. https://9011371:xxxxxxx@api.orgaddress.1c.ru/orgaddress/v1?wsdl
по причине:
Ошибка работы с Интернет: Peer certificate cannot be authenticated with given CA certificates". Что-то поменялось у 1С-ников?
27. AlekSo 13 29.08.18 08:00 Сейчас в теме
(26)У меня работает по прежнему. Если ругается на сертификат, то может причина в обновлении винды?
28. SashasDas 29.08.18 10:02 Сейчас в теме
Не обновлял. Движок 8.2.19.130. На винде обновление отключено. Сейчас просто вставил метаданные из БП в КА, и ФИАС получаю по связи кода кладр между РС АдресныеОбъекты и АдресныйКлассификатор. Недостаток: связь вижу на уровне улицы - не глубже.
29. Dmtr666 08.11.18 07:33 Сейчас в теме
Костыль с curl :)
Работает на 8.2.19.80
В папку с curl нужно добавить cacert.pem поновее(я брал на its).

Процедура КнопкаВыполнитьНажатие(Кнопка)
	Перем КодВозврата;

	ДирКурл = "C:\curl";
	УИН_Улицы = "";
	УИН_Дома = "";
	
	ЗапуститьПриложение(
		ДирКурл + "\curl -k --cacert " + ДирКурл + "\cacert.pem --tlsv1.2 https://" + Логин + ":" + Пароль + "@api.orgaddress.1c.ru/orgaddress/v1?wsdl -o wsdl.xsd",
		ДирКурл,
		Истина,
		КодВозврата
	);
	WSОпределения = Новый WSОпределения(ДирКурл + "\wsdl.xsd");//, Логин, Пароль);
	
	Сервис = Новый WSПрокси(WSОпределения, "http://www.v8.1c.ru/ssl/AddressSystem", "AddressSystem", "AddressSystemSoap12");
	Сервис.Пользователь	= Логин;
	Сервис.Пароль		= Пароль;
	
	СписокДляПроверки = Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.v8.1c.ru/ssl/AddressSystem", "AddressList"));
	//В список проверки добавляем адрес
	ТипЭлементаСписка = СписокДляПроверки.Свойства().Получить("Item").Тип;
	ПроверяемыйАдрес =  СписокДляПроверки.Item.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
	//Уровни, по которым проверяется адрес (см. в специальной функции)
	ПроверяемыйАдрес.Levels  = УровниКлассификатораФИАС();
	
	АдресXDTO = Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.v8.1c.ru/ssl/contactinfo", "АдресРФ"));
	
	АдресXDTO.СубъектРФ	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.Регион);
	
	Если ЗначениеЗаполнено(АдресСотрудника.Район) Тогда
		//Добавим в адрес район 
		ТипЭлемента = АдресXDTO.Свойства().Получить("СвРайМО").Тип;
		РайонАдреса = Сервис.ФабрикаXDTO.Создать(ТипЭлемента);
		РайонАдреса.Район = Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.Район);
		АдресXDTO.СвРайМО = РайонАдреса;
	КонецЕсли;
	
	АдресXDTO.Город 	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.Город);
	
	Если ЗначениеЗаполнено(АдресСотрудника.НаселенныйПункт) Тогда
		//Добавим в адрес населенный пункт 
		АдресXDTO.НаселПункт = Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.НаселенныйПункт);
	КонецЕсли;
	
	АдресXDTO.Улица 	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.Улица);
	
	//Добавим в адрес дом 
	ТипЭлементаСписка = АдресXDTO.Свойства().Получить("ДопАдрЭл").Тип;
	ДомАдреса = АдресXDTO.ДопАдрЭл.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
	
	ТипЭлементаСписка = ДомАдреса.Свойства().Получить("Номер").Тип;
	НомерДома = ДомАдреса.Номер.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
	
	Если АдресСотрудника.ТипДома = Перечисления.ТипыДомов.Дом Тогда
		КодЭлементаДом = "1010";
	ИначеЕсли АдресСотрудника.ТипДома = Перечисления.ТипыДомов.Владение Тогда
		КодЭлементаДом = "1020";
	КонецЕсли;
	
	Если КодЭлементаДом = Неопределено Тогда
		Предупреждение("Неверно заполнен тип дома сотрудника. Перезаполните его заново");
		Возврат "";
	КонецЕсли;
	
	НомерДома.Тип 	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), КодЭлементаДом);
	НомерДома.Значение 	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"),  АдресСотрудника.Дом);
	
	Если ЗначениеЗаполнено(АдресСотрудника.Корпус) Тогда 
		//Добавим в адрес корпус
		ТипЭлементаСписка	= АдресXDTO.Свойства().Получить("ДопАдрЭл").Тип;
		КорпусАдреса		= АдресXDTO.ДопАдрЭл.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
		
		ТипЭлементаСписка	= КорпусАдреса.Свойства().Получить("Номер").Тип;
		НомерКорпуса		= КорпусАдреса.Номер.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
		
		Если АдресСотрудника.ТипКорпуса = Перечисления.ТипыКорпусов.Корпус Тогда
			КодЭлементаПомещения = "1050";
		ИначеЕсли АдресСотрудника.ТипКорпуса = Перечисления.ТипыКорпусов.Литера Тогда
			КодЭлементаПомещения = "1080";
		ИначеЕсли АдресСотрудника.ТипКорпуса = Перечисления.ТипыКорпусов.Строение Тогда
			КодЭлементаПомещения = "1060";
		КонецЕсли;

		
		НомерКорпуса.Тип		= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), КодЭлементаПомещения);
		НомерКорпуса.Значение	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.Корпус);
	КонецЕсли;

	Если ЗначениеЗаполнено(АдресСотрудника.Квартира) Тогда 
		//Добавим в адрес квартиру
		ТипЭлементаСписка	= АдресXDTO.Свойства().Получить("ДопАдрЭл").Тип;
		КвартираАдреса		= АдресXDTO.ДопАдрЭл.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
		
		ТипЭлементаСписка	= КвартираАдреса.Свойства().Получить("Номер").Тип;
		НомерКвартиры		= КвартираАдреса.Номер.Добавить(Сервис.ФабрикаXDTO.Создать(ТипЭлементаСписка));
		
		Если АдресСотрудника.ТипКвартиры = Перечисления.ТипыКвартир.Квартира Тогда
			КодЭлементаПомещения = "2010";
		ИначеЕсли АдресСотрудника.ТипКвартиры = Перечисления.ТипыКвартир.Комната Тогда
			КодЭлементаПомещения = "2050";
		ИначеЕсли АдресСотрудника.ТипКвартиры = Перечисления.ТипыКвартир.Офис Тогда
			КодЭлементаПомещения = "2030";
		ИначеЕсли АдресСотрудника.ТипКвартиры = Перечисления.ТипыКвартир.Помещение Тогда
			КодЭлементаПомещения = "2020";
		КонецЕсли;
		
		НомерКвартиры.Тип		= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), КодЭлементаПомещения);
		НомерКвартиры.Значение	= Сервис.ФабрикаXDTO.Создать(Сервис.ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema", "string"), АдресСотрудника.Квартира);
	КонецЕсли;
	
	ПроверяемыйАдрес.Address = АдресXDTO;
	
	ПараметрыЗаписиXML = Новый ПараметрыЗаписиXML("CESU-8", "1.0", Истина);
	ЗаписьXML = Новый ЗаписьXML;
	ЗаписьXML.ОткрытьФайл("C:\curl\request.xml", ПараметрыЗаписиXML);
	ЗаписьXML.ЗаписатьНачалоЭлемента("soap:Envelope");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("soap", "http://www.w3.org/2003/05/soap-envelope");
	ЗаписьXML.ЗаписатьНачалоЭлемента("soap:Body");
	ЗаписьXML.ЗаписатьНачалоЭлемента("m:Analyze");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("m", "http://www.v8.1c.ru/ssl/AddressSystem");
	ЗаписьXML.ЗаписатьНачалоЭлемента("m:Values");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xs", "http://www.w3.org/2001/XMLSchema");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
   	//Сервис.ФабрикаXDTO.ЗаписатьXML(ЗаписьXML, СписокДляПроверки);
	Сервис.ФабрикаXDTO.ЗаписатьXML(ЗаписьXML, ПроверяемыйАдрес, "Item");
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ЗаписьXML.ЗаписатьНачалоЭлемента("m:Locale");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xs", "http://www.w3.org/2001/XMLSchema");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
	ЗаписьXML.ЗаписатьТекст("ru");
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ЗаписьXML.ЗаписатьНачалоЭлемента("m:CheckAsKladr");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xs", "http://www.w3.org/2001/XMLSchema");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
	ЗаписьXML.ЗаписатьТекст("false");
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ЗаписьXML.ЗаписатьНачалоЭлемента("m:ConfigurationName");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xs", "http://www.w3.org/2001/XMLSchema");
	ЗаписьXML.ЗаписатьСоответствиеПространстваИмен("xsi", "http://www.w3.org/2001/XMLSchema-instance");
	ЗаписьXML.ЗаписатьТекст("БухгалтерияПредприятия");
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ЗаписьXML.ЗаписатьКонецЭлемента();
	ЗаписьXML.ЗаписатьКонецЭлемента();
	
   	ЗаписьXML.Закрыть();
	ЗапуститьПриложение(
		ДирКурл + "\curl -k --cacert " + ДирКурл + "\cacert.pem --tlsv1.2 --header ""content-type: application/soap+xml"" --data @request.xml https://" + Логин + ":" + Пароль + "@api.orgaddress.1c.ru/orgaddress/v1 -o response.xml",
		ДирКурл,
		Истина,
		КодВозврата);

        ЧтениеXML = Новый ЧтениеXML;
	Попытка
		ЧтениеXML.ОткрытьФайл("C:\curl\response.xml");
	Исключение
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Не удалось получить ответ.";
		Сообщение.Сообщить();
		Возврат;
	КонецПопытки;

	Пока ЧтениеXML.Прочитать() Цикл
		Если ЧтениеXML.ТипУзла <> ТипУзлаXML.НачалоЭлемента Тогда Продолжить; КонецЕсли; 
		Если ЧтениеXML.Имя = "Error" Тогда
			Сообщение = Новый СообщениеПользователю;
			Сообщение.Текст = ЧтениеXML.ЗначениеАтрибута("Text");
			Сообщение.Сообщить();
		ИначеЕсли ЧтениеXML.Имя = "Variant" Тогда
			УИН_Улицы = ЧтениеXML.ЗначениеАтрибута("ID");
		    УИН_Дома = ЧтениеXML.ЗначениеАтрибута("HouseID");
		КонецЕсли;
	КонецЦикла;

КонецПроцедуры
Показать
30. dendzu 46 26.11.18 08:49 Сейчас в теме
Обработка хорошая (спасибо), помогла в моем проекте, но брал только уникальный код дома. Уникальные коды региона, города, населенного пункта - вот этих данных жаль нет в этой проге. Пришлось брать другим путем. Код смотрел Ваш, но не стал углубятся - времени не было.
31. dendzu 46 26.11.18 13:29 Сейчас в теме
(30)Еще добавлю. Из 146 сотрудников из списка таки не нашел УИН домов у 5 -ых. Смотрел в чем проблема, но не увидел ошибок. Зашел на сайт ФИАС, набил адрес и так проставил УИН.
32. silis 06.12.18 10:26 Сейчас в теме
Не работает, если тип дома - владение, поправьте, пожалуйста
33. AlekSoTSK 07.12.18 10:21 Сейчас в теме
(32) В коде стоит подстановка владения. Есть какой-нибудь адрес с владением для проверки?
34. silis 07.12.18 14:07 Сейчас в теме
(33)429150, Чувашская Республика - Чувашия, Комсомольский р-н, Асаново д, Советская ул, владение № 16

...Если АдресСотрудника.ТипДома = Перечисления.ТипыДомов.Владение Тогда
КодЭлементаДом = "1020";
КонецЕсли;

Откуда взяли этот код? Я перерыл информацию, ничего не нашел.
Методом проб и ошибок, я подобрал, что, если поставить КодЭлементаДом = "1030", тогда работает верно.
35. diml 2 11.11.19 14:23 Сейчас в теме
С корпусом тоже проблемы. Не бьется УИН дома, хотя на сайте ФИАС проходит.
36. gpinf 26.11.19 18:39 Сейчас в теме
Добрый день!

Выдает ошибку:

{ВнешняяОбработка.ПолучениеКодаФИАС.Форма.Форма.Форма(109)}: Индекс находится за границами массива
Отзыв = Результат.Item[0].Variant[0];
user849791; +1 Ответить
Оставьте свое сообщение

См. также

Установка предопределенных элементов: просмотр, исправление и поиск ошибок (задвоенных и отсутствующих) Промо

Инструментарий разработчика Универсальные обработки v8 1cv8.cf Абонемент ($m)

Простая обработка для просмотра и установки значений предопределенных элементов. Позволяет заменить значение предопределенного элемента с одного элемента справочника на другой, удалить предопределенный элемент (снять пометку предопределенности), установить пометку переопределенного элемента. Проверяет предопределенные данные на наличие задвоений и отсутствующих. Работает со справочниками, планами счетов, планами видов характеристик, планами видов расчетов.

2 стартмани

06.10.2014    142259    1941    ekaruk    164    

Заполнение кода ФИАС (расширение для Инфокрафт: Формула ЖКХ)

Обработка справочников WEB v8 v8::УФ 1cv8.cf Энергетика и ЖКХ Россия Абонемент ($m)

Расширение для конфигурации "Инфокрафт: Формула ЖКХ" начиная с версии 1.0.23.06 и выше (на других не тестировалось). Позволяет заполнить "Код дома по ФИАС" для здания по указанному адресу. Функционал доступен только при подключенной интернет-поддержке пользователей (https://users.v8.1c.ru/).

2 стартмани

10.07.2019    1742    3    dsuryaninov    0    

Сравнение pdf-файлов актов сверки

Универсальные обработки Дебиторская и кредиторская задолженность Дебиторская и кредиторская задолженность v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Обработка сравнивает два pdf-файла, в которых находятся стандартные печатные формы актов сверки, и показывает на экране совпадающие и/или отличающиеся по суммам документы взаиморасчетов.

1 стартмани

19.12.2018    14210    6    Torin99    2    

Расчет Тарификации и зарплаты в средних общеобразовательных школах для ЗКГУ 3.1 (релиз 3.1.14.55) Промо

Бухгалтерия Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Данная настройка конфигурации предназначена для расчета Тарификации педработников и расчета зарплаты в средних общеобразовательных учреждениях. Настройка сделана на базе Типовой конфигурации "Зарплата и кадры государственного учреждения" редакции 3.1.

2 стартмани

05.09.2018    21320    42    ivnik    10    

Выгрузка изображений из справочника на диск

Учет ТМЦ Универсальные обработки Учет ТМЦ v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Обработка позволяет записать изображения из справочка Номенклатура на диск в указанное место.

1 стартмани

30.11.2018    13832    5    wrooom    8    

Обнуление остатков регистров бухгалтерии и накопления

Универсальные обработки Чистка базы v8 v8::БУ v8::ОУ v8::УФ КА1 БП2.0 ЗУП2.5 УТ10 УПП1 УНФ БГУ ERP2 БП3.0 УТ11 УХ КА2 ЗУП3.x Россия Абонемент ($m)

Обработка позволяет обнулить остатки по регистру накопления или бухгалтерии на определенную дату. Поддерживается большинство типовых конфигураций (БП 3, БП 2, УТ 11, УТ 10, ЗУП 3, ЗУП 2, БГУ 2, БГУ 1, ERP, УПП, КА 2, КА 1, УХ 3, УХ 1, УНФ). Гибкая настройка (отборы, заполнение реквизитов и любых полей корр. счета, возможность обнулять ресурсы выборочно). Несколько режимов работы. Два интерфейса: простой и с расширенным набором настроек.

2 стартмани

19.11.2018    18868    253    morozov.sv    34    

Проверка действительности паспортов, проверка ФЛ на негатив в ЗУП 3.1

Бухгалтерские Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Обработка проверки действительности паспортов физических лиц в 1С ЗУП 3.x. Обработка обращается к API сервису проверки паспортов и открытых реестров. При работе в демо режиме обращение к сервису происходит с задержкой в 2 секунды. Проверка ФЛ на негатив осуществляется по следующим открытым реестрам: реестр дисквалифицированных лиц, реестр массовых руководителей, реестр массовых учредителей, реестр лиц причастных к террористической деятельности, открытый реестр недействительных паспортов. Не работает в демо режиме.

1 стартмани

04.11.2018    14923    15    user718500    4    

Навигатор по конфигурации базы 1С 8.3 Промо

Инструментарий разработчика Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для просмотра метаданных конфигураций баз 1С 8.3. Отображает свойства и реквизиты объектов конфигурации, их количество, основные права доступа и т.д. Отображаемые характеристики объектов: свойства, реквизиты, стандартные рекизиты, реквизиты табличных частей, предопределенные данные, регистраторы для регистров, движения для документов, команды, чужие команды, подписки на события, подсистемы. Отображает структуру хранения объектов базы данных, для регистров доступен сервис "Управление итогами". Платформа 8.3, управляемые формы. Версия 1.1.0.59 от 07.05.2020

3 стартмани

28.10.2018    28060    268    ROL32    67    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    28108    111    json    33    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    17299    12    RocKeR_13    16    

Расширение резервов отпусков

Обработка документов Зарплата Зарплата v8 v8::СПР ERP2 ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Произвольная настройка базы для расчета резервов отпусков.

2 стартмани

10.08.2018    21172    51    СергейКа    16    

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    199974    3056    ekaruk    178    

Пример использования REST API Яндекс Диска

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    20238    32    MKFreeUser    14    

Обмен файловыми базами данных через Yandex диск

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    14657    5    slimper    1    

Проверка и корректировка данных по выплате зарплаты

Закрытие периода Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Госбюджет Абонемент ($m)

Обработка показывает остатки и движения взаиморасчетов с сотрудниками. Также обработка может откорректировать сумму остатков. Конфигурации: "Зарплата и управление персоналом" , релиз не ниже 3.1.2.105 и "Зарплата и кадры государственного учреждения" , релиз не ниже 3.1.2.105.

2 стартмани

08.06.2018    21602    146    APTEM_SLV    14    

Внешняя компонента для работы по Web-socket протоколу Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

5 стартмани

30.03.2018    21401    31    Ditron    68    

Конфигурация для просмотра публичных телеграм каналов

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    15339    10    DO_WHILE_LOOP    7    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    19545    18    notserioussam    2    

Подстановка кода ФИАС в больничном листе. ЗУП 2.5

Зарплата Обработка документов Зарплата v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Подстановка кода ФИАС в больничном листе ЗУП 2.5 при выборе сотрудника.

3 стартмани

28.04.2018    14010    46    zul333    4    

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    10912    34    RocKeR_13    10    

Просмотр, изменение реквизитов объекта. Сравнение двух одинаковых объектов метаданных ИБ

Универсальные обработки v8 1cv8.cf Россия Абонемент ($m)

Показывает реквизиты объекта (ов) или сравнивает два одинаковых объекта конфигурации справочники, документы.

1 стартмани

26.04.2018    15784    24    Vin_Tik    0    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    26345    67    charivnick    3    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    35053    151    kostya_whiskas    24    

Трудовой договор, Дополнительное соглашение к трудовому договору, Лист ознакомления, Договор о материальной ответственности, Договор о коммерческой тайне, Согласие на обработку персональных данных для ЗУП 3.1 Промо

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Комплект печатных форм для отдела кадров для документов Прием на работу и Кадровый перевод: Трудовой договор, Доп. соглашение к трудовому договору, Лист ознакомления с локальными нормативными актами, Договор о полной материальной ответственности, Договор о неразглашении коммерческой тайны, Согласие на обработку персональных данных.

2 стартмани

12.03.2019    26211    139    Asenka    34    

Построение маршрута доставки с расчётом расстояния для любой базы УФ

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    30992    40    KorotkovRV    16    

Трудовой договор, Дополнительное соглашение, Материальная ответственность, Коллективная материальная ответственность, Кадровый перевод, Индексация, Т-53 для ЗУП 3 внешние (7 печатных форм). Создание ведомостей по каждому сотруднику одной кнопкой

Печатные формы документов Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

1. Комплект из 6 печатных форм для документов: Прием на работу, Индексация, Кадровый перевод, Кадровый перевод списком для ЗУП 3.1.11 и более ранних Трудовой договор, дополнительное соглашение, договор личной материальной ответственности, договор коллективной материальной ответственности, индексация, Ведомость Т-53 без лишних строк. Не требуется изменения конфигурации. Подключается через стандартное подключение внешних обработок. 2. Обработка для создания ведемостей из начисления зарплаты. 3. Расширение конфигурации для ЗУП 3.1.11 и КА 2.4.6 для редактирования стажа как в ЗУП 2.5 (Из трудовой деятельности сотрудника. Если ввели строки трудовой деятельности, то стаж считается до даты приема сотрудника).

1 стартмани

26.01.2018    40243    486    p.ugrumov    96    

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    26702    141    btydj    3    

Настройки отчета "Анализ начислений и удержаний" для ЗУП/ЗГУ 3.1 Промо

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Несколько полезных настроек отчета "Анализ начислений и удержаний" для зарплаты редакции 3.1. В состав входят настройки: Свод в разрезе налогообложения, Сводные данные для статистики, Реестр пособий, Расчетная ведомость по зарплате, Свод в разрезе финансирования, Отклонения от режима работы, Свод по зарплате в разрезе ИФНС, Начисления с детализацией отсутствий, Лицевые счета сотрудников, Распределение отпусков, Сводка затрат

2 стартмани

03.05.2018    32425    221    the1    36    

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника. ЗУП 3.1

Обработка документов Загрузка и выгрузка в Excel Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Абонемент ($m)

Расчет начисления зарплаты со сложной формулой, по данным из внешнего источника по данным экономического отдела. ЗУП 3.1.

3 стартмани

20.12.2017    40995    31    mvv1975    7    

Сервер push сообщений “Push0k“ 18.05

WEB v8 1cv8.cf Абонемент ($m)

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    15326    12    PloAl    20    

Справка о заработной плате и других доходах (измененная форма №46)

Справки Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 Россия БУ Абонемент ($m)

Форма разработана для автоматизированного формирования справки по форме № 46. Внешний отчет с возможностью пользовательских настроек.

3 стартмани

24.11.2017    35328    52    agospodarin    15    

Быстрый запрос Промо

Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Можно ли дать пользователю "удочку", а не "рыбу"? До сих пор ответ на этот вопрос был отрицательным. Всякий инструмент, который мог бы делать с базой данных все или почти все (или хотя бы многое), отвергался пользователями, как слишком сложный. Вспомните тот же SQL, который изначально разрабатывался именно как пользовательский инструмент. "Быстрый запрос" - это попытка устранить сложность, но сохранить при этом универсальность.

1 стартмани

29.04.2019    12597    25    mkalimulin    28    

Налоги и взносы (кратко) по подразделениям и сотрудникам. ЗУП 3

Бухгалтерские Зарплата Зарплата v8 v8::СПР ЗУП3.x Россия БУ НДФЛ ФОМС, ПФ, ФСС Абонемент ($m)

Отчет "Налоги и взносы (кратко)" в разрезе подразделений и сотрудников.

3 стартмани

13.11.2017    32200    164    tritonof    9    

Подсистема Вики - интеграция 1С и сайта под управлением MediaWiki

WEB v8 Абонемент ($m)

Редактирование статей сайта Mediawiki из 1С. Формирование функционального описания конфигурации на сайте Вики.

1 стартмани

19.09.2017    25929    33    shmalevoz    20    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    14820    10    vipchep    0    

Проверка VAT номеров Промо

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    9750    0    wtlz    1    

Инструменты бухгалтера: Виджеты рабочего стола

Универсальные обработки Рабочее место v8 v8::БУ БП3.0 Абонемент ($m)

Настраиваемые виджеты на начальной странице, своеобразная панель для быстрого доступа к объектам. Виджеты это элементы интерфейса в виде цветных прямоугольников со ссылками на объекты конфигурации. Использование виджетов позволяет сконцентрировать на начальной странице часто используемые функции, например, варианты отчетов, списки документов, или используя виджет вводить новый документ прямо из начальной страницы.

2 стартмани

28.08.2017    33835    168    Bazil    26    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    68842    48    Indgo    33    

Перемещение остатков по счету МЦ04 между материально ответственными лицами для конфигураций (8.2). Промо

Обработка документов Универсальные обработки Учет ТМЦ Учет ТМЦ v8 БП2.0 Россия БУ Абонемент ($m)

Небольшая обработка, которая позволяет перекидывать остатки по счету МЦ04 с одного материально ответственного лица на другое

1 стартмани

22.11.2012    11115    13    niksaf    4    

Поиск и исправление ошибок при заполнении 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0, УПП 1.3 версия от 28.08.2018

Регламентированная отчетность Бухгалтерские Анализ учета Зарплата Зарплата v8 v8::БУ v8::СПР БП2.0 ЗУП2.5 УПП1 Россия БУ НДФЛ Абонемент ($m)

Помощь в поиске и исправлении ошибок при заполнении отчёта 6-НДФЛ в ЗУП 2.5, Бухгалтерии 2.0 Просмотр всех записей регистров, имеющих отношение к учёту НДФЛ с детализаций до сотрудника и документа. Ручная корректировка основных регистров. Обновлённая версия от 02.07.2018г

3 стартмани

25.10.2016    33820    212    serge_msk    21    

Настройка рекламной кампании Яндекс.Директ на 30000 ключевых фраз за 60 минут - теперь это реально!

WEB v8 Реклама, PR и маркетинг Россия Абонемент ($m)

Конфигурация для настройки Яндекс.Директа.

10 стартмани

20.10.2016    27283    51    avalakh    10    

Поиск и отключение зависших сеансов на сервере 1С: Предприятия

Универсальные обработки v8 1cv8.cf Россия Абонемент ($m)

Обработка предназначена для мониторинга и отключения спящих (зависших) сеансов на сервере 1С: Предприятия.

1 стартмани

14.09.2016    29004    61    wowchik_85    11    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    23179    8    Smaylukk    3    

Редактор движений документа. Сохранение в XML, обмен между базами, замена регистратора.

Обработка документов Универсальные обработки Обмен через XML v8 Абонемент ($m)

Редактор набора записей движений документа. Позволяет сохранить набор записей в XML, в настройки пользователя, прочитать сохраненный XML в другой идентичной базе, заменить регистратор. Можно изменять порядок записей, менять активность, как массово, так и по одной и др. Тонкий клиент, управляемые формы.

1 стартмани

07.09.2016    37840    153    Aphanas    4    

Универсальный поиск объектов по глобальному уникальному идентификатору (ГУИД, GUID)

Универсальные обработки Поиск данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Универсальная обработка поиска объектов информационной базы по глобальному уникальному идентификатору (ГУИД, GUID) или по его части.

1 стартмани

06.09.2016    29996    101    Dzenn    9    

Конструктор-тестер http запросов в 1С

WEB Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Данная обработка позволяет в несколько кликов конструировать http запросы на языке 1С и просматривать результаты их выполнения.

3 стартмани

19.08.2016    39226    294    hlopik    17    

Редактор объектов информационной базы 8.3 Промо

Инструментарий разработчика Универсальные обработки v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Универсальная внешняя обработка для редактирования реквизитов и табличных частей объектов информационной базы, редактирование движений документов. Доступ ко всем реквизитам объектов, есть возможность выгрузки и загрузки данных (объекты и движения документов) через XML. Платформа 8.3, управляемые формы. Версия 1.1.0.45 от 01.05.2020

2 стартмани

23.01.2019    22346    245    ROL32    33    

Легкий интернет-магазин из УТ 11.2

WEB Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля v8 УТ10 УУ Абонемент ($m)

Обработка создания интернет-магазина из УТ 11. Создается единственный файл html, который содержит все выгруженные товары. Клиент составляет и отправляет заказ вам на e-mail прямо из браузера, не прибегая к использованию стороннего ПО.

11.08.2016    28126    23    hlopik    36    

Hello world на metadata.js

Инструментарий разработчика WEB Мобильная разработка v8 1cv8.cf Абонемент ($m)

Про браузерные offline-first приложения можно написать миллионы слов. Сэкономлю своё и ваше время и перейду сразу к делу. В статье не будет рекламы и агитации за новые технологии, не будет критики традиционных или попсовых решений. Рассмотрим по шагам разработку простейшей программы на metadata.js. Постараюсь сделать акцент не на том «как это сделано», а «почему сделано именно так»

1 стартмани

11.08.2016    54255    111    unpete    208    

Оптимальный способ расчета контрольной суммы объекта/записи регистра (CRC32, MD5, SHA1, SHA256)

Универсальные обработки v8 1cv8.cf Абонемент ($m)

Была задача сравнить документы в распределенных базах и пометить на выгрузку измененные. Но сравнение изменений документов методом перебора реквизитов - долгоиграющий процесс, особенно если общее количество сравниваемых данных переваливает за миллион. Был найден выход, который ускоряет процесс сравнения - расчет контрольной суммы объекта и сравнение ее с другой контрольной суммой. Скорость сравнения увеличивается во много раз.

1 стартмани

01.08.2016    27713    6    hakerxp    9    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен)

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    30734    19    c1nil    4