IE 2018

Добавление МРОТ в регистр Минимальная оплата труда РФ

Обработки - Универсальные обработки

МРОТ минимального размера оплаты труда минимальная размер оплата труда плата труда добавить МинимальнаяОплатаТрудаРФ

0
Добавление значений минимального размера оплаты труда (МРОТ) в регистр сведений Минимальная оплата труда РФ.

Данная обработка предназначена для добавления новых значений МРОТ в регистр МинимальнаяОплатаТрудаРФ. 

Обработка тестировалась на конфигурации 1С:ERP Управление предприятием 2 (2.2.4)

Пример добавления МРОТ в регистр.

Проверим что в регистре нет значения на интересующую нас дату.

Укажем значение и дату нового МРОТ.

Нажмем "Добавить МРОТ", затем "Открыть регистр". Убедимся в том, что новое значение добавлено.

Далее представлен код обработки.

&НаСервере
Процедура ДобавитьМРОТНаСервере()
     НаборЗаписей = РегистрыСведений.МинимальнаяОплатаТрудаРФ.СоздатьНаборЗаписей();
    НаборЗаписей.ДополнительныеСвойства.Вставить("ЗаписьОбщихДанных");
    НаборЗаписей.Отбор.Период.Использование = Истина;
    НаборЗаписей.Отбор.Период.Значение = ДатаДействия;
    
    НоваяЗапись = НаборЗаписей.Добавить();
    НоваяЗапись.Период = ДатаДействия;
    НоваяЗапись.Размер = Размер;
    
    НаборЗаписей.ОбменДанными.Загрузка = Истина;
    НаборЗаписей.Записать();
КонецПроцедуры

&НаКлиенте
Процедура ДобавитьМРОТ(Команда)
    ДобавитьМРОТНаСервере();
КонецПроцедуры

&НаКлиенте
Процедура ОткрытьРегистр(Команда)
    ОткрытьФорму("РегистрСведений.МинимальнаяОплатаТрудаРФ.ФормаСписка");
КонецПроцедуры


 

0

Скачать файлы

Наименование Файл Версия Размер
Добавление МРОТ в регистр МинимальнаяОплатаТрудаРФ
.epf 6,22Kb
23.05.18
2
.epf 1.0 6,22Kb 2 Скачать

См. также

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение