Альтернативная форма выбора времени для УФ как Android

Программирование - Работа с интерфейсом

2
Форму можно использовать в разработках, где требуется указывать время альтернативным способом. Например, на тачскрине пальцем/стилусом.

Приведен пример вызова данной формы. Алгоритм: вызвали форму, указали дату, часы, указали минуты, нажали "Готово", обновили дату в реквизите.

Процедура ДатаВыгрузкиОткрытие(Элемент, СтандартнаяОбработка)
	Если Элемент.ТолькоПросмотр ИЛИ НЕ Элемент.Доступность Тогда
		Возврат;
	КонецЕсли;
	
	П = Новый Структура;
    П.Вставить("Дата",   НачалоДня(Объект.ДатаВыгрузки));
    П.Вставить("Час",    Час(Объект.ДатаВыгрузки));
    П.Вставить("Минута", Минута(Объект.ДатаВыгрузки));

	Оп = Новый ОписаниеОповещения("ВыполнитьПослеЗакрытияВыбораВремени", ЭтотОбъект, П);
   	ОткрытьФорму("ОбщаяФорма.ВыборВремени", П, ЭтаФорма,,,,Оп);		
	
	СтандартнаяОбработка = Ложь;
	
КонецПроцедуры


Процедура ВыполнитьПослеЗакрытияВыбораВремени(ВыбЭлемент, ДопПараметры)
	Если НЕ ВыбЭлемент = Неопределено Тогда
		Объект.ДатаВыгрузки = ВыбЭлемент.Дата + 3600 * ВыбЭлемент.Час + 60 * ВыбЭлемент.Минута;
	КонецЕсли;
КонецПроцедуры

Универсальная, для управляемого приложения.

Тестировал на релизе 8.3.10.2580.

2

Скачать файлы

Наименование Файл Версия Размер
Альтернативная форма выбора времени для УФ как Android:
.epf 6,93Kb
30.05.18
1
.epf 6,93Kb 1 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
2. saa@kuzov.org 30.05.18 16:42 Сейчас в теме
Подскажите, пожалуйста, если эта форма альтернативная, то какая форма для выбора ВРЕМЕНИ штатная?
4. avkonyshev 2 31.05.18 11:25 Сейчас в теме
штатная, это ввод цифр ручками в поле ввода
5. ЧерныйКот 31.05.18 12:54 Сейчас в теме
2 года назад такую искал, сейчас неактуально, но плюсану, полезная штука
Оставьте свое сообщение