Андрей Овсянкин | Профессиональный разработчик | ООО Серебряная Пуля

«1Script.Web - будущее интернет-приложений на 1Script»

Современный мир технологий неотделим от веб-инфраструктуры. 4 года назад на Инфостарт был анонсирован проект 1Script, который был призван снизить порог вхождения специалиста 1С в мир скриптов автоматизации: настройки серверов, развертывания баз, тестирования и прочего DevOps. Спустя 4 года можно заключить, что проект удался. Количество 1С-специалистов, осваивающих современные инженерные практики с помощью знакомого синтаксиса растет день ото дня. Веб-приложения это не только сайты и интернет-магазины. Запрос рынка таков, что любое современное клиент-серверное приложение должно иметь веб-интерфейс. Почему бы тогда не писать такие приложения на языке 1С? В своем докладе я хочу анонсировать новую платформу на базе 1Script - новый движок веб-приложений, который должен дать 1С-никам возможность создавать востребованные веб-приложения, не переключаясь в малознакомые языковые экосистемы. Мы обсудим возможности этой платформы, подумаем о перспективах этого направления и тому, какие возможности она может нам (как сообществу 1С-ников) предоставить. В качестве демонстрации покажу "боевое" приложение на новом движке - кросс-платформенную консоль администрирования парка кластеров 1С с веб-интерфейсом на борту. В кулуарах будут приветствоваться жаркие споры и священные войны.

Альтернативная форма выбора времени для УФ как Android

Программирование - Работа с интерфейсом

Форму можно использовать в разработках, где требуется указывать время альтернативным способом. Например, на тачскрине пальцем/стилусом.

Приведен пример вызова данной формы. Алгоритм: вызвали форму, указали дату, часы, указали минуты, нажали "Готово", обновили дату в реквизите.

Процедура ДатаВыгрузкиОткрытие(Элемент, СтандартнаяОбработка)
	Если Элемент.ТолькоПросмотр ИЛИ НЕ Элемент.Доступность Тогда
		Возврат;
	КонецЕсли;
	
	П = Новый Структура;
    П.Вставить("Дата",   НачалоДня(Объект.ДатаВыгрузки));
    П.Вставить("Час",    Час(Объект.ДатаВыгрузки));
    П.Вставить("Минута", Минута(Объект.ДатаВыгрузки));

	Оп = Новый ОписаниеОповещения("ВыполнитьПослеЗакрытияВыбораВремени", ЭтотОбъект, П);
   	ОткрытьФорму("ОбщаяФорма.ВыборВремени", П, ЭтаФорма,,,,Оп);		
	
	СтандартнаяОбработка = Ложь;
	
КонецПроцедуры


Процедура ВыполнитьПослеЗакрытияВыбораВремени(ВыбЭлемент, ДопПараметры)
	Если НЕ ВыбЭлемент = Неопределено Тогда
		Объект.ДатаВыгрузки = ВыбЭлемент.Дата + 3600 * ВыбЭлемент.Час + 60 * ВыбЭлемент.Минута;
	КонецЕсли;
КонецПроцедуры

Универсальная, для управляемого приложения.

Тестировал на релизе 8.3.10.2580.

Скачать файлы

Наименование Файл Версия Размер
Альтернативная форма выбора времени для УФ как Android:
.epf 6,93Kb
30.05.18
1
.epf 6,93Kb 1 Скачать

См. также

Комментарии
2. Алексей Шачнев (saa@kuzov.org) 30.05.18 16:42 Сейчас в теме
Подскажите, пожалуйста, если эта форма альтернативная, то какая форма для выбора ВРЕМЕНИ штатная?
4. Александр Конышев (avkonyshev) 2 31.05.18 11:25 Сейчас в теме
штатная, это ввод цифр ручками в поле ввода
5. Андрей Белов (ЧерныйКот) 31.05.18 12:54 Сейчас в теме
2 года назад такую искал, сейчас неактуально, но плюсану, полезная штука
Оставьте свое сообщение