Печать всех документов без проведения в ЗУП 3.1 (без изменения конфигурации)

Обработки - Обработка документов

Печать без проведения ЗУП

5
Подключаемое расширение к конфигурации ЗУП 3.1, которое позволяет печатать любые документы без необходимости проведения.

В типовой конфигурации при печати большинства документов требуется проведение документа.

Кое-где такое требование является излишним. К примеру, печать Приказа на отпуск. В связи с такой необходимостью было сделано простенькое расширение конфигурации, которое переопределяет необходимость проведения документа на просто запись.

Текст расширения:

&После("ПриОпределенииКомандПодключенныхКОбъекту")
Процедура Расш1_ПриОпределенииКомандПодключенныхКОбъекту(НастройкиФормы, Источники, ПодключенныеОтчетыИОбработки, Команды)
    Для каждого СтрокаКоманда Из Команды Цикл
        Если СтрокаКоманда.РежимЗаписи = "Проводить" Тогда 
              СтрокаКоманда.РежимЗаписи = "Записывать";
        КонецЕсли;     
    КонецЦикла;
КонецПроцедуры

Для подключения расширения необходимо:

1. Открыть раздел Администрирование, выбрать "Печатные формы, отчеты и обработки".

2. Открыть "Расширения"

3. Выбрать приложенный к публикации файл.

4. Снять галку "Безопасный режим".

5. Перезапустить сеанс 1С.

 

Естественно, что для некоторых документов проведение необходимо. Не забывайте проводить документы перед формированием таких печатных форм ;)

Расширение разрабатывалось для версии ЗУП 3.1.6.54. Но должно работать и в более поздних.

5

Скачать файлы

Наименование Файл Версия Размер
Печать всех документов без проведения в ЗУП 3.1 (без изменения конфигурации):
.cfe 5,07Kb
08.06.18
16
.cfe 1.1.2 5,07Kb 16 Скачать

См. также

Комментарии
Избранное Подписка Сортировка: Древо
1. plus_sign 4 08.06.18 09:35 Сейчас в теме
Расширение отключает необходимость перепроведения для всех команд.
В т.ч. для команды ДвиженияДокумента.
1) Открываем документ. Например, Индивидуальный график
2) Удаляем 1 строку
3) Не перепроводя, вызваем команду "Движения документа". На требование записи данных отвечаем положительно.
4) Видим, что в движения по удаленной строке по-прежнему остались.

В связи с этим, ИМХО имеет смысл вставить проверку:

Если СтрокаКоманда.Идентификатор = "ДвиженияДокумента" тогда
Продолжить;
КонецЕсли;
3. Wrols 74 08.06.18 18:18 Сейчас в теме
(1)Добавил. Спасибо!
Правда у себя такое поведение воспроизвести не смог.
Если записывается проведенный документ, то по всей логике он должен быть проведен (если программно не указано иное).
2. dsdred 872 08.06.18 10:43 Сейчас в теме
Вот же параметр который за проверку отвечает:
// * ПроверкаПроведенияПередПечатью - Булево - (необязательный) Признак необходимости проверки проведенности
// документов перед печатью. Если выбран хотя бы один непроведенный документ, то
// перед выполнением команды печати возникает диалог проведения.
// Для непроведенных документов команда печати не выполняется.
// Если параметр не указан, то проверка проведенности не выполняется.

Вот статья по этому поводу https://infostart.ru/public/829577/
4. Wrols 74 08.06.18 18:18 Сейчас в теме
5. НЕЛ 56 13.11.18 10:14 Сейчас в теме
Расширение не подключается из-за режима совместимости . ЗУП 3.1 , релиз 3.1.8.137. Платформа 8.3.13.1513.
Прикрепленные файлы:
6. НЕЛ 56 13.11.18 10:18 Сейчас в теме
Расширение не сработало (режим совместимости) .ЗУП 3.1, релиз 3.1.8.137 . Платформа 8.3.13.1513.
Оставьте свое сообщение