Козлов Илья | Директор по ИТ | ООО "Агрохолдинг "Энергомера"

«СКД от Microsoft. Что умеет MS SQL Reporing Services и в чём он лучше СКД от 1С?»

- Что представляет из себя MS SQL Server Reporting Services (SSRS). Как это работает. - Установка и развертывание SSRS. Это действительно просто. - SQL Server Data Tools. От запроса до отчета несколько кликов мышью. - Усложним задачу. Группировки, вложенные отчеты, расшифровки, параметризация. - Функции SSRS которых нет (и скорее всего никогда не будет) в СКД. Цель доклада - не противопоставление SSRS и СКД и выяснение, кто сильнее: кит или слон. Цель доклада - познакомить с хорошим инструментом создания отчетов и показать сценарии, в которых им можно пользоваться.

Программное удаление документов

Администрирование - Чистка базы

Программное непосредственное удаление документов для 1С: 8.3 (управляемые формы).

Иногда необходимо удалить документы из базы 1С несмотря на наличие ссылок на них. Пометка на удаление и затем удаление помеченных объектов желаемого результата не принесут.

Ниже представлен код управляемой формы обработки, который удаляет все документы ПорчаТоваров.

&НаСервере
Процедура Команда1НаСервере()
	// Вставить содержимое обработчика.
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	ПорчаТоваров.Ссылка КАК Ссылка
	               |ИЗ
	               |	Документ.ПорчаТоваров КАК ПорчаТоваров";
	Выборка = Запрос.Выполнить().Выбрать();
	Пока Выборка.Следующий() Цикл
		ПорчаТоваровОбъект = Выборка.Ссылка.ПолучитьОбъект();
		ПорчаТоваровОбъект.Удалить();
	КонецЦикла;	
КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
	Команда1НаСервере();
КонецПроцедуры

В моем случае обработка пригодилась для завершения обновления 1С Управление торговлей до версии 11.4.3.160. После обновления выполняются дополнительные процедуры обработки данных, часть из которых у меня завершалась ошибкой. И в разделе НСИ и администрирование - Обслуживание - Результаты обновления и дополнительная обработка данных было указано: "Не все процедуры удалось выполнить (выполнено 12 из 14)."

Одна из процедур завершилась ошибкой:
"Процедура "Документы.ПорчаТоваров.ОбработатьДанныеДляПереходаНаНовуюВерсию" обработки данных завершилась с ошибкой:
"{ОбщийМодуль.ОбновлениеИнформационнойБазыСлужебный.Модуль(4342)}: Произошло зацикливание процедуры обработки данных. Выполнение прервано. ВызватьИсключение ТекстИсключения;"

При установке пометки удаления на документ Порча товаров (у меня был единственный в базе) возникала ошибка: "Ошибка при выполнении обработчика - 'ПередЗаписью' по причине:
{ОбщийМодуль.ОбновлениеИнформационнойБазы.Модуль(194)}: Действия с объектом временно запрещены, так как не завершен переход на новую версию программы.
Не завершены следующие процедуры обработки данных: Документы.ПорчаТоваров.ОбработатьДанныеДляПереходаНаНовуюВерсию ВызватьИсключение Результат.ТекстИсключения."

В общем получился замкнутый круг, в связи с чем и было принято решение удалить документ программно с использованием приложенной обработки, после чего ошибка ушла.

Открывать через Файл - Открыть.

Тестировалось на 1С: Управление торговлей, редакция 11.4.3.160.

Скачать файлы

Наименование Файл Версия Размер
Программное удаление документов 1с 8.3:
.epf 5,79Kb
14.06.18
0
.epf 5,79Kb Скачать

См. также

Комментарии
1. Александр Невский (user627612_petroa) 15.06.18 09:12 Сейчас в теме
Простите конечно, но мне кажется подобные методы решения знают многие)
2. Timur Maleev (Timur.V) 11 15.06.18 10:30 Сейчас в теме
Наверно, это вредная обработка, которая создает битые ссылки в программе 1С.
Администрирование - Удаление помеченных объектов - Удалить выборочно.
Посмотрите ссылки на объект, проанализируйте можно ли удалить ссылки. А затем принимайте правильное решение.
3. Николай Иванов (PhoenixAOD) 54 15.06.18 10:33 Сейчас в теме
А чем типовое решение не устроило? Лень искать объекты на которые ссылается удаляемый?
9. Игорь Васильев (vasilievil) 10 16.06.18 00:04 Сейчас в теме
(3) Более подробно описал в публикации причину разработки кода, чтобы было понятно в каких случаях может пригодиться.
4. Имя Фамилия (user774630) 15.06.18 10:48 Сейчас в теме
Зачем выкладывать подобный мусор?
manuel; BigB; user633533_encantado; Bassgood; V.Stavinsky; +5 Ответить
5. Вадим Иванов (vynosmozga) 5 15.06.18 10:58 Сейчас в теме
А еще бы обработку, что бы диск системный форматнуть ... на низком уровне. )))
6. John Doe (Jimbo) 6 15.06.18 11:41 Сейчас в теме
ВнешняяОбработка1 и Команда1 довольно мудрое решение, сразу всем понятно что она делает, как и самодокументированный код. Наверно всем понадобится
7. Александр Васильев (user633533_encantado) 2 15.06.18 11:47 Сейчас в теме
8. Игорь Костюк (foxey) 3 15.06.18 13:25 Сейчас в теме
Хмм... Загрузок 0. Разве на это рассчитывал автор?
10. Роман Ложкин (webester) 28 16.06.18 19:49 Сейчас в теме
уиии я удалил документ программно! пойду запилю пост на ИС :) как же я завидую ТС
Оставьте свое сообщение