Конвертация прериодических реквизитов справочников

Публикация № 84763

Разработка - Практика программирования

6
Активно работаю с конфигурацией "Конвертация" версии 2.0, но возникают ситуации,
когда необходимо написать правила обмена между базами данных 1С:Предприятие. Когда
и источник и приемник имеют версию 7.7. И камень преткновения - выгрузка периодических
реквизитов справочников.

Мне удалось с этим справиться следующим образом.

ВЫГРУЗКА ПЕР. РЕКВИЗИТОВ:
1). Для возможности  отбора (ограничения) реквизитов, для которых необходимо
выгружать всю историю изменения их значений добавил
параметр "Периодика" и в обработчике "Перед выгрузкой данных" присвоил ему тип
"Список значений"

Параметры.Периодика = СоздатьОбъект("СписокЗначений");
практческий смысл его использования покажу на примере:
Например для выгрузки справочника "Цены", имеющего периодические реквизиты "Цена",
Валюта" "и "Единица" укажу только те, которые понадобятся при загрузке:
ВыгрРеквЦены = СоздатьОбъект("СписокЗначений");
ВыгрРеквЦены.ДобавитьЗначение("Единица");
ВыгрРеквЦены.ДобавитьЗначение("Цена");
Параметры.Периодика.Установить("Цены", ВыгрРеквЦены);
2). создал алгоритм  "ВыгрузитьПериодическиеРеквизиты"
//*********************************************************
Проверять = 0;  ВыгруженоЗаписей = 0;
СписокПерРекв = Параметры.Периодика.Получить(Источник.Вид());
Если ТипЗначенияСтр(СписокПерРекв) = "СписокЗначений" Тогда 
 Если СписокПерРекв.РазмерСписка() > 0 Тогда Проверять = 1; КонецЕсли;
КонецЕсли;
Информация = СоздатьУзел("ПериодическиеРеквизиты");
СпрМД = Метаданные.Справочник(Источник.Вид());
НеИспользуется = ?(Источник.ЭтоГруппа()=1, "ДляЭлемента", "ДляГруппы");
П = СоздатьОбъект("Периодический");
ДатаНач = ДатаНачала; ДатаКон = ДатаОкончания;
Если ДатаНач = Дата(0) Тогда ДатаНач = РабочаяДата(); КонецЕсли;
Если ДатаКон = Дата(0) Тогда ДатаКон = РабочаяДата(); КонецЕсли;
Для Инд = 1 По СпрМД.Реквизит() Цикл  
 // Заполняем список периодических реквизитов выбранного справочника
 Если (СпрМД.Реквизит(Инд).Периодический = 1) Тогда
  РеквМД = СпрМД.Реквизит(Инд);
  ИмяРеквизита = РеквМД.Идентификатор;
  Если РеквМД.Использование = НеИспользуется Тогда Продолжить; КонецЕсли;
  Если Проверять = 1 Тогда
   Если СписокПерРекв.НайтиЗначение(ИмяРеквизита) = 0 Тогда Продолжить; КонецЕсли;
  КонецЕсли;
  П.ИспользоватьОбъект(ИмяРеквизита, Источник);
  //Сообщить("  Оборабатывается реквизит "+ИмяРеквизита);
  СтароеЗнач = 0; СчПП = 0;
  П.ВыбратьЗначения(ДатаНач, ДатаКон); 
  Пока П.ПолучитьЗначение() > 0 Цикл
   ТекДок = П.ТекущийДокумент();
   Если ПустоеЗначение(ТекДок) = 0 Тогда
    Если ТекДок.ДатаДок > ДатаКон Тогда Продолжить; КонецЕсли;
   КонецЕсли;
   ТекущееЗнач = П.Значение;
   ТипРекв = ТипЗначенияСтр(ТекущееЗнач);
   Если ПустоеЗначение(ТекущееЗнач) = 1 Тогда 
    Если ТипРекв = "Число" Тогда // 0 тоже может быть
    ИначеЕсли ТипРекв = "Строка" Тогда // пустая строка тоже может быть
    Иначе
     Продолжить; 
    КонецЕсли; 
   КонецЕсли; 
   Если ТекущееЗнач <> СтароеЗнач Тогда
    СчПП = СчПП + 1;
    УзелСвойства = СоздатьУзел("Свойство");  
    УстановитьАтрибут(УзелСвойства, "Имя", ИмяРеквизита);
    ТипИВидРекв = ТипРекв;
    Если (ТипРекв = "Документ") ИЛИ (ТипРекв = "Справочник") ИЛИ (ТипРекв = "Перечисление") Тогда
     ТипИВидРекв = ТипРекв+"Ссылка."+ТекущееЗнач.Вид();
    КонецЕсли;
    УстановитьАтрибут(УзелСвойства, "Тип", ТипИВидРекв);
    УстановитьАтрибут(УзелСвойства, "ДатаЗнач", ПолучитьДатуV8(П.ДатаЗнач));
    Если (ТипРекв = "Документ") ИЛИ (ТипРекв = "Справочник") Тогда
     //УзелСсылки = СоздатьУзел("Ссылка");
     УзелСсылки = ВыгрузитьПоПравилу(ТекущееЗнач, , , , ТекущееЗнач.Вид()); // , УзелСсылки
     ДобавитьПодчиненный(УзелСвойства, УзелСсылки.cloneNode(1));
    ИначеЕсли (ТипРекв = "Перечисление") Тогда
     ЗаписатьЭлемент(УзелСвойства, "Значение", ТекущееЗнач.Идентификатор());
    Иначе
     ЗаписатьЭлемент(УзелСвойства, "Значение", ТекущееЗнач); 
    КонецЕсли;
    
    ДобавитьПодчиненный(Информация, УзелСвойства);
    СтароеЗнач = ТекущееЗнач; ВыгруженоЗаписей = ВыгруженоЗаписей + 1;
   КонецЕсли;
  КонецЦикла;
  
  Если СчПП = 0 Тогда // запишем хоть что-нибудь
   ТекущееЗнач = П.ЗначениеНаДату(ДатаНач);
   ТипРекв = ТипЗначенияСтр(ТекущееЗнач);
   Если ПустоеЗначение(ТекущееЗнач) = 1 Тогда 
    //Если ТипРекв = "Число" Тогда // 0 тоже может быть (на Ваше усмотрение) !!!
    //ИначеЕсли ТипРекв = "Строка" Тогда // пустая строка тоже может быть
    //Иначе
     Продолжить; 
    //КонецЕсли; 
   КонецЕсли; 
   УзелСвойства = DOMDocument.createNode(1, "Свойство", "");  
   УстановитьАтрибут(УзелСвойства, "Имя", ИмяРеквизита);
   ТипИВидРекв = ТипРекв;
   Если (ТипРекв = "Документ") ИЛИ (ТипРекв = "Справочник") ИЛИ (ТипРекв = "Перечисление") Тогда
    ТипИВидРекв = ТипРекв+"Ссылка."+ТекущееЗнач.Вид();
   КонецЕсли;
   УстановитьАтрибут(УзелСвойства, "Тип", ТипИВидРекв);
   УстановитьАтрибут(УзелСвойства, "ДатаЗнач", ПолучитьДатуV8(ДатаНач));
   Если (ТипРекв = "Документ") ИЛИ (ТипРекв = "Справочник") Тогда
    УзелСсылки = ВыгрузитьПоПравилу(ТекущееЗнач, , , , ТекущееЗнач.Вид()); // , УзелСсылки
    ДобавитьПодчиненный(УзелСвойства, УзелСсылки.cloneNode(1));
   ИначеЕсли (ТипРекв = "Перечисление") Тогда
    ЗаписатьЭлемент(УзелСвойства, "Значение", ТекущееЗнач.Идентификатор());
   Иначе
    ЗаписатьЭлемент(УзелСвойства, "Значение", ТекущееЗнач); 
   КонецЕсли;
   
   ДобавитьПодчиненный(Информация, УзелСвойства);
   ВыгруженоЗаписей = ВыгруженоЗаписей + 1;
  КонецЕсли;
 КонецЕсли;
КонецЦикла;
ДобавитьПодчиненный(Приемник, Информация);
//**********************************************
3). Для справочников, периодические раевизиты которых вы хотите выгружать
в обработчике "После выгрузки" правил конвертации следует прописать указанную выше
процедуру ВыгрузитьПериодическиеРеквизиты();
ЗАГРУЗКА ДАННЫХ:
Для загруки можно прописать в обработке загрузки (и каждый раз при
ее обновлении не забывать вновь вносить корректировки) или внести изменения
в базе "Конвертация" через конфигуратор:
Обработка "Выгрузка крнвертации", макет "ПроцедурыИФункцииМодуляЗагрузки"
Добавил процедуру и ссылки на нее:
//--------------------------------------------------------------------------------------------------
Процедура ЗагрузитьПериодичРеквизиты(Объект, Элемент, Вид, ОбъектМД)
 //левченко  периодические реквизиты
 Значения = Объект.ВыбратьУзел("ПериодическиеРеквизиты"); 
 Если ПустоеЗначение(Значения) = 0 Тогда  
  Пер=СоздатьОбъект("Периодический");
   
  Реквизиты = Значения.ВыбратьУзлы("Свойство");
  Для Сч = 0 По Реквизиты.КоличествоУзлов() - 1 Цикл
   Реквизит     = Реквизиты.ПолучитьУзел(Сч);
   ИдРеквизита     = Реквизит.ПолучитьАтрибут("Имя");
   НеЗамещатьРеквизит   = Реквизит.ПолучитьАтрибут("НеЗамещать");
   Значение     = УстановитьРеквизитV8(Реквизит, "Справочник", Вид, ИдРеквизита);
   ДатаЗначения = ДатаИзXML(Реквизит.ПолучитьАтрибут("ДатаЗнач"));  
   
   Пер.ИспользоватьОбъект(ИдРеквизита, Элемент);
   Если Пер.ЗначениеНаДату(ДатаЗначения) = Значение Тогда продолжить КонецЕсли;
   
   Если Значение = "#НеУстановлен" Тогда
    ЗаписатьОшибку("Не установлен реквизит.  Справочник." + Вид + ":  Реквизит: " + ИдРеквизита);
    Продолжить;
   КонецЕсли;
 
   Если ИдРеквизита = "ПометкаУдаления" Тогда
    ПометкаУдаления = Значение;
   Иначе
    Если Найти("Код,Наименование,Родитель,Владелец", ИдРеквизита) = 0 Тогда
     РеквМД      = ОбъектМД.Реквизит(ИдРеквизита);
     ПредставлениеРеквизита  = " (Справочник." + Вид + "." + ИдРеквизита + ")";
     Если РеквМД.Выбран()  = 0 Тогда ЗаписатьОшибку("Неверное имя реквизита:" + ПредставлениеРеквизита); Продолжить;     КонецЕсли;
     
     Если РеквМД.Тип="Неопределенный" Тогда
      ТипЗнач = ОпределитьСтроковыйТип(Реквизит.ПолучитьАтрибут("Тип"));
      Точность  = 0;
      Если ТипЗнач = "Число" Тогда
       СтрТочность = Значение;
       Точность = СтрДлина( ОтделитьРазделителем(СтрТочность, ".") );
      КонецЕсли;
      Пер.НазначитьТип(ТипЗнач, СтрДлина(Значение) + 10, Точность);
     КонецЕсли; 
    КонецЕсли; 
                         
    // Это помогает при отладке
    Если ФормФлРежимОтладки = 0 Тогда
     Пер.ДатаЗнач = ДатаЗначения;
     Пер.Значение = Значение;
     Пер.Записать();
    Иначе
     Попытка   
      Пер.ДатаЗнач = ДатаЗначения;
      Пер.Значение = Значение;
      Пер.Записать();
     Исключение
      ЗаписатьОшибку("Неудачная попытка установки значения периодического реквизита "+ИдРеквизита+" объекта: " + Элемент + " - " + ОписаниеОшибки());
     КонецПопытки;
    КонецЕсли;
    
   КонецЕсли;
   
  КонецЦикла;
  
 КонецЕсли;                                                                     
КонецПроцедуры
//--------------------------------------------------------------------------------------------------
Процедура ЗагрузитьОбъектСправочникаV8(Объект, Вид, ИмяПравила)
...................
   Если ПустоеЗначение(СозданНовыйОбъект) = 1 Тогда
    Если ПустоеЗначение(НеЗамещатьНайденные) = 0 Тогда
     Если ТекущийОбъект.ПометкаУдаления() = 0 Тогда // этот объект не создан по ссылке из реквизитов других объектов
      ЗагрузитьПериодичРеквизиты(Объект, ТекущийОбъект, Вид, ОбъектМД);  // левченко
      Возврат; // найденные не замещаем
     КонецЕсли;
    КонецЕсли;
   КонецЕсли;
   ОбъектБД.НайтиЭлемент(ТекущийОбъект);
  КонецЕсли;
  
 Иначе // Ссылки нет
..................
 
 ЗагрузитьПериодичРеквизиты(Объект, ОбъектБД, Вид, ОбъектМД); //левченко
 
КонецПроцедуры  // ЗагрузитьОбъектСправочникаV8()
 
6

Специальные предложения

См. также

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре 0

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия БУ Внешнеэкономическая деятельность (ВЭД) НДС Бесплатно (free) Практика программирования

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    9066    AndKovalchuk    0       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция 111

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    50534    Serginio    33       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Использование классов .Net в 1С для новичков 148

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    65966    Serginio    104       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним 78

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    75571    shmellevich    35       

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки. 3

Статья Системный администратор Программист Бухгалтер Нет файла v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Подготовка сведений для ПФР ЗиК 339. СЗВ-6-4 две незначительные ошибки: 1.При переносе сотрудника из одной пачки в другую у него теряются сведения о выплатах. 2.Неактивна кнопка сортировки сотрудников.

11.10.2013    11227    Cvetic    7       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Скрытие помеченных на удаление в справочнике 5

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    11941    mikukrnet    7       

Исправление и проведение документов 5

Статья Программист Нет файла v77::БУ 1С7:ПУБ Россия Бесплатно (free) Практика программирования

Исправление и проведение документов, например, счетов-фактур, введенных на основании документов реализации, можно организовать многими способами. Описан сравнительно простой подход, реализованный и работающий несколько лет в реальной бухгалтерии 1Cv7.7. Без внешних компонентов.

23.07.2012    12044    BorisBelov    11       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Продажа собственной фирме (интеркомпани) - заполнение отрицательными остатками 9

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Учет ТМЦ Бесплатно (free) Практика программирования

В документе "Продажа собственной фирме" приходится добавлять номенклатуру вручную через подбор. А ведь можно сэкономить время и заполнить спецификацию документа на основании отрицательных остатков фирмы. Все просто...

06.05.2012    11756    2sw    4       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Ввод остатков по 76.ВА в 1С ПУБ 2

Статья Программист Нет файла v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Бесплатно (free) Практика программирования

Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

29.04.2012    8516    Пользователь 1С    0       

Обновление базы 1с 7.7. с помощью движка 1с 8.х 92

Статья Системный администратор Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Администрирование данных 1С

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    16683    Valerich    31       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г. 18

Статья Программист Нет файла v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    7815    leo072    7       

Ошибка при формировании отчета 4-ФСС для УСН 7,7 12q1007 6

Статья Программист Нет файла v77::БУ 1С7:Бух Россия НУ Бесплатно (free) Практика программирования

При формировании таблицы 6,7 раздела 2 возникает ошибка ИтАн.ИспользоватьСубконто(ВидыСубконто.ВидыПлатежейВФонды, Перечисление.ВидыПлатежей.Штраф); {C:\PROGRAM FILES\1CV77\SSTDEMO\EXTFORMS\RP12Q1.GRP\FSS4_1212.ERT(2330)}: Поле агрегатного объекта не обнаружено (ВидыПлатежейВФонды)

11.04.2012    9766    *Zed*    1       

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

v77. Паинт 53

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

v77. 1С:Паинт :) Такая вот игрушка. Без внешних компонент.

06.03.2012    12883    81    item    38       

Быстрый отбор в журнале на конкретную дату 7

Статья Программист Нет файла v77::ОУ 1cv7.md Россия Бесплатно (free) Практика программирования

Лень - двигатель прогресса. Полезная фича для быстрого отбора документов в любом журнале на конкретную дату.

27.02.2012    9753    avers007    16       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая 25

Статья Программист Нет файла v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    5329    filh    19       

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД 11

Статья Программист Нет файла v77::БУ 1С7:Бух Россия Зарплата Бесплатно (free) Практика программирования

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

22.01.2012    8595    lelbraun    3       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Как уменьшить количество заблокированных объектов 26

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    13934    ShEvOvIcH    18       

Медленное формирование отчета в ФСС. Ошибка в алгоритме файл: ESN_GET.ERT 6

Статья Системный администратор Программист Нет файла v77::БУ 1С7:Бух Россия Бесплатно (free) Практика программирования

Достаточно старая ошибка 1С (исправляю уже пару лет) в файле ESN_GET.ERT (1С7.7 бухгалтерский учет). Проявляется в том, что очень медленно формируются регламентные отчеты в фонды ФСС и ПФР, если в типовой бухгалтерии ведётся начисление зарплаты сотрудникам и количество сотрудников превышает определённое количество (в моём примере 90, но замедление скорости видно и на 20)

11.01.2012    5955    Digo65    2