Подготовка сведений для ПФР 2011 с расчетом уплаченных НЕ через коэффициент

Публикация № 86473

Разработка - Практика программирования

16
Создан для исправления любого предыдущего отчета  с последующим созданием отчетов в свете новых требований ПФР.

Использует файл сохраненный настроек отчета за прошлый период (например - "_1_ИСХОДНАЯ_12010.pf")

Сделан для себя (НЕ ДЛЯ УПРОЩЕНКИ).

Старался минимизировать свои изменения, они помечены "// новое начало" и "// новое конец"

Для  исправления предыдущего отчета или создания нового, но с учетом доплаты или переплаты в прошлом отчете, поставить флажок  "в прошлом периоде"

Для создания нового без исправлений, с расчетом не коэффициентом, и с условием, что прошлый период был рассчитан не коэфф. и не требуется доплата/удержание за него, оба флажка: "в этом периоде" и  "в прошлом периоде" НЕ ставить.

 

По сути изменения:

Добавил процедурку:

 

// Новое начало           СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц()
//******************************************************************************
// СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц() 
//Описание:
//процедура заполняет суммы уплаченных взносов пересчитав начисленные
//по сотрудникам  за тот-же  период со сдвигом на месяц назад
//
Процедура  СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц() 
ТабПоУплатамПредПериод = СоздатьОбъект("ТаблицаЗначений");
ТабПоУплатамПредПериод.НоваяКолонка("Объект");
ТабПоУплатамПредПериод.НоваяКолонка("Период"); 
ТабПоУплатамПредПериод.НоваяКолонка("УплачСтрах"); 
ТабПоУплатамПредПериод.НоваяКолонка("УплачНакоп");
ТабПоУплатамТекПериод = СоздатьОбъект("ТаблицаЗначений");
ТабПоУплатамПредПериод.Выгрузить(ТабПоУплатамТекПериод);
 
    // вычислим период, за который начисленные СтрахВзносы входили в уплату по текущему периоду
ТекущийОтченыйПериод= ПолучитьДатуНачала(); 
НачОтсчТекПериодаРасчета= НачМесяца(ТекущийОтченыйПериод - 1); 
КонОтсчТекПериодаРасчета= КонМесяца((Мин(глПолучитьДатуОкончанияОтчетногоПериодаСЗВ(ТекущийОтченыйПериод),ДатаОтчета))-32); 
 
// вычислим период, за который начисленные СтрахВзносы входили в уплату по предыдущему периоду
// что-бы узнать остатки с прошлого периода. Если Сотр был уволен в середине предыдущего периода
ДатаСоЗдвигом= ПолучитьОтчетныйПериодПоДате(НачОтсчТекПериодаРасчета);
ВременОтчетныйПериод= ОтчетныйПериод;
ОтчетныйПериод= ДатаСоЗдвигом; 
 
ПредыдущийОтченыйПериод= ПолучитьДатуНачала();
ОтчетныйПериод = ВременОтчетныйПериод;
ТекущийОтченыйПериод= ПолучитьДатуНачала();  // возможно лишнее обращение и можно удалить
НачОтсчПредПериодаРасчета= НачМесяца(ПредыдущийОтченыйПериод - 1); 
КонОтсчПредПериодаРасчета= КонМесяца((Мин(глПолучитьДатуОкончанияОтчетногоПериодаСЗВ(ПредыдущийОтченыйПериод),ДатаОтчета))-32); 
 
// Сообщить("ТекущийОтченыйПериод");
// Сообщить(ТекущийОтченыйПериод);
// Сообщить("НачОтсчТекПериодаРасчета");
// Сообщить(НачОтсчТекПериодаРасчета);
// Сообщить("КонОтсчТекПериодаРасчета");
// Сообщить(КонОтсчТекПериодаРасчета);
// Сообщить("ПредыдущийОтченыйПериод");
// Сообщить(ПредыдущийОтченыйПериод);
// Сообщить("НачОтсчПредПериодаРасчета");
// Сообщить(НачОтсчПредПериодаРасчета);
// Сообщить("КонОтсчПредПериодаРасчета");
// Сообщить(КонОтсчПредПериодаРасчета);
 
 
 
ТабПоУплатам = СоздатьОбъект("ТаблицаЗначений");
 
ЗапросПоВзносам=СоздатьОбъект("Запрос");
 
ТекстЗапроса="//{{ЗАПРОС(ЗапросПоВзносам)
|С НачОтсчПредПериодаРасчета по КонОтсчТекПериодаРасчета;
|Объект = ЖурналРасчетов.СтраховыеВзносы.Объект;
|ВР = ЖурналРасчетов.СтраховыеВзносы.ВидРасч;
|Результат = ЖурналРасчетов.СтраховыеВзносы.Результат;
|Регистрация = ЖурналРасчетов.СтраховыеВзносы.ДатаОкончания;
|Группировка Объект Без Групп Без Упорядочивания; 
|Группировка ВР Без Групп Без Упорядочивания; 
|Группировка Результат Без Групп;
|Без Итогов;
|Группировка Регистрация;
|Условие((Результат <> 0) И ((ВР = ВидРасчета.ПФРСтраховаяЧастьс2010) ИЛИ (ВР = ВидРасчета.ПФРНакопительнаяЧастьс2010)));
|"//}}ЗАПРОС
;
 
Если ЗапросПоВзносам.Выполнить(ТекстЗапроса)=0 Тогда 
Сообщить("Не удалось обработать журнал взносов");
КонецЕсли; 
ЗапросПоВзносам.Выгрузить(ТабПоУплатам);
ТабПоУплатам.Сортировать("Объект,Регистрация");
ТабПоУплатам.НоваяКолонка("ПериодОплаты"); 
 
ТабПоУплатам.ВыбратьСтроки();
Пока ТабПоУплатам.ПолучитьСтроку()=1 Цикл
Если ТабПоУплатам.Регистрация>=НачОтсчТекПериодаРасчета Тогда 
ТабПоУплатамТекПериод.НоваяСтрока();
ТабПоУплатамТекПериод.Период = ТекущийОтченыйПериод;
ТабПоУплатамТекПериод.Объект = ТабПоУплатам.Объект;   // удалить
ТабПоУплатам.ПериодОплаты = ТекущийОтченыйПериод;
Если ТабПоУплатам.ВР = ВидРасчета.ПФРСтраховаяЧастьс2010  Тогда
ТабПоУплатамТекПериод.УплачСтрах = ТабПоУплатам.Результат;
ТабПоУплатамТекПериод.УплачНакоп = 0;
ТабПоУплатам.ПериодОплаты = ТекущийОтченыйПериод;  // удалить
Иначе
ТабПоУплатамТекПериод.УплачНакоп = ТабПоУплатам.Результат;
ТабПоУплатамТекПериод.УплачСтрах = 0; 
КонецЕсли;
Иначе 
ТабПоУплатамПредПериод.НоваяСтрока();
ТабПоУплатамПредПериод.Период = ПредыдущийОтченыйПериод;  
ТабПоУплатамПредПериод.Объект = ТабПоУплатам.Объект;  
ТабПоУплатам.ПериодОплаты  = ПредыдущийОтченыйПериод;  // удалить
Если ТабПоУплатам.ВР = ВидРасчета.ПФРСтраховаяЧастьс2010  Тогда
ТабПоУплатамПредПериод.УплачСтрах = ТабПоУплатам.Результат;
ТабПоУплатамПредПериод.УплачНакоп = 0; 
Иначе
ТабПоУплатамПредПериод.УплачНакоп = ТабПоУплатам.Результат;
ТабПоУплатамПредПериод.УплачСтрах = 0; 
КонецЕсли;
КонецЕсли;
КонецЦикла; 
 
ТабПоУплатамТекПериод.Свернуть("Объект,Период","УплачСтрах,УплачНакоп");
ТабПоУплатамТекПериод.Сортировать("Объект,Период");
//ТабПоУплатамТекПериод.ВыбратьСтроку(,"ТабПоУплатамТекПериод_3_ВнутриПроцедуры");
 
ТабПоУплатамПредПериод.Свернуть("Объект,Период","УплачСтрах,УплачНакоп");
ТабПоУплатамПредПериод.Сортировать("Объект,Период");
//ТабПоУплатамПредПериод.ВыбратьСтроку(,"ТабПоУплатамПредПериод_3_ВнутриПроцедуры");
 
 
// ------------------------------------------------------------------------------------------
    // получим из файла настроек    
 
ОтчетныйПериодВременный= ОтчетныйПериод ;       
ОтчетныйПериод = ПредыдущийОтченыйПериод;
ДатаПериода = ОтчетныйПериод; 
 
ИмяФайла    = ПолучитьИмяФайлаНастроек();       
УплатыПредПериод= СоздатьОбъект("ТаблицаЗначений");
 
Если ФС.СуществуетФайл(ИмяФайла) =1 Тогда
ФайлНастр = СоздатьОбъект("Текст");
ФайлНастр.Открыть(ИмяФайла);
Иначе Возврат;
КонецЕсли;  
// список документов в 3-й строке
СтрокаСписокДокументов  = СтрЗаменить(ФайлНастр.ПолучитьСтроку(3), констКод1, констКод10);
УплатыПредПериод= ЗначениеИзСтрокиВнутр(СтрокаСписокДокументов); 
//УплатыПредПериод.ВыбратьСтроку(,"СписокДокументов УплатыПредПериод");
// очистим и восстановим переменные
    ОтчетныйПериод   = ОтчетныйПериодВременный;
ДатаПериода = ОтчетныйПериод; 
ИмяФайлаНастроек   = ПолучитьИмяФайлаНастроек();
ТаблицаПачки= "";
СтрокаСписокДокументов  = ""; 
ТабПоУплатам = "";
КонецПроцедуры      // СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц()   
// новое конец      // СосчитатьВыплатыЧерезНачисленияСоЗдвигомНаМесяц()
 
 
ну и в процедуре  ЗаполнитьСуммыВзносов()  добавил:
 
ТабИсчисленоВзносов.ВыбратьСтроки();
Пока ТабИсчисленоВзносов.ПолучитьСтроку()=1 Цикл
 
КоэффициентСтраховая = 0;
КоэффициентНакопительная = 0;
 
ДатаПериода = ТабИсчисленоВзносов.ОтчетныйПериод;
НомСтроки = "";
Если ТабУплатыВзносов.НайтиЗначение(ДатаПериода,НомСтроки,"ОтчетныйПериод")=1 Тогда
КоэффициентСтраховая = ТабУплатыВзносов.ПолучитьЗначение(НомСтроки,"КоэффициентСтраховая");
КоэффициентНакопительная = ТабУплатыВзносов.ПолучитьЗначение(НомСтроки,"КоэффициентНакопительная");
КонецЕсли;
 
ТабИсчисленоВзносов.Ключ = ПолучитьКлючСотрудника(ТабИсчисленоВзносов.Сотрудник,ТабИсчисленоВзносов.КатегорияЗЛ);     
   // новое начало
НомСтрок1 = 0; 
НомСтрок2 = 0;
НомСтрок3 = 0;
НовУплачСтрах = 0;  
НовУплачНакоп = 0; 
Если  (КоэфДА=0) И (ДатаПериода=ТекущийОтченыйПериод) Тогда   // это  начислен/удерж тек периода и по новому
   ТабПоУплатамТекПериод.НайтиЗначение(ТабИсчисленоВзносов.Сотрудник,НомСтрок1,"Объект");
Если  (НомСтрок1=0) Тогда// не найдена, значт не было начислений и они будут состоять только из остатков с пр периода  
   ТабИсчисленоВзносов.УплаченоСтраховая = 0;
ТабИсчисленоВзносов.УплаченоНакопительная = 0;
Иначе    // нашли, плюсуем
ТабПоУплатамТекПериод.ПолучитьСтрокуПоНомеру(НомСтрок1);
ТабИсчисленоВзносов.УплаченоСтраховая = ТабПоУплатамТекПериод.УплачСтрах;   
ТабИсчисленоВзносов.УплаченоНакопительная = ТабПоУплатамТекПериод.УплачНакоп;  
КонецЕсли;
ИначеЕсли (КоэфДА=0) И (ДатаПериода<>ТекущийОтченыйПериод)  Тогда  //это  начислен\удерж прошл периода и по новому
Если  (КоэфДА1=0) Тогда// прошлый период был посчитан по новому
ТабИсчисленоВзносов.УплаченоСтраховая = 0;  
ТабИсчисленоВзносов.УплаченоНакопительная = 0;
ИначеЕсли  (КоэфДА1=1)  Тогда  // прошлый период был посчитан по старому 
   ТабПоУплатамПредПериод.НайтиЗначение(ТабИсчисленоВзносов.Сотрудник,НомСтрок2,"Объект");
   УплатыПредПериод.НайтиЗначение(ТабИсчисленоВзносов.Сотрудник,НомСтрок3,"Сотрудник");
Если  (НомСтрок2=0) и (НомСтрок3<>0)  Тогда// значт были начисления, но не должны были быть ????????????
// нашли, считываем начисления прошлого периода старым способом, полученные из файла
УплатыПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок3);
ТабИсчисленоВзносов.УплаченоСтраховая = УплатыПредПериод.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = УплатыПредПериод.УплаченоНакопительная;
Сообщить(Строка(ТабИсчисленоВзносов.Сотрудник) + "   были начисления, но не должны были быть ?????  НЕДОУПЛАТА");
// реальная недоуплата должна быть разницей (Правильно - ЧерезКоэф)
ТабИсчисленоВзносов.УплаченоСтраховая = 0 - ТабИсчисленоВзносов.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = 0 - ТабИсчисленоВзносов.УплаченоНакопительная; 
ИначеЕсли  (НомСтрок2<>0) и (НомСтрок3=0)  Тогда// значт не было начислений, но должны были быть ???????????? 
//  сколько должны были начислить, еслиб считали не коэффициентом 
ТабПоУплатамПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок2);
ТабИсчисленоВзносов.УплаченоСтраховая = ТабПоУплатамПредПериод.УплачСтрах;  
ТабИсчисленоВзносов.УплаченоНакопительная = ТабПоУплатамПредПериод.УплачНакоп;
Сообщить(Строка(ТабИсчисленоВзносов.Сотрудник) + "   не было начислений, но должны были быть  ПЕРЕПЛАТА  ???????");
ИначеЕсли  (НомСтрок2=0) и (НомСтрок3=0)  Тогда// значт не было начислений, и не должно было быть
ТабИсчисленоВзносов.УплаченоСтраховая = 0;  
ТабИсчисленоВзносов.УплаченоНакопительная = 0;
Иначе 
// нашли, считываем начисления прошлого периода старым способом, полученные из файла
УплатыПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок3);
ТабИсчисленоВзносов.УплаченоСтраховая = УплатыПредПериод.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = УплатыПредПериод.УплаченоНакопительная;
//  сколько должны были начислить, еслиб считали не коэффициентом 
ТабПоУплатамПредПериод.ПолучитьСтрокуПоНомеру(НомСтрок2);
НовУплачСтрах = ТабПоУплатамПредПериод.УплачСтрах;  
НовУплачНакоп = ТабПоУплатамПредПериод.УплачНакоп;   // 2222222222222222222222222
// реальная недоуплата должна быть разницей (Правильно - ЧерезКоэф)
ТабИсчисленоВзносов.УплаченоСтраховая = НовУплачСтрах - ТабИсчисленоВзносов.УплаченоСтраховая;  
ТабИсчисленоВзносов.УплаченоНакопительная = НовУплачНакоп - ТабИсчисленоВзносов.УплаченоНакопительная;
КонецЕсли; 
КонецЕсли;  
ИначеЕсли (КоэфДА=1) и (КоэфДА1=1) Тогда  // всё считаем по  старому
// новое конец
ТабИсчисленоВзносов.УплаченоСтраховая = ОКР(ТабИсчисленоВзносов.ИсчисленоСтраховая * КоэффициентСтраховая,2);
ТабИсчисленоВзносов.УплаченоНакопительная = ОКР(ТабИсчисленоВзносов.ИсчисленоНакопительная * КоэффициентНакопительная,2);
// новое начало    
КонецЕсли;
// новое конец
Если ДатаПериода<>ТекущийОтченыйПериод Тогда
ТабИсчисленоВзносов.ИсчисленоСтраховая = 0;
ТабИсчисленоВзносов.ИсчисленоНакопительная = 0;    
КонецЕсли;
 
КонецЦикла;  

 

Это из крупных изменений =) остальное так... по мелочи =)

 

Исходник: //infostart.ru/public/84659/

Удачи в борьбе с 1С.

 

ИСПРАВЛЕНИЯ:

Поправил немного, были пара-тройка уволенных невовремя) сотров потеряны правил в спешке, но  теперь НОВЫЙ отчет без ошибок!

 

16

Скачать файлы

Наименование Файл Версия Размер
ПодготовкаСведПФР_НЕ_коэффициентомРелиз3.ert
.ert 453,50Kb
13.08.13
246
.ert 453,50Kb 246 Скачать

Специальные предложения

См. также

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Подготовка сведений в ПФР за 2013 год с распределением суммы уплаченных взносов, превышающих начисленные 41

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Windows Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Регламентированная отчетность

При подготовке к сдаче отчета в ПФР столкнулся с тем, что программа не учитывает переплату - не распределяет сумму уплаченных взносов, превышающую начисленную, даже если это оплата проходит в январе 2013 за декабрь 2012. В случае, когда есть долг по оплате на начало периода (например, за декабрь 2012 платят в январе 2013) сумма уплаченных взносов может быть больше суммы начисленных. Программа же ставит сумму уплаченных взносов равную сумме начисленных. В этой обработке распределяются суммы уплаченных взносов, превышающих начисленные, а так же внесены исправления, связанные с возможными ошибками при формировании штатной обработки из 335 релиза (в пачки попадали ненужные уволенные, неправильно распределялись уплаты взносов, при выгрузке в файл возникали ошибки).

1 стартмани

20.04.2013    21734    425    mirrr    65       

Онлайн-курс "Технология выполнения проектов ERP-класса – процессный подход". Третий поток. Курс проходит с 21 января по 18 марта 2020 года. Промо

Курс разработан Внедренческим центром «Раздолье». Курс предназначен для подготовки аналитиков, архитекторов и руководителей проектов автоматизации процессов управления с использованием комплексных ИТ-систем (1С:ERP, 1С:УХ, 1С:КА, 1С:УТ). В основе курса лежит методика применения процессного подхода.

9000 рублей

Быстрая проверка расчета страховых взносов (ЗиК 7.7) 32

Отчеты и формы Бухгалтер Внешний отчет (ert,erf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские Анализ учета

Пользуюсь этим отчетом для проверки расчета страховых взносов. Даже если в базе несколько сотен сотрудников, легко увидеть у кого неверно считаются страховые взносы. Получаем расшифровку, щелкая по цифре процентов.

1 стартмани

05.07.2012    12065    239    asi24    21       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Свод проводок с детализацией по сотрудникам и видам расчетов 37

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Доработанный свод проводок, позволяющий детализировать данные по сотрудникам и видам расчетов в любом порядке следования - полезен расчетчикам в случаях когда "непонятно откуда взялась такая сумма в проводке".

1 стартмани

12.04.2012    22336    269    alx300    17       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

НДФЛ как на ладони 37

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов Бухгалтерские Налоговые

НДФЛ посчитали... А когда, как и куда уплатили? А за кого и сколько еще надо уплатить? А почему столько? А можно документ создать автоматически?

1 стартмани

27.03.2012    21592    325    DarkAn    41       

Расчет резерва отпусков, Зарплата и кадры. 35

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Для бухгалтеров, кадровиков и руководителей. Расчет резерва отпусков всего предприятия или несколькими выборками в необходимых разрезах -это несложно! Есть широкие возможности настройки параметров отчета.

1 стартмани

21.03.2012    29917    365    sergdem486    48       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Вывод и перенумерация отчета с заранее неизвестным количеством группировок. 20

Инструменты и обработки Программист Внешняя обработка (ert,epf) openconf v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Абонемент ($m) Практика программирования Работа с интерфейсом

1C v.7.7 Пример вывода отчета с заранее неизвестным количеством группировок, с возможностью изменять уровень вложенности группировок из списка значений на форме, с нумерацией конечного отчета, с выводом структуры вложенности группировок (с помощью внешней компоненты Йоксель - http://yoksel.net.ru/Hotfixes). В приложенном файле показан пример вывода отчета из сформированной таблицы значений. Код я старался закомментировать как можно подробней. Хоть семерка и вымирающая платформа, думаю еще есть люди, которые только начинают ей заниматься, и им это может пригодиться.

1 стартмани

21.03.2012    23937    20    unichkin    11       

Расчет остатка дней отпуска 42

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата Управление персоналом (HRM) Абонемент ($m) Бухгалтерские

Надо уволить сотрудника, а сколько дней отпуска ему компенсировать или наоборот???

1 стартмани

13.03.2012    20345    234    DarkAn    42       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Автоматическое создание документов "Перечисление НДФЛ в бюджет" для ЗиК 7.7 27

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК 1С7:Комплекс 1С7:ТиС Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов

Уж недалек отчет, а документы распределения НДФЛ по работникам за 2011 год не введены. Можно ввести их вручную, а можно воспользоваться обработкой, выгрузить их в MS Excel и сформировать автоматически. Для этого подготовлен данный комплекс обработок.

1 стартмани

05.03.2012    19930    95    Krasnyj    44       

Алгоритм распределения перечисленного НДФЛ в ЗиК 7.7 и вариант его улучшения 46

Инструменты и обработки Бухгалтер Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Обработка документов

Доработка конфигурации ЗиК 7.7 релизы 320-322 с целью улучшить распределение сумм перечисленного НДФЛ по сотрудникам. Полезна, если Вы хотите видеть "красивые" регистры налогового учета по НДФЛ - с подробной расшифровкой перечисленных налогов до даты платежа и номера платежки. Ну и разумеется годовую отчетность по НДФЛ в полном соответствии с этими регистрами. Внимание! Если Вам просто надо показать в справке/отчете 2-НДФЛ перечисленную сумму равной начисленной и удержанной, - можно дальше не читать, а сразу идти сюда: http://infostart.ru/public/115064/

1 стартмани

28.02.2012    15460    243    sam41    75       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Свод проводок + страховые взносы (в разрезе видов расчета) 14

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Отчет рекомендуется для использования с конфигурацией "1С:Зарплата и кадры 7.7" (начиная релиза 7.70.320). Преимущества отчета: 1. Группировка данных о начислениях и страховых взносах по видам расчета (легко сверяется со сводом по зарплате и налоговой ведомостью); 2. Данные об удержаниях формируются отдельно; 2. Возможность расшифровки до конечных проводок с указанием всей аналитики; 3. Дополнительный сводный анализ по счетам участвующим проводках; 4. Использование типового механизма получения данных о проводках (глПроводкиЗаПериод).

1 стартмани

24.02.2012    18698    202    kondrp    11       

Расчет компенсации за неиспользованный отпуск при увольнении, а также расчет причитающегося сотруднику отпуска на выбранную дату 104

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Windows Зарплата Абонемент ($m) Обработка документов

Обработка позволяет рассчитывать количество дней компенсации за неиспользованный отпуск при увольнении, а также причитающийся сотруднику отпуск на определенную дату. Теперь с возможностью ввода дополнительных данных!!!!

3 стартмани

23.02.2012    24724    222    Krasnyj    38       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Отчет по изменению окладов для ЗиК 7.7 43

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата Абонемент ($m) Бухгалтерские

Вам необходимо отследить оклады сотрудников и повышение их по датам? Этот отчет для Вас.

1 стартмани

22.02.2012    12296    35    Krasnyj    9       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Исправляем СЗВ 6-3 53

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Абонемент ($m) Бухгалтерские

Переделанный отчет "Подготовка сведений для ПФР" с возможностью редактировать данные таблицы СЗВ 6-3

1 стартмани

06.02.2012    14080    254    legioner    47       

Модернизация формы 2-НДФЛ 2015 г. для ЗиК 102

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ НУ Зарплата НДФЛ Абонемент ($m) Справки

Форма 2-НДФЛ 2015 для конфигурации ЗиК. Добавлены некоторые механизмы для более удобной и успешной сдачи отчета. Утверждена приказом ФНС России от 30.10.2015 № ММВ-7-11/485@.

1 стартмани

01.02.2012    26605    649    victuan    98       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Справки по НДФЛ 2011: сделаем перечисленный равным удержанному (ЗиК 7.7, Бух 7.7) 35

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ v77::Расчет 1С7:Бух 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Справки Налоговые

Отчет "Справки по НДФЛ" для бухгалтеров, которые просто хотят отчитаться в ИФНС и выдать сотрудникам справки 2-НДФЛ и не хотят вводить документы "Перечисление НДФЛ в бюджет" и разбираться с тем, как в них считается перечисленный налог. Для "1С:Зарплата и кадры 7.7.320" и "1С:Бухгалтерия 7.7.535".

1 стартмани

01.02.2012    15972    200    Antia    22       

Нумерация справок для "Зарплаты и Кадры", ред.2.3 8

Отчеты и формы Бухгалтер Конфигурация (md, cf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ ФОМС, ПФ, ФСС Абонемент ($m) Справки

Нумерация в отчетах: "ПодготовкаСведенийДляИМНС" "СправкаВыплатЗа3Года" "СправкаОДоходах" "СправкиПоНДФЛ"

1 стартмани

05.01.2012    15838    34    Одинец    9       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

Исправленный и улучшенный отчет 2НДФЛ (318 релиз ЗиК) 60

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Налоговые

- Исправлена ошибка размера применненого имущественного вычета - В печатную форму "Реестр2011Дополнительный" добавлена колонка с суммой перечисленного НДФЛ. - Добавлена новая печатная форма "Список справок 2-НДФЛ" - Добавлены режимы формирования отчета, в которых суммы перечисленного НДФЛ берутся не из документов "Перечисление НДФЛ в бюджет РФ", а приравнивается к суммам исчисленного или удержанного налога.

1 стартмани

25.12.2011    16523    251    Kapitan911    46       

Проверка соответствия НДФЛ удержанного/перечисленного (ЗиК) 63

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК Россия БУ Зарплата НДФЛ Абонемент ($m) Анализ учета

Отчет, позволяющий выявить ошибки при распределении сумм НДФЛ уплаченных (ЗиК)

1 стартмани

17.11.2011    20589    374    legioner    97       

Перенос данных БП 2.0 => УТ 11 / КА 2 / ERP 2 (перенос остатков, документов и справочников из "1С:Бухгалтерия предприятия 8", ред. 2.0 в "1С:Управление торговлей 8", ред.11 / КА 2 / ERP 2). Обновлено до УТ 11.4.10.х, КА 2.4.10.х, ERP 2.4.10.х! Промо

Перенос позволяет загрузить в УТ 11 / КА 2 / ERP 2 документы за выбранный период, справочную информацию и остатки по счетам бух. учета. Переносятся остатки денежных средств, взаиморасчетов, остатки товаров и материалов на складах. Переносятся девятнадцать основных видов документов за выбранный период и вся нормативно-справочная информация. Есть фильтр по организации. Если нужно переносить что-то дополнительно, то обычно бесплатно дорабатываю правила (перед покупкой согласуйте необходимые доработки).

29700 руб.

Сверка начисленных, уплаченных и перечисленных сумм НДФЛ для ЗиК 43

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::Расчет 1С7:ЗиК 1С7:Комплекс Россия БУ Зарплата НДФЛ Абонемент ($m) Налоговые

Отчет, позволяющий видеть исчисленные, уплаченные и перечисленные в бюджет суммы НДФЛ с отбором по сотрудникам за указанный период.

1 стартмани

16.11.2011    12650    269    Livsi    47       

Плагин для лечения выгрузки и загрузки больших баз в 1С 7.7 (портирование под Win7) 61

Инструменты и обработки Системный администратор Компонента, плагин (dll, vbs,..) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Абонемент ($m) Практика программирования

В связи с изменением состава DLL в Wiindows 7 оригинальный плагин выложенный здесь http://infostart.ru/public/15364/ перестал работать в Windows7/WindowsServer 2008 R2. (Что именно там изменилось можно посмотреть здесь http://ru.wikipedia.org/wiki/MinWin) Данный плагин - это простое портирование оригинального плагина под Windows 7

1 стартмани

31.10.2011    50411    572    avgreen    90