Замена ставки НДС на 20%

Публикация № 959413

Обработки - Обработка справочников

3
Изменение ставки НДС у пользователей и в справочнике Номенклатура.

При клике на кнопку номенклатура, обработка перебирает справочник Номенклатура и если находит в нем значение 18 или 18/118 меняет на 20/120 процентов.

При клике на кнопку НастройкаПользователей, обработка делается запрос к РегиструСведений - НастройкаПользователей и выбирает тех, у кого стоит свойство ставка НДС и у кого стоит 18 или 18/118 меняет на 20 или 20/120 процентов.

Тестировалось на УПП 1.3.

3

Скачать файлы

Наименование Файл Версия Размер
Замена ставки НДС на 20%:
.epf 6,63Kb
07.12.18
40
.epf 6,63Kb 40 Скачать

См. также

Специальные предложения

Вознаграждение за ответ
Показать полностью
Комментарии
Избранное Подписка Сортировка: Дата
1. vadim92 07.12.18 12:28 Сейчас в теме
а не проще групповое изменение реквизитов?
2. VmvLer 07.12.18 12:46 Сейчас в теме
(1) не все знают, что уже 15 лет есть стандартные обработки замены реквизитов работающие в любых конфигурациях.

зато кнопки красивые - пользователи такое любят.
3. capitan 1193 07.12.18 13:04 Сейчас в теме
П-Предусмотрительность ))))
4. azali 07.12.18 13:40 Сейчас в теме
В УПП и обработку добавили по замене ставок в Номенклатуре.
5. Bazil 420 07.12.18 14:20 Сейчас в теме
(2) Кнопки красивые? Они даже разной ширины!
demkonst; wowik; madonov; rpgshnik; NazarovV; Lok`Tar; WellMaster; chump0000; +8 Ответить
6. RocKeR_13 592 07.12.18 17:26 Сейчас в теме
Из описания последнего релиза УПП 1.3.113.4
НДС

Учет НДС по ставке 20%

Поддержаны изменения учета НДС в связи со вступлением в силу с 01.01.2019г. Федерального закона от 03.08.2018г. № 303-ФЗ в части замены ставки НДС с 18% на 20%.

Реализована обработка "Помощник замены ставки НДС на 20%", позволяющее выполнять замену ставки НДС с 18% на 20% в карточках элементов номенклатуры.

Аналогичная обработка сделана и в УТ 10.3. Там еще даже отбор есть)
wowik; apostal86; +2 Ответить 1
7. svetanik 3 11.12.18 05:10 Сейчас в теме
Так ставки заменить в справочнике — это далеко не всё! Нужно, чтобы эта ставка обрабатывалась в конфигурации! КНиги покупок и книги продаж никто не отменял. А там каждая ставка поименно обрабатывается.
8. Kontakt 70 11.12.18 10:58 Сейчас в теме
(7) Каждая ставка имеет ссылку на ПеречислениеСсылка.СтавкиНДС и там уже давно есть значение 20%
это все!
Проблемы возможно будут при возвратах, при корректировки.
rpgshnik; apostal86; +2 Ответить 1
9. apostal86 208 12.12.18 09:19 Сейчас в теме
О, хайповая тема. Только 1С в обновления штатную такую обработку вставляет. По крайней мере в УТ 10.3 видел - есть.
10. chump0000 13.12.18 08:50 Сейчас в теме
(8)Это не все. Например, в УПП 1.3.113.2 в модулях УчетНДС, УчетНДСФормированиеДвижений есть места, где ставка НДС 20% еще не учтена наравне с остальными в стандартном коде, либо зашита ссылка на ставку 18%.
11. Балабас 165 13.12.18 11:31 Сейчас в теме
Однако 5 человек уже скачали!
12. namazi74 2 14.12.18 09:44 Сейчас в теме
(9) да, во всех конфигурациях добавили в обновлении от 4 декабря
13. madonov 153 25.12.18 06:59 Сейчас в теме
А можно просто добавить в конце типовой функции
"ЗаполнитьСтавкуНДСТабЧасти"

//UPD Переход на НДС 20%	
ДатаПереходаНаНДС20 = Дата(2019,1,1);
	
Если ДокументОбъект.Дата >= ДатаПереходаНаНДС20 Тогда
		
	Если СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.НДС18 Тогда 
		СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
	ИначеЕсли СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.НДС18_118 Тогда
		СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.НДС20_120;
	КонецЕсли;

КонецЕсли;
//UPD_END Переход на НДС 20%
Показать
Lyubogradov.P; erp3000; +2 Ответить 2
14. erp3000 25.12.18 17:57 Сейчас в теме
(13)
ЗаполнитьСтавкуНДСТабЧасти


Красаучег!
15. putdv 27.12.18 03:54 Сейчас в теме
Поддерживаю! Я тоже поправил процедуру "ЗаполнитьСтавкуНДСТабЧасти" общего модуля "ОбработкаТабличныхЧастей" в УПП:

		Если НеЯвляетсяРезидентом И Не НалоговыйАгентНерезидент И ВидДокумента = "Приобретение" Тогда
			СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.БезНДС;
			Возврат;
		ИначеЕсли РеализацияНаЭкспорт И ВидДокумента = "Реализация" Тогда
			СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.НДС0;
			//возможно, дальше ставка будет изменена на БезНДС, если применяется ЕНВД
		Иначе
			СтрокаТабличнойЧасти.СтавкаНДС = СтрокаТабличнойЧасти.Номенклатура.СтавкаНДС;
			//PDV {***
			Если ДокументОбъект.Дата>=Дата('20190101')
				или
				(ТипЗнч(ДокументОбъект) = Тип("ДокументОбъект.СчетНаОплатуПокупателю")
				и ДокументОбъект.Дата>=Дата('20181201')
				и не ДокументОбъект.ТекущийМесяц) Тогда
				СтрокаТабличнойЧасти.СтавкаНДС = Перечисления.СтавкиНДС.НДС20;
			КОнецЕсли;
			//PDV ***}
		КонецЕсли;
Показать
16. user1134800 21.01.19 11:52 Сейчас в теме
(6)Добрый день!
Подскажите, где найти обработку для НДС в УТ 10.3.
17. RocKeR_13 592 21.01.19 11:55 Сейчас в теме
(16) через все функции можно найти, обработка вроде так и называется "Помощник замены ставки НДС на 20%"
18. senshkr 7 21.01.19 16:06 Сейчас в теме
Обработка, которая Вам поможет, называется "ПоискИЗаменаЗначений.epf"
19. pjv 23.01.19 10:45 Сейчас в теме
Мы заменяли через обработку, которая была в обновлении релиза
20. user1145434 04.02.19 08:31 Сейчас в теме
(13)
ЗаполнитьСтавкуНДСТабЧасти



А как и куда вставлять этот код. можно пошагово пж.
Оставьте свое сообщение