СТАБИЛЬНАЯ Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel (код открыт скачать можно бесплатно)

Публикация № 97415

Обмен - Загрузка и выгрузка в Excel

213
В таких случаях многие заказывают соответствующие обработки у собственных штатных программистов, фирм-франчайзи или сторонних разработчиков, но это дополнительные расходы и время.

Как быть, если по различным причинам такой возможности нет?

У каждого пользователя профессиональной версии 1С:Предприятие 8 подобная обработка уже есть! На диске ИТС!

Типовая обработка «ЗагрузкаДанныхИзТабличногоДокумента.epf», находиться в разделе «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Обратите внимание, начиная с Февраля 2010 г. на диске ИТС данная обработка для конфигураций на платформе 8.1 находиться в другом разделе: «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Платформа 1С:Предприятие 8.1» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

 

Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel

Имеются исходные данные:

  • Прайс-лист в Excel «ПрайсОнлайнХимСнаб.xls» — Microsoft Office Excel 97-2003 (.xls)
  • Типовая конфигурация Управление торговлей Ред.10.3, релиз 10.3.10.4, платформа 8.2 (8.2.10.77)
  • Необходимо загрузить в 1С из Excel не только наименования товаров и цены как в Примере 1, а также артикулы и штрих-кода, при этом необходимо чтобы номенклатура загружалась не в один каталог (группу), а распределялась по производителям в справочнике номенклатуры 1С.

загрузка 1с +из excel

Для того чтобы из Прайс-листа можно было загрузить справочник номенклатуры в 1С:Управление торговлей 8 с автоматическим распределением по группам (производители) необходимо будет подготовить форму файла для загрузки. Понадобиться добавить колонку с указанием единицы измерения (шт.) и производителя товара, при этом наименование производителя в прайс-листе должно соответствовать наименованию группы в справочнике номенклатуры программы 1С:Управление торговли 8.

1с 8 excel

Используем типовую обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» которая идет на ИТС.

1. Запускаем программу 1С

2. Для запуска обработки выбираем пункт меню «Файл»>«Открыть».

выгрузка в 1с из excel

3. В октрывшемся окне находим файл обработки, который располагается на диске ИТС в каталоге \1CIts\EXE\EXTREPS\UNIREPS82\UploadFromTableDocument

Если предварительно вы скопировали файл обработки на свой компьютер, то можете выбрать его.

ex2_04.jpg

Откроется окно

1с 8.1 excel

Обратите внимание, что загрузка данных будет осуществляться в три этапа:

Этап 1 — загрузка наименований и установка значений реквизитов новых элементов справочников необходимых для начала работы (единица измерения, ставка НДС, признак товар/услуга). 
Этап 2 — загрузка цен. 
Этап 3 — загрузка штрих-кодов

4. Этап 1. Загрузка наименований

Устанавливаем «Режим загрузки» — Загрузка в справочник

«Вид справочника» — Номенклатура

1с 8.2 excel

5. В закладке «Табличный документ» нажимаем кнопку image011.jpg«Открыть файл», в появившемся окне выбора находим каталог, в котором у нас находиться прайс-лист в Excel из которого мы планируем загружать данные в 1С.

загрузка из excel 1с 8

Первоначально файл может не отобразиться. Установите Тип файла «Лист Excel (*.xls)»

импорт из excel в 1с

Выбираем наш файл

номенклатура из excel в 1с

Файл успешно прочитался

7. Далее выбираем закладку «Настройка»

1с загрузка из excel

Отражаются реквизиты карточки номенклатуры.

загрузка справочников 1с из excel

8. Настраиваем параметры загрузки наименований

Для удобства установим «Ручную нумерацию колонок»

На данном этапе загружаем только те реквизиты, которые позволят начать работать с программой, поэтому снимаем галочки с полей, которые нас пока не интересуют

«Первая строка данных табличного документа» — смотрим наш прайс-лист, отбрасываем шапку, данные для загрузки начитаются с девятой строки — ставим «9» (см.Рис. 2 «Прайс-лист»)

«Не создавать новых элементов» — галочку НЕ ставим, опция нужна, если планируем только изменять уже имеющиеся элементы.

ex2_12.jpg

Строки «Наименование» и «Полное наименование» — устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе наименование в третьей колонке — ставим «3»

Строка «Родитель» — в колонке «Режим загрузки» выбираем «Искать», в колонке «№ Колонки табличного документа» — в нашем прайс-листе производители в четвертой колонке — ставим «4».

Если необходимости распределения по производителям нет и загрузить все новые элементы требуется в одну папку, тогда в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем группу номенклатуры, в которую будем загружать данные из прайс-листа.

Строка «Артикул» — ставим галку в колонке «Поле поиска» (вторая колонка) — программа проверит наличие в базе данных 1С элемента с таким артикулом, и если таковой уже существует, то новый элемент с таким наименованием создаваться не будет. Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе артикул во второй колонке — ставим «2»

Строка «Базовая единица измерения» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем единицу измерения (в нашем случае — шт.)

Строка «Весовой» — в нашем случае товар НЕ весовой, поэтому «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Нет»

Строка «Ставка НДС» — в нашем случае для всех загружаемых элементов устанавливаем НДС 18%, для этого в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «18%».

1с 8.2 загрузка из excel

Если товары идут с разным НДС, который указывается в отдельной колонке загружаемого прайс-листа, то в колонке «Режим загрузки» установите «Искать» и номер соответствующей колонки прайс-листа в «№ Колонки табличного документа».

Строка «Услуга» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Нет» (в нашем случае все позиции это товары).

Строка «Вид номенклатуры» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Товар».

Мы задали минимальные значения новых элементов справочника номенклатуры, которые позволят начать работать.

Если вы готовы задать значения недостающих реквизитов сейчас, то укажите и их.

Нажимаем «Загрузить» в правом нижнем углу, на вопрос нажимаем «Да»

перенос в 1с из excel

как загрузить в 1с excel

Если загрузка пройдет нормально, то по результатам будет выдано сообщение об успешной загрузке.

8. Проверяем наличие новых элементов в соответствующих группах справочника номенклатуры.

ex2_16.jpg

ex2_17.jpg

На настоящий момент мы загрузили из прайс-листа в Excel наименования товаров в справочник номенклатуры 1С.

ex2_18.jpg

Как видите, реквизиты «Единица для отчетов» и «Единица хранения остатков» остались не заполненными.

Следующим шагом необходимо установить данные реквизиты, т.к. они потребуются при загрузке цен, штрих-кодов и дальнейшей работе.

Возможны два варианта:

Ручной.

Данные реквизиты создаются программой автоматически, при первом открытии и сохранении карточки номенклатуры. Если допустима ручная установка, то можно этот шаг пропустить и перейти сразу к этапу загрузки цен. Если не планируется загрузка штрих-кодов, то вполне допустимо даже оставить как есть — при первом использовании элемента номенклатуры необходимо будет отрыть и сохранить карточку товара.

Недостаток: ручная процедура открытия и записи может быть довольно трудоёмкой и занять довольно много времени при большом количестве элементов справочника.

Автоматический.

Возможна и автоматическая загрузка единиц измерения, но она рассчитана для продвинутых пользователей и потребует базовых навыков в программировании 1С.

Возможны два варианта: с идентификацией по артикулу или наименованию.

Идентификация по Артикулу более предпочтительна, но в прайс-листе колонки с артикулами может и не быть.

Вариант 1. Идентификация по Артикулу

ex2_19.jpg

Ставим «галку» в поле «Не создавать новых элементов» и снимаем «галки» со всех строк.

Строка «Артикул» — ставим галку в колонке «Поле поиска» (вторая колонка). Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе артикул во второй колонке — ставим «2»

В строках «Единица для отчетов» и «Единица хранения остатков» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, наш специалист из отдела внедрения, за пару минут предложил такой код:

ex2_20.jpg

 СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", ТекущиеДанные["Артикул"]); БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796); ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификаторуquot;,БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры); Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; НайденнаяЕдиницаОбъект.Коэффициент = 1; НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; Попытка НайденнаяЕдиницаОбъект.Записать(); Результат = НайденнаяЕдиницаОбъект.Ссылка; Исключение Сообщить("Не удалось записать"); КонецПопытки; Иначе Результат =ТекСпр.Ссылка; КонецЕсли; 
//© Компания "Онлайн" 2010, www.online-ufa.ru

Если планируется многократное повторение данной процедуры, то в алгоритм необходимо дополнительно добавить процедуру проверки, чтобы исключить повторный ввод единиц измерения с тем же наименованием.

Вариант 2. В случае идентификации по Наименованию

ex2_21.jpg

Ставим «галочку» в поле «Не создавать новых элементов»

Снимаем «галки» со всех строк

Строка «Наименование» — ставим галку в колонке «Поле поиска» (вторая колонка). Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе наименования в третьей колонке — ставим «3»

В строках «Единица для отчетов» и «Единица хранения остатков» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С, например такой:

ex2_22.jpg

 
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Наименование"]);
БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("
ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения);
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения;
НайденнаяЕдиницаОбъект.Коэффициент = 1;
НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры;
Попытка НайденнаяЕдиницаОбъект.Записать();
Результат = НайденнаяЕдиницаОбъект.Ссылка;
Исключение Сообщить("Не удалось записать");
КонецПопытки;
Иначе Результат =ТекСпр.Ссылка;
КонецЕсли;



//© Компания "Онлайн" 2010, www.online-ufa.ru

9. Открываем карточку товара, проверяем правильность загрузки реквизитов

ex2_23.jpg

Если всё правильно, то можно приступить ко второму этапу — загрузке цен из прайс-листа в Excel.

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка наименований товаров из прайс-листа Excel».

ex2_24.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопку image046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_25.jpg

10. Этап 2. Загрузка цен

В «Управление торговлей» Ред.10.3 установка цен производится с помощью документа «Установка цен номенклатуры».

Используем ту же обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» с диска ИТС.

ex2_26.jpg

11. Устанавливаем «Режим загрузки» — «Загрузка в табличную часть».

ex2_27.jpg

12. В поле «Ссылка» выбираем «Установка цен номенклатуры».

ex2_28.jpg

После этого в том же самом поле «Ссылка» снова нажимаем на кнопку выбора

Открывается журнал документов «Установка цен номенклатуры».

Здесь можно выбрать уже существующий документ, в который мы хотим добавить новые элементы, или создать Новый (рекомендуется), в документе указываем какой «Тип цен» будем загружать (в нашем примере «Розничная»).

ex2_29.jpg

Нажимаем «Ок» и сохраняем пока пустой документ.

Теперь выбираем этот новый сохранённый документ из журнала в строке «Ссылка».

В поле «Табличная часть» выбираем «Товары».

ex2_30.jpg

13. Обратите внимание, что сейчас нужно перейти закладку «Табличный документ» и снова выбрать наш прайс-лист в Excel из которого мы загрузили наименования, а теперь будем загружать цены (см. пункт 5).

14. Настраиваем параметры загрузки

Опять устанавливаем «Первая строка данных табличного документа» — как и при загрузке наименований, ставим «9» и «Ручную нумерацию колонок».

В строке «Номенклатура» устанавливаем режим загрузки «Искать», «№ Колонки табличного документа» — в нашем примере ставим «3». Если необходима идентификация по артикулу, то в колонке "Искать по" выбираем "Артикул", а в «№ Колонки табличного документа» ставим номер колонки с артикулами - в нашем примере "2".

В строке «Цена» устанавливаем режим загрузки «Искать», «№ Колонки табличного документа» — ставим номер колонки с ценами, которые хотим загрузить, сначала будем загружать розничную цену, значит, ставим «5».

ex2_31.jpg

В строке «Валюта» устанавливаем Режим загрузки «Устанавливать», выбираем валюту (в примере «руб.»)

В строке «Единица измерения» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, такой код: 

ex2_31_1.jpg

 СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Номенклатура"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков; 

В строке «Тип цен» устанавливаем Режим загрузки «Устанавливать», выбираем цену, которую будем загружать «Розничная».

ex2_32.jpg

Если в вашем прайс-листе цены товаров приведены в разных валютах, которая указывается в отдельной колонке загружаемого прайс-листа, то в колонке «Режим загрузки» установите «Искать» и номер соответствующей колонки прайс-листа в «№ Колонки табличного документа».

В строке «Способ расчета цены» устанавливаем Режим загрузки «Устанавливать», выбираем «По процентной наценке на базовый тип»

ex2_33.jpg

Нажимаем «Загрузить» и отвечаем «Да»

ex2_34.jpg

Если загрузка пройдет нормально, то по результатам будет выдано сообщение об успешной загрузке.

15. Открываем документ «Установка цен номенклатуры», в который загружали данные (нажав кнопочку с изображением лупы image065.jpg в строке «Ссылка»)

ex2_35.jpg

16. Проверяем документ, если всё в порядке нажимаем «Ок».

Цены должны установиться.

17. Открываем справочник номенклатуры, проверяем закладку «Цены» в карточке загруженных элементов, нажимаем кнопку «Перечитать текущие цены».

ex2_36.jpg

Если всё в порядке, то можно приступать к загрузке остальных цен (оптовые, закупочные и т.д.). Процедура аналогична.

Обратите внимание, что 1С:Управление торговлей 8 поддерживает расчет одних цен на основании других. Поэтому загружать, возможно, будет достаточно только одну базовую цену, например Розничную или наоборот Закупочную, а для других цен указать алгоритмы формирования (скидка %, наценка %, округление до знака и т.д.).

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка Розничных Цен из прайс-листа Excel».

ex2_37.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопкуimage046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_38.jpg

18. Этап 3. Загрузка штрих-кодов

Используем всё ту же обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» с диска ИТС.

ex2_39.jpg

19. Устанавливаем «Режим загрузки» — «Загрузка в регистр сведений». 
"Вид регистра" выбираем "Штрихкоды".

ex2_40.jpg

20. Обратите внимание, что сейчас нужно перейти закладку «Табличный документ» и снова выбрать наш прайс-лист в Excel из которого мы загрузили наименования и цены, а теперь будем загружать штрихкоды (см. пункт 5).

21. Настраиваем параметры загрузки

Опять устанавливаем параметр «Первая строка данных табличного документа» - ставим «9» и «Ручную нумерацию колонок».

ex2_41.jpg

Настраиваем параметры загрузки

Удаляем «галки» со всех строк, с которых возможно.

В оставшихся строках устанавливаем параметры

В строке «Штрихкод» устанавливаем Режим загрузки «Искать», в колонке «№ Колонки табличного документа» пишем как в нашем прайс-листе «9».

ex2_42.jpg

В строке «Владелец» в колонке «Описание типов» открываем окно «Редактирование типа данных» устанавливаем (оставляем) галку только в поле «Номенклатура». Режим загрузки устанавливаем «Искать». Для идентификации по Артикулу, в колонке «№ Колонки табличного документа» пишем номер колонки, в которой в нашем прайс-листе указаны артикулы — т.е. «2». В колонке «Искать по», устанавливаем «Артикул».

ex2_43.jpg

В случае, если в прайс-листе нет колонки с артикулами, то в колонке «Искать по» необходимо выбрать «Наименование», а в ячейке «№ Колонки табличного документа» указать номер колонки прайс-листа с наименованиями.

В строке «Тип штрихкода» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «EAN13».

В строке «Единица измерения» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, такой код:

ex2_43_1.jpg

 CсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков; 

ex2_44.jpg

В строке «Качество» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Новый».

В строках «Характеристика номенклатуры», «Серия номенклатуры», «Удалить код» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» оставляем пустые ячейки.

Нажимаем «Загрузить»

Открываем карточку товара, проверяем наличие штрих-кода.

ex2_45.jpg

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка штрих-кодов товаров из прайс-листа Excel».

ex2_46.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопкуimage046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_47.jpg

 

213

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Дата
136. seregapplk 30.08.18 19:40 Сейчас в теме
не ставит единицы

"сылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Наименование"]);
БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);"

это я так понимаю код по классификатору "НайтиПоКоду(796)" у мея другой код конфиг для украины, ошибок не выдает но не ставит хотя код я изменил не пойму что не так
135. helsik 06.10.17 11:02 Сейчас в теме
все получилось, но только с этой обработкой https://infostart.ru/public/81468/
134. SkyLink2012 253 02.03.12 17:15 Сейчас в теме
Bublik2011! Для коррекции единиц хранения измерения номенклатуры в справочнике штрих-коды или штрихкоды создайте в конфигураторе - "Новая" - "Обработка" и вставьте код по действию "Выполнить".

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ВыборкаШК = РегистрыСведений.Штрихкоды.Выбрать();
	Пока ВыборкаШК.Следующий() Цикл
		Если ВыборкаШК.Владелец = ВыборкаШК.ЕдиницаИзмерения.Владелец Тогда
			Продолжить;
		КонецЕсли;
		Если ВыборкаШК.Владелец.ЭтоГруппа Тогда
			Продолжить;
		КонецЕсли;
		Состояние("Обрабатывается: "  + ВыборкаШК.Владелец);
		Запись = ВыборкаШК.ПолучитьМенеджерЗаписи(); 
		Запись.Прочитать();
		
		Запись.ЕдиницаИзмерения = Запись.Владелец.ЕдиницаХраненияОстатков;
		Попытка
			Запись.Записать()
		Исключение
			ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки())
		КонецПопытки;
		Состояние("Обрабатывается: ......");
		
	КонецЦикла;
	Сообщить("Обработка завершена!");
КонецПроцедуры


Показать



Прикрепленные файлы:
CorrectEAN-13.epf
133. Bublik2011 9 02.03.12 14:55 Сейчас в теме
Необходимо загрузить в справочник Номенклатура данные из файла Excel с помощью обработки "Универсальный загрузчик табличного документа" , что с диска ИТС (конфигурация 1С:Управление Торговлей). Нашел инструкцию как это делается для УТ 10.3, но с теми же настройками обработки не получается загрузить. Ошибки возникают на пунктах: Единица хранения остатков и Единица для отчетов. Не загружается единица для штрихкода. Как исправить для моей конфигурации?
132. manager16 28.09.16 10:28 Сейчас в теме
добрый день. как с помощью обработки данной загрузить еще аналоги. То есть в карточке номенклатуры есть вкладка аналог. Вот туда и надо мне загрузить практически под каждый артикул загрузить от 1-15 аналогов.
131. darkvampire1991 23.05.16 06:43 Сейчас в теме
Здравствуйте подскажите используя обработку необходимо добавить в Номенклатуру Производителей чтобы они записывались сразу в Номенклатуру, просто если ставишь Режим загрузки: Устанавливать то не записываются производители, если же Искать то не находит соответственно их. Приходится в ручную идти в Номенклатуру и создавать производителя. Думаю вопрос правильно изложил, код какой-то написать в обработку по автоматическому добавлению производителей из файла Excel? Спасибо за ответ заранее)
130. vsomova 18.05.16 20:21 Сейчас в теме
(129) Online-Ufa,
Это просто чудо! Немного потыкалась в настройках и все получилось - и артикулы изменить и цены новые подтянуть!!! Я даже не знаю как Вас благодарить! Спасибо ОГРОМНОЕ!!!!
darkvampire1991; +1 Ответить
129. Online-Ufa 18.05.16 17:46 Сейчас в теме
какая проблема? с помощью этой же обработки можете менять артикулы, только тогда идиентификация будет производится по названию? товаров с одинаковыми названими нет? названия в вашей базе и екселе сходятся на 100% с точностью до каждого знака?
если на все вопросы ответ "да", то пожалуйста, загружайте свои артикулы
darkvampire1991; +1 Ответить 1
128. vsomova 18.05.16 11:21 Сейчас в теме
(127) Online-Ufa,
Добрый день!
Спасибо огромное за подробную инструкцию, но у меня проблем а в том, что по этой инструкции удается только создать новые артикулы, а как быть со старыми - нужно изменить артикулы, которые уже есть в 1С. Номенклатуры много, сейчас вот решили изменить полностью все кодировки артикульные. Если руками обрабатывать, то даже месяца времени не хватит. Может есть какие-то другие обработки групповые? Спасибо заранее!
darkvampire1991; +1 Ответить
127. Online-Ufa 17.05.16 20:23 Сейчас в теме
наврал,
предыдущая ссылка на статью про загрузку накладной
оригинал вот
http://www.online-ufa.ru/content/articles/loading_data_into_1c_from_excel_part_2/
126. Online-Ufa 17.05.16 20:15 Сейчас в теме
ха... увидеть свою статью через столько лет под чужим именем - это забавно :-)
http://www.online-ufa.ru/content/articles/loading_data_into_1c_from_excel_part_3/
источник чтоли хотя бы указал
darkvampire1991; +1 Ответить
125. vsomova 17.05.16 19:26 Сейчас в теме
Добрый день! Подскажите, пожалуйста, с помощью этой обработки можно изменить уже существующие артикулы? Наименование и все прочие данные остаются без изменений.
darkvampire1991; +1 Ответить
124. xavikz 25.08.15 11:23 Сейчас в теме
Подскажите пожалуйста, есть база в управлении торговлей 1 8.2 (Штрих-М).
В номенклатуре есть много свойств, и на половине товаров вбиты значения этих свойств, в другой нет.
Как то можно из ексель импортировать значения свойств объектов для номенклатуры?
Наименований очень много, десятки тысяч
aRaBest; darkvampire1991; +2 Ответить
123. tihokir 04.06.15 16:50 Сейчас в теме
Помогите, пожалуйста, новичку. Есть две характеристики номенклатуры Размер и Цвет, у каждого по три значения, то есть, всего 9 характеристик получается. Как их загрузить в 1С УТ стандартными программными средствами ЗагрузкаДанныхИзТабличногоДокумента?
darkvampire1991; +1 Ответить
122. micha76 29.05.15 13:43 Сейчас в теме
В принципе, грузится и с группами (только группы первого уровня отдельно завести). А серийные номера в УТ никто не пробовал переносить?
darkvampire1991; +1 Ответить
121. KarinaSV 6 12.05.15 23:20 Сейчас в теме
!!!Помогите пожалуйста!!!

При нажатии на кнопку загрузить выдает ошибку:

"Ошибка при вызове метода контекста (Вопрос)"

Нажимаю подробно выходит:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента.МодульОбъекта(946)}: Ошибка при вызове метода контекста (Вопрос)
Если Вопрос("Загрузить "+КоличествоЭлементов + ТекстВопросаИсточника, РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да Тогда
по причине:
Использование модальных окон в данном режиме запрещено!

Заранее огромное спасибо!
darkvampire1991; +1 Ответить
120. AlexO 126 23.04.15 16:22 Сейчас в теме
А еще мне заголовок нравится:
"СТАБИЛЬНАЯ Загрузка справочника номенклатуры".
Т.е. остальные - нестабильные, в полураспаде...
darkvampire1991; +1 Ответить
119. WWWolfy 100 23.04.15 16:05 Сейчас в теме
118. progaoff 03.04.15 10:36 Сейчас в теме
Выбивает ошибку "не удалось записать" захожу в карточку товара единицы пустые, записываю в ручную карточку товара, появляються единицы. В чем проблема?
darkvampire1991; +1 Ответить 1
117. WWWolfy 100 09.02.15 19:56 Сейчас в теме
(116) NE_ZNAIY, так в вашей конфе посмотрите код поиска по штрихкоду и сделайте по аналогии
116. NE_ZNAIY 07.02.15 23:07 Сейчас в теме
А подскажите, пожалуйста, как из экселя (накладная поставщика) загрузить в документ поступления.
Номенклатура поставщика отличается от нашей. В накладной поставщика есть штрих-коды, которые занесены в нашу номенклатуру.
Можно ли сделать так, чтоб обработка ЗагрузкаДанныхИзтабличногоДокумента искала штрихкод, а в документ поступления подставляла нашы наименования номенклатуры. Раньше, когда поставщик в своих накладных не использовал штрих-код мы выходили из положения так. в карточке номенклатуры наименование - наше наименование, полное наименование - наименование номенклатуры поставщика. и в настройке обработки в строке наименование ставили вычислять и такой код
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.НаименованиеПолное ПОДОБНО &НаименованиеПолное";

Запрос.УстановитьПараметр("НаименованиеПолное", ТекстЯчейки);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Если Выборка.Следующий() Тогда
Результат = Выборка.Ссылка;
Иначе
ОписаниеОшибки = "Не найдена ноиенклатура с полным наименованием " + ТекстЯчейки;
КонецЕсли;

Может его как-нибудь подправить, чтоб обработка брала из регистра штрих-коды?
Может поможет кто-нибудь?
darkvampire1991; +1 Ответить 1
115. WWWolfy 100 05.02.15 21:48 Сейчас в теме
ЗагрузкаДанныхИзТабличногоДокумента.epf / Единица для хранения остатков / Родитель

1. Легко можно загрузить сразу в первом проходе все Единицы измерения ( Единица для хранения остатков + Единица для отчетов )
Допустим "Базовую единицу" вы прописали откуда брать, тогда добавьте такой код в События (в настройках над таблицей) в заладку "При записи"

текБазоваяЕдиницаИзмерения = Объект.БазоваяЕдиницаИзмерения;
текСсылка = Объект.Ссылка;

Если НЕ ЗначениеЗаполнено(Объект.ЕдиницаХраненияОстатков) Тогда
	ВыборкаЕдиниц = Справочники.ЕдиницыИзмерения.Выбрать(, текСсылка);
	Если ВыборкаЕдиниц.Следующий() Тогда
		НайденнаяЕдиница = ВыборкаЕдиниц.Ссылка;
	Иначе
		НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
		НайденнаяЕдиницаОбъект.Наименование            = СокрЛП(текБазоваяЕдиницаИзмерения);
		НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = текБазоваяЕдиницаИзмерения;
		НайденнаяЕдиницаОбъект.Коэффициент             = 1;
		НайденнаяЕдиницаОбъект.Владелец                = текСсылка;

		Попытка
			НайденнаяЕдиницаОбъект.Записать();
			НайденнаяЕдиница = НайденнаяЕдиницаОбъект.Ссылка;
		Исключение
			//Сообщить("Не удалось записать единицу хранения остатков: " + ОписаниеОшибки(), СтатусСообщения.Важное);
			Отказ = Истина;
		КонецПопытки;
	КонецЕсли;

	Если НЕ Отказ Тогда
		Объект.ЕдиницаХраненияОстатков = НайденнаяЕдиница;
		Объект.ЕдиницаДляОтчетов = НайденнаяЕдиница;
	КонецЕсли;		
КонецЕсли;
Показать

учтите что в этом коде нельзя использовать"Возврат"

2. Чтобы создать группу (родителя) автоматически, добавьте следующий код (в строку Родитель):
ИмяРодителя = ТекстЯчейки;
текГруппа = Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ИмяРодителя),Истина);
Если текГруппа = Справочники.Номенклатура.ПустаяСсылка() Тогда
	ГруппаНоменклатуры = Справочники.Номенклатура.СоздатьГруппу();
	ГруппаНоменклатуры.Наименование = ИмяРодителя;
	ГруппаНоменклатуры.Записать();
	текГруппа = ГруппаНоменклатуры.Ссылка;
КонецЕсли;
Результат = текГруппа;
Показать

Пример для одноуровневых справочников, для многоуровневых доработайте сами
Но учтите! По кнопке [Контроль заполнения] папки сразу создадутся! Можно вынести в "При записи".
114. AlexO 126 02.02.15 13:07 Сейчас в теме
(113)
Это кажется, из "Управление Торговлей для Украины 3" ?
Вы их наизусть, что ли, помните? ))
Чтобы не допустить "задваивания", приходится ставить отметку поле поиска - "код"
У кого код задваивает, у кого - наименование.
Это каждый должен смотреть у себя по своим данным, универсального решения быть не может.
В тяжелых случаях - "вычислять"
Бесполезно так вычислять - можно найти массу похожих.
Единственный вариант - сделать многоступенчатую проверку и идентификацию: проверка по коду и наименованию, нет - только по наименованию (полностью), нет - похожесть. Найдено - еще раз перепроверить из найденного по коду. И только в этом случае записывать.
Особо "нестандартные" случаи - просто выводить информацией, что и как не совпало.
Только так, это - единственный вариант, закрывающий 90% обменов.
остальное - только вручную настраивать под "нюансы" кокнретной базы (конкретные данные обмена).
113. SkyLink2012 253 01.02.15 18:56 Сейчас в теме
(112) Deroswent, утверждаю обратное :) Обработка не совсем глючная.

Постоянно загружается по 10 накладных в день.

Ставьте проверку и обработку ошибок. Поможет в Вашем случае? Что особенного?

КолонкаШтрихкоды=3; //если пусто -1
КолонкаРисунок=-4   ; //если пусто - ставим отрицательно

Если КолонкаШтрихкоды>0 И ЗначениеЗаполнено(СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды])) Тогда
	Если НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(ТекстыЯчеек[КолонкаШтрихкоды]) Тогда
		
		//Запись= РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
		
		Попытка
			Объект.Записать(Истина);
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;			
		
		
		
	КонецЕсли;		
КонецЕсли;

Показать


Эта обработка прекрасна и очаровательна на файловой БД.

Вас не затруднит напомнит про ПроверитьДопустимостьИзмененияРеквизитовСправочника () ? Это кажется, из "Управление Торговлей для Украины 3" ? Не видел эту функцию. Есть идея, выполнить проверку допустимости запросом, например. Это уже не топик, простите, как и прочие "костыли".
Соглашусь, "задваивает" элементы. Чтобы не допустить "задваивания", приходится ставить отметку поле поиска - "код", например. В тяжелых случаях - "вычислять"

	Запрос=новый Запрос; Запрос.Текст="
	|  ВЫБРАТЬ Номенклатура.Ссылка ИЗ Справочник.Номенклатура КАК Номенклатура ГДЕ
	|	Номенклатура.Артикул = &Артикул  
	|	И Номенклатура.Поставщик ПОДОБНО &Поставщик
	|";
	Запрос.УстановитьПараметр("Артикул",СтрКодАртикул);
    Запрос.УстановитьПараметр("Поставщик",СтрКодПоставщик);
    РезультатЗапроса = Запрос.Выполнить();
		Если НЕ РезультатЗапроса.Пустой() Тогда
		   Результат = РезультатЗапроса.Выгрузить()[0].Ссылка;
		КонецЕсли;
Показать
darkvampire1991; +1 Ответить 1
112. Deroswent 26.01.15 18:14 Сейчас в теме
Очень уж глючная эта обработка. Точнее не глючная а "унифицирована"... у меня например вылетает с ошибкой
Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика - 'ПередЗаписью': {Справочник.Номенклатура.МодульОбъекта(46)}: Ошибка при вызове метода контекста (ПроверитьДопустимостьИзмененияРеквизитовСправочника): Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода ПроверитьДопустимостьИзмененияРеквизитовСправочника ().

И как бы я не боролся с ней - все бесполезно. Свежие идеи есть?
darkvampire1991; +1 Ответить 1
111. Kutnor 12.08.14 11:05 Сейчас в теме
когда загружаю характеристики поле связь по владельцу в настройках почему то недоступно.
darkvampire1991; +1 Ответить
110. Kutnor 12.08.14 10:30 Сейчас в теме
p.s. данной обработкой загрузил характеристики. Сначала все было хорошо.
Потом у нс расширился ассортимент характеристик и я подгрузил новые, поставил галочку не создавать новые.
Так он что сделал:
допустим есть товар пряжа из шерсти цвет черный 50 уп.
когда я загружал пряжу из хлопка цвет черный, он его не создал а взял и спер у пряжи из шерсти вместе с количеством.
теперь на складе лежит 50 уп. пряжи из шерсти, а в 1С их нет, зато есть пряжа из хлопка 50 уп.

кто подскажет как этого в будущем избежать и как мне теперь все это исправить.
то есть как я понял у характеристики есть 3 параметра:
1)Наименование
2)Номенклатура
3)ХарактеристикаНоменклатуры.Владелец

вот сейчас у меня у некоторых характеристик поля 2 и 3 разные, а должны быть одинаковые.
109. Kutnor 12.08.14 10:20 Сейчас в теме
(103) Kutnor, забыл тут написать что в статье код с английской буквой С. поэтому и ошибку выдавало.
108. SerGan757 07.06.14 20:17 Сейчас в теме
Bublik2011 - спасибо огромное :)
darkvampire1991; +1 Ответить
107. Bublik2011 9 07.06.14 12:35 Сейчас в теме
(105) SerGan757, Вот хороший инструмент для работы с паттернами, в аттаче.
Прикрепленные файлы:
RegExp.exe
darkvampire1991; SerGan757; +2 Ответить
106. Bublik2011 9 07.06.14 12:18 Сейчас в теме
(105) SerGan757,

Лучше-бы я не давал совет. Совет: Есть смысл перестроить справочник.

Плохой совет: ввести в Справочник.Номенклатура реквизит Размер (строка,фиксированная,10,индексировать)
         +поиск по реквизиту облегчается
         +очевидный списочный отбор
         -эволюция трудна, при превышении 1000 ценников уже придется модифицировать структуру    

Совет получше: ввести в Справочник.Номенклатура реквизит Размер (создать Справочник.Размеры)
         +преимущество подбора размерного ряда

Идеальный вариант: 1.каждый товар вести учет характеристики
                   2. на каждый штрихкод установить характеристику и размер 
         +будет возможность легко обрабатывать большие объемы, больше 25000 ценников
         +если есть сайт, обратил внимание, выбор по размеру и цвету? Думаю, идеальный вариант лучше
  
Показать


Ответ на вопрос
а как перебрать и поставить с нужным размером ?


Предпочел-бы цифру из строки выбрать с помощью Regexp и построить выбор не по НайтиПоРеквизиту, а запросом. Вот в аттаче РаботаСЗапросами.epf

Вот примерно так,

    стр="Строка с наименование р.599";
	СтрокаАртикул="Артикул-Какой-то"
	
	
    RegExp.IgnoreCase = Истина; //Игнорировать регистр
    RegExp.Global = Истина; //Поиск всех вхождений шаблона
    RegExp.MultiLine = Истина; //Многострочный режим
    RegExp.Pattern = "([^0-9]*)([0-9]+)([^0-9]*)"; 
    стр=RegExp.Replace(стр, "$2"); 
	
	Если (RegExp.Test(стр)) Тогда
		СтрокаЦифраРазмера=Стр;
	Иначе
		СтрокаЦифраРазмера="";
    КонецЕсли;

   Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
|	Номенклатура.Ссылка,
|	Номенклатура.Наименование
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.Артикул = &Артикул
|	И Номенклатура.Наименование ПОДОБНО ""%"" + &ЦифраРазмера + ""%""
|";
Запрос.УстановитьПараметр("Артикул",СтрокаАртикул);
Запрос.УстановитьПараметр("ЦифраРазмера",СтрокаЦифраРазмера);
РезультатЗ = Запрос.Выполнить();
Результат = РезультатЗ.Выгрузить();
Для каждого СтрокаТЗ из РезультатЗ Цикл
КонецЦикла;
РезультатЗапроса = Запрос.Выполнить();
  Если НЕ РезультатЗапроса.Пустой() Тогда
        СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];
		Результат=СтрокаРезультата.Ссылка;
  КонецЕсли;
Показать


возможно ошибки типов, не проверял.
Прикрепленные файлы:
РаботаСЗапросами.epf
SerGan757; +1 Ответить
105. SerGan757 07.06.14 01:13 Сейчас в теме
уперся...загружаю такую накладную (см файл) с одинаковыми артикулами!, только в наименовании Товара отличается размером (последние цифры без скобки), в базе у меня есть такой товар тоже артикулы одинаковые, только в Наименовании в конце размер стоит, Нахожу нужный артикул и он ставит самый первый из базы,
а как перебрать и поставить с нужным размером ?
Родитель = Справочники.Номенклатура.НайтиПоНаименованию("ТМ БУМ",Истина);
Результат = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", ТекстЯчейки, Родитель);
????
Прикрепленные файлы:
darkvampire1991; +1 Ответить 2
104. Bublik2011 9 02.06.14 19:04 Сейчас в теме
(103) Kutnor, честно сказать? Часто сомневаюсь и жму кнопку "проверить заполнение данных" перед "выполнить".
А иногда до ступора доходит и во внешней обработке проверяю орфографию, начав текст примерно так
ТекстыЯчеек= Новый Массив; 	
СсылкаН=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ТекстыЯчеек[1]));


загружаю шрих-коды то вылазит вот такая ошибка

Да, ошибки будут постоянно. 1С - это тоже ошибка. Исправление старых багов и создание новых )) Но мне для ведения учета вполне, тьфу-тьфу, хватает. АВС и XYZ анализ проводить, например.
Весьма интересно все-таки знать продукт. Например зачастую очень удобно большие данные обрабатывать не внешней обработкой, а применять встроенные отчеты и обработки. Правда, пока не могу "вырасти" до покупки ИТС и подключаемых платных модулей, кроме типовых. Все-таки не внешней обработкой , а этой вот ЗагрузкаДанныхИзТабличногоДокумента.epf, речь о которой идет в этой статье. Мда-а-а, я философ? Нет, так, пару строк написал, чтобы поисковый идекс статья попала и упоминание про УниверсальныеПодборИОбработкаОбъектов.epf
Простите, Kutnor, увлекся... :) Если ближе к делу, стал подгружать ШК из внешнего файлика. Почему? Для загрузки 23000 штрихкодов - это удобнее, чем копипастить в таблицу. Вот пример для УниверсальныеПодборИОбработкаОбъектов.epf
Вот файлик c:\bcode.txt
1709009-4;4620769209832;				
1709009-5;4620769209917;				
1709009-6;4620769209849;

В обработка\настройка - произвольный алгоритм Универсальной Подбора И Обработки Объектов вставил код
	Текст = "";
Запр = Новый Запрос("
 | ВЫБРАТЬ
 | 	Штрихкоды.Штрихкод как Код,
 | 	Штрихкоды.Владелец.Ссылка
 | ИЗ
 | 	РегистрСведений.Штрихкоды КАК Штрихкоды
 | ГДЕ
 | 	Штрихкоды.Владелец.Ссылка = &Товар ");

Запр.УстановитьПараметр("Товар", Объект.Ссылка);
ВыбМ = Запр.Выполнить().Выбрать();
ВыбТ = Запр.Выполнить().Выгрузить();
Индекс = ВыбТ.Количество(); 

Если Индекс=0  Тогда

НазваниеФайла="c:\bcode.txt";
Текст = Новый ЧтениеТекста(НазваниеФайла, КодировкаТекста.ANSI);
Стр=""; Найдено=1; ШКСуществует=1;
СписокНоменклатуры = Новый СписокЗначений;
	Пока Стр<>Неопределено Цикл
	 	Стр = Текст.ПрочитатьСтроку();
			Строк=СокрЛП(Стр);
			Разделитель=Найти(Строк,";");
		Если СтрДлина(Строк)>3 Тогда  
			КонецПервого=Разделитель;
			Первое=СтрЗаменить(Сред(Строк,1,КонецПервого),";","");
			Второе=СтрЗаменить(Сред(Строк,КонецПервого,СтрДлина(Строк)),";","");
						
			Если СокрЛП(Объект.Артикул)=Первое Тогда				
				Если ЗначениеЗаполнено(Второе) Тогда
						Для Каждого ЭлементМассива Из ВыбТ Цикл ШКСуществует=0; 						
							Если СокрЛП(ЭлементМассива[0]) = СокрЛП(Второе) Тогда 
								Сообщить("Для арт.:"+СокрЛП(Объект.Артикул)+" уже существует ШК, предлагаемый для арт:"+СокрЛП(Первое)); ШКСуществует=1;Прервать;
							КонецЕсли; 
						КонецЦикла; 
						Если НЕ ШКСуществует=1 Тогда
                               БуфернаяСтрока=СокрЛП(Второе);
							     Сообщить(Второе);									 
									Если ОбщегоНазначения.ТолькоЦифрыВСтроке(БуфернаяСтрока) Тогда
									Номенкл = Объект.Ссылка;
								Запись                             = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
								Запись.Штрихкод                       = СокрЛП(БуфернаяСтрока);
								Запись.Владелец                       = Номенкл;
								Запись.ТипШтрихкода                 = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
								Запись.ЕдиницаИзмерения                 = Номенкл.ЕдиницаХраненияОстатков;
								Запись.Качество                       = Справочники.Качество.НайтиПоНаименованию("Новый");
								Попытка	Запись.Записать(Истина); Исключение	Сообщить("Не удалось записать ШК: "+СокрЛП(БуфернаяСтрока)+" для элемента: "+Строка(Номенкл)+" "+СокрЛП(Номенкл.Код)+" ||| "+ ОписаниеОшибки());	КонецПопытки;	
										ИначеЕсли НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(БуфернаяСтрока) Тогда	Сообщить("В буфере обмена нет данных формата EAN "+БуфернаяСтрока);	КонецЕсли;
						Иначе		
							 Сообщить("-");	
						КонецЕсли;
						
					Найдено=1;Прервать;
				КонецЕсли;
				
			Иначе
				Найдено=0;
			КонецЕсли;
		КонецЕсли;
	
			
			
	КонецЦикла; 
Если НЕ Найдено=1 Тогда Сообщить("Для "+""+СокрЛП(Объект.Код)+" , арт.:"+СокрЛП(Объект.Артикул)+" не найдено .") ; КонецЕсли;
Текст.Закрыть();
	
КонецЕсли;

Показать


... и ... ЗАРАБОТАЛО !!! :)))
darkvampire1991; +1 Ответить
103. Kutnor 02.06.14 16:39 Сейчас в теме
весьма странно: поставил свой текст и все заработало, он под номер 1, для сравнения с тем что раньше было ставлю текст который был раньше под номером 2
1)СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
2)CсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;

тесты идентичны, с номером 1 работает, а с номером 2 нет.
darkvampire1991; +1 Ответить 2
102. Kutnor 02.06.14 16:26 Сейчас в теме
Помогите пожалуйста, когда загружаю шрих-коды то вылазит вот такая ошибка:

Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(2,14)}: Переменная не определена (СсылкаНоменклатуры)

как это лечить? или может код не правильный?
101. Bublik2011 9 25.04.14 01:46 Сейчас в теме
(98) Kutnor, это сообщение изменю, пока сделайте бэкап базы.

Думаю, подход к делу надо изменить. В настройках.
1) Качество - устанавливать
2) Единицы измерения - вычислять
100. Bublik2011 9 25.04.14 01:15 Сейчас в теме
(99) Kutnor, Решил проблему так: сравниваю цены (история1), на этом этапе создаются характеристики.

"Я Пойду по другому пути" (с)DJ Ленин :) То есть решил Штрихкоды добавить, а затем характеристики выяснить необходимость добавления характеристики, а потом - добавить штрихкод. Фанатею по EAN13 или Code128 производителя (история2)

Итак, характеристики можно добавить так например, извините на неправильное названия переменных, написанных впопыхах)

		Если (Какое то условие, что цена ОТЛИЧАЕТСЯ и надо вводить характеристику) Тогда
			ЗапросХНА=новый Запрос;
			ЗапросХНА.Текст="
			|     ВЫБРАТЬ
			|	ХарактеристикиНоменклатуры.Ссылка,
			|	ХарактеристикиНоменклатуры.Владелец.Код
			|from
			|	Справочник.ХарактеристикиНоменклатуры КАК ХарактеристикиНоменклатуры
			|where
			|	ХарактеристикиНоменклатуры.Наименование ПОДОБНО &харнаим
			|	И ХарактеристикиНоменклатуры.Владелец = &харнокод
			|   И НЕ ХарактеристикиНоменклатуры.ПометкаУдаления
			|";
			ЗапросХНА.УстановитьПараметр("харнокод",НоменклЦ);
			ЗапросХНА.УстановитьПараметр("харнаим",ХарактеристикаНаименованиеЕ);
			РезультатПустой1 = ЗапросХНА.Выполнить().Пустой();		
		Если РезультатПустой1 И УстанавливатьХарактеристикиНовые Тогда		
		Характеристика          = Справочники.ХарактеристикиНоменклатуры.СоздатьЭлемент();
		Характеристика.Владелец = НоменклЦ;
		Характеристика.Наименование = ХарактеристикаНаименование;	
			Попытка 
				Характеристика.Записать();
				новШк = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи(); 
					  новШк.Владелец         = НоменклЦ; 
					  новШк.ЕдиницаИзмерения = НоменклЦ.ЕдиницаХраненияОстатков; 
					  новШк.ТипШтрихкода     = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13; 
					  новШк.Качество         = Справочники.Качество.Новый; 
					  новШк.Штрихкод         = РаботаСТорговымОборудованием.СформироватьШтрихКод(); 
					  новШк.ХарактеристикаНоменклатуры = Характеристика.Ссылка;
					  новШк.Записать();
				
			Исключение 
				Сообщить(СокрЛП(ОписаниеОшибки())) ;
			КонецПопытки;
		Иначе	
			 Сообщить(СокрЛП(СокрЛП(ТекстыЯчеек[1]))+";"+СокрЛП(ХарактеристикаНаименование)+";"+СокрЛП(ЦенаНоменклатуры)+";"+Формат((Строка(БазоваяЦцена)), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));
		    КонецЕсли;
            Иначе
                  Сообщить(СокрЛП(СокрЛП(ТекстыЯчеек[1]))+";"+СокрЛП("")+";"+СокрЛП(ЦенаНоменклатуры)+";"+Формат((Строка(БазоваяЦцена)), "ЧЦ=13; ЧДЦ=0; ЧГ=0"));
            КонецЕсли;



Показать



Это преступление, давать грязный кусок кода. Не знаю, что поможет тебе Kuthor , приаттаченая настройка или подробнее история1 или история2 ? С утра попробую разобраться в вопросе)) Обратил внимание на рисунок настроек. Как и говорил, предлагаю свой вариант (приаттаченный скрин настроек). ЧЕМ ОН НЕУДОБЕН ?


По крайней мере, ОБРАБОТКА ОШИБКИ - "ХАРАКТЕРИСТИКА НЕ НАЙДЕНА" в ЭТОМ ответе есть. Если честно - один товар - много характеристик - это История3 Какая из историй будет полезна?
Прикрепленные файлы:
99. Kutnor 24.04.14 16:39 Сейчас в теме
вот еще файл настроек.
я пропустил 2 первых этапа, т.к. у меня уже цена на товар есть и сам товар есть, нужно просто в него добавить штрихкоды и характеристики.
Штрихкоды добавились, а характеристики нет.
Прикрепленные файлы:
98. Kutnor 24.04.14 16:36 Сейчас в теме
скажите пожалуйста, а как загружать с характеристиками? Я попробовал у меня штрихкоды загрузились, а характеристики к ним нет.
Вот ошибка:
Ячейка[R2C5](Характеристика номенклатуры): Не найден
Добавлена запись № 1.

прикрепляю файл который пробовал загрузить.
Прикрепленные файлы:
тест.xls
97. Isperator 28.03.14 15:37 Сейчас в теме
Полезная статья. Мне как раз помогла.
96. Bublik2011 9 02.03.14 14:57 Сейчас в теме
Как видите, реквизиты «Единица для отчетов» и «Единица хранения остатков» остались не заполненными.


Попробовал загружать номенклатуру без идентификации по артикулу и коду. Вот, например код, который вставляется "Нумерация объектов-События-При записи объектов"

Мне понравилась идея вместо постоянной писанины обработок сразу создать номенклатуру, штрихкод, единицы измерения БЕЗ ПОВТОРНЫХ запусков. Ну. знаете, например, чекбокс "не создавать новые" и т.п. Но быдьте осмотрительны, ИДЕНТИФИКАЦИИ по коду\артикулу нет. Это уже самостоятельно :)

КолонкаШтрихкоды=-3; //если не заполнена или неохота записывать -1
 //если пусто -1


Спр=Объект.Ссылка.ПолучитьОбъект();
СсылкаНоменклатуры=Объект.Ссылка;
						БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("796");
						ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
						//Сообщить(ТекСпр.Пустая());
						
						Если ТекСпр.Пустая() Тогда 
						НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); 
								НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); 
								НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; 
								НайденнаяЕдиницаОбъект.Коэффициент = 1; 
								НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры;
								Попытка НайденнаяЕдиницаОбъект.Записать();
									СпрКод=Справочники.Номенклатура.НайтиПоКоду(СсылкаНоменклатуры.Код).ПолучитьОбъект();
									Объект.ЕдиницаДляОтчетов = НайденнаяЕдиницаОбъект.Ссылка;
									Объект.ЕдиницаХраненияОстатков = НайденнаяЕдиницаОбъект.Ссылка;							
									Объект.ЕдиницаИзмеренияМест= НайденнаяЕдиницаОбъект.Ссылка;
						    Исключение Сообщить("Не удалось записать еденицу "+" "+ ОписаниеОшибки()); 
							КонецПопытки;
						 //Сообщить(Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры).Пустая());
						КонецЕсли;		
Объект.Записать();


Если КолонкаШтрихкоды>0 И ЗначениеЗаполнено(СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды])) Тогда	
Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
|	Штрихкоды.Штрихкод,
|	Штрихкоды.Владелец.Ссылка,
|	Штрихкоды.Владелец.Код Код,
|	Штрихкоды.ХарактеристикаНоменклатуры.Ссылка,
|	Штрихкоды.ХарактеристикаНоменклатуры.Наименование
|ИЗ
|	РегистрСведений.Штрихкоды КАК Штрихкоды
|ГДЕ
|	Штрихкоды.Штрихкод = &lkjhgfds
//|	И Штрихкоды.ХарактеристикаНоменклатуры.Наименование ПОДОБНО &srgdthfyjuki
|";
Запрос.УстановитьПараметр("lkjhgfds",СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды]));
//Запрос.УстановитьПараметр("srgdthfyjuki",СокрЛП(?(Результат.ВГраница()>=ХаракНоменклатуры, СокрЛП(Результат[ХаракНоменклатуры]), "")));
	РезультатЗапроса = Запрос.Выполнить();
	Если НЕ РезультатЗапроса.Пустой() Тогда
		СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];	
		длорпавы = СтрокаРезультата.Код;
		Xcvghjkjbv("нашли владельца штрихкода, "+Строка(длорпавы)+" "+Строка(СтрокаРезультата.ВладелецСсылка)) ;
	Иначе		
	    				Запись= РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
						Запись.Штрихкод                       = СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды]);
						Запись.Владелец                       = СсылкаНоменклатуры;
						Запись.ТипШтрихкода                 = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
						Запись.ЕдиницаИзмерения                 = СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
						Запись.Качество                       = Справочники.Качество.НайтиПоНаименованию("Новый");
 							Попытка
						Запись.Записать(Истина);
							Исключение
								Xcvghjkjbv("Не удалось записать ШК: "+" для элемента: "+Строка(Объект)+" "+СокрЛП(Объект.Код)+" ||| "+ ОписаниеОшибки());
							КонецПопытки;
		
		
		
		
		
		
	КонецЕсли;
КонецЕсли;	

Показать


95. Bublik2011 9 16.10.13 14:46 Сейчас в теме
Предпочел-бы запросом делать отбор по номенклатуре, чтобы не загружать то что уже есть в справочниках. Тогда можно фильтровать по нескольким признакам.

Вот вариант, без создания единиц хранения остатков при создании. Подходит? Не проверял, как работает, но синтаксических ошибок нет. Предусмотрен вариант ошибки , что артикул или строка, по которому ведется поиск, незаполнен.

АртикулДляПоиска=СокрЛП(ТекстыЯчеек[40]);

Если НЕ ЗначениеЗаполнено(АртикулДляПоиска) Тогда
	Режим = РежимДиалогаВопрос.ДаНет;		
			Ответ = Вопрос("Пустая строка для поиска, возможен иной результат", Режим);
			Если Ответ = КодВозвратаДиалога.Да Тогда
			    //
			Иначе		
				Возврат 0;					
			КонецЕсли;
КонецЕсли;

	
Запрос=новый Запрос;
Запрос.Текст="
|  ВЫБРАТЬ  
|	Номенклатура.Ссылка,
|	Номенклатура.Код,
|	Номенклатура.Артикул,
|	Номенклатура.Поставщик
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.Артикул = &kjhgfd
//|	И Номенклатура.Поставщик = &fghjk
|";
Запрос.УстановитьПараметр("fghjk",АртикулДляПоиска);

РезультатЗ = Запрос.Выполнить().Выгрузить();
РезультатЗапроса = Запрос.Выполнить();

		//Если НЕ РезультатЗапроса.Пустой() Тогда
		//	СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];	
		//	  	Ссылка=СтрокаРезультата.Ссылка ;
		//КонецЕсли;

	Если  РезультатЗапроса.Пустой() Тогда			
			Объект=Справочники.Номенклатура.СоздатьЭлемент();
	  		Объект.Артикул=АртикулДляПоиска;
			Объект.БазоваяЕдиницаИзмерения=Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду("796");
					Попытка 
						Объект.Записать();
						Результат=Объект.Ссылка;				
					Исключение 
						Сообщить("Не удалось записать  "+СокрЛП(ОписаниеОшибки()));
					КонецПопытки; 					
	Иначе 				
		СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];	
	    Результат=СтрокаРезультата.Ссылка ;  		 					
	КонецЕсли;	

Показать
94. valya977 5 16.10.13 02:49 Сейчас в теме
А есть возможность делать отбор по номенклатуре (не загружать то что уже есть в справочниках)?
93. valya977 5 16.10.13 01:05 Сейчас в теме
Довольно часто пользуюсь данной обработкой.Спасибо за полный и понятный показ действий очень удобно и экономит много времени.
92. SerGan757 17.08.13 10:25 Сейчас в теме
СПАСИБО РАБОТАЕТ!!!вот результат
цена1 ="0.85"; 
цена2 = ОбщегоНазначения.ПривестиСтрокуКЧислу(ТекстыЯчеек[4]);
Результат = цена1*цена2;
91. Bublik2011 9 17.08.13 10:09 Сейчас в теме
Ответ: SerGan757, надо писать в кавычках

цена1 = "0.86" ; 
цена2 = "8";
выражение1 =   цена2*цена1;



Но я бы воспользовалься функцией ПривестиСтрокуКЧислу . Гарантия избежать всевозможных ошибок.

цена1 = ОбщегоНазначения.ПривестиСтрокуКЧислу("0.86") ; 
цена2 = ОбщегоНазначения.ПривестиСтрокуКЧислу(8);
выражение1 =   цена2*цена1;


Вот функция ПривестиСтрокуКЧислу, которая находится УправлениеТорговлей-Общие-ОбщиеМодули-ОбщегоНазначения-ПривестиСтрокуКЧислу

Функция ПривестиСтрокуКЧислу(ЧислоСтрокой, ВозвращатьНеопределено = Ложь) Экспорт
	
	ОписаниеТипаЧисла = Новый ОписаниеТипов("Число");
	ЗначениеЧисла = ОписаниеТипаЧисла.ПривестиЗначение(ЧислоСтрокой);
	
	Если ВозвращатьНеопределено И (ЗначениеЧисла = 0) Тогда
		
		Стр = Строка(ЧислоСтрокой);
		Если Стр = "" Тогда
			Возврат Неопределено;
		КонецЕсли;
		
		Стр = СтрЗаменить(СокрЛП(Стр), "0", "");
		Если (Стр <> "") И (Стр <> ".") И (Стр <> ",") Тогда
			Возврат Неопределено;
		КонецЕсли;
	КонецЕсли;
	
	Возврат ЗначениеЧисла;	
	
КонецФункции

Показать
90. SerGan757 16.08.13 22:08 Сейчас в теме
кто поможет? почему не работает? нужно цену из накладной умножить на коэффициент, но уперся и мучаюсь...

цена1 = 0.86; 
цена2 = ТекстыЯчеек[24];
выражение1 =	цена2*цена1;
Результат = Вычислить(выражение1);

Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(1,3)}: Ошибка в выражении
Преобразование значения к типу Число не может быть выполнено
89. fgremlin 03.04.13 11:57 Сейчас в теме
(87) fgremlin,
Продолжаем разговор:
гружу упаковки (которые состоят из конечных упаковок)
Скрин настроек во вложении.
Комментарии и код:
1. Как и в прошлой загрузке Владелец ищется по наименованию номенклатуры из колонки таблицы.
2. Родитель (конечная упаковка из которой состоит текущая) ищется и заполняется кодом:

//Ищем конечную единицу для номенклатуры:
Штука = Справочники.ЕдиницыИзмерения.НайтиПоКоду(796);
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные.Владелец.Код);
Если Не(СсылкаНоменклатуры.Пустая()) Тогда
	КонУпаковка = Справочники.УпаковкиНоменклатуры.НайтиПоРеквизиту("ЕдиницаИзмерения",Штука,,СсылкаНоменклатуры);
	Если КонУпаковка.Пустая() Тогда 
		Сообщить("Нет конечной упаковки!!!");	
	КонецЕсли;
Иначе
    Сообщить("Не найдена номенклатура");	
КонецЕсли;

Сообщить(""+КонУпаковка.Ссылка.Наименование);
Результат = КонУпаковка.Ссылка;
Показать


3. Ставим флаг "Состоит из других упаковок"
4. "Единица измерения" из классификатора ставлю вручную, но ничего не мешает поискать по коду или наименованию в классификаторе...
5. Количество в упаковке берем из колонки таблицы.
6. Коэффициент пересчитываем из текущих данных таким кодом:

//Пересчитываем коэффициенты на основании конечной единицы
КонечныйКоэффициент = ТекущиеДанные.Родитель.Коэффициент;
КоличествоУпаковок = ТекущиеДанные.КоличествоУпаковок;
Результат = КонечныйКоэффициент*КоличествоУпаковок;


7. Ну и, конечно же наименование, которое формируется из текущих данных по штатным алгоритмам таким кодом и вроде даже проверяется на уникальность не позволяя задвоить упаковку:


Результат = СокрЛП(СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + " (" + Формат(ТекущиеДанные.Коэффициент,"ЧРД=.") + " " + СокрЛП(ТекущиеДанные.Родитель.ЕдиницаИзмерения) + ")");


Ну, вот как-то так.
В общем и целом данной обработкой можно делать много чего.
Надеюсь кому нибудь это пригодится.
При загрузке использовались исключительно материалы данной статьи и ветки форума, за что авторам огромное спасибо.
Прикрепленные файлы:
SkyLink2012; Bublik2011; +2 Ответить
88. fgremlin 02.04.13 17:55 Сейчас в теме
(87) fgremlin,
Понемногу решаю вопрос, результаты буду выкладывать тут, чтобы сохранялась информация для тех, кто столкнется с подобными проблемами.
При описании предполагаю, что читающий осознал все вышеописанное в самой статье и в обсуждениях:
Итак, грузим "конечные" единицы (шт) потому, что их потом потребуется использовать в качестве родителей для более крупных упаковок:
скрин настроек обработки во вложении, обратите внимание на то, что
1. поле "наименование" спущено в самый низ для того чтобы наименованию было из чего формироваться ("Единица измерения", "Коэффициент") и по нему проверяется наличие данной упаковки
2. Поиск происходит в том числе по полю "Владелец" что-бы владелец подставлялся из справочника номенклатуры (работает по наименованию)
3. Заполнял поля только необходимые для меня, остальные добавляйте "по вкусу".

код формирования наименования такой:
Результат = СокрЛП(СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + " (" + Формат(ТекущиеДанные.Коэффициент,"ЧРД=.") + " " + СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + ")");



p.s. В понимании некоторых процессов могу заблуждаться, прошу коллег попровлять меня.
p.p.s. ... to be continued...
Прикрепленные файлы:
87. fgremlin 02.04.13 16:42 Сейчас в теме
Господа практикующие программеры, подскажите:
каким кодом можно корректно сформировать упаковки для номенклатуры. Использую индивидуальные наборы для номенклатуры (что-бы для каждой позиции указывать количество в упаковке).
Использую 1С:Предприятие 8.2 (8.2.17.153) Управление торговлей, редакция 11.0 (11.0.9.15)
Предполагаю поступать таким образом:
1. Для начала формирую конечные единицы (шт.), грузить в справочник "Упаковки", тут трудность только в формировании наименования. В конфигурации это делается таким кодом:
СокрЛП(СокрЛП(ЕдиницаИзмерения) + " (" + Формат(Коэффициент,"ЧРД=.") + " " + СокрЛП(ЕдиницаИзмеренияВладельца) + ")")

2. Сформировать упаковки, тут две трудности:
а. Выбрать и установить конечную единицу измерения (родительскую)
б. Сформировать наименование из родительской единицы измерения и текущей.

И все эти единицы требуется проверять на наличие и если такие существуют, то грузить их не требуется...

Может кто делал подобное?
86. Bublik2011 9 28.03.13 16:11 Сейчас в теме
я обязательно напишу подробно решение этого вопроса-по артикулам. мне не лень, просто физически за комп не могу приземлиться)) С утра 29.03 попытаюсь порекомендовать простое решение. Поверьте, оно есть. Решение очень простое. Буду весьма рад, что типовая обработка работы со справочниками пригодится в приенении. Я аж прям фэн этого решения от 1С ))) Пока рекомендую взглянуть на http:// help1c . com/faq8.html - работа с примитивными справочниками.

Пожалуйста, вместо скриншота ошибки - скриншот какие данные есть, на примере http://forum.infostart.ru/ajax/show_comment.php?t=45830&c=54 .
85. passtools 28.03.13 13:36 Сейчас в теме
(65) Bublik2011, Для какой версии СозданиеГруппы.epf ? Он у меня выводит ошибку. Мой УТ 10.3

Вот что выводит.

{Справочник.ВнешниеОбработки.Форма.ФормаЭлемента(189)}: Ошибка при вызове метода контекста (Создать): Ошибка подключения внешних метаданных: Ошибка загрузки документа.
Внешняя обработка не может быть прочитана текущей версией программы.
Прикрепленные файлы:
84. passtools 27.03.13 16:00 Сейчас в теме
(81) Bublik2011, " где ОбъектСсылка - это найденный товар по артикулу " он у меня не находит изображения. Мне кажется надо прописать где ОбъектСсылка не по коду, а надо по артикулу. Вот только я в программировании НОЛЬ. не знаю что точно прописать, чтобы искал файлы по артикулу а не по коду. Может так ОбъектСсылка=Справочники.Номенклатура.НайтиПоАртикулу(АртикулЭлемента); А то выдает такую ошибку Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(1,55)}: Переменная не определена (КодЭлемента) Код который Вы выложили я вставил в обработчик, указав в настройке Основное изображение -> Вычислить.
83. Bublik2011 9 27.03.13 13:31 Сейчас в теме
(82) passtools, да, это удобно загрузить номенклатуру с изображениями от контрагентов и обновлять свою базу.Но недавно избавился от гемора по сжатию файловой базы и чистки Справочники.ХранилищеЗначений. Может не надо так много грузить?) Если такое количество картнок надо для сайта, то лучше качественное и большое фото держать вне файловой базы и подгружать при выгрузке из отдельного файла. Как? Это другой вопрос))

А пока, думаю, чтобы найти несколько фото с добавлением _1.jpg _2.jpg _3.jpg, можно
1)перебирать каталог
2)явно указать в строке таблицы и проверять: пустая строка ? есть файл? например так
ФайлКартинки = Новый Файл(СокрЛП("c:\Мои документы\Jooob\foto\"+(Строка(ТекстыЯчеек[2]))+"__"+(Строка(ТекстыЯчеек[5]))+"_a.jpg"));
Если ФайлКартинки.Существует() Тогда
......	
КонецЕсли;


3) в аттаче архив - НАДО проверить на одном товаре. Может не работать, синтаксис, опять-таки((

Чорт! Ну ей Богу, если срочно, то лучше обработку создать с перебором файлов, если в названии файла есть артикул - запись.
Прикрепленные файлы:
РаботаСИзображениями_MXLZ.zip
82. passtools 26.03.13 15:09 Сейчас в теме
Bublik2011 В смысле- "одинаковые артикулы" ? Я наверное не точно передал смысл. " Одинаковые артикулы " Я имел в виду, что у каждого товара свой артикул, и названия рисунков так же имеют тот же артикут товара. Названия рисунка это артикул товара. Так же некоторые товары имеют несколько фото с добавлением _1.jpg _2.jpg _3.jpg
81. Bublik2011 9 26.03.13 14:55 Сейчас в теме
(80) passtools, например записать изображение можно отдельной обработкой


		ОбъектСсылка=Справочники.Номенклатура.НайтиПоКоду(КодЭлемента);
		ОбъектСправочник=ОбъектСсылка.ПолучитьОбъект();

	 ХранилищеОбъект = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
		ХранилищеОбъект.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
		ХранилищеОбъект.Хранилище = Новый ХранилищеЗначения(Новый Картинка(СокрЛП(ПолеВвода2+ВходныеДанные+".jpg")),Новый СжатиеДанных);
		ХранилищеОбъект.Объект = ОбъектСсылка;
		ХранилищеОбъект.Наименование = СокрЛП(ОбъектСсылка.Наименование);
		ХранилищеОбъект.ИмяФайла = СокрЛП("РасположениеФайлов"+".jpg");
		ХранилищеОбъект.Записать();
				
		ОбъектСправочник.ОсновноеИзображение=ХранилищеОбъект.Ссылка;
        ОбъектСправочник.Записать();

Показать


Или применить ее в этой теме, где ОбъектСсылка - это найденный товар по артикулу . Вечером посмотрю другие шаблоны ..

В смысле- "одинаковые артикулы" ? У меня было такое, пришлось по Кодам или по УникальнымИдентификаторам искать. Подробнее?
80. passtools 26.03.13 00:42 Сейчас в теме
Как добавлять рисунки картинки по артиклу? Все рисунки и товары илеют одинаковые артикулы.
79. NikolasI 25.03.13 13:51 Сейчас в теме
Оу!
Спасибо! :)
Видимо я перемудрил...
78. fgremlin 25.03.13 12:25 Сейчас в теме
(76) NikolasI,
Теоретически там код писать не нужно...
В представлении реквизита "Номенклатура" ставишь искать по полю табличного документа (артикул) - из твоей таблицы с данными, в поле "искать по" выбираешь "Артикул", и все, должен привязывать к нужному родителю в номенклатуре найдя его по артикулу...
Смотрел в редакции УТ 11, в живую не проверял, но раньше пробовал таким образом другие справочники грузить.
77. fgremlin 25.03.13 12:12 Сейчас в теме
(76) NikolasI,
А куда грузишь? Редакция, конфигурация?
76. NikolasI 25.03.13 11:50 Сейчас в теме
Полезная обработка.
Сейчас пытаюсь забить при помощи нее Номенклатуру поставщика. Не получается - помогите кто сможет.
То есть у нас есть своя номенклатура, в ней артикулы совпадают с поставщиком, наименования некоторые отличаются.
Соответсвенно надо произвести поиск поля Наименования по артикулу справочника Номенклатура.

Написал такое:

СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",ТекущиеДанные.Номенклатура.Артикул);
Результат=СсылкаНоменклатуры.Наименование;


Выдает такое:
Поле объекта не обнаружено (Номенклатура)
Загружен элемент справочника: <>


Что не так делаю?
75. fgremlin 11.02.13 20:06 Сейчас в теме
А на управляемых интерфейсах запускал кто нибудь эту обработку? Что-то у меня не получилось... :( поделитесь опытом!
74. kirillkr 28 18.01.13 17:49 Сейчас в теме
А как можно перед добавлением строки в табличную часть выполнить код - надо ли добавлять новую строку или нет.
Например, мне выкладывают прайс лист и помимо номенклатуры выдают все шк, т.е. одинаковых строк отличающихся только ШК - уйма. Как сделать так, чтобы в ценообразование загружать каждую номенклатуру единожды?
73. Bublik2011 9 16.01.13 04:47 Сейчас в теме
(72) alex54, Сколько бы обработок вроде ЗагрузкаданныхизТабличногоДокумента конечно не появлялось, эта остается классикой. Грех просто предьявлять претензии, исходный код открыть - изучай, не хочу... Еще чем мне нравится эта обработка - тем что вы читаете данные из внешнего источника, показываете их с помощью объекта табличное поле и только затем выбираете алгоритм загрузки в 1С.

Но что-то в ней не хватает. Конечно стандарта офисных документов ODF (Open Document Format). Теперь возможно загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в OpenOffice ODF (Open Document Format). Как можно загрузить в 1с8 из OpenOffice ? Можно прочитать http://infostart.ru/public/158951/
72. alex54 18.12.12 15:57 Сейчас в теме
(68) Мощный, есть что нового ?
71. alex54 10.12.12 20:04 Сейчас в теме
есть что нового по теме? из бюджетных ничего пока подобрать не могу (
70. alex54 09.12.12 17:19 Сейчас в теме
попробовал вот эту обработку http://infostart.ru/public/125082/

архи неудобная, НО, что там удачно, так это возможность задать диапазон загрузки

если это реализовать в данной версии - цены бы не было )
69. alex54 09.12.12 17:06 Сейчас в теме
ребят, не надо создавать группы в обработке, они созданы, это не так уж и сложно сделать вручную и родителя

обработка все делает на ура, единственно что нужно, так это задать диапазон загрузки

со строки такой - до строки такой.......... и все

и не надо во всем прайсе дописывать родителя, я его устанавливаю в из готовых заготовок

это еще и потому, что у разных поставщиков на одинаковую номенклатуру - разные родители или вообще нет

вот есть у меня прайс на 5000 наименований и даже разделение есть по группам (как задумал поставщик) а у меня другие для этого группы (родитель)
я устанавливаю куда грузить и задаю диапазон в прайсе....все.... остальное там идеально

если надо, я прикреплю обработку, которая есть у меня, сюда
68. Мощный 09.12.12 16:00 Сейчас в теме
(66) Bublik2011, Так я и говорю, что исключительно для внутреннего употребления, как правило для обучения.. То есть технологическая..
67. SkyLink2012 253 09.12.12 15:52 Сейчас в теме
(60) Мощный,


Если не лень сбросьте и исходную, и доделанную постараюсь понять почему весь список попадает без учет разделения


Наверное мне кажется, но вижу, что "Устанавливать"-"Свечи". Потому и "весь список попадает без учет разделения".


А что касаемо алгоритма с группами, сброшу сегодня попозже, ну например с опознаванием ячеек на обьединение


Поверьте пожалуйста, создано столько замечательных обработок с различными объектами. Обновлены методы работы с объектами,например, понравилась статья "Загрузка из EXCEL в 1С тремя методами. Часть I. MS ADODB.Connection". Но все равно приходится, черт побери, да, приходится иногда загружать с помощью "Универсальной загрузки справочников". Проще и надежнее. Извините, если ошибаюсь.
66. Bublik2011 9 09.12.12 15:41 Сейчас в теме
(64) Мощный, ну так интересно.. Консоль-же переделали ведь. Очень предпочитаю придерживатьмя тематике группы. Да, бывают моменты - сложно создать группу. Бывают crazy вроде меня, которые усложняю моменты, делают проверку соответсвии в тех местах, где не это не требуется. :) Мне иногда парсить прайсы с сайтов приходится и искать товары по УникальномуИдентификатору. Конечно, ерунда, есть решение проще. В остальном - этот продукт "Загрузка данных" - просто идеален. Загрузка Справочника номенклатуры мз Excel в стандартном виде - незаменимая вещь. Она доступна и решает 80% проблем. Позволяет избежать лишних затрат. Очень рад, что мне тоже нравится эта обработка. Рассматриваю эту универсальную стандартную обработку, идущую в комплекте с 1с как эдакий черновик, после чего можно сформулировать Техническое Задание.
65. Bublik2011 9 09.12.12 15:32 Сейчас в теме
(52) VladimirVladimir, Действительно, сложно наверно. Вероятно обязательно указать ЕденицуИзмерения. А для группы это не предусмотрено.

Наверно создать группу лучше в два этапа
1. Создать группы
2. Назначить каждой группе родителя


Вот пример:
1. Создаете файл: каждая строка - название группы без спец символов вроде кавычек. Допускается тире, цифры, пробел.

Название группы1
Вторая группа
Автозапчасти
Велосипеды
Шины


Создаете обработку (или из аттача берите) с текстом для кнопки "Выполнить"

	
	  файл = Новый ТекстовыйДокумент;
	  адресФайла="C:\ТекстСНовымиГруппами.txt";
	Попытка файл.Прочитать(адресФайла);
	Исключение 
		Предупреждение("файл по данному адресу не найден");	
	КонецПопытки;
Для Сч=1 По файл.КоличествоСтрок() Цикл	
		ОбработкаПрерыванияПользователя();
		Стр = файл.ПолучитьСтроку(Сч);
		Состояние("обработка файла "+Строка(Сч));
	НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу();
	//НоваяГруппа.Код = Строка(ТекстыЯчеек[2]);
	НоваяГруппа.Наименование = СокрЛП(Стр);	
	НоваяГруппа.Записать();
КонецЦикла;

Показать
Прикрепленные файлы:
СозданиеГруппы.epf
64. Мощный 09.12.12 15:26 Сейчас в теме
(62) Bublik2011, извините но реальному усру это .. не торт в общем.. Все должно быть намного проще, т.е. ехелька без предобработки
И по хорошему, представленную вещчть надо бы переделать процентов на 95
63. Мощный 09.12.12 15:21 Сейчас в теме
62. Bublik2011 9 09.12.12 15:03 Сейчас в теме
(59) alex54, Было-бы здорово, если-бы заранее в строку прописать для товара кроме артикула еще и родителя (см фото)



Иначе придется придумать, куда (наверное в "при обработку и загрузке") засунуть переменную "НазваниеКаталогПродукции". На деле это будет так:


-В первой строке есть название. Название АВТОСВЕЧИ установить в переменную НазваниеКаталогПродукции.
-Во второй строке нет названия, есть товар. Для товара установить Родителя с названием из переменной НазваниеКаталогПродукции.
-Во третьей строке нет названия, есть товар. Для товара установить Родителя с названием из переменной НазваниеКаталогПродукции.
-В Строке ХХ ....


Вот один из шаблонов для определения группы товара

Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ 
|	Номенклатура.Наименование,
|	Номенклатура.Ссылка как Результат,
|	Номенклатура.ЭтоГруппа	
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.ЭтоГруппа
|	И Номенклатура.Наименование = &Наименование
|";
Запрос.УстановитьПараметр("Наименование","Прочее");
РезультатЗапрсаВМассиве = Запрос.Выполнить().Выбрать();

Если 		Выборка.Количество()=0  Тогда
		Вопрос("Не найдено ни одного родителя, необходимо создать новый или записывать в отдельную группу ДляРазбросаПоКаталогам. Сейчас прервать загрузку?", РежимДиалогаВопрос.ДаНет)
	  Если Ответ = КодВозвратаДиалога.Да Тогда
            Возврат; //выйти из цикла или процедуры
	  КонецЕсли;
ИначеЕсли Выборка.Количество()>1 Тогда
	Предупреждение("Найдено более двух родителей. Надо с этим что-то предпринять..",60);
КонецЕсли;

Пока РезультатЗапрсаВМассиве.Следующий() Цикл
        	Результат= РезультатЗапроса.Результат 
	//Объект = РезультатЗапроса.ссылка.ПолучитьОбъект();
         //Объект.наименование = что-то с элементом
         //Объект.записать();
  КонецЦикла; 
Показать


Вот еще несколько шаблонов, кроме "Работа с Текстом (Строкой) 1с" при загрузке прайса:

Сообщить(" в текущих данных Код сейчас  "+Строка(ТекущиеДанные["Код"]));
Сообщить(" в текущих данных Владелец сейчас  "+Строка(ТекущиеДанные["Владелец"]));

Сообщить(" в ТекстыЯчеек[1] сейчас  "+Строка(Строка(ТекстыЯчеек[1])));
Сообщить(" в ТекстыЯчеек[2] сейчас  "+Строка(Строка(ТекстыЯчеек[2])));



Понимаете, сейчас только осталось в программный код перевести рассказ "-В первой строке есть названи и т.д. (см выше)" Задача интересная - определить переменную таким образом, чтобы она изменялась или читалась из прайса. Вот вижу еще один маневр:


Если значение из колонки два пустая, следовательно, в колонке 1 - название группы


	   Если СтрДлина(СокрЛП(Строка(Строка(ТекстыЯчеек[2]))))=0 Тогда	   
текстПеременнаяРодительДляСледующихСтрок=Строка(ТекстыЯчеек[1]));
			  //хочется в Результат и наити по наименованию 
			  //засунуть Результат=Строка(ТекстыЯчеек[2])); 
			  //но надо ссылку найти	    ссылПеременнаяРодительДляСледующихСтрок=Справочники.Номенклатура.НайтиПоНаименованию(Строка(ТекстыЯчеек[2]));
		         Если ссылПеременнаяРодительДляСледующихСтрок.ЭтоГруппа Тогда			 
				 	Результат=ссылПеременнаяРодительДляСледующихСтрок; 
			 КонецЕсли; 
	   КонецЕсли; 
Показать


В-общем, надо будет поэксперементировать с вкладками "События-Перед записью объекта" и "События-При записи объекта". Ответ наверно чуть позже.


Если известно, что количество стобцов всегда одинаковое и всегда соответсвует, тогда скину свою обработку. У меня так и есть: "Обработка для поставщика 1", "Обработка для поставщика 2". Только я требую от поставщиков прайсы с кодами или со штрихкодами. Так можно избежать ошибки при количестве товаров в базе более 25000
61. alex54 09.12.12 13:34 Сейчас в теме
60. Мощный 09.12.12 13:30 Сейчас в теме
(59) alex54, к сожалению у меня нет такой обработки с ИТС, а ежли есть, то искать просто некогда.. Обработки пишу сам.. Поэтому не сочтите за труд, ежли такая обработка есть перешлите на досуге подделаю.. tihon1t@mail.ru
А что касаемо алгоритма с группами, сброшу сегодня попозже, ну например с опознаванием ячеек на обьединение
Если не лень сбросьте и исходную, и доделанную постараюсь понять почему весь список попадает без учет разделения
59. alex54 09.12.12 12:18 Сейчас в теме
(54) Мощный, что-то ничего не выходит ((( грузит весь список, хотя разделение есть, что-то я не догоняю (((







58. alex54 09.12.12 11:36 Сейчас в теме
а вот была бы возможность выбрать заданный диапазон в обработке - было бы круто ) загрузил файл и меня начальную и конечную ячейки - загружай что хочешь и куда хочешь
57. alex54 09.12.12 11:34 Сейчас в теме
(55) Мощный, спасибо, кажется малость доходит, но в моем случае все-равно надо дорабатывать эксел, типа раскрасить все в разные цвета или добавить пустые строки... я правильно понимаю?
56. alex54 09.12.12 11:31 Сейчас в теме
мне присылают прайсы, как правило, где номенклатура в алфавитном порядке без разделения
вот я и хочу, обозначив 1 и последнюю строку, выделенную часть загрузить в одну папку, затем выделив другую часть - загрузить в другую



к примеру аккумуляторы в одну папку
амортизаторы в другую ..... и т.д.

приходиться каждый раз лишнее удалять... загружать, а потом опять открывать документ по-новой (((

может я делаю что-то не так? подскажите
55. Мощный 09.12.12 11:23 Сейчас в теме
(52) VladimirVladimir, Если в ехеле будут каким-то образом идентифицироваться группа ( или отступом, или обьединением ячннк или цвнтом, или шрифтом, то проблем как понимаеие нет - все в один проход
54. Мощный 09.12.12 11:19 Сейчас в теме
(53) alex54,
а зачем начальная и конечная? если есть начальная, т.е. строка ехеля каким-то образом выделенная, например наименование группы размещенное по какому-то фиксированному адресу, например, в обьединении ячеек.. Тогда до признака окончаниия строк или следующей такой ячейки реализуется а один проход
53. alex54 09.12.12 09:01 Сейчас в теме
хорошая штука, но мне нужно указать помимо начальной строки - еще и конечную, чтоб загрузить весь прайс, а потом частями загружать в нужные папки
а так приходиться перед этим лопатить эксел предварительно, что тоже не удобно

можно это дело как-то поправить?

заранее огромное спасибо
52. VladimirVladimir 4 20.11.12 17:41 Сейчас в теме
Подскажите как добавить новые группы номенклатуры из файла. Спасибо.
51. Bacemo 06.11.12 16:11 Сейчас в теме
50. azeraus 06.11.12 15:43 Сейчас в теме
(49) Bublik2011, База новая, у контрагентов в списке договоров нет ни одного пункта.Контрагентов загрузил (проставил - юр.лицо, наименование, полное наименование, галочка "Покупатель"). Я бы хотел на вкладке счета и договора создать новый договор контрагента и указать его основным с проставлением следующих реквизитов:
1. Наименование "Основной договор"
2. Вид договора "С покупателем"
3. Ведение взаиморасчетов "По договору в целом", валюта "тенге"
4. Условия договора "Без дополнительных условий"
Как это все можно сделать?
Ваша идея насчет скриншотов или видеоролика очень бы мне помогла.
Заранее спасибо!
49. Bublik2011 9 06.11.12 10:55 Сейчас в теме
(48) azeraus, Если задача создать справочник с договорами контрагентов. Я бы предложил поочередно внести контрагентов с минимально необходимыми реквизитами, а затем список договоров. Мог-бы видеоролик предложить или идею скриншот приаттачить, если перечислите, какие данные-реквизиты интересуют для обновления.
48. azeraus 06.11.12 10:02 Сейчас в теме
Хорошая статья с подробными описаниями, очень помогло, но я бы хотел спросить, КАК МОЖНО АВТОМАТИЧЕСКИ СОЗДАТЬ ДОГОВОРА КОНТРАГЕНТОВ при загрузке в справочник контрагентов. Извините за таков "простой вопрос" просто в 1С пока разбираюсь не очень.
47. Bublik2011 9 13.10.12 12:07 Сейчас в теме
(46) AlexO, предлагаю, чтобы не задваивалось, прерывание ставитьпо признаку. Извините, у меня так пока

        Если Лев(ТаблицаЗначенийМассив[НомерСтроки].КодТовара,3)<>"001"  Тогда
                  Продолжить;
        КонецЕсли;


Но лучше загрузка и синхронизация справочников 1с по ГУИД (Уникальный идентификатор) в качестве подстраховки

1. Найти из УникальныйИдентификатор код элемента
Функция НайтиЭлементПоИД (строкаИД)
				ГУИД=Новый УникальныйИдентификатор(строкаИД);
		Для Каждого МД Из Метаданные.Справочники Цикл
			РезСсылка=Справочники[МД.Имя].ПолучитьСсылку(ГУИД);			
			Если РезСсылка.ПолучитьОбъект()<>Неопределено Тогда
				Возврат РезСсылка.Код;
			КонецЕсли;
		КонецЦикла;	 
КонецФункции
Показать



2.Найти УникальныйИдентификатор по коду

Функция НайтиЭлементПоКоду(строкаКод)
	НоменклатураСсылка = Справочники.Номенклатура.НайтиПоКоду(СокрЛП(строкаКод));
Если НЕ НоменклатураСсылка.Пустая() Тогда
   Сообщить("GUID = " + НоменклатураСсылка.УникальныйИдентификатор());
КонецЕсли; 
КонецФункция



Для обработки загрузка, естественно, вводятся только одна-две , э-э-э-э, отличия . Первое - "ТекстыЯчеек[1]".

а) в поле "представление реквизита" - например "комментарий"
б) режим загрузки - "вычислять"
в) в поле "выражение"
Сообщить("В табличном документе есть данные - 1столбец:"+Строка(ТекстыЯчеек[1])+"  2столбец:"+Строка(ТекстыЯчеек[2])+" 3столбец"+Строка(ТекстыЯчеек[3])); 


И второе отличие ЗагрузкаДанныхИзТабличногоДокумента.epf найти по Уникальному Идентификатору - в выражение вместо "Возврат" пишется "Результат". То есть для ЗагрузкаДанныхИзТабличногоДокумента это будет иметь вид:

//Функция НайтиЭлементПоИД (строкаИД) //это тоже не надо
				ГУИД=Новый УникальныйИдентификатор(строкаИД);
		Для Каждого МД Из Метаданные.Справочники Цикл
			РезСсылка=Справочники[МД.Имя].ПолучитьСсылку(ГУИД);			
			Если РезСсылка.ПолучитьОбъект()<>Неопределено Тогда
//Возврат РезСсылка.Код; // ТУТ уже вставляется все что возможно Код Наименование Комментарий НаименованиеПолное
Результат РезСсылка.Код
			КонецЕсли;
		КонецЦикла;	 
//КонецФункции //и это не надо
Показать


Поиск по уникальному идентификатору занимает долгое время, зато уж гарантированно)) Для парсера или для синхронизации уж точно пригодится. Технология XML c ИдЭлемента - это наверно в другой ветке.
46. AlexO 126 10.10.12 16:07 Сейчас в теме
все бы хорошо, но кроме номенклатуры, типовая грузит все другие справочники крайне плохо - не ищет по строковым полям, задваивает позиции, переносит только после идеального соответствия номера и наименования.
Да и по поводу загрузки "связанных" справочников - тоже вопросы.
Так что все равно нужно писать свои обработки.
и фразы
наш специалист из отдела внедрения, за пару минут предложил такой код:

очень умиляют, спасибо :)
видимо, и остальные специалисты, и в самой 1С в том числе, также пишут весь код "за пару минут".
45. oksevi 10.10.12 15:40 Сейчас в теме
Спасибо за подробное описание.
Осваиваем.
Подскажите, пожалуйста, можно ли и каким образом еще один из параметров в прайс-листе добавить как дополнительный реквизит номенклатуры? Конфигурация 1С:Бухгалтерия 8
44. gravizapa 02.10.12 17:38 Сейчас в теме
(43) да просто с помощью той же самой обработки я делал описание, по сути то же самое,только описание другое
43. SkyLink2012 253 02.10.12 17:11 Сейчас в теме
(40) vitaliyua, А если попробовать так:
1) в первой колонке - название Группы, во второй колонке - родитель (наименование или код?)

2) В настройке: в строке Наименование-
НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу(); 
НоваяГруппа.Наименование = СокрЛП(ТекстыЯчеек[1]); 
НоваяГруппа.Родитель =ТекущиеДанные["Родитель"];


в Настройке Родитель - искать по колонке № 2 искать по Наименованию
42. SkyLink2012 253 02.10.12 17:04 Сейчас в теме
(41) gravizapa, Ваш способ модификации обработки - это очень актуально. Создавайте свою ветку. Не надо рассеивать внимание , Вам очень это необходимо сделать. Ваш способ - он более устойчив и скоростнее , как и загрузка из Excel через ADO )) А в этой ветке уж по старинке, что есть в комплекте с основной конфигурацией.

Зачем создавать лишнее, если есть доступный и бесплатный инструмент?
40. vitaliyua 19.09.12 11:56 Сейчас в теме
А как быть с созданием групп? Например, переносим справочник номенклатуры, в настройках Обработки негде указывать, группа это или элемент. Как быть?
38. SkyLink2012 253 20.06.12 09:53 Сейчас в теме
(37) CaSH_2004, прошу Вас, воспринимайте это как элемент SEO оптимизации. :)
37. CaSH_2004 354 20.06.12 02:31 Сейчас в теме
Замечательная статья, но вот вопрос: зачем в теме сабжа указано
код открыт скачать можно бесплатно

если суть просто в описании?
Какой код и что скачивать?
36. lawko 02.06.12 14:32 Сейчас в теме
Также отплюсовал, т.к. просто поражен был тем, что может выдать эта обработка, которая буквально "валялась" на виду, но и в голову не приходило, что можно добиться таких результатов. Огромнейшее спасибо за статью!
Из ручного труда осталось вбивать лишь значения свойств товара и загрузка изображений.
Еще раз большое спасибо!
35. NE_ZNAIY 28.05.12 17:14 Сейчас в теме
Ещё одно спасибо за труд.
Оставьте свое сообщение