СТАБИЛЬНАЯ Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel (код открыт скачать можно бесплатно)

Публикация № 97415

Разработка - Обмен данными 1С - Загрузка и выгрузка в Excel

212
В таких случаях многие заказывают соответствующие обработки у собственных штатных программистов, фирм-франчайзи или сторонних разработчиков, но это дополнительные расходы и время.

Как быть, если по различным причинам такой возможности нет?

У каждого пользователя профессиональной версии 1С:Предприятие 8 подобная обработка уже есть! На диске ИТС!

Типовая обработка «ЗагрузкаДанныхИзТабличногоДокумента.epf», находиться в разделе «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

Обратите внимание, начиная с Февраля 2010 г. на диске ИТС данная обработка для конфигураций на платформе 8.1 находиться в другом разделе: «Технологическая поддержка» > «Методическая поддержка 1С:Предприятие 8» > «Платформа 1С:Предприятие 8.1» > «Универсальные отчеты и обработки» > «Загрузка данных из табличного документа».

 

Загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в Excel

Имеются исходные данные:

  • Прайс-лист в Excel «ПрайсОнлайнХимСнаб.xls» — Microsoft Office Excel 97-2003 (.xls)
  • Типовая конфигурация Управление торговлей Ред.10.3, релиз 10.3.10.4, платформа 8.2 (8.2.10.77)
  • Необходимо загрузить в 1С из Excel не только наименования товаров и цены как в Примере 1, а также артикулы и штрих-кода, при этом необходимо чтобы номенклатура загружалась не в один каталог (группу), а распределялась по производителям в справочнике номенклатуры 1С.

загрузка 1с +из excel

Для того чтобы из Прайс-листа можно было загрузить справочник номенклатуры в 1С:Управление торговлей 8 с автоматическим распределением по группам (производители) необходимо будет подготовить форму файла для загрузки. Понадобиться добавить колонку с указанием единицы измерения (шт.) и производителя товара, при этом наименование производителя в прайс-листе должно соответствовать наименованию группы в справочнике номенклатуры программы 1С:Управление торговли 8.

1с 8 excel

Используем типовую обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» которая идет на ИТС.

1. Запускаем программу 1С

2. Для запуска обработки выбираем пункт меню «Файл»>«Открыть».

выгрузка в 1с из excel

3. В октрывшемся окне находим файл обработки, который располагается на диске ИТС в каталоге \1CIts\EXE\EXTREPS\UNIREPS82\UploadFromTableDocument

Если предварительно вы скопировали файл обработки на свой компьютер, то можете выбрать его.

ex2_04.jpg

Откроется окно

1с 8.1 excel

Обратите внимание, что загрузка данных будет осуществляться в три этапа:

Этап 1 — загрузка наименований и установка значений реквизитов новых элементов справочников необходимых для начала работы (единица измерения, ставка НДС, признак товар/услуга). 
Этап 2 — загрузка цен. 
Этап 3 — загрузка штрих-кодов

4. Этап 1. Загрузка наименований

Устанавливаем «Режим загрузки» — Загрузка в справочник

«Вид справочника» — Номенклатура

1с 8.2 excel

5. В закладке «Табличный документ» нажимаем кнопку image011.jpg«Открыть файл», в появившемся окне выбора находим каталог, в котором у нас находиться прайс-лист в Excel из которого мы планируем загружать данные в 1С.

загрузка из excel 1с 8

Первоначально файл может не отобразиться. Установите Тип файла «Лист Excel (*.xls)»

импорт из excel в 1с

Выбираем наш файл

номенклатура из excel в 1с

Файл успешно прочитался

7. Далее выбираем закладку «Настройка»

1с загрузка из excel

Отражаются реквизиты карточки номенклатуры.

загрузка справочников 1с из excel

8. Настраиваем параметры загрузки наименований

Для удобства установим «Ручную нумерацию колонок»

На данном этапе загружаем только те реквизиты, которые позволят начать работать с программой, поэтому снимаем галочки с полей, которые нас пока не интересуют

«Первая строка данных табличного документа» — смотрим наш прайс-лист, отбрасываем шапку, данные для загрузки начитаются с девятой строки — ставим «9» (см.Рис. 2 «Прайс-лист»)

«Не создавать новых элементов» — галочку НЕ ставим, опция нужна, если планируем только изменять уже имеющиеся элементы.

ex2_12.jpg

Строки «Наименование» и «Полное наименование» — устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе наименование в третьей колонке — ставим «3»

Строка «Родитель» — в колонке «Режим загрузки» выбираем «Искать», в колонке «№ Колонки табличного документа» — в нашем прайс-листе производители в четвертой колонке — ставим «4».

Если необходимости распределения по производителям нет и загрузить все новые элементы требуется в одну папку, тогда в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем группу номенклатуры, в которую будем загружать данные из прайс-листа.

Строка «Артикул» — ставим галку в колонке «Поле поиска» (вторая колонка) — программа проверит наличие в базе данных 1С элемента с таким артикулом, и если таковой уже существует, то новый элемент с таким наименованием создаваться не будет. Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе артикул во второй колонке — ставим «2»

Строка «Базовая единица измерения» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем единицу измерения (в нашем случае — шт.)

Строка «Весовой» — в нашем случае товар НЕ весовой, поэтому «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Нет»

Строка «Ставка НДС» — в нашем случае для всех загружаемых элементов устанавливаем НДС 18%, для этого в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «18%».

1с 8.2 загрузка из excel

Если товары идут с разным НДС, который указывается в отдельной колонке загружаемого прайс-листа, то в колонке «Режим загрузки» установите «Искать» и номер соответствующей колонки прайс-листа в «№ Колонки табличного документа».

Строка «Услуга» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Нет» (в нашем случае все позиции это товары).

Строка «Вид номенклатуры» — в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Товар».

Мы задали минимальные значения новых элементов справочника номенклатуры, которые позволят начать работать.

Если вы готовы задать значения недостающих реквизитов сейчас, то укажите и их.

Нажимаем «Загрузить» в правом нижнем углу, на вопрос нажимаем «Да»

перенос в 1с из excel

как загрузить в 1с excel

Если загрузка пройдет нормально, то по результатам будет выдано сообщение об успешной загрузке.

8. Проверяем наличие новых элементов в соответствующих группах справочника номенклатуры.

ex2_16.jpg

ex2_17.jpg

На настоящий момент мы загрузили из прайс-листа в Excel наименования товаров в справочник номенклатуры 1С.

ex2_18.jpg

Как видите, реквизиты «Единица для отчетов» и «Единица хранения остатков» остались не заполненными.

Следующим шагом необходимо установить данные реквизиты, т.к. они потребуются при загрузке цен, штрих-кодов и дальнейшей работе.

Возможны два варианта:

Ручной.

Данные реквизиты создаются программой автоматически, при первом открытии и сохранении карточки номенклатуры. Если допустима ручная установка, то можно этот шаг пропустить и перейти сразу к этапу загрузки цен. Если не планируется загрузка штрих-кодов, то вполне допустимо даже оставить как есть — при первом использовании элемента номенклатуры необходимо будет отрыть и сохранить карточку товара.

Недостаток: ручная процедура открытия и записи может быть довольно трудоёмкой и занять довольно много времени при большом количестве элементов справочника.

Автоматический.

Возможна и автоматическая загрузка единиц измерения, но она рассчитана для продвинутых пользователей и потребует базовых навыков в программировании 1С.

Возможны два варианта: с идентификацией по артикулу или наименованию.

Идентификация по Артикулу более предпочтительна, но в прайс-листе колонки с артикулами может и не быть.

Вариант 1. Идентификация по Артикулу

ex2_19.jpg

Ставим «галку» в поле «Не создавать новых элементов» и снимаем «галки» со всех строк.

Строка «Артикул» — ставим галку в колонке «Поле поиска» (вторая колонка). Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе артикул во второй колонке — ставим «2»

В строках «Единица для отчетов» и «Единица хранения остатков» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, наш специалист из отдела внедрения, за пару минут предложил такой код:

ex2_20.jpg

 СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", ТекущиеДанные["Артикул"]); БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796); ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификаторуquot;,БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры); Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; НайденнаяЕдиницаОбъект.Коэффициент = 1; НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; Попытка НайденнаяЕдиницаОбъект.Записать(); Результат = НайденнаяЕдиницаОбъект.Ссылка; Исключение Сообщить("Не удалось записать"); КонецПопытки; Иначе Результат =ТекСпр.Ссылка; КонецЕсли; 
//© Компания "Онлайн" 2010, www.online-ufa.ru

Если планируется многократное повторение данной процедуры, то в алгоритм необходимо дополнительно добавить процедуру проверки, чтобы исключить повторный ввод единиц измерения с тем же наименованием.

Вариант 2. В случае идентификации по Наименованию

ex2_21.jpg

Ставим «галочку» в поле «Не создавать новых элементов»

Снимаем «галки» со всех строк

Строка «Наименование» — ставим галку в колонке «Поле поиска» (вторая колонка). Устанавливаем Режим загрузки «Искать», «№ Колонки табличного документа» — в нашем прайс-листе наименования в третьей колонке — ставим «3»

В строках «Единица для отчетов» и «Единица хранения остатков» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С, например такой:

ex2_22.jpg

 
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Наименование"]);
БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("
ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения);
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения;
НайденнаяЕдиницаОбъект.Коэффициент = 1;
НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры;
Попытка НайденнаяЕдиницаОбъект.Записать();
Результат = НайденнаяЕдиницаОбъект.Ссылка;
Исключение Сообщить("Не удалось записать");
КонецПопытки;
Иначе Результат =ТекСпр.Ссылка;
КонецЕсли;



//© Компания "Онлайн" 2010, www.online-ufa.ru

9. Открываем карточку товара, проверяем правильность загрузки реквизитов

ex2_23.jpg

Если всё правильно, то можно приступить ко второму этапу — загрузке цен из прайс-листа в Excel.

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка наименований товаров из прайс-листа Excel».

ex2_24.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопку image046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_25.jpg

10. Этап 2. Загрузка цен

В «Управление торговлей» Ред.10.3 установка цен производится с помощью документа «Установка цен номенклатуры».

Используем ту же обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» с диска ИТС.

ex2_26.jpg

11. Устанавливаем «Режим загрузки» — «Загрузка в табличную часть».

ex2_27.jpg

12. В поле «Ссылка» выбираем «Установка цен номенклатуры».

ex2_28.jpg

После этого в том же самом поле «Ссылка» снова нажимаем на кнопку выбора

Открывается журнал документов «Установка цен номенклатуры».

Здесь можно выбрать уже существующий документ, в который мы хотим добавить новые элементы, или создать Новый (рекомендуется), в документе указываем какой «Тип цен» будем загружать (в нашем примере «Розничная»).

ex2_29.jpg

Нажимаем «Ок» и сохраняем пока пустой документ.

Теперь выбираем этот новый сохранённый документ из журнала в строке «Ссылка».

В поле «Табличная часть» выбираем «Товары».

ex2_30.jpg

13. Обратите внимание, что сейчас нужно перейти закладку «Табличный документ» и снова выбрать наш прайс-лист в Excel из которого мы загрузили наименования, а теперь будем загружать цены (см. пункт 5).

14. Настраиваем параметры загрузки

Опять устанавливаем «Первая строка данных табличного документа» — как и при загрузке наименований, ставим «9» и «Ручную нумерацию колонок».

В строке «Номенклатура» устанавливаем режим загрузки «Искать», «№ Колонки табличного документа» — в нашем примере ставим «3». Если необходима идентификация по артикулу, то в колонке "Искать по" выбираем "Артикул", а в «№ Колонки табличного документа» ставим номер колонки с артикулами - в нашем примере "2".

В строке «Цена» устанавливаем режим загрузки «Искать», «№ Колонки табличного документа» — ставим номер колонки с ценами, которые хотим загрузить, сначала будем загружать розничную цену, значит, ставим «5».

ex2_31.jpg

В строке «Валюта» устанавливаем Режим загрузки «Устанавливать», выбираем валюту (в примере «руб.»)

В строке «Единица измерения» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, такой код: 

ex2_31_1.jpg

 СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Номенклатура"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков; 

В строке «Тип цен» устанавливаем Режим загрузки «Устанавливать», выбираем цену, которую будем загружать «Розничная».

ex2_32.jpg

Если в вашем прайс-листе цены товаров приведены в разных валютах, которая указывается в отдельной колонке загружаемого прайс-листа, то в колонке «Режим загрузки» установите «Искать» и номер соответствующей колонки прайс-листа в «№ Колонки табличного документа».

В строке «Способ расчета цены» устанавливаем Режим загрузки «Устанавливать», выбираем «По процентной наценке на базовый тип»

ex2_33.jpg

Нажимаем «Загрузить» и отвечаем «Да»

ex2_34.jpg

Если загрузка пройдет нормально, то по результатам будет выдано сообщение об успешной загрузке.

15. Открываем документ «Установка цен номенклатуры», в который загружали данные (нажав кнопочку с изображением лупы image065.jpg в строке «Ссылка»)

ex2_35.jpg

16. Проверяем документ, если всё в порядке нажимаем «Ок».

Цены должны установиться.

17. Открываем справочник номенклатуры, проверяем закладку «Цены» в карточке загруженных элементов, нажимаем кнопку «Перечитать текущие цены».

ex2_36.jpg

Если всё в порядке, то можно приступать к загрузке остальных цен (оптовые, закупочные и т.д.). Процедура аналогична.

Обратите внимание, что 1С:Управление торговлей 8 поддерживает расчет одних цен на основании других. Поэтому загружать, возможно, будет достаточно только одну базовую цену, например Розничную или наоборот Закупочную, а для других цен указать алгоритмы формирования (скидка %, наценка %, округление до знака и т.д.).

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка Розничных Цен из прайс-листа Excel».

ex2_37.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопкуimage046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_38.jpg

18. Этап 3. Загрузка штрих-кодов

Используем всё ту же обработку «ЗагрузкаДанныхИзТабличногоДокумента.epf» с диска ИТС.

ex2_39.jpg

19. Устанавливаем «Режим загрузки» — «Загрузка в регистр сведений». 
"Вид регистра" выбираем "Штрихкоды".

ex2_40.jpg

20. Обратите внимание, что сейчас нужно перейти закладку «Табличный документ» и снова выбрать наш прайс-лист в Excel из которого мы загрузили наименования и цены, а теперь будем загружать штрихкоды (см. пункт 5).

21. Настраиваем параметры загрузки

Опять устанавливаем параметр «Первая строка данных табличного документа» - ставим «9» и «Ручную нумерацию колонок».

ex2_41.jpg

Настраиваем параметры загрузки

Удаляем «галки» со всех строк, с которых возможно.

В оставшихся строках устанавливаем параметры

В строке «Штрихкод» устанавливаем Режим загрузки «Искать», в колонке «№ Колонки табличного документа» пишем как в нашем прайс-листе «9».

ex2_42.jpg

В строке «Владелец» в колонке «Описание типов» открываем окно «Редактирование типа данных» устанавливаем (оставляем) галку только в поле «Номенклатура». Режим загрузки устанавливаем «Искать». Для идентификации по Артикулу, в колонке «№ Колонки табличного документа» пишем номер колонки, в которой в нашем прайс-листе указаны артикулы — т.е. «2». В колонке «Искать по», устанавливаем «Артикул».

ex2_43.jpg

В случае, если в прайс-листе нет колонки с артикулами, то в колонке «Искать по» необходимо выбрать «Наименование», а в ячейке «№ Колонки табличного документа» указать номер колонки прайс-листа с наименованиями.

В строке «Тип штрихкода» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «EAN13».

В строке «Единица измерения» в поле «Режим загрузки» выбираем «Вычислять». В поле «Выражение» пишем алгоритм на встроенном языке программирования 1С. Например, такой код:

ex2_43_1.jpg

 CсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков; 

ex2_44.jpg

В строке «Качество» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» выбираем «Новый».

В строках «Характеристика номенклатуры», «Серия номенклатуры», «Удалить код» в колонке «Режим загрузки» выбираем «Устанавливать», в колонке «Значение по умолчанию» оставляем пустые ячейки.

Нажимаем «Загрузить»

Открываем карточку товара, проверяем наличие штрих-кода.

ex2_45.jpg

Если в будущем планируется использовать данную процедуру загрузки данных с такими же настройками параметров загрузки, то рекомендуем сохранить текущие настройки. Для этого нажмите кнопочку image043.png «Сохранить настройки» и понятно назовите текущую настройку, например, «Загрузка штрих-кодов товаров из прайс-листа Excel».

ex2_46.jpg

В следующий раз сможете загрузить сохраненные настройки, нажав на кнопкуimage046.jpg «Восстановить настройки» и выбрав нужную из списка.

ex2_47.jpg

 

212

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Рейтинг
16. Bublik2011 9 28.12.11 18:37 Сейчас в теме
SkyLink2k Предлагаю включить в описание загрузку изображений и картинок в 1с 8 УТ из Excel. Загрузка идет в Хранилище информации. Если поменять переменную - загрузка картинок пойдет в отдельный файл.

В аттаче - файл настроек для той-же обработки в Номенклатуру. Во вкладке "настройка"-"восстановить настройки из файла.."- открыть этот файл из аттача. В "События"-"При записи" должна быть такая функция:

Если Объект.БазоваяЕдиницаИзмерения.Пустая()=Ложь Тогда
	
	ЗапросЕдИзм = Новый Запрос();
	ЗапросЕдИзм.Текст = ""
	|ВЫБРАТЬ
	|	ЕдиницыИзмерения.Ссылка
	|ИЗ
	|	Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
	|ГДЕ
	|	ЕдиницыИзмерения.Владелец = &Владелец
	|	И ЕдиницыИзмерения.ЕдиницаПоКлассификатору = &ЕдиницаПоКлассификатору"";
	
	ЗапросЕдИзм.УстановитьПараметр(""Владелец"", Объект.Ссылка);
	ЗапросЕдИзм.УстановитьПараметр(""ЕдиницаПоКлассификатору"",Объект.БазоваяЕдиницаИзмерения.Ссылка);
	
	Выборка = ЗапросЕдИзм.Выполнить().Выбрать();
	Если Выборка.Количество() <= 0 Тогда
		
		Ед = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
		Ед.ЕдиницаПоКлассификатору = Объект.БазоваяЕдиницаИзмерения.Ссылка;
		Ед.Вес = 1;
		Ед.Владелец = Объект.Ссылка;
		Ед.Коэффициент = 1;
		Ед.Наименование = Объект.БазоваяЕдиницаИзмерения.Наименование;
		Ед.Записать();
		Объект.ЕдиницаДляОтчетов = Ед.Ссылка;
		Объект.ЕдиницаХраненияОстатков = Ед.Ссылка;
	КонецЕсли;
КонецЕсли;

НомерСтолбцаИзображение = 8;
НомерСтолбцаОписаниеИзображение = 3; 


ЗапросСуществующих = Новый Запрос();
ЗапросСуществующих.Текст = ""
|ВЫБРАТЬ
|	ХранилищеДополнительнойИнформации.Ссылка
|ИЗ
|	Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДополнительнойИнформации
|ГДЕ
|	ХранилищеДополнительнойИнформации.Объект = &Объект
|	И ХранилищеДополнительнойИнформации.Наименование = &Наименование"";

Объект.Записать();

ФайлКартинки = Новый Файл(СокрЛП(ТекстыЯчеек[НомерСтолбцаИзображение]));
 //Предупреждение(ФайлКартинки.Существует());
Если ФайлКартинки.Существует() Тогда
	//Предупреждение(""!"");
	ЗапросСуществующих.УстановитьПараметр(""Объект"", Объект.Ссылка);
	ЗапросСуществующих.УстановитьПараметр(""Наименование"", СокрЛП(ТекстыЯчеек[НомерСтолбцаОписаниеИзображение]));
	Выборка = ЗапросСуществующих.Выполнить().Выбрать();
	Если Выборка.Количество() <= 0 Тогда
	//	Предупреждение(""!!"");
		ХранилищеОбъект = Справочники.ХранилищеДополнительнойИнформации.СоздатьЭлемент();
		ХранилищеОбъект.ВидДанных = Перечисления.ВидыДополнительнойИнформацииОбъектов.Изображение;
		ХранилищеОбъект.Хранилище = Новый ХранилищеЗначения(Новый Картинка(ТекстыЯчеек[НомерСтолбцаИзображение]),Новый СжатиеДанных);
		ХранилищеОбъект.Объект = Объект.Ссылка;
		ХранилищеОбъект.Наименование = СокрЛП(ТекстыЯчеек[НомерСтолбцаОписаниеИзображение]);
		ХранилищеОбъект.ИмяФайла = ТекстыЯчеек[НомерСтолбцаИзображение];
		ХранилищеОбъект.Записать();
		Объект.ОсновноеИзображение=ХранилищеОбъект.Ссылка;
	КонецЕсли;
КонецЕсли;

Показать
Прикрепленные файлы:
load_image.mxlz
isheninp; decide; МимохожийОднако; +3 Ответить 1
10. Модератор раздела Alraune 13.12.11 10:19 Сейчас в теме
(8) Так добавьте, не надо бояться )))
11. Pawlick 14.12.11 15:22 Сейчас в теме
5 лет иметь под рукой ТАКОЙ функционел и не использоватьего!?

Ребятам из компании 1С - МИНУС за отсутствие рекомендаций по использованию;

Ребятам из Компании "Онлайн" - БРАВО!
sergio199; Bublik2011; +2 Ответить
89. fgremlin 03.04.13 11:57 Сейчас в теме
(87) fgremlin,
Продолжаем разговор:
гружу упаковки (которые состоят из конечных упаковок)
Скрин настроек во вложении.
Комментарии и код:
1. Как и в прошлой загрузке Владелец ищется по наименованию номенклатуры из колонки таблицы.
2. Родитель (конечная упаковка из которой состоит текущая) ищется и заполняется кодом:

//Ищем конечную единицу для номенклатуры:
Штука = Справочники.ЕдиницыИзмерения.НайтиПоКоду(796);
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные.Владелец.Код);
Если Не(СсылкаНоменклатуры.Пустая()) Тогда
	КонУпаковка = Справочники.УпаковкиНоменклатуры.НайтиПоРеквизиту("ЕдиницаИзмерения",Штука,,СсылкаНоменклатуры);
	Если КонУпаковка.Пустая() Тогда 
		Сообщить("Нет конечной упаковки!!!");	
	КонецЕсли;
Иначе
    Сообщить("Не найдена номенклатура");	
КонецЕсли;

Сообщить(""+КонУпаковка.Ссылка.Наименование);
Результат = КонУпаковка.Ссылка;
Показать


3. Ставим флаг "Состоит из других упаковок"
4. "Единица измерения" из классификатора ставлю вручную, но ничего не мешает поискать по коду или наименованию в классификаторе...
5. Количество в упаковке берем из колонки таблицы.
6. Коэффициент пересчитываем из текущих данных таким кодом:

//Пересчитываем коэффициенты на основании конечной единицы
КонечныйКоэффициент = ТекущиеДанные.Родитель.Коэффициент;
КоличествоУпаковок = ТекущиеДанные.КоличествоУпаковок;
Результат = КонечныйКоэффициент*КоличествоУпаковок;


7. Ну и, конечно же наименование, которое формируется из текущих данных по штатным алгоритмам таким кодом и вроде даже проверяется на уникальность не позволяя задвоить упаковку:


Результат = СокрЛП(СокрЛП(ТекущиеДанные.ЕдиницаИзмерения) + " (" + Формат(ТекущиеДанные.Коэффициент,"ЧРД=.") + " " + СокрЛП(ТекущиеДанные.Родитель.ЕдиницаИзмерения) + ")");


Ну, вот как-то так.
В общем и целом данной обработкой можно делать много чего.
Надеюсь кому нибудь это пригодится.
При загрузке использовались исключительно материалы данной статьи и ветки форума, за что авторам огромное спасибо.
Прикрепленные файлы:
SkyLink2012; Bublik2011; +2 Ответить
107. Bublik2011 9 07.06.14 12:35 Сейчас в теме
(105) SerGan757, Вот хороший инструмент для работы с паттернами, в аттаче.
Прикрепленные файлы:
RegExp.exe
darkvampire1991; SerGan757; +2 Ответить
124. xavikz 25.08.15 11:23 Сейчас в теме
Подскажите пожалуйста, есть база в управлении торговлей 1 8.2 (Штрих-М).
В номенклатуре есть много свойств, и на половине товаров вбиты значения этих свойств, в другой нет.
Как то можно из ексель импортировать значения свойств объектов для номенклатуры?
Наименований очень много, десятки тысяч
aRaBest; darkvampire1991; +2 Ответить
13. RakovskiyK 19.12.11 16:41 Сейчас в теме
тааак. беру на тест очередную обработку. :)
Bublik2011; +1 Ответить
49. Bublik2011 9 06.11.12 10:55 Сейчас в теме
(48) azeraus, Если задача создать справочник с договорами контрагентов. Я бы предложил поочередно внести контрагентов с минимально необходимыми реквизитами, а затем список договоров. Мог-бы видеоролик предложить или идею скриншот приаттачить, если перечислите, какие данные-реквизиты интересуют для обновления.
101. Bublik2011 9 25.04.14 01:46 Сейчас в теме
(98) Kutnor, это сообщение изменю, пока сделайте бэкап базы.

Думаю, подход к делу надо изменить. В настройках.
1) Качество - устанавливать
2) Единицы измерения - вычислять
103. Kutnor 02.06.14 16:39 Сейчас в теме
весьма странно: поставил свой текст и все заработало, он под номер 1, для сравнения с тем что раньше было ставлю текст который был раньше под номером 2
1)СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
2)CсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоНаименованию(ТекущиеДанные["Владелец"]); Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;

тесты идентичны, с номером 1 работает, а с номером 2 нет.
darkvampire1991; +1 Ответить 2
104. Bublik2011 9 02.06.14 19:04 Сейчас в теме
(103) Kutnor, честно сказать? Часто сомневаюсь и жму кнопку "проверить заполнение данных" перед "выполнить".
А иногда до ступора доходит и во внешней обработке проверяю орфографию, начав текст примерно так
ТекстыЯчеек= Новый Массив; 	
СсылкаН=Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ТекстыЯчеек[1]));


загружаю шрих-коды то вылазит вот такая ошибка

Да, ошибки будут постоянно. 1С - это тоже ошибка. Исправление старых багов и создание новых )) Но мне для ведения учета вполне, тьфу-тьфу, хватает. АВС и XYZ анализ проводить, например.
Весьма интересно все-таки знать продукт. Например зачастую очень удобно большие данные обрабатывать не внешней обработкой, а применять встроенные отчеты и обработки. Правда, пока не могу "вырасти" до покупки ИТС и подключаемых платных модулей, кроме типовых. Все-таки не внешней обработкой , а этой вот ЗагрузкаДанныхИзТабличногоДокумента.epf, речь о которой идет в этой статье. Мда-а-а, я философ? Нет, так, пару строк написал, чтобы поисковый идекс статья попала и упоминание про УниверсальныеПодборИОбработкаОбъектов.epf
Простите, Kutnor, увлекся... :) Если ближе к делу, стал подгружать ШК из внешнего файлика. Почему? Для загрузки 23000 штрихкодов - это удобнее, чем копипастить в таблицу. Вот пример для УниверсальныеПодборИОбработкаОбъектов.epf
Вот файлик c:\bcode.txt
1709009-4;4620769209832;				
1709009-5;4620769209917;				
1709009-6;4620769209849;

В обработка\настройка - произвольный алгоритм Универсальной Подбора И Обработки Объектов вставил код
	Текст = "";
Запр = Новый Запрос("
 | ВЫБРАТЬ
 | 	Штрихкоды.Штрихкод как Код,
 | 	Штрихкоды.Владелец.Ссылка
 | ИЗ
 | 	РегистрСведений.Штрихкоды КАК Штрихкоды
 | ГДЕ
 | 	Штрихкоды.Владелец.Ссылка = &Товар ");

Запр.УстановитьПараметр("Товар", Объект.Ссылка);
ВыбМ = Запр.Выполнить().Выбрать();
ВыбТ = Запр.Выполнить().Выгрузить();
Индекс = ВыбТ.Количество(); 

Если Индекс=0  Тогда

НазваниеФайла="c:\bcode.txt";
Текст = Новый ЧтениеТекста(НазваниеФайла, КодировкаТекста.ANSI);
Стр=""; Найдено=1; ШКСуществует=1;
СписокНоменклатуры = Новый СписокЗначений;
	Пока Стр<>Неопределено Цикл
	 	Стр = Текст.ПрочитатьСтроку();
			Строк=СокрЛП(Стр);
			Разделитель=Найти(Строк,";");
		Если СтрДлина(Строк)>3 Тогда  
			КонецПервого=Разделитель;
			Первое=СтрЗаменить(Сред(Строк,1,КонецПервого),";","");
			Второе=СтрЗаменить(Сред(Строк,КонецПервого,СтрДлина(Строк)),";","");
						
			Если СокрЛП(Объект.Артикул)=Первое Тогда				
				Если ЗначениеЗаполнено(Второе) Тогда
						Для Каждого ЭлементМассива Из ВыбТ Цикл ШКСуществует=0; 						
							Если СокрЛП(ЭлементМассива[0]) = СокрЛП(Второе) Тогда 
								Сообщить("Для арт.:"+СокрЛП(Объект.Артикул)+" уже существует ШК, предлагаемый для арт:"+СокрЛП(Первое)); ШКСуществует=1;Прервать;
							КонецЕсли; 
						КонецЦикла; 
						Если НЕ ШКСуществует=1 Тогда
                               БуфернаяСтрока=СокрЛП(Второе);
							     Сообщить(Второе);									 
									Если ОбщегоНазначения.ТолькоЦифрыВСтроке(БуфернаяСтрока) Тогда
									Номенкл = Объект.Ссылка;
								Запись                             = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
								Запись.Штрихкод                       = СокрЛП(БуфернаяСтрока);
								Запись.Владелец                       = Номенкл;
								Запись.ТипШтрихкода                 = ПланыВидовХарактеристик.ТипыШтрихкодов.EAN13;
								Запись.ЕдиницаИзмерения                 = Номенкл.ЕдиницаХраненияОстатков;
								Запись.Качество                       = Справочники.Качество.НайтиПоНаименованию("Новый");
								Попытка	Запись.Записать(Истина); Исключение	Сообщить("Не удалось записать ШК: "+СокрЛП(БуфернаяСтрока)+" для элемента: "+Строка(Номенкл)+" "+СокрЛП(Номенкл.Код)+" ||| "+ ОписаниеОшибки());	КонецПопытки;	
										ИначеЕсли НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(БуфернаяСтрока) Тогда	Сообщить("В буфере обмена нет данных формата EAN "+БуфернаяСтрока);	КонецЕсли;
						Иначе		
							 Сообщить("-");	
						КонецЕсли;
						
					Найдено=1;Прервать;
				КонецЕсли;
				
			Иначе
				Найдено=0;
			КонецЕсли;
		КонецЕсли;
	
			
			
	КонецЦикла; 
Если НЕ Найдено=1 Тогда Сообщить("Для "+""+СокрЛП(Объект.Код)+" , арт.:"+СокрЛП(Объект.Артикул)+" не найдено .") ; КонецЕсли;
Текст.Закрыть();
	
КонецЕсли;

Показать


... и ... ЗАРАБОТАЛО !!! :)))
darkvampire1991; +1 Ответить
105. SerGan757 07.06.14 01:13 Сейчас в теме
уперся...загружаю такую накладную (см файл) с одинаковыми артикулами!, только в наименовании Товара отличается размером (последние цифры без скобки), в базе у меня есть такой товар тоже артикулы одинаковые, только в Наименовании в конце размер стоит, Нахожу нужный артикул и он ставит самый первый из базы,
а как перебрать и поставить с нужным размером ?
Родитель = Справочники.Номенклатура.НайтиПоНаименованию("ТМ БУМ",Истина);
Результат = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул", ТекстЯчейки, Родитель);
????
Прикрепленные файлы:
darkvampire1991; +1 Ответить 2
106. Bublik2011 9 07.06.14 12:18 Сейчас в теме
(105) SerGan757,

Лучше-бы я не давал совет. Совет: Есть смысл перестроить справочник.

Плохой совет: ввести в Справочник.Номенклатура реквизит Размер (строка,фиксированная,10,индексировать)
         +поиск по реквизиту облегчается
         +очевидный списочный отбор
         -эволюция трудна, при превышении 1000 ценников уже придется модифицировать структуру    

Совет получше: ввести в Справочник.Номенклатура реквизит Размер (создать Справочник.Размеры)
         +преимущество подбора размерного ряда

Идеальный вариант: 1.каждый товар вести учет характеристики
                   2. на каждый штрихкод установить характеристику и размер 
         +будет возможность легко обрабатывать большие объемы, больше 25000 ценников
         +если есть сайт, обратил внимание, выбор по размеру и цвету? Думаю, идеальный вариант лучше
  
Показать


Ответ на вопрос
а как перебрать и поставить с нужным размером ?


Предпочел-бы цифру из строки выбрать с помощью Regexp и построить выбор не по НайтиПоРеквизиту, а запросом. Вот в аттаче РаботаСЗапросами.epf

Вот примерно так,

    стр="Строка с наименование р.599";
	СтрокаАртикул="Артикул-Какой-то"
	
	
    RegExp.IgnoreCase = Истина; //Игнорировать регистр
    RegExp.Global = Истина; //Поиск всех вхождений шаблона
    RegExp.MultiLine = Истина; //Многострочный режим
    RegExp.Pattern = "([^0-9]*)([0-9]+)([^0-9]*)"; 
    стр=RegExp.Replace(стр, "$2"); 
	
	Если (RegExp.Test(стр)) Тогда
		СтрокаЦифраРазмера=Стр;
	Иначе
		СтрокаЦифраРазмера="";
    КонецЕсли;

   Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ
|	Номенклатура.Ссылка,
|	Номенклатура.Наименование
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.Артикул = &Артикул
|	И Номенклатура.Наименование ПОДОБНО ""%"" + &ЦифраРазмера + ""%""
|";
Запрос.УстановитьПараметр("Артикул",СтрокаАртикул);
Запрос.УстановитьПараметр("ЦифраРазмера",СтрокаЦифраРазмера);
РезультатЗ = Запрос.Выполнить();
Результат = РезультатЗ.Выгрузить();
Для каждого СтрокаТЗ из РезультатЗ Цикл
КонецЦикла;
РезультатЗапроса = Запрос.Выполнить();
  Если НЕ РезультатЗапроса.Пустой() Тогда
        СтрокаРезультата = РезультатЗапроса.Выгрузить()[0];
		Результат=СтрокаРезультата.Ссылка;
  КонецЕсли;
Показать


возможно ошибки типов, не проверял.
Прикрепленные файлы:
РаботаСЗапросами.epf
SerGan757; +1 Ответить
108. SerGan757 07.06.14 20:17 Сейчас в теме
Bublik2011 - спасибо огромное :)
darkvampire1991; +1 Ответить
111. Kutnor 12.08.14 11:05 Сейчас в теме
когда загружаю характеристики поле связь по владельцу в настройках почему то недоступно.
darkvampire1991; +1 Ответить
112. Deroswent 26.01.15 18:14 Сейчас в теме
Очень уж глючная эта обработка. Точнее не глючная а "унифицирована"... у меня например вылетает с ошибкой
Ошибка при вызове метода контекста (Записать): Ошибка при выполнении обработчика - 'ПередЗаписью': {Справочник.Номенклатура.МодульОбъекта(46)}: Ошибка при вызове метода контекста (ПроверитьДопустимостьИзмененияРеквизитовСправочника): Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода ПроверитьДопустимостьИзмененияРеквизитовСправочника ().

И как бы я не боролся с ней - все бесполезно. Свежие идеи есть?
darkvampire1991; +1 Ответить 1
113. SkyLink2012 251 01.02.15 18:56 Сейчас в теме
(112) Deroswent, утверждаю обратное :) Обработка не совсем глючная.

Постоянно загружается по 10 накладных в день.

Ставьте проверку и обработку ошибок. Поможет в Вашем случае? Что особенного?

КолонкаШтрихкоды=3; //если пусто -1
КолонкаРисунок=-4   ; //если пусто - ставим отрицательно

Если КолонкаШтрихкоды>0 И ЗначениеЗаполнено(СокрЛП(ТекстыЯчеек[КолонкаШтрихкоды])) Тогда
	Если НЕ ОбщегоНазначения.ТолькоЦифрыВСтроке(ТекстыЯчеек[КолонкаШтрихкоды]) Тогда
		
		//Запись= РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
		
		Попытка
			Объект.Записать(Истина);
		Исключение
			Сообщить(ОписаниеОшибки());
		КонецПопытки;			
		
		
		
	КонецЕсли;		
КонецЕсли;

Показать


Эта обработка прекрасна и очаровательна на файловой БД.

Вас не затруднит напомнит про ПроверитьДопустимостьИзмененияРеквизитовСправочника () ? Это кажется, из "Управление Торговлей для Украины 3" ? Не видел эту функцию. Есть идея, выполнить проверку допустимости запросом, например. Это уже не топик, простите, как и прочие "костыли".
Соглашусь, "задваивает" элементы. Чтобы не допустить "задваивания", приходится ставить отметку поле поиска - "код", например. В тяжелых случаях - "вычислять"

	Запрос=новый Запрос; Запрос.Текст="
	|  ВЫБРАТЬ Номенклатура.Ссылка ИЗ Справочник.Номенклатура КАК Номенклатура ГДЕ
	|	Номенклатура.Артикул = &Артикул  
	|	И Номенклатура.Поставщик ПОДОБНО &Поставщик
	|";
	Запрос.УстановитьПараметр("Артикул",СтрКодАртикул);
    Запрос.УстановитьПараметр("Поставщик",СтрКодПоставщик);
    РезультатЗапроса = Запрос.Выполнить();
		Если НЕ РезультатЗапроса.Пустой() Тогда
		   Результат = РезультатЗапроса.Выгрузить()[0].Ссылка;
		КонецЕсли;
Показать
darkvampire1991; +1 Ответить 1
115. WWWolfy 100 05.02.15 21:48 Сейчас в теме
ЗагрузкаДанныхИзТабличногоДокумента.epf / Единица для хранения остатков / Родитель

1. Легко можно загрузить сразу в первом проходе все Единицы измерения ( Единица для хранения остатков + Единица для отчетов )
Допустим "Базовую единицу" вы прописали откуда брать, тогда добавьте такой код в События (в настройках над таблицей) в заладку "При записи"

текБазоваяЕдиницаИзмерения = Объект.БазоваяЕдиницаИзмерения;
текСсылка = Объект.Ссылка;

Если НЕ ЗначениеЗаполнено(Объект.ЕдиницаХраненияОстатков) Тогда
	ВыборкаЕдиниц = Справочники.ЕдиницыИзмерения.Выбрать(, текСсылка);
	Если ВыборкаЕдиниц.Следующий() Тогда
		НайденнаяЕдиница = ВыборкаЕдиниц.Ссылка;
	Иначе
		НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент();
		НайденнаяЕдиницаОбъект.Наименование            = СокрЛП(текБазоваяЕдиницаИзмерения);
		НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = текБазоваяЕдиницаИзмерения;
		НайденнаяЕдиницаОбъект.Коэффициент             = 1;
		НайденнаяЕдиницаОбъект.Владелец                = текСсылка;

		Попытка
			НайденнаяЕдиницаОбъект.Записать();
			НайденнаяЕдиница = НайденнаяЕдиницаОбъект.Ссылка;
		Исключение
			//Сообщить("Не удалось записать единицу хранения остатков: " + ОписаниеОшибки(), СтатусСообщения.Важное);
			Отказ = Истина;
		КонецПопытки;
	КонецЕсли;

	Если НЕ Отказ Тогда
		Объект.ЕдиницаХраненияОстатков = НайденнаяЕдиница;
		Объект.ЕдиницаДляОтчетов = НайденнаяЕдиница;
	КонецЕсли;		
КонецЕсли;
Показать

учтите что в этом коде нельзя использовать"Возврат"

2. Чтобы создать группу (родителя) автоматически, добавьте следующий код (в строку Родитель):
ИмяРодителя = ТекстЯчейки;
текГруппа = Справочники.Номенклатура.НайтиПоНаименованию(СокрЛП(ИмяРодителя),Истина);
Если текГруппа = Справочники.Номенклатура.ПустаяСсылка() Тогда
	ГруппаНоменклатуры = Справочники.Номенклатура.СоздатьГруппу();
	ГруппаНоменклатуры.Наименование = ИмяРодителя;
	ГруппаНоменклатуры.Записать();
	текГруппа = ГруппаНоменклатуры.Ссылка;
КонецЕсли;
Результат = текГруппа;
Показать

Пример для одноуровневых справочников, для многоуровневых доработайте сами
Но учтите! По кнопке [Контроль заполнения] папки сразу создадутся! Можно вынести в "При записи".
116. NE_ZNAIY 07.02.15 23:07 Сейчас в теме
А подскажите, пожалуйста, как из экселя (накладная поставщика) загрузить в документ поступления.
Номенклатура поставщика отличается от нашей. В накладной поставщика есть штрих-коды, которые занесены в нашу номенклатуру.
Можно ли сделать так, чтоб обработка ЗагрузкаДанныхИзтабличногоДокумента искала штрихкод, а в документ поступления подставляла нашы наименования номенклатуры. Раньше, когда поставщик в своих накладных не использовал штрих-код мы выходили из положения так. в карточке номенклатуры наименование - наше наименование, полное наименование - наименование номенклатуры поставщика. и в настройке обработки в строке наименование ставили вычислять и такой код
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
| Номенклатура.Ссылка
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.НаименованиеПолное ПОДОБНО &НаименованиеПолное";

Запрос.УстановитьПараметр("НаименованиеПолное", ТекстЯчейки);

Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();

Если Выборка.Следующий() Тогда
Результат = Выборка.Ссылка;
Иначе
ОписаниеОшибки = "Не найдена ноиенклатура с полным наименованием " + ТекстЯчейки;
КонецЕсли;

Может его как-нибудь подправить, чтоб обработка брала из регистра штрих-коды?
Может поможет кто-нибудь?
darkvampire1991; +1 Ответить 1
118. progaoff 03.04.15 10:36 Сейчас в теме
Выбивает ошибку "не удалось записать" захожу в карточку товара единицы пустые, записываю в ручную карточку товара, появляються единицы. В чем проблема?
darkvampire1991; +1 Ответить 1
119. WWWolfy 100 23.04.15 16:05 Сейчас в теме
120. AlexO 127 23.04.15 16:22 Сейчас в теме
А еще мне заголовок нравится:
"СТАБИЛЬНАЯ Загрузка справочника номенклатуры".
Т.е. остальные - нестабильные, в полураспаде...
darkvampire1991; +1 Ответить
121. KarinaSV 5 12.05.15 23:20 Сейчас в теме
!!!Помогите пожалуйста!!!

При нажатии на кнопку загрузить выдает ошибку:

"Ошибка при вызове метода контекста (Вопрос)"

Нажимаю подробно выходит:

{ВнешняяОбработка.ЗагрузкаДанныхИзТабличногоДокумента.МодульОбъекта(946)}: Ошибка при вызове метода контекста (Вопрос)
Если Вопрос("Загрузить "+КоличествоЭлементов + ТекстВопросаИсточника, РежимДиалогаВопрос.ДаНет) = КодВозвратаДиалога.Да Тогда
по причине:
Использование модальных окон в данном режиме запрещено!

Заранее огромное спасибо!
darkvampire1991; +1 Ответить
122. micha76 29.05.15 13:43 Сейчас в теме
В принципе, грузится и с группами (только группы первого уровня отдельно завести). А серийные номера в УТ никто не пробовал переносить?
darkvampire1991; +1 Ответить
123. tihokir 04.06.15 16:50 Сейчас в теме
Помогите, пожалуйста, новичку. Есть две характеристики номенклатуры Размер и Цвет, у каждого по три значения, то есть, всего 9 характеристик получается. Как их загрузить в 1С УТ стандартными программными средствами ЗагрузкаДанныхИзТабличногоДокумента?
darkvampire1991; +1 Ответить
125. vsomova 17.05.16 19:26 Сейчас в теме
Добрый день! Подскажите, пожалуйста, с помощью этой обработки можно изменить уже существующие артикулы? Наименование и все прочие данные остаются без изменений.
darkvampire1991; +1 Ответить
126. Online-Ufa 17.05.16 20:15 Сейчас в теме
ха... увидеть свою статью через столько лет под чужим именем - это забавно :-)
http://www.online-ufa.ru/content/articles/loading_data_into_1c_from_excel_part_3/
источник чтоли хотя бы указал
darkvampire1991; +1 Ответить
128. vsomova 18.05.16 11:21 Сейчас в теме
(127) Online-Ufa,
Добрый день!
Спасибо огромное за подробную инструкцию, но у меня проблем а в том, что по этой инструкции удается только создать новые артикулы, а как быть со старыми - нужно изменить артикулы, которые уже есть в 1С. Номенклатуры много, сейчас вот решили изменить полностью все кодировки артикульные. Если руками обрабатывать, то даже месяца времени не хватит. Может есть какие-то другие обработки групповые? Спасибо заранее!
darkvampire1991; +1 Ответить
129. Online-Ufa 18.05.16 17:46 Сейчас в теме
какая проблема? с помощью этой же обработки можете менять артикулы, только тогда идиентификация будет производится по названию? товаров с одинаковыми названими нет? названия в вашей базе и екселе сходятся на 100% с точностью до каждого знака?
если на все вопросы ответ "да", то пожалуйста, загружайте свои артикулы
darkvampire1991; +1 Ответить 1
130. vsomova 18.05.16 20:21 Сейчас в теме
(129) Online-Ufa,
Это просто чудо! Немного потыкалась в настройках и все получилось - и артикулы изменить и цены новые подтянуть!!! Я даже не знаю как Вас благодарить! Спасибо ОГРОМНОЕ!!!!
darkvampire1991; +1 Ответить
1. boygena 09.11.11 13:21 Сейчас в теме
Очень удобно и работает без ошибок. Пока ошибок еще не нашел =))) Поставил +
2. SkyLink2012 251 10.11.11 17:44 Сейчас в теме
Да, иметь под рукой диск ИТС или найти по ФТП-поиску обработку - решение многих проблем.
3. sevipa 20.11.11 01:09 Сейчас в теме
Да, походу это единственный путь, как без доработок используя только типовые возможности непросто загрузить номенклатуру и цены, а загрузить с предсказуемым результатом... вот только научить этому порядку менеджеров отдела снабжения будет достаточно проблематично. Даже имея подобную инструкцию... А так +
4. kirillkr 28 20.11.11 23:32 Сейчас в теме
Замечательное описание. Огромное спасибо.

Кстати, а никто не видел такую же обработку для управляемых форм?
5. PaulV 26.11.11 20:38 Сейчас в теме
Споткнулся на пункте 14: мне нужен был поиск по артикулу.

Решил так:
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",ТекущиеДанные.Номенклатура.Артикул);
Результат=СсылкаНоменклатуры.ЕдиницаХраненияОстатков;
6. SkyLink2012 251 26.11.11 21:42 Сейчас в теме
Да, пришлось тоже поменять при загрузке (условие: коды разные, наименования:попадаются одинаковые) Едениц для Отчетов:

Еденица для отчетов
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные["Код"]); 
 БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
 ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
 Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); 
 НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); 
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; 
 НайденнаяЕдиницаОбъект.Коэффициент = 1; 
 НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; 
 Попытка НайденнаяЕдиницаОбъект.Записать(); 
 Результат = НайденнаяЕдиницаОбъект.Ссылка; 
  Исключение Сообщить("1Не удалось записать"+ТекущиеДанные["Наименование"]); 
 КонецПопытки; 
 Иначе Результат =ТекСпр.Ссылка; 
  КонецЕсли;

Показать



Еденица для хранения остатков
СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоКоду(ТекущиеДанные["Код"]); 
 БазоваяЕдиницаИзмерения = Справочники.КлассификаторЕдиницИзмерения.НайтиПоКоду(796);
 ТекСпр=Справочники.ЕдиницыИзмерения.НайтиПоРеквизиту("ЕдиницаПоКлассификатору",БазоваяЕдиницаИзмерения,,СсылкаНоменклатуры);
 Если ТекСпр.Пустая() Тогда НайденнаяЕдиницаОбъект = Справочники.ЕдиницыИзмерения.СоздатьЭлемент(); 
 НайденнаяЕдиницаОбъект.Наименование = СокрЛП(БазоваяЕдиницаИзмерения); 
НайденнаяЕдиницаОбъект.ЕдиницаПоКлассификатору = БазоваяЕдиницаИзмерения; 
 НайденнаяЕдиницаОбъект.Коэффициент = 1; 
 НайденнаяЕдиницаОбъект.Владелец = СсылкаНоменклатуры; 
 Попытка НайденнаяЕдиницаОбъект.Записать(); 
 Результат = НайденнаяЕдиницаОбъект.Ссылка; 
  Исключение Сообщить("2Не удалось записать"+ТекущиеДанные["Наименование"]); 
 КонецПопытки; 
 Иначе Результат =ТекСпр.Ссылка; 
  КонецЕсли;
 
 
Показать
7. Volga1904 11.12.11 19:26 Сейчас в теме
Очень удобное описание, спасибо
8. SkyLink2012 251 13.12.11 09:08 Сейчас в теме
Я бы с удовольствием еще-бы добавил описания и ключевых поисковых слов. Но боюсь, лишнее модераторы добавят в минус-слова
9. Magicanin 13.12.11 09:36 Сейчас в теме
Где скачать? Не вижу ничего)
12. SkyLink2012 251 14.12.11 16:13 Сейчас в теме
Буду очень счастлив, если порекомендуете статью или способ импорта знакомым
14. w22u 30 25.12.11 16:42 Сейчас в теме
(12) эту статью порекомендую своим знакомым, только если есть возможность быстрее победить неустановившиеся единицы хранения остатков через эту разработку: http://infostart.ru/public/61676/
почему бы не воспользоваться?
15. Bublik2011 9 28.12.11 18:33 Сейчас в теме
w22u таки беспроблемно грузятся и еденицы. Мне, правда, пришлось, в отличие от Skylink2k выборку делать по кодам, а не по артикулу и номенклатуре. В аттаче есть файл настройки.
Прикрепленные файлы:
ed_xranenija_ostatkow.mxlz
17. МимохожийОднако 127 09.01.12 08:17 Сейчас в теме
Хорошее описание, которого не хватает на ИТС. Может быть, есть еще где-нибудь подобные описания?
18. SkyLink2012 251 19.01.12 16:08 Сейчас в теме
(16) Bublik2011, сердечное спасибо за замечание)
19. SkyLink2012 251 19.01.12 16:13 Сейчас в теме
(17) МимохожийОднако, есть в копирайтах и в комментариях. А на какую тему подобное описание интересно? Очень хочу, чтобы статья была полезная , необходимая и решающая большинство проблем.
20. МимохожийОднако 127 19.01.12 19:50 Сейчас в теме
(19)Сходу ответить сложно. Думаю, статистика наиболее популярных "баянистых" вопросов вокруг универсальных обработок и отчетов с ИТС и типовых конфигураций может натолкнуть на наиболее популярную тематику. Например, для меня интересен набор методов при использовании Универсальной обработки подбора объектов.
21. progres488 25.01.12 21:58 Сейчас в теме
Ребят а кто как бориться если в артикле стоит 0 перед число, у меня ексель съедает ноль и пото мне находит номенклатуру ко артиклу
22. SkyLink2012 251 27.01.12 17:15 Сейчас в теме
(21) progres488, а что если столбец в Екзеле присвоить формат столбца - текстовый?
23. InShallaH 50 10.02.12 16:06 Сейчас в теме
Действительно удобно. Но, к сожалению, для большинства менеждеров проще попросить написать большую красную кнопку "Сделать Все".
24. Yakud3a 20.02.12 05:18 Сейчас в теме
Всё просто и понятно, молодца, как то не обращал внимания на эту обработку на ИТС
25. BalVlad 21.02.12 08:47 Сейчас в теме
Отличная статья с подробным описанием. Спасибо и плюс.
26. takeshi3 27.02.12 13:27 Сейчас в теме
29. Анна79 19.03.12 09:21 Сейчас в теме
А вы можете сделать такую большую красную кнопку? "Сделать все!!!" Спасибо обработка просто отличная, да еще и бесплатная...
30. kvp 16.04.12 15:17 Сейчас в теме
Спасибо! действительно отлично все описано, и эту обработку раньше игнорировала, а выходит очень даже полезная.
31. Stamper 37 18.04.12 19:06 Сейчас в теме
использовать UNIREPS -- это очень правильно
горы времени экономит
32. DoctorRoza 02.05.12 18:08 Сейчас в теме
Вы можете выложить эту статью в более удобном формате, например, в word'e? Я имею в виду Ваш исходный файл, источник, а не сохраненную страницу из браузера. Материал нужный, как раз отличное пособие для пользования обработкой. Заранее благодарю!
33. SkyLink2012 251 03.05.12 09:26 Сейчас в теме
(32) DoctorRoza, к вечеру накатаю, хорошо? Прошу, наберитесь терпения. Очень счастлив, что статья будет полезна и избавит Вас и ваших друзей от ошибок и вбухивания средств-времени впустую. :)
34. DoctorRoza 03.05.12 10:14 Сейчас в теме
35. NE_ZNAIY 28.05.12 17:14 Сейчас в теме
Ещё одно спасибо за труд.
36. lawko 02.06.12 14:32 Сейчас в теме
Также отплюсовал, т.к. просто поражен был тем, что может выдать эта обработка, которая буквально "валялась" на виду, но и в голову не приходило, что можно добиться таких результатов. Огромнейшее спасибо за статью!
Из ручного труда осталось вбивать лишь значения свойств товара и загрузка изображений.
Еще раз большое спасибо!
37. CaSH_2004 354 20.06.12 02:31 Сейчас в теме
Замечательная статья, но вот вопрос: зачем в теме сабжа указано
код открыт скачать можно бесплатно

если суть просто в описании?
Какой код и что скачивать?
38. SkyLink2012 251 20.06.12 09:53 Сейчас в теме
(37) CaSH_2004, прошу Вас, воспринимайте это как элемент SEO оптимизации. :)
40. vitaliyua 19.09.12 11:56 Сейчас в теме
А как быть с созданием групп? Например, переносим справочник номенклатуры, в настройках Обработки негде указывать, группа это или элемент. Как быть?
42. SkyLink2012 251 02.10.12 17:04 Сейчас в теме
(41) gravizapa, Ваш способ модификации обработки - это очень актуально. Создавайте свою ветку. Не надо рассеивать внимание , Вам очень это необходимо сделать. Ваш способ - он более устойчив и скоростнее , как и загрузка из Excel через ADO )) А в этой ветке уж по старинке, что есть в комплекте с основной конфигурацией.

Зачем создавать лишнее, если есть доступный и бесплатный инструмент?
43. SkyLink2012 251 02.10.12 17:11 Сейчас в теме
(40) vitaliyua, А если попробовать так:
1) в первой колонке - название Группы, во второй колонке - родитель (наименование или код?)

2) В настройке: в строке Наименование-
НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу(); 
НоваяГруппа.Наименование = СокрЛП(ТекстыЯчеек[1]); 
НоваяГруппа.Родитель =ТекущиеДанные["Родитель"];


в Настройке Родитель - искать по колонке № 2 искать по Наименованию
44. gravizapa 02.10.12 17:38 Сейчас в теме
(43) да просто с помощью той же самой обработки я делал описание, по сути то же самое,только описание другое
45. oksevi 10.10.12 15:40 Сейчас в теме
Спасибо за подробное описание.
Осваиваем.
Подскажите, пожалуйста, можно ли и каким образом еще один из параметров в прайс-листе добавить как дополнительный реквизит номенклатуры? Конфигурация 1С:Бухгалтерия 8
46. AlexO 127 10.10.12 16:07 Сейчас в теме
все бы хорошо, но кроме номенклатуры, типовая грузит все другие справочники крайне плохо - не ищет по строковым полям, задваивает позиции, переносит только после идеального соответствия номера и наименования.
Да и по поводу загрузки "связанных" справочников - тоже вопросы.
Так что все равно нужно писать свои обработки.
и фразы
наш специалист из отдела внедрения, за пару минут предложил такой код:

очень умиляют, спасибо :)
видимо, и остальные специалисты, и в самой 1С в том числе, также пишут весь код "за пару минут".
47. Bublik2011 9 13.10.12 12:07 Сейчас в теме
(46) AlexO, предлагаю, чтобы не задваивалось, прерывание ставитьпо признаку. Извините, у меня так пока

        Если Лев(ТаблицаЗначенийМассив[НомерСтроки].КодТовара,3)<>"001"  Тогда
                  Продолжить;
        КонецЕсли;


Но лучше загрузка и синхронизация справочников 1с по ГУИД (Уникальный идентификатор) в качестве подстраховки

1. Найти из УникальныйИдентификатор код элемента
Функция НайтиЭлементПоИД (строкаИД)
				ГУИД=Новый УникальныйИдентификатор(строкаИД);
		Для Каждого МД Из Метаданные.Справочники Цикл
			РезСсылка=Справочники[МД.Имя].ПолучитьСсылку(ГУИД);			
			Если РезСсылка.ПолучитьОбъект()<>Неопределено Тогда
				Возврат РезСсылка.Код;
			КонецЕсли;
		КонецЦикла;	 
КонецФункции
Показать



2.Найти УникальныйИдентификатор по коду

Функция НайтиЭлементПоКоду(строкаКод)
	НоменклатураСсылка = Справочники.Номенклатура.НайтиПоКоду(СокрЛП(строкаКод));
Если НЕ НоменклатураСсылка.Пустая() Тогда
   Сообщить("GUID = " + НоменклатураСсылка.УникальныйИдентификатор());
КонецЕсли; 
КонецФункция



Для обработки загрузка, естественно, вводятся только одна-две , э-э-э-э, отличия . Первое - "ТекстыЯчеек[1]".

а) в поле "представление реквизита" - например "комментарий"
б) режим загрузки - "вычислять"
в) в поле "выражение"
Сообщить("В табличном документе есть данные - 1столбец:"+Строка(ТекстыЯчеек[1])+"  2столбец:"+Строка(ТекстыЯчеек[2])+" 3столбец"+Строка(ТекстыЯчеек[3])); 


И второе отличие ЗагрузкаДанныхИзТабличногоДокумента.epf найти по Уникальному Идентификатору - в выражение вместо "Возврат" пишется "Результат". То есть для ЗагрузкаДанныхИзТабличногоДокумента это будет иметь вид:

//Функция НайтиЭлементПоИД (строкаИД) //это тоже не надо
				ГУИД=Новый УникальныйИдентификатор(строкаИД);
		Для Каждого МД Из Метаданные.Справочники Цикл
			РезСсылка=Справочники[МД.Имя].ПолучитьСсылку(ГУИД);			
			Если РезСсылка.ПолучитьОбъект()<>Неопределено Тогда
//Возврат РезСсылка.Код; // ТУТ уже вставляется все что возможно Код Наименование Комментарий НаименованиеПолное
Результат РезСсылка.Код
			КонецЕсли;
		КонецЦикла;	 
//КонецФункции //и это не надо
Показать


Поиск по уникальному идентификатору занимает долгое время, зато уж гарантированно)) Для парсера или для синхронизации уж точно пригодится. Технология XML c ИдЭлемента - это наверно в другой ветке.
48. azeraus 06.11.12 10:02 Сейчас в теме
Хорошая статья с подробными описаниями, очень помогло, но я бы хотел спросить, КАК МОЖНО АВТОМАТИЧЕСКИ СОЗДАТЬ ДОГОВОРА КОНТРАГЕНТОВ при загрузке в справочник контрагентов. Извините за таков "простой вопрос" просто в 1С пока разбираюсь не очень.
50. azeraus 06.11.12 15:43 Сейчас в теме
(49) Bublik2011, База новая, у контрагентов в списке договоров нет ни одного пункта.Контрагентов загрузил (проставил - юр.лицо, наименование, полное наименование, галочка "Покупатель"). Я бы хотел на вкладке счета и договора создать новый договор контрагента и указать его основным с проставлением следующих реквизитов:
1. Наименование "Основной договор"
2. Вид договора "С покупателем"
3. Ведение взаиморасчетов "По договору в целом", валюта "тенге"
4. Условия договора "Без дополнительных условий"
Как это все можно сделать?
Ваша идея насчет скриншотов или видеоролика очень бы мне помогла.
Заранее спасибо!
51. Bacemo 06.11.12 16:11 Сейчас в теме
52. VladimirVladimir 4 20.11.12 17:41 Сейчас в теме
Подскажите как добавить новые группы номенклатуры из файла. Спасибо.
53. alex54 09.12.12 09:01 Сейчас в теме
хорошая штука, но мне нужно указать помимо начальной строки - еще и конечную, чтоб загрузить весь прайс, а потом частями загружать в нужные папки
а так приходиться перед этим лопатить эксел предварительно, что тоже не удобно

можно это дело как-то поправить?

заранее огромное спасибо
54. Мощный 09.12.12 11:19 Сейчас в теме
(53) alex54,
а зачем начальная и конечная? если есть начальная, т.е. строка ехеля каким-то образом выделенная, например наименование группы размещенное по какому-то фиксированному адресу, например, в обьединении ячеек.. Тогда до признака окончаниия строк или следующей такой ячейки реализуется а один проход
55. Мощный 09.12.12 11:23 Сейчас в теме
(52) VladimirVladimir, Если в ехеле будут каким-то образом идентифицироваться группа ( или отступом, или обьединением ячннк или цвнтом, или шрифтом, то проблем как понимаеие нет - все в один проход
56. alex54 09.12.12 11:31 Сейчас в теме
мне присылают прайсы, как правило, где номенклатура в алфавитном порядке без разделения
вот я и хочу, обозначив 1 и последнюю строку, выделенную часть загрузить в одну папку, затем выделив другую часть - загрузить в другую



к примеру аккумуляторы в одну папку
амортизаторы в другую ..... и т.д.

приходиться каждый раз лишнее удалять... загружать, а потом опять открывать документ по-новой (((

может я делаю что-то не так? подскажите
57. alex54 09.12.12 11:34 Сейчас в теме
(55) Мощный, спасибо, кажется малость доходит, но в моем случае все-равно надо дорабатывать эксел, типа раскрасить все в разные цвета или добавить пустые строки... я правильно понимаю?
58. alex54 09.12.12 11:36 Сейчас в теме
а вот была бы возможность выбрать заданный диапазон в обработке - было бы круто ) загрузил файл и меня начальную и конечную ячейки - загружай что хочешь и куда хочешь
59. alex54 09.12.12 12:18 Сейчас в теме
(54) Мощный, что-то ничего не выходит ((( грузит весь список, хотя разделение есть, что-то я не догоняю (((







60. Мощный 09.12.12 13:30 Сейчас в теме
(59) alex54, к сожалению у меня нет такой обработки с ИТС, а ежли есть, то искать просто некогда.. Обработки пишу сам.. Поэтому не сочтите за труд, ежли такая обработка есть перешлите на досуге подделаю.. tihon1t@mail.ru
А что касаемо алгоритма с группами, сброшу сегодня попозже, ну например с опознаванием ячеек на обьединение
Если не лень сбросьте и исходную, и доделанную постараюсь понять почему весь список попадает без учет разделения
61. alex54 09.12.12 13:34 Сейчас в теме
62. Bublik2011 9 09.12.12 15:03 Сейчас в теме
(59) alex54, Было-бы здорово, если-бы заранее в строку прописать для товара кроме артикула еще и родителя (см фото)



Иначе придется придумать, куда (наверное в "при обработку и загрузке") засунуть переменную "НазваниеКаталогПродукции". На деле это будет так:


-В первой строке есть название. Название АВТОСВЕЧИ установить в переменную НазваниеКаталогПродукции.
-Во второй строке нет названия, есть товар. Для товара установить Родителя с названием из переменной НазваниеКаталогПродукции.
-Во третьей строке нет названия, есть товар. Для товара установить Родителя с названием из переменной НазваниеКаталогПродукции.
-В Строке ХХ ....


Вот один из шаблонов для определения группы товара

Запрос=новый Запрос;
Запрос.Текст="
|ВЫБРАТЬ 
|	Номенклатура.Наименование,
|	Номенклатура.Ссылка как Результат,
|	Номенклатура.ЭтоГруппа	
|ИЗ
|	Справочник.Номенклатура КАК Номенклатура
|ГДЕ
|	Номенклатура.ЭтоГруппа
|	И Номенклатура.Наименование = &Наименование
|";
Запрос.УстановитьПараметр("Наименование","Прочее");
РезультатЗапрсаВМассиве = Запрос.Выполнить().Выбрать();

Если 		Выборка.Количество()=0  Тогда
		Вопрос("Не найдено ни одного родителя, необходимо создать новый или записывать в отдельную группу ДляРазбросаПоКаталогам. Сейчас прервать загрузку?", РежимДиалогаВопрос.ДаНет)
	  Если Ответ = КодВозвратаДиалога.Да Тогда
            Возврат; //выйти из цикла или процедуры
	  КонецЕсли;
ИначеЕсли Выборка.Количество()>1 Тогда
	Предупреждение("Найдено более двух родителей. Надо с этим что-то предпринять..",60);
КонецЕсли;

Пока РезультатЗапрсаВМассиве.Следующий() Цикл
        	Результат= РезультатЗапроса.Результат 
	//Объект = РезультатЗапроса.ссылка.ПолучитьОбъект();
         //Объект.наименование = что-то с элементом
         //Объект.записать();
  КонецЦикла; 
Показать


Вот еще несколько шаблонов, кроме "Работа с Текстом (Строкой) 1с" при загрузке прайса:

Сообщить(" в текущих данных Код сейчас  "+Строка(ТекущиеДанные["Код"]));
Сообщить(" в текущих данных Владелец сейчас  "+Строка(ТекущиеДанные["Владелец"]));

Сообщить(" в ТекстыЯчеек[1] сейчас  "+Строка(Строка(ТекстыЯчеек[1])));
Сообщить(" в ТекстыЯчеек[2] сейчас  "+Строка(Строка(ТекстыЯчеек[2])));



Понимаете, сейчас только осталось в программный код перевести рассказ "-В первой строке есть названи и т.д. (см выше)" Задача интересная - определить переменную таким образом, чтобы она изменялась или читалась из прайса. Вот вижу еще один маневр:


Если значение из колонки два пустая, следовательно, в колонке 1 - название группы


	   Если СтрДлина(СокрЛП(Строка(Строка(ТекстыЯчеек[2]))))=0 Тогда	   
текстПеременнаяРодительДляСледующихСтрок=Строка(ТекстыЯчеек[1]));
			  //хочется в Результат и наити по наименованию 
			  //засунуть Результат=Строка(ТекстыЯчеек[2])); 
			  //но надо ссылку найти	    ссылПеременнаяРодительДляСледующихСтрок=Справочники.Номенклатура.НайтиПоНаименованию(Строка(ТекстыЯчеек[2]));
		         Если ссылПеременнаяРодительДляСледующихСтрок.ЭтоГруппа Тогда			 
				 	Результат=ссылПеременнаяРодительДляСледующихСтрок; 
			 КонецЕсли; 
	   КонецЕсли; 
Показать


В-общем, надо будет поэксперементировать с вкладками "События-Перед записью объекта" и "События-При записи объекта". Ответ наверно чуть позже.


Если известно, что количество стобцов всегда одинаковое и всегда соответсвует, тогда скину свою обработку. У меня так и есть: "Обработка для поставщика 1", "Обработка для поставщика 2". Только я требую от поставщиков прайсы с кодами или со штрихкодами. Так можно избежать ошибки при количестве товаров в базе более 25000
63. Мощный 09.12.12 15:21 Сейчас в теме
64. Мощный 09.12.12 15:26 Сейчас в теме
(62) Bublik2011, извините но реальному усру это .. не торт в общем.. Все должно быть намного проще, т.е. ехелька без предобработки
И по хорошему, представленную вещчть надо бы переделать процентов на 95
65. Bublik2011 9 09.12.12 15:32 Сейчас в теме
(52) VladimirVladimir, Действительно, сложно наверно. Вероятно обязательно указать ЕденицуИзмерения. А для группы это не предусмотрено.

Наверно создать группу лучше в два этапа
1. Создать группы
2. Назначить каждой группе родителя


Вот пример:
1. Создаете файл: каждая строка - название группы без спец символов вроде кавычек. Допускается тире, цифры, пробел.

Название группы1
Вторая группа
Автозапчасти
Велосипеды
Шины


Создаете обработку (или из аттача берите) с текстом для кнопки "Выполнить"

	
	  файл = Новый ТекстовыйДокумент;
	  адресФайла="C:\ТекстСНовымиГруппами.txt";
	Попытка файл.Прочитать(адресФайла);
	Исключение 
		Предупреждение("файл по данному адресу не найден");	
	КонецПопытки;
Для Сч=1 По файл.КоличествоСтрок() Цикл	
		ОбработкаПрерыванияПользователя();
		Стр = файл.ПолучитьСтроку(Сч);
		Состояние("обработка файла "+Строка(Сч));
	НоваяГруппа = Справочники.Номенклатура.СоздатьГруппу();
	//НоваяГруппа.Код = Строка(ТекстыЯчеек[2]);
	НоваяГруппа.Наименование = СокрЛП(Стр);	
	НоваяГруппа.Записать();
КонецЦикла;

Показать
Прикрепленные файлы:
СозданиеГруппы.epf
66. Bublik2011 9 09.12.12 15:41 Сейчас в теме
(64) Мощный, ну так интересно.. Консоль-же переделали ведь. Очень предпочитаю придерживатьмя тематике группы. Да, бывают моменты - сложно создать группу. Бывают crazy вроде меня, которые усложняю моменты, делают проверку соответсвии в тех местах, где не это не требуется. :) Мне иногда парсить прайсы с сайтов приходится и искать товары по УникальномуИдентификатору. Конечно, ерунда, есть решение проще. В остальном - этот продукт "Загрузка данных" - просто идеален. Загрузка Справочника номенклатуры мз Excel в стандартном виде - незаменимая вещь. Она доступна и решает 80% проблем. Позволяет избежать лишних затрат. Очень рад, что мне тоже нравится эта обработка. Рассматриваю эту универсальную стандартную обработку, идущую в комплекте с 1с как эдакий черновик, после чего можно сформулировать Техническое Задание.
67. SkyLink2012 251 09.12.12 15:52 Сейчас в теме
(60) Мощный,


Если не лень сбросьте и исходную, и доделанную постараюсь понять почему весь список попадает без учет разделения


Наверное мне кажется, но вижу, что "Устанавливать"-"Свечи". Потому и "весь список попадает без учет разделения".


А что касаемо алгоритма с группами, сброшу сегодня попозже, ну например с опознаванием ячеек на обьединение


Поверьте пожалуйста, создано столько замечательных обработок с различными объектами. Обновлены методы работы с объектами,например, понравилась статья "Загрузка из EXCEL в 1С тремя методами. Часть I. MS ADODB.Connection". Но все равно приходится, черт побери, да, приходится иногда загружать с помощью "Универсальной загрузки справочников". Проще и надежнее. Извините, если ошибаюсь.
68. Мощный 09.12.12 16:00 Сейчас в теме
(66) Bublik2011, Так я и говорю, что исключительно для внутреннего употребления, как правило для обучения.. То есть технологическая..
69. alex54 09.12.12 17:06 Сейчас в теме
ребят, не надо создавать группы в обработке, они созданы, это не так уж и сложно сделать вручную и родителя

обработка все делает на ура, единственно что нужно, так это задать диапазон загрузки

со строки такой - до строки такой.......... и все

и не надо во всем прайсе дописывать родителя, я его устанавливаю в из готовых заготовок

это еще и потому, что у разных поставщиков на одинаковую номенклатуру - разные родители или вообще нет

вот есть у меня прайс на 5000 наименований и даже разделение есть по группам (как задумал поставщик) а у меня другие для этого группы (родитель)
я устанавливаю куда грузить и задаю диапазон в прайсе....все.... остальное там идеально

если надо, я прикреплю обработку, которая есть у меня, сюда
70. alex54 09.12.12 17:19 Сейчас в теме
попробовал вот эту обработку http://infostart.ru/public/125082/

архи неудобная, НО, что там удачно, так это возможность задать диапазон загрузки

если это реализовать в данной версии - цены бы не было )
71. alex54 10.12.12 20:04 Сейчас в теме
есть что нового по теме? из бюджетных ничего пока подобрать не могу (
72. alex54 18.12.12 15:57 Сейчас в теме
(68) Мощный, есть что нового ?
73. Bublik2011 9 16.01.13 04:47 Сейчас в теме
(72) alex54, Сколько бы обработок вроде ЗагрузкаданныхизТабличногоДокумента конечно не появлялось, эта остается классикой. Грех просто предьявлять претензии, исходный код открыть - изучай, не хочу... Еще чем мне нравится эта обработка - тем что вы читаете данные из внешнего источника, показываете их с помощью объекта табличное поле и только затем выбираете алгоритм загрузки в 1С.

Но что-то в ней не хватает. Конечно стандарта офисных документов ODF (Open Document Format). Теперь возможно загрузка справочника номенклатуры в 1С:Управление торговлей 8 из прайс-листа в OpenOffice ODF (Open Document Format). Как можно загрузить в 1с8 из OpenOffice ? Можно прочитать http://infostart.ru/public/158951/
74. kirillkr 28 18.01.13 17:49 Сейчас в теме
А как можно перед добавлением строки в табличную часть выполнить код - надо ли добавлять новую строку или нет.
Например, мне выкладывают прайс лист и помимо номенклатуры выдают все шк, т.е. одинаковых строк отличающихся только ШК - уйма. Как сделать так, чтобы в ценообразование загружать каждую номенклатуру единожды?
75. fgremlin 11.02.13 20:06 Сейчас в теме
А на управляемых интерфейсах запускал кто нибудь эту обработку? Что-то у меня не получилось... :( поделитесь опытом!
76. NikolasI 25.03.13 11:50 Сейчас в теме
Полезная обработка.
Сейчас пытаюсь забить при помощи нее Номенклатуру поставщика. Не получается - помогите кто сможет.
То есть у нас есть своя номенклатура, в ней артикулы совпадают с поставщиком, наименования некоторые отличаются.
Соответсвенно надо произвести поиск поля Наименования по артикулу справочника Номенклатура.

Написал такое:

СсылкаНоменклатуры = Справочники.Номенклатура.НайтиПоРеквизиту("Артикул",ТекущиеДанные.Номенклатура.Артикул);
Результат=СсылкаНоменклатуры.Наименование;


Выдает такое:
Поле объекта не обнаружено (Номенклатура)
Загружен элемент справочника: <>


Что не так делаю?
77. fgremlin 25.03.13 12:12 Сейчас в теме
(76) NikolasI,
А куда грузишь? Редакция, конфигурация?
78. fgremlin 25.03.13 12:25 Сейчас в теме
(76) NikolasI,
Теоретически там код писать не нужно...
В представлении реквизита "Номенклатура" ставишь искать по полю табличного документа (артикул) - из твоей таблицы с данными, в поле "искать по" выбираешь "Артикул", и все, должен привязывать к нужному родителю в номенклатуре найдя его по артикулу...
Смотрел в редакции УТ 11, в живую не проверял, но раньше пробовал таким образом другие справочники грузить.
Оставьте свое сообщение

См. также

Объединение организаций в ЗУП при реорганизации с переносом данных из ЗУП 2.5 в ЗУП 3.1 9

Статья Программист Нет файла v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Бесплатно (free) Зарплата Управление персоналом (HRM) Перенос данных из 1C8 в 1C8

В этой статье описан опыт объединения 2-х организаций при реорганизации в ЗУП 3.1 с переносом данных одной организации из ЗУП 2.5 (релизы баз более или менее свежие, но не самые последние на момент перехода, примерно двух- и трехмесячной давности). За основу было взято решение из этой статьи https://infostart.ru/public/833658/, в которой описан алгоритм решения задачи, за что автору статьи огромная благодарность! Здесь же даны некоторые комментарии и пояснения к алгоритму переноса и объединения, описаны выявленные мною ошибки. Также приведена небольшая инструкция по использованию обработки ирПодборИОбработкаОбъектовБД — она будет полезна для пользователей — «не программистов», впервые работающих в не управляемых формах.

09.10.2019    665    Neti    0       

EnterpriseData: простой способ защиты данных в базе получателя при одностороннем обмене 20

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Очень часто бухгалтеры ругаются, когда уже отраженные документы в бухгалтерском учета меняются сотрудниками.

04.10.2019    1559    handscenter    11       

Конвертация Данных. Нюансы использования конструкции "НеЗамещатьОбъект = Истина" в обработчике события "ПриЗагрузке" 27

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

У конвертации данных есть «особенности», которые «пьют кровь» программистов. Эта статья про очередную обнаруженную «особенность».

10.09.2019    1933    ivanek    21       

Обмен данными через Web Сервисы 80

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Ознакомительная статья о том, как загружать\выгружать данные с одной базы в другую, используя Web Сервисы.

02.09.2019    4037    user5300    27       

Выгрузка и загрузка документов с движениями 13

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Возникла задача перенести документы с движениями, но подменив организацию. Наткнулся на проблему с выгрузкой движений, опишу свой опыт.

02.09.2019    1352    human_new    7       

EnterpriseData – часть 3. Загрузка данных, идентификация объектов 61

Статья Программист Нет файла v8 v8::УФ 1cv8.cf ОС Бесплатно (free) Практика программирования Математика и алгоритмы Перенос данных из 1C8 в 1C8 Разработка

Основные этапы загрузки данных через EnterpriseData. Идентификация объектов загружаемых полностью и по ссылке. Приведены схемы процессов загрузки данных. Описание основных операций и обработчиков. Перечень процедур БСП, используемых при загрузке данных, структура «КомпонентыОбмена».

22.08.2019    3277    ids79    7       

Перенос дополнительных реквизитов в Конвертации данных 2.0 16

Статья Программист Нет файла v8 КД Россия УУ Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример написания правил обмена (КД 2.0) для переноса дополнительных реквизитов справочника "Номенклатура", в том числе перенос ПВХ с разными типами значений.

13.08.2019    1834    vikulinamari    3       

Полезные приемы при работе с Конвертацией данных 2.1. Логирование, интерактивное управление, дозаполнение и постпроведение документов 43

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Некоторые полезные приемы для КД 2.1, которые могут пригодиться как при доработке типовых правил, так и самописных.

22.04.2019    4050    maks_20    9       

Преобразование EXCEL в таблицу значений без COM и других извращений 208

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Получение таблицы значений из excel в 1С v8, без COM, внешних источников данных и т.д. EXCELВТаблицуЗначений() - За 10 строчек кода! Реализация протестирована на 1С 8.3.12.1714 (x64).

18.04.2019    11979    9    Eret1k    43       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7233    m-rv    16       

Работа с ComОбъектом 1С 8.2; 8.3 100

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Определение типов и значений через COM соединение между конфигурациями.

15.04.2019    10440    vik070777    12       

RabbitMQ + Конвертация Данных 3.0 178

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 КД Бесплатно (free) Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    13648    barelpro    82       

Копирование числовых ячеек из 1С в Excel 26

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    10332    itriot11    21       

Конвертация данных 2.1: поиск по условию 18

Статья Программист Нет файла v8 КД ERP2 Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

Задача. При обмене документами "Реализация товаров и услуг", поиск контрагента осуществлять по полям "ИНН", "КПП". Если вид договора с комиссионером, то поиск осуществлять по полям "ИНН", "КПП", "Наименование".

15.01.2019    5634    wowik    13       

Запись одной книги Excel на нескольких листах средствами 1С (без внешних компонент) 139

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Пользователи часто просят сохранить им стопиццот отчетов в один файл Excel, чтобы отчеты были в одном файле. Ну или клиент хочет счет, накладную и счет-фактуру получить в одном документе. 1С умеет это делать без всяких там COM-объектов. Давайте разберемся, куда нажимать и что крутить.

14.01.2019    11598    starik-2005    23       

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д) 35

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Как легко загружать данные из электронных таблиц (Excel, OpenOffice и т.д). На примере загрузки в табличную часть документа Поступление товаров и услуг в УТ 11.4.

09.01.2019    6668    rasdag    14       

Заметки КД 2.1: Как передать файл, динамически создаваемый в источнике, в справочник присоединенных файлов приемника 25

Статья Программист Нет файла v8 КД Россия Windows Бесплатно (free) Перенос данных из 1C8 в 1C8

В БП 3.0 есть документ "Книга Продаж Для Передачи В ЭлектронномВиде" из которого выгружается XML файл. Задача: Нужно из БП 3.0 посредством правил обмена, вместе с документом книга продаж сформировать и перенести XML файл в базу приемник. В приемнике файл будет храниться в справочнике "Книга Продаж Присоединенные Файлы".

10.10.2018    5276    Viktor_Ermakov    6       

Работа с Excel через COM 20

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel

Несколько примеров работы с excel (ms office 2010, в моем случае) через COM.

01.10.2018    5001    jaroslav.h    0       

Выгрузка в Excel с использованием формата OpenXML, разбор файла sheet1.xml 13

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Судя по количеству просмотров темы https://infostart.ru/public/900022/ решил описать структуру файла Листа excel. На полноту не претендую, опишу то, что знаю.

21.09.2018    4082    user1045404    2       

Excel: создание в формате xlsx без COM технологии 112

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

По работе приходится часто выгружать данные в Excel формате. При большом количестве строк и формул этот процесс достаточно длительный. Решил написать для своих целей небольшую библиотечку для выгрузки данных. Используется технология open-xml. Никаких библиотек не надо, пишу напрямую в xml файлики. На данном этапе сделано форматирование, формулы.

10.09.2018    7672    user1045404    16       

Планы обмена 1С 158

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье - мастер-классе Дмитрий Жичкин рассказывает, для чего нужны планы обмена 1С и какие задачи они решают. Он подробно описывает физическую структуру планов обмена и механизмов регистрации изменений, рассматривает основные проблемы, возникающие при выгрузке изменений и предлагает методы их решения.

10.09.2018    29925    zhichkin    4       

Конвертация 2.0. Обмен данными между справочниками по сопоставлению артикулов с помощью регистра сведений (пример). 13

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример обмена данными между справочниками по сопоставлению артикулов с помощью регистра сведений

27.08.2018    4349    Lyubogradov.P    0       

Конвертация 2.0. Перенос независимого справочника в подчиненный (пример). 9

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример переноса независимого справочника в подчиненный с помощью Конвертации 2.0.

15.08.2018    5475    Lyubogradov.P    6       

Из Excel в 1С запросом 33

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    13466    m-rv    5       

Конвертация 2.0. Перенос элементов и групп справочника, имеющих различный вид иерархии (пример). 12

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

Пример переноса справочника, имеющего различный вид иерархии, с помощью Конвертации 2.0.

13.08.2018    5186    Lyubogradov.P    0       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19185    olegtymko    43       

hsИнтегратор - технология онлайнового обмена данными между базами на платформе 1С:Предприятие. Использование технологии в виде расширения, без изменения конфигураций баз данных, участвующих в обмене 33

Статья Программист Нет файла v8 v8::УФ 1cv8.cf Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

hsИнтегратор : Простое в использовании решение, работает в качестве клиента и сервиса (в мобильном приложении – только клиента). Не обязательно требует внесения изменений в конфигурации интегрируемых баз данных. Маленький трафик обмена между клиентом и сервером, быстрая реакция на запросы со стороны клиента. Единый сервис для обмена данными различной структуры, механизмы для обеспечения безопасности.

25.06.2018    8551    12    hobi    8       

Обмен через универсальный формат. Пример нестандартной конвертации данных 82

Статья Программист Нет файла v8 УТ11 Россия Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

В статье описан небольшой пример обмена данными через EnterpriseData без снятия конфигурации с поддержки. Тестовая площадка: Управление торговлей, редакция 11 (11.4.3.126), версия платформы 8.3.11

18.06.2018    22151    artkor    12       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІІ: Регистры сведений 16

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Часть III публикаций об универсальном обмен через REST интерфейс OData - обмен регистрами сведений

26.05.2018    6289    V.Stavinsky    3       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть ІІ: Документы 30

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Продолжение статьи об универсальном обмене между идентичными конфигурации через REST интерфейс OData (https://infostart.ru/public/829356/). В части второй разберем особенности обмена документами.

19.05.2018    7623    V.Stavinsky    5       

Универсальный обмен между идентичными конфигурациями через REST интерфейс OData. Часть І: Справочники 96

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Сейчас все чаще интеграции различных конфигураций проектируются через HTTP-сервисы - они и работают быстрее, и "войти" в режим отладки гораздо проще, тем самым обойдя "черный ящик" универсального обмена через xml, например. Более года назад я начал работать в компании, в которой разработчики работали с конфигурациями 1С в режиме совместимости еще 8.2.16 (менять режим совместимости в типичных базах мы не хотели) - а как Вы наверное знаете, если интересовались HTTP-сервисами в 1С, их использование в режиме совместимости 8.3.4 и ниже недопустимо - и здесь я уже не надеялся на разработку и использование HTTP-сервисов. Но позже меня заинтересовал такой "сервис" как REST интерфейс OData, так как его можно использовать не меняя режим совместимости конфигурации - именно он и стал для меня идеальным вариантом решения "нетривиальных" задач.

11.05.2018    16148    V.Stavinsky    11       

Как написать обмен с 50 поставщиками и не сойти с ума. Техника 20

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

О том как из обмена с одним идеальным поставщиком сделать обмены с 50 реальными поставщиками.

16.04.2018    6859    m-rv    1       

Конвертация данных. Произвольная иерархия справочника 11

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Источник: Бухгалтерский учет ред. 4.5 платформы 7.7. Приемник: Бухгалтерия предприятия 3.0. Задача: При загрузке справочника «Номенклатура» в приемнике, все элементы поместить в папку «Товары» с сохранением имеющейся иерархии в 7.7.

10.04.2018    7234    pyrkin_vanya    3       

Перенос помеченных на удаление объектов. Конвертация 2.1 18

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Иногда при переносе данных возникает задача: не переносить помеченные на удаление документы, а те документы, которые были ранее перенесены в базу приемник и теперь в приемнике стали помеченными на удаления - переносить так, чтобы в базу приемник не тянулись связанные с объектом ссылки, но искомый объект помечался на удаление. В данной статье будет рассказано, как это можно сделать достаточно просто, используя конфигурацию "Конвертация 2.1".

02.04.2018    10090    Shmell    2       

Совместная работа БП 3.0 и ЗУП 3.1. Устранение ошибки синхронизации персональных данных физических лиц 12

Статья Системный администратор Программист Нет файла v8 БП3.0 ЗУП3.x Управление персоналом (HRM) Бесплатно (free) Перенос данных из 1C8 в 1C8

При совместной работе указанных конфигураций с использованием встроенного плана обмена «ОбменЗарплата3Бухгалтерия3» персональные данные физических лиц передаются некорректно. Это связано с ошибкой в правилах обмена (замшелой уже, с учётом того, сколько времени эта ошибка «кочует» из версии в версию правил).

31.03.2018    9825    ser73461014    11       

Настройка обмена через универсальный формат между СВОЕЙ КОНФИГУРАЦИЕЙ и ТИПОВОЙ, не снимая типовую с поддержки (+ фишка БСП) 53

Статья Программист Нет файла v8 Бесплатно (free) Перенос данных из 1C8 в 1C8

Возникла необходимость настроить синхронизацию между своей отраслевой конфигурацией и Бухгалтерией 3.0, основным условием было - НЕ снимать Бухгалтерию с поддержки. Предлагаю краткую инструкцию + одну "фишку" БСП, которая по умолчанию не отображается.

25.12.2017    19766    tmn72.1C    18       

Синхронизация под контролем (на примере синхронизации «1С:Зарплата и управление персоналом 3.1» и «1С:Бухгалтерия 3.0») 10

Статья Программист Нет файла v8 БП3.0 ЗУП3.x Россия БУ Зарплата Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье рассматривается возможность наглядного анализа переносимых данных при синхронизации, построенной на технологии «1С:Конвертация 2».

19.12.2017    11782    leosoft    6       

Как самому написать обмен между Бухгалтерией 2.0 и ЗУП 3.1. (Часть 1) 29

Статья Программист Нет файла v8 БП2.0 ЗУП3.x БУ Windows Зарплата Бесплатно (free) Перенос данных из 1C8 в 1C8

Речь пойдет о том, как можно осуществить переход на ЗУП 3.1 и при этом сохранить работоспособность системы обмена, написав свой обмен между конфигурациями разных поколений в Конвертации данных. В этой части речь пойдет только об документе Отражения зарплаты (перенос начислений).

15.12.2017    11292    alex_bitti    0       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 720

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136941    MaxS    251       

Обмен между базами 1С 8.3. Доработка типового плана обмена (синхронизации) между конфигурациями 1С на примере обмена 1С: Зарплата и управление персоналом 3 и 1С: Бухгалтерия предприятия 3 112

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Перенос данных из 1C8 в 1C8

Для чего нужно изучить данную статью и когда эти знания могут пригодиться? В первую очередь приведенная ниже информация потребуется программистам 1С, когда перед ними встанет задача доработать типовой обмен между конфигурациями, который настроен через синхронизацию данных, т.е. по плану обмена. Что же такое «План обмена»? План обмена в 1С – это объект, который входит в состав метаданных конфигурации и служит для синхронизации данных между информационными базами.

09.11.2017    49349    user858846    36       

Конвертация данных. Удобная навигация (Открыть алгоритм или запрос) v0.5 48

Статья Программист Нет файла v8 КД Россия Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Цель: выявить (зафиксировать) и реализовать удобную навигацию в КД, например: -Открытие алгоритмов в правилах конвертации объектов и правилах выгрузки данных.

27.10.2017    9090    Trise    6       

1С: Конвертация данных 2. Разработка с "нуля" на простых примерах разработки 154

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

1. Вступление 2. Что понадобится: конфигурация 1С: Конвертация данных 2. и обработки из пакета. Для примера задач возьмем конфигурации 1С: Управление торговлей 11 и 1С: БП 3.*. 3. Нам понадобятся Обработки для выгрузки структуры метаданных и обмена. 4. Выгрузка структуры метаданных конфигурации 1С: Управление торговлей 11.3 и 1С: Бухгалтерия предприятия 3.0.* 5. Загрузка структур метаданных конфигураций в базу конвертации. 6. Создание правил конвертации в 1С на конкретном примере задачи. 7. Подводим итоги: Выгрузка и загрузка данных с помощью разработанных правил обмена данными.

26.10.2017    57485    somel    21       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24443    arakelyan    39       

Основные концепции Конвертации данных (КД) для новичков 120

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

В КД очень важно понять основные принципы работы. Вроде и самой КД сто лет в обед, и понаписано уже не счесть, но все как-то не так, как мне бы хотелось. Постепенно крепло желание написать эдакое послание самому себе, начинающему изучать КД, да никак руки не доходили. Последней каплей стала очередная попавшаяся на глаза "неправильная" статья, и я решил - ничего страшного, пусть будет еще одна статья, зато гештальт закрою :) Даже если я излишне самонадеян, авось кому-то она все же поможет. Скриншотов не будет, будет только унылый текст. Но я бы в свое время за него многое отдал. Чтобы не перегружать статью, в ней не освещаются особенности вроде правил регистрации, особенностей КД 3.0 и т.п.

17.10.2017    23489    herfis    26       

Настройка автоматического обмена между конфигурациями Управление торговлей 10.3 и Управление торговлей 11. 3 при помощи механизмов планов обмена и правил обмена 54

Статья Программист Нет файла v8 УТ10 УТ11 Россия Бесплатно (free) Перенос данных из 1C8 в 1C8

В статье описывается методика настройки автоматического обмена между конфигурациями УТ 10 -УТ 11 3 при помощи механизмов планов обмена и правил обмена

25.09.2017    14078    The Ded    18       

Правила конвертации между регистрами сведений подчиненным регистратору и независимым 16

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Принцип настройки правил обмена в БСП между регистрами сведений, когда один из них подчинен регистратору, а второй независимый.

31.08.2017    12607    Pervuy    2       

Конвертация данных 2.* + Планы обмена - метод передачи в сообщении удаления независимых регистров 11

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8

Описывается метод передачи в сообщениях информации для удаления независимых регистров в узлах приемниках при использовании планов обменов в связке с конвертацией данных и обработкой "Универсальный обмен данными в формате XML" из поставки "Конвертация данных 2.x".

28.08.2017    8285    rawlik    8       

Что такое конвертация данных 1С (статья написана исключительно для новичков) 79

Статья Программист Стажер Нет файла v8 КД Бесплатно (free) Обмен через XML Перенос данных из 1C8 в 1C8

О том, что "Конвертация данных" - мощный инструмент и прочую терминологию, вы прочтёте в любом источнике. Я хочу поделиться кратким пояснением как пользоваться данной конфигурацией. Речь пойдет о версии 2.1.

07.08.2017    29345    perepetulichka    33