gifts2017

Ошибка в релизе 189 Конфигурации 1С: УСН 77 и релизе 535 Конфигурации 1С: Бух ПРОФ 77 (СправкиПоНДФЛ)

Опубликовал BlackMor (BlackMor) в раздел Печать - Регламентированная отчетность

Обнаружена ошибка в 1С: УСН 77 релиз 189 и Бух ПРОФ 77 релиз 353 (Отчет СправкиПоНДФЛ).

В Отчете СправкиПоНДФЛ при подборе Сотрудника выдает ошибку модуля.
Лечится просто. Найти Функцию "ОбработкаПодбора" Модуля Отчета:

Для 1С: УСН релиз 189 это строка номер 4780

Для 1С: ПРОФ релиз 535 это строка номер 4782

В функции найти и закомментировать следующие строки:

    //Если Элемент.ОсновнойЭлемент <> Элемент Тогда
     //Элемент = Элемент.ОсновнойЭлемент
    //КонецЕсли;

 

См. также

Подписаться Добавить вознаграждение
Комментарии
0. BlackMor (BlackMor) 01.02.12 04:58
Обнаружена ошибка в 1С: УСН 77 релиз 189 и Бух ПРОФ 77 релиз 353 (Отчет СправкиПоНДФЛ).


Перейти к публикации

1. Victor Nespyatin (victuan) 01.02.12 04:58
А не проще было написать
закомментируйте строки:
Если Элемент.ОсновнойЭлемент <> Элемент Тогда
Элемент = Элемент.ОсновнойЭлемент
КонецЕсли;
?
Vital451; +1 Ответить
2. mikhailovaew (mikhailovaew) 07.02.12 14:36
В УСН 190 и Бухгалтерии 536 ошибку исправили так:
Если Элемент.ТекущийЭлемент() <> Элемент Тогда
Элемент = Элемент.ТекущийЭлемент();
КонецЕсли;