gifts2017

Алгоритм распределения перечисленного НДФЛ в ЗиК 7.7 и вариант его улучшения

Опубликовал Александр Музыченко (sam41) в раздел Обработки - Обработка документов

Доработка конфигурации ЗиК 7.7 релизы 320-322 с целью улучшить распределение сумм перечисленного НДФЛ по сотрудникам. Полезна, если Вы хотите видеть "красивые" регистры налогового учета по НДФЛ - с подробной расшифровкой перечисленных налогов до даты платежа и номера платежки. Ну и разумеется годовую отчетность по НДФЛ в полном соответствии с этими регистрами.            
Внимание!        Если Вам просто надо показать в справке/отчете 2-НДФЛ перечисленную сумму равной начисленной и удержанной, - можно дальше не читать, а сразу идти сюда: http://infostart.ru/public/115064/

Посмотрим, как задумано распределение перечисленного налога в типовой конфигурации. Для этого действа применяется документ «Перечисление НДФЛ в бюджет». В дальнейшем речь пойдет только о нем.

Табличная часть заполняется сотрудниками в соответствии с выбранным ОКАТО/КПП. По ним собираются суммы НДФЛ исчисленного (или удержанного, в зависимости от переключателя в форме документа). Сумма платежа делится на общую сумму НДФЛ и с помощью полученного коэффициента вычисляется часть перечисляемого налога для каждого сотрудника. В завершение разность между суммой платежки и общей суммой по сотрудникам (она может быть и положительной, и отрицательной) относится на сотрудника, получившего в данном документе максимальный «кусок» налога к перечислению.

Что не так в типовой конфигурации.

  1. Из-за орфографической ошибки в модуле формы «нераспределенный» НДФЛ всегда относится на последнего в списке сотрудника, а не так, как задумано.

  2. Типовой алгоритм совершенно не учитывает случай, когда НДФЛ перечислялся дважды в месяце: при выплате аванса и получки. (А бывает и больше). Поскольку каждый раз для вычисления коэффициента принимается общая сумма НДФЛ за месяц, резко увеличиваются ошибки, связанные с округлением до целых рублей.

  3. Если в каком-то месяце вдруг перечислили больше, чем надо, то возможна ситуация, когда перечислено по сотруднику больше, чем начислено и удержано. (Это как понимать? Человек может требовать возврата???) При этом сумма переплаты (как и недоплаты) никогда не зачтется в последующих периодах.

Как устранить перечисленные недостатки.

Если Вас не устраивает только недостаток №1, то достаточно в строке 249 модуля формы документа заменить идентификатор «МаскСумма» на «МаксСумма».

Недостатки №2 и 3 предлагается решить, заменив текст процедуры «ЗаполнитьТаблицуНалогов» в модуле формы документа прилагаемым текстом. При этом «нераспределенный» НДФЛ не относится никуда, - я считаю, что так лучше. И пускай сумма перечислений по строкам отличается от суммы платежки, вряд ли кому придет в голову их когда-либо сравнивать, зато это расхождение будет учтено при следующем платеже. «Нераспределенный» НДФЛ нигде не хранится, вычисляется каждый раз из предыдущих документов, поэтому после изменения любого документа необходимо просчитать и провести все последующие.

Кроме того обязательно надо в конфигурации в табличной части документа "ПеречислениеНДФЛВБюджет" реквизиту «Сумма» установить признак «Итог по колонке».

 

И напоследок совет. Не забудьте про переходящие отпуска.

Поясню подробнее.

Процедура учета перечислений действует с 2011года, поэтому первым документом, который вводят, обычно является перечисление НДФЛ за январь в первых числах февраля. Никто не вспоминает, что были сотрудники, ушедшие в отпуск в декабре, и им был насчитан НДФЛ за январь 2011 года. И этот НДФЛ перечислен вместе с декабрьским по всем остальным сотрудникам. Так вот, чтобы он тоже оказался в нужном месте в регистре налогового учета, нужно ввести вручную еще один документик по перечислению НДФЛ за январь с датой платежки по декабрьскому НДФЛ. Таких людей обычно немного, и это нетрудно сделать.

Аналогично надо поступить с отпусками, переходящими на 2012 год.

 

Примечание. Описанная методика успешно протестирована на трех базах ЗиК, релизы 7.7.320 и 7.7.321 численностью от 30 до 160 человек.

Изм. от 11.03.2012

По совету http://infostart.ru/profile/28861/ уточнен подсчет факта переплаты НДФЛ (рассматривается период с начала года).

Включена возможность отрицательной суммы к уплате в случае возврата НДФЛ сотруднику (именно так хочет налоговый кодекс),.

Добавлена новая проверка: в случае, если по строкам документа сумма получается больше суммы платежки, тогда, начиная с самых крупных налогоплательщиков, суммы сотрудников уменьшаются, выравниваясь с суммой платежа.

По просьбам читателей после расчета из таблицы удаляются строки с нулевыми суммами.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ЗаполнитьТаблицуНалогов
.txt 8,04Kb
11.03.12
242
.txt 8,04Kb 242 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

. Maxim (the1) 02.03.12 13:06
sam41, спасибо за наводку. Однако оригинальный модуль у меня не пошел, т.к. налоги платятся неравномерно + есть отрицательные суммы НДФЛ, соответственно в итог за год я не вышел. Причина, ПМСМ, кроется в том, что Вы запретили "переплачивать" НДФЛ в конкретном месяце. А смотреть надобно ширше, переплачивать нельзя по итогам года! Я тут немножко изменил, текст прилагаю, предлагаю потестить.

Процедура ЗаполнитьТаблицуНалогов(СписокСотрудников,ТаблицаНалогов,ДоходыВычетыНалогиСотрудников,Режим = 0)

ТаблицаНалогов.НоваяКолонка("СуммаУдержаноВсего", "Число");
ТаблицаНалогов.НоваяКолонка("СуммаПеречисленоВсего", "Число");

НомерМесяца = ДатаМесяц(МесяцНалоговогоПериода);
ОкончаниеГода = КонГода(МесяцНалоговогоПериода);

Ставка13 = Константа.СтавкаНДФЛсЗарплатыРезидентов.Получить(ОкончаниеГода);
Ставка35 = Константа.СтавкаНДФЛсПрочихДоходовРезидентов.Получить(ОкончаниеГода);
Ставка9 = Константа.СтавкаНДФЛсДивидендов.Получить(ОкончаниеГода);
Ставка30 = Константа.СтавкаНДФЛсДоходовНеРезидентов.Получить(ОкончаниеГода);
Ставка15 = Константа.СтавкаНДФЛсДивидендовНеРезидентов.Получить(ОкончаниеГода);

ВсегоСотрудников=СписокСотрудников.РазмерСписка();
Для ИндексСотрудникаВСписке = 1 По ВсегоСотрудников Цикл

глСтатусСтрока(Контекст,"Рассчитываются суммы налога ("+Окр(ИндексСотрудникаВСписке/ВсегоСотрудников*100)+"%)");

СотрудникИзСписка = СписокСотрудников.ПолучитьЗначение(ИндексСотрудникаВСписке);

Резидент=глПолучитьСтатусРезидентаРасчет(СотрудникИзСписка,ОкончаниеГода);
СтатусРезидента=глПолучитьСтатусРезидентаРасчет(СотрудникИзСписка,КонМесяца(МесяцНалоговогоПериода));
СтатусРезидента = ?(Резидент <> 1,Резидент,СтатусРезидента);

Если ((Ставка = Ставка30) или (Ставка = Ставка15)) и (СтатусРезидента = 1) Тогда
Продолжить;
ИначеЕсли ((Ставка = Ставка13) или (Ставка = Ставка35) или (Ставка = Ставка9)) и (Резидент=2) Тогда
Продолжить;
КонецЕсли;

СтрокаИтоговойТаблицы = ИндексСотрудникаВСписке*12 - 12 + НомерМесяца;
// во 2 колонке - таблица доходов
// доходы смотрим за МесяцНалоговогоПериода месяц нарастающим итогом за год
ТаблицаДоходов = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,2);

Если ТипЗначения(ТаблицаДоходов) <> 100 Тогда // доходов не было
Продолжить
ИначеЕсли ТаблицаДоходов.КоличествоСтрок() = 0 Тогда // доходов не было
Продолжить
КонецЕсли;

ПодразделениеСотрудника = ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,"Подразделение");
//получим ОКАТО и КПП
НомСтроки = "";
ОКАТО_КПП_Сотрудника = "";
Если ТаблицаКодовОКАТО.НайтиЗначение(ПодразделениеСотрудника, НомСтроки, "Подразделение")=1 Тогда
ТаблицаКодовОКАТО.ПолучитьСтрокуПоНомеру(НомСтроки);
ОКАТО_КПП_Сотрудника = СОКРЛП(ТаблицаКодовОКАТО.ОКАТО)+"/"+СОКРЛП(ТаблицаКодовОКАТО.КПП)
КонецЕсли;
Если ОКАТО_КПП_Сотрудника <> СОКРЛП(ОКАТО_КПП) Тогда
Продолжить;
КонецЕсли;

СуммаНалогаУдержанная = 0;
СуммаНалогаУдержаннаяВсего = 0;

Если (Ставка = Ставка13) или (Ставка = Ставка30) Тогда

НомерКолонки = ?(ЗаполнятьПоНачисленному=1,4,"НУ1");

СуммаНалогаУдержанная = Окр(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,НомерКолонки));
СуммаНалогаУдержаннаяВсего = СуммаНалогаУдержанная;
Если НомерМесяца>1 Тогда
СуммаНалогаУдержанная = СуммаНалогаУдержанная - Окр(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,НомерКолонки));
КонецЕсли;

КонецЕсли;


Если (Ставка = Ставка35) или (Ставка = Ставка30) Тогда

СуммаНалогаУдержанная = СуммаНалогаУдержанная + Окр(глВСуммуИзСтроки_НДФЛ(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,12)));
СуммаНалогаУдержаннаяВсего = СуммаНалогаУдержаннаяВсего + Окр(глВСуммуИзСтроки_НДФЛ(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,12)));
Если НомерМесяца>1 Тогда
СуммаНалогаУдержанная = СуммаНалогаУдержанная - Окр(глВСуммуИзСтроки_НДФЛ(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,12)));
КонецЕсли;

КонецЕсли;

Если (Ставка = Ставка9) или (Ставка = Ставка15) Тогда

СуммаНалогаУдержанная = СуммаНалогаУдержанная + Окр(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,11));
СуммаНалогаУдержаннаяВсего = СуммаНалогаУдержаннаяВсего + Окр(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы,11));
Если НомерМесяца>1 Тогда
СуммаНалогаУдержанная = СуммаНалогаУдержанная - Окр(ДоходыВычетыНалогиСотрудников.ПолучитьЗначение(СтрокаИтоговойТаблицы-1,11));
КонецЕсли;

КонецЕсли;

Если (СуммаНалогаУдержанная > 0) или (СуммаНалогаУдержаннаяВсего > 0) или (Режим = 1) Тогда
ТаблицаНалогов.НоваяСтрока();
ТаблицаНалогов.Сотрудник = СотрудникИзСписка;
ТаблицаНалогов.СуммаУдержано = ?(СуммаНалогаУдержанная>0, СуммаНалогаУдержанная, 0);
ТаблицаНалогов.СуммаУдержаноВсего = ?(СуммаНалогаУдержаннаяВсего>0, СуммаНалогаУдержаннаяВсего, 0);
КонецЕсли;

КонецЦикла;

// уменьшим суммы в таблице на величину, уже введенную другими документами ПеречислениеНДФЛВБюджет за этот же период
// заодно определим, сколько нераспределенного перечисленного налога осталось от предыдущих документов
Нераспределено = 0;

ДокДляПроверки = СоздатьОбъект("Документ.ПеречислениеНДФЛВБюджет");
ДокДляПроверки.УстановитьФильтр(1,0);
ДокДляПроверки.ВыбратьДокументы(,ТекущийДокумент()); // подумать, как сократить выборку
Пока ДокДляПроверки.ПолучитьДокумент() = 1 Цикл

Если ДокДляПроверки.ОКАТО_КПП <> ОКАТО_КПП Тогда
Продолжить;
ИначеЕсли ДокДляПроверки.Ставка <> Ставка Тогда
Продолжить;
КонецЕсли;

Если ДокДляПроверки.ТекущийДокумент() = ТекущийДокумент() Тогда
Прервать;
КонецЕсли;

Если КонМесяца(ДокДляПроверки.МесяцНалоговогоПериода)=КонМесяца(МесяцНалоговогоПериода) Тогда
ДокДляПроверки.ВыбратьСтроки();
Пока ДокДляПроверки.ПолучитьСтроку()=1 Цикл
ТаблицаНалогов.НоваяСтрока();
ТаблицаНалогов.Сотрудник = ДокДляПроверки.Сотрудник;
ТаблицаНалогов.СуммаУдержано = -ДокДляПроверки.Сумма;
КонецЦикла;
КонецЕсли;

ДокДляПроверки.ВыбратьСтроки();
Пока ДокДляПроверки.ПолучитьСтроку()=1 Цикл
Если СписокСотрудников.НайтиЗначение(ДокДляПроверки.Сотрудник) <> 0 Тогда
ТаблицаНалогов.НоваяСтрока();
ТаблицаНалогов.Сотрудник = ДокДляПроверки.Сотрудник;
ТаблицаНалогов.СуммаПеречисленоВсего = ДокДляПроверки.Сумма;
КонецЕсли;
КонецЦикла;

Нераспределено = Нераспределено + ДокДляПроверки.СуммаПеречислено - ДокДляПроверки.Итог("Сумма");

КонецЦикла;

ТаблицаНалогов.Свернуть("Сотрудник", "Сумма,СуммаУдержано,СуммаУдержаноВсего,СуммаПеречисленоВсего");
ТаблицаНалогов.НоваяКолонка("Коэффициент", "Число");

ВсегоУдержано = ТаблицаНалогов.Итог("СуммаУдержано");
Если ВсегоУдержано=0 Тогда
Возврат;
КонецЕсли;

ТаблицаНалогов.Сортировать("Сотрудник");

Коэффициент = (СуммаПеречислено + Нераспределено) / ВсегоУдержано;
//Коэффициент = Мин(Коэффициент, 1); //больше начисленного не записываем!

ТаблицаНалогов.ВыбратьСтроки();
Пока ТаблицаНалогов.ПолучитьСтроку()=1 Цикл
ТаблицаНалогов.Коэффициент = Коэффициент;
ТаблицаНалогов.Сумма = ОКР(ТаблицаНалогов.СуммаУдержано * Коэффициент, 0);
Дельта = ТаблицаНалогов.СуммаУдержаноВсего - (ТаблицаНалогов.Сумма + ТаблицаНалогов.СуммаПеречисленоВсего);
Если Дельта < 0 Тогда // образовалась переплата, больше начисленного не записываем!
ТаблицаНалогов.Сумма = Макс(ТаблицаНалогов.Сумма + Дельта, 0)
КонецЕсли;
КонецЦикла;

КонецПроцедуры // ЗаполнитьТаблицуНалогов


Да, и обязательно исправьте в определении ТаблицаНалогов, чтобы колонки суммы были именно числовыми, т.к. при сворачивании суммирование по пустому полю обнуляет (точнее опустошает) колонку.
0. Александр Музыченко (sam41) 29.02.12 16:15
Доработка конфигурации ЗиК 7.7 релизы 320-322 с целью улучшить распределение сумм перечисленного НДФЛ по сотрудникам. Полезна, если Вы хотите видеть "красивые" регистры налогового учета по НДФЛ - с подробной расшифровкой перечисленных налогов до даты платежа и номера платежки. Ну и разумеется годовую отчетность по НДФЛ в полном соответствии с этими регистрами.
Внимание! Если Вам просто надо показать в справке/отчете 2-НДФЛ перечисленную сумму равной начисленной и удержанной, - можно дальше не читать, а сразу идти сюда: http://infostart.ru/public/115064/

Перейти к публикации

1. andrewks 29.02.12 16:15
Если Строка(ДокДляПроверки) = Строка(ТекущийДокумент()) Тогда//по другому не получается!
			Прервать;
		КонецЕсли;
...Показать Скрыть


заменить на

Если ДокДляПроверки.ТекущийДокумент() = ТекущийДокумент() Тогда//по другому получается!!!
			Прервать;
		КонецЕсли;
...Показать Скрыть


также
Если ДокДляПроверки.Проведен()=0 Тогда
			Продолжить;
		КонецЕсли;
...Показать Скрыть


в топку, вместо этого использовать
ДокДляПроверки.УстановитьФильтр(1,0);
перед выборкой
JER_MARK; Трям; +2 Ответить 1
2. andrewks 29.02.12 16:20
и ещё: не вижу, как учитываются в дальнейшем те суммы, которые "зависают" (разность между общей суммой перечисления, и итогом по колонке ТЧ)
3. Александр Музыченко (sam41) 01.03.12 01:15
(1) andrewks, Спасибо за поправки, включил в текст модуля. Про метод "УстановитьФильтр()" для документа вообще раньше не знал, особое спасибо, буду использовать.
4. Александр Музыченко (sam41) 01.03.12 01:25
(2) andrewks,

В переменной "Нераспределено" после цикла по имеющимся документам находится сумма нераспределенного НДФЛ. Довольно коряво, но я так и не придумал, где эту сумму можно сохранить. Ни регистров, ни счетов в ЗиК нету. Можно справочник создать с периодическими реквизитами, - тоже как-то некрасиво. В общем нигде эта сумма не сохраняется, каждый раз перебирает все документы с начала и вычисляет ее.
Да, я сразу не подчеркнул: чтобы все корректно работало, надо документы просчитать/провести последовательно друг за другом.
5. andrewks 01.03.12 10:55
кстати, большой вопрос, как правильно поступать с суммами переплат. возможно, в течение налогового периода (года) и разумно оставлять их "на потом", а вот как быть с декабрём? по-любому надо их кому-то раскидать, иначе оплата не сойдётся. или ИФНС не проверяет соответствие показанных сумм уплаты фактическим? или она так и должна остаться, и её можно автоматом учесть как оплату в 2012-м году? и надо ли в этом случае писать на эту тему письмо в ИФНС (чтобы зачесть переплату с 2011 г на 2012 г)?

кто уже сдавал, поделитесь инфой на эту тему
6. Александр Музыченко (sam41) 01.03.12 11:09
(5) andrewks,
Насколько я знаю, переплата налога (любого) не учитывается при определении расходов организации. То есть можешь хоть в три раза больше перечислить, но в расходы включай только то, что реально начислено. Тогда получается, что и в справке/отчете по НДФЛ нет смысла показывать лишние перечисления.
Мое мнение: сдавать чтобы перечислено = удержано и заявление в ИФНС о зачете переплаты налога в счет предстоящих платежей.
7. Ula1c (ula1c) 01.03.12 12:20
(5) andrewks, Переплата по НДФЛ не может быть распределена по людям. Это вытекает из нижеследующего письма (выделение мое):

МИНИСТЕРСТВО ФИНАНСОВ РОССИЙСКОЙ ФЕДЕРАЦИИ
ФЕДЕРАЛЬНАЯ НАЛОГОВАЯ СЛУЖБА
ПИСЬМО
от 4 июля 2011 г. № ЕД-4-3/10764

Федеральная налоговая служба рассмотрела письмо о возврате суммы налога на доходы физических лиц, излишне перечисленной в бюджетную систему Российской Федерации, и сообщает.

Налоговые агенты согласно п. 6 ст. 226 Налогового кодекса Российской Федерации (далее - Кодекс) обязаны перечислять суммы исчисленного и удержанного налога не позднее дня фактического получения в банке наличных денежных средств на выплату дохода, а также дня перечисления дохода со счетов налоговых агентов в банке на счета налогоплательщика либо по его поручению на счета третьих лиц в банках.

При этом п. 9 ст. 226 Кодекса установлено, что уплата налога за счет средств налоговых агентов не допускается.

Статьей 231 Кодекса за счет предстоящих платежей по налогу предусмотрен только возврат налогоплательщику излишне удержанной суммы налога.

В данном случае перечисленная в бюджетную систему Российской Федерации сумма, превышающая сумму фактически удержанного из доходов физических лиц налога на доходы физических лиц, не является налогом на доходы физических лиц. Перечисление указанной суммы произведено неправомерно.

Наличие переплаты не освобождает налогового агента от обязанности перечислить в бюджетную систему Российской Федерации сумму налога, фактически удержанного из доходов физических лиц, выплачиваемых в более поздние сроки.

В рассматриваемой ситуации налоговому агенту необходимо обратиться в налоговый орган с заявлением о возврате на расчетный счет организации суммы, не являющейся налогом на доходы физических лиц и ошибочно перечисленной в бюджетную систему Российской Федерации.

Таким образом сдавать нужно перечислено<=удержано. Если есть переплата, то заявление в ИФНС, сверка, проверка (выездная/камеральная) и возврат ее на расчетный счет налогового агента.
Однако, по мнению клиентов-бухгалтеров, почти все хотят включить переплату на конец 2010г. в платежи 2011г, т.к. у них при проверках НДФЛ в прошлые годы уплату НДФЛ проверяли в общей сумме за несколько лет.
Вообще со сдачей НДФЛ как-то до сих пор не сложилась однотипная практика, соответствующая требованиям НК. Кто во что горазд- кто-то НДФЛ будущего года (отпускные) требует включить в файл за текущий год, аргументируя тем, что мне надо чтобы К68.1 шел с исчисленным в реестре и все. Другие требуют точно разделить НДФЛ текущего года, убрав из него НДФЛ прошлого ( в случае корректировки начисленной ЗП прошлого года в текущем) и будущего года (отпускные), т.е.как в 1С и прекрасно ориентируются в своем 68.1. Но в моей практике НФНС до сих пор принимала оба эти варианта.
Думаю в плане учета НДФЛ ИФНС приближается к системе ПФ. Хотелось бы узнать сегодняшний опыт сдачи НДФЛ.
8. andrewks 01.03.12 13:25
что-то начинает потихоньку проясняться.

вот официальная позиция 1С:

============================================================­====================
Если же перечисленная сумма больше удержанной суммы налога, то она полностью будет распределена между физическими лицами, в результате будет зарегистрирован тот факт, что по каждому физическому лицу налога перечислено больше, чем положено (удержано). В этом случае из учета не только будет полностью списана необходимость перечислить по каждому физическому лицу сумму налога, но и будет зарегистрирован излишне перечисленный налог, т.е. "необходимость со знаком минус". Такая необходимость на последующие месяцы налогового периода не переносится, т.е. не может быть зачтена при регистрации необходимости перечислить удержанный по этому физическому лицу налог за другой месяц налогового периода, по другой ставке налога, по другим кодам ОКАТО и КПП. Такой подход основывается на положениях НК РФ и подтверждается письмом ФНС от 19 октября 2011 г. N ЕД-3-3/3432@, в котором сказано:

"… ежемесячное перечисление в бюджет суммы, превышающей сумму фактически удержанного из доходов физических лиц налога на доходы физических лиц, не является налогом. В таком случае налоговому агенту следует обратиться в налоговый орган с заявлением о возврате на расчетный счет организации суммы, не являющейся налогом на доходы физических лиц и ошибочно перечисленной в бюджетную систему Российской Федерации."

Поэтому следует с осторожностью перечислять суммы НДФЛ в бюджет и соответственно отражать этот факт в программе. Если все-таки была перечислена сумма большая, чем полагается, то в программе этот факт регистрировать не следует, т.е. в качестве общей суммы следует указать сумму равную удержанной, а сумму, не являющуюся налогом, вернуть из ФНС. Автоматических средства контроля такой переплаты типовая конфигурация не содержит.
============================================================­====================
http://its.1c.ru/db/metod81#content:4701:1

т.е. 1С открыто признаётся, что реализовала распределение уплаты НДФЛ методологически неправильно, но, несмотря на это, видимо, не собирается это исправлять, а спихивает всё на бухов.

зато в ЗУП реализовали ведение и отслеживание переходящих сальдо в разрезе сотрудников, чего нет, и видимо, уже не будет в типовом ЗиК
9. andrewks 01.03.12 18:23
(4) я увидел только учёт в текущем документе нераспределённых сумм, оставшихся от предыдущих платёжек за этот же месяц. но никак не рассматривается и не решается проблема нераспределённых сумм, оставшихся от платёжек за предыдущие месяца этого же налогового периода (года).
т.е., если переплата зависла после платежа за апрель (в мае), то при распределении за май, июнь и т.д., она уже никак не учтётся, и фактически "зависнет"

надо будет подумать над этой проблемой
10. Александр Музыченко (sam41) 01.03.12 19:35
(9) andrewks,
Неправда, в нераспределенные попадают суммы за все предыдущие месяцы, я только что еще раз посмотрел.
11. andrewks 01.03.12 20:59
(10) да, каюсь, невнимательно посмотрел. учитывать-то она их учитывает, но увеличивает сумму в текущем документе, т.е. итог по колонке должен получиться больше, чем сумма платёжки, а это не есть гут, на мой взгляд. вроде, так получается, поправь, если ошибаюсь.

просто я пока смотрю только код в текстовике, на рабочих базах пока не гонял. в ближайшее время планирую заняться этим вплотную, тогда и видно будет, можно будет ещё малясь допилить этот алгоритм, или придётся с нуля что-то ваять, чтобы полностью обрабатывались всякие сложные случаи
12. Александр Музыченко (sam41) 01.03.12 21:15
(11) andrewks,

Ну да, увеличивается сумма в текущем документе, а куда ее еще девать? К сумме текущей платежки прибавляется переплата/недоплата с предыдущих платежек и все вместе распределяется по людям. По-моему так и надо...
13. andrewks 01.03.12 21:31
(12) ну вот представь себе - будет камералить предприятие налоговик. что он запросит? правильно, регистры по НДФЛ. начнёт проверять, сложит суммы по сотрудникам по конкретной платёжке - получится, например, 3000. а сама платёжка на 2500. и что после этого подумает налоговик?

думаю, более правильно добавить суммы/сотрудников в тот документ, где осталась нераспределённая сумма, чтобы суммы сравнялись. это, вроде, не противоречит НК:
"...обязаны перечислять суммы исчисленного и удержанного налога не позднее дня фактического получения в банке наличных денежных средств на выплату дохода..."
16. NPMar (NPMar) 05.03.12 08:57
Ув. Maxim, Вы конечно же правы! Расчетчик тупо перечисляет 13% от выплаты, не учитывая вычеты по сотрудникам, возвраты налога и имущественные вычеты. Если большая численночсь, он же не будет проверять каждого человека.
Поэтому налог, как правило перечисляется больше. Кроме того, одному человеку может быть перечислено в течение месяца более одного раза. Попробую проверить, как будет работать эта обработка в таких ситуациях.
17. Любовь Жаткина (Полковник) 05.03.12 23:14
Доброе время суток, ребята, а как быть если расчетчики до середины года бросали аванс и з/плату на НДФЛ что называется "приблизительно", но всегда с плюсом (так сказать на всякий случай, что бы не было недоимки). Потом прочитали внимательно очередное письмо, спохватились и стали перечислять налог соответственно по начисленным суммам, естественно не учитывая переплату, которая сложилась на середину года?
Ув.SAM41 получается, мне все документы по перечислению надо тянуть с января 2011г? Правильно я понимаю? И тогда вся переплата будет видна в декабре 2011? Или я ее не увижу?
18. Александр Музыченко (sam41) 05.03.12 23:29
(17) Полковник, если все документы последовательно рассчитать и провести, то да, в последнем будет видна переплата. То есть она напрямую не видна, надо вычесть из суммы платежки сумму по строкам документа, которая показана справа от табличной части.
19. Александр Музыченко (sam41) 05.03.12 23:31
(15) Maxim, мысль разумная, обязательно попробую, только чуть позже.
20. Любовь Жаткина (Полковник) 06.03.12 01:56
(18) sam41, тогда еще один вопрос:
Вы пишите, что по суммам 2010г (переходящие отпуска) нужно сделать док. перечисления. Я тоже так считала, но если задуматься получается:
1. часть начислений отпуска падает на январь 2011г.
2. начисления НДФЛ также на январь 2011г., но выплачиваем отпускные и перечисляем НДФЛ в декабре 2010.
Если посмотреть регистр в ЗиКе, то и отпускные и НДФЛ видны в январе, фактически завышен исчисленный и уплаченный налог (потому что за него уже отчитывались в 2010г.) и включали в доход (видно по справке 2-ндфл за 2010г.) Скорее всего надо вносить корректировку в регистр и убирать начисление отпуска приходящееся на январь 2011г.?
21. Любовь Жаткина (Полковник) 06.03.12 02:26
Простите, пожалуйста, еще раз перепроверила. Действительно суммы приходящиеся на 2011г. в 2010г. не прошли, поэтому их надо показывать в 2011г.
22. Александр Музыченко (sam41) 06.03.12 07:49
(21) Полковник, именно так. Я делаю следующим образом. Открываю свод начислений и удержаний, на закладке "Настройка" ставлю отметку "Разбивать по периодам действия", формирую свод за декабрь 2010. Вижу сумму НДФЛ, отнесенную на январь 2011 и на эту сумму создаю документ "Перечисление НДФЛ". Дата и номер платежки - та, которой перечисляли в январе за декабрь, а сам налог - за январь 2011.
23. andrewks 06.03.12 09:32
(15) что-то у меня не взлетело. во-первых, минуса всё-таки не пропускает (т.е. когда в месяце прошёл возврат НДФЛ по сотруднику), распределяя при этом разницу по другим сотрам. во-вторых, делает нулевые строчки. (2-й пункт, конечно, мелочь, но некрасиво)
24. Любовь Жаткина (Полковник) 06.03.12 10:07
Спасибо. Только мы в декабре перечисляли. Вся зарплата декабря и налоги перечислены 30-31 декабря.
25. Александр Музыченко (sam41) 06.03.12 11:07
(23) andrewks, возврат НДФЛ по сотруднику оформлен документом "Возврат НДФЛ"? В регистре по НДФЛ этот минус виден?
26. andrewks 06.03.12 11:43
(25) нет, ситуация немного иная. в декабре у сотрудника не было дохода, а вычет применился. соответственно, НДФЛ получился с минусом. перечислена была общая сумма НДФЛ, естественно, с учётом этого минуса. но при распределении этот минус не записывается в документ, а у остальных сотрудников происходит неоправданное увеличение сумм перечисленного НДФЛ
27. Александр Музыченко (sam41) 06.03.12 12:04
(26) andrewks, это другая тема. Это про то, как считается НДФЛ удержанный, моя доработка эти вопросы не регулирует. В регистре этого минуса ведь нет, правильно?
30. andrewks 07.03.12 13:40
(27) тема та же. если НДФЛ исчисленный/удержанный идёт минусом, нужно это отразить и в расчётах, иначе как у вас сойдётся 2-НДФЛ по году?
31. Александр Музыченко (sam41) 07.03.12 16:12
(30) andrewks, Повторяю вопрос: В регистре по НДФЛ есть минус удержанного налога или нет?
32. andrewks 07.03.12 16:30
(31) на пальцах: Регистр формируется за налоговый период (год), а начисление и перечисление производятся ежемесячно. чувствуешь разницу?

в Регистре картина такая: (например), удержано налога 1500, перечислено 1550 (т.е. переплата по сотру), в то время, как этих 50-ти рублей не хватает в перечислених по другим сотрам
33. Александр Музыченко (sam41) 07.03.12 16:35
(32) andrewks, ну если уж на пальцах, тогда давай называй три цифры: НДФЛ начисленный, НДФЛ удержанный, НДФЛ перечисленный. И все целиком за год.
34. andrewks 07.03.12 16:52
35. Александр Музыченко (sam41) 07.03.12 16:59
(34) andrewks, ага, проясняется. Давай теперь регистр по НДФЛ сформируй по этому человечку, раздел 6 меня интересует.
37. Александр Музыченко (sam41) 07.03.12 17:41
(36) andrewks, да, что-то не так. Нет, как раз цифры в разделе 6 все совпали (это и есть цель данной публикации), но мне не нравится оплата на отрицательную сумму. Попробую у себя воспроизвести, подумаю. Надо кстати почитать, как вообще в таком случае регистр должен выглядеть...
38. andrewks 07.03.12 17:47
(37) представленная картина - не результат работы твоего алгоритма, а ручная разноска. результат работы твоего алгоритма (и предложенного алгоритма в (15) ) я описал в (32)

я сейчас ваяю свой алгоритм :)

по поводу отрицательной оплаты - да, конечно, на первый взгляд, немного режет глаз, но если вдуматься - по другому не сведёшь к правильным итогам
39. Александр Музыченко (sam41) 07.03.12 17:51
(38) andrewks, Пока не соглашусь. Надо разобраться, что считать "правильными итогами". Я заинтересовался, постараюсь выяснить, сообщу.
40. andrewks 09.03.12 23:56
(39) к сожалению, бухгалтеры торопят, так что пришлось сварганить свой алгоритм.
выложил на обсуждение: http://infostart.ru/public/120119/
41. Александр Музыченко (sam41) 10.03.12 23:30
(40) andrewks, по поводу отрицательного НДФЛ в колонке уплачено: я пришел к точно такому же выводу, он должен там быть, однозначно...
42. Александр Музыченко (sam41) 12.03.12 13:23
Протестировал алгоритм на базе в 420 человек со ставками 13 и 35%, все цифры встали на места. Проверял распределение и по начисленному НДФЛ, и по удержанному. Суммы отличаются, но за год все закрывается верно. Перечисляли с запасом.

Сейчас на очереди база около 900 человек, - не работает алгоритм. В этой базе обособленные подразделения, больше 20 разных ОКАТО_КПП, при этом были месяцы, когда НДФЛ перечислялся не полностью. Вся сложность в том, что сотрудники переходили из одного подразделения в другое, поэтому надо где-то сохранять недоперечисленный налог в разрезе не только сотрудников, но и ОКАТО_КПП. По-видимому новый журнал расчета придется изобретать.
43. andrewks 12.03.12 14:13
44. Александр Музыченко (sam41) 12.03.12 17:35
45. andrewks 12.03.12 22:53
(44) а ты встречался с ситуациями, когда в течение года сотрудник перемещался из одного подразделения в другое, причём у этих подразделений разные ОКАТО/КПП?

в таком случае косят все обработки, найденные мной здесь, включая твою и мою :)
если встречался, есть мысли по доработке алгоритма с целью обработки данных случаев?
46. JER MARK (JER_MARK) 13.03.12 06:42
У меня как раз такое предприятие: 3 ОКАТО и сотрудники переходили из одного подразделения в другое.
Уже писала в комментах к другой обработке, что если сотруднику НДФЛ корректирвоался вручную через обработку Корректировка, то эти данные не учитываются при распределении.
47. Александр Музыченко (sam41) 13.03.12 07:37
(45) andrewks, пока мысль одна: забить на сумму платежки и распределить всем по начисленному (уплаченному). Ну то есть в модуле присвоить Коэффициент=1. Уж больно долго все способы выверять - 22 ОКАТО * 12 месяцев = 264 немаленьких документа. И все по порядку надо просчитывать.
48. andrewks 13.03.12 08:09
(47) ты всё-таки попробуй мой алгоритм. по замыслу и по практике, он пока правильно учитывает все ситуации, кроме перемещений сотрудника между разными ОКАТО/КПП и ручных корректировок регистра
49. andrewks 13.03.12 08:11
(46) в ближайшие пару дней планирую реализовать это в своём алгоритме. посматривай сюда: http://infostart.ru/public/120119/
50. Александр Музыченко (sam41) 13.03.12 08:21
(46) JER_MARK, а что за проблемы с ручными корректировками? Ведь при распределении вызывается процедура глСобратьДанныеДляНДФЛ(), она все ручные исправления обрабатывает, в чем загвоздка? Может просто в документе поставить переключатель "По удержанному"?
51. andrewks 13.03.12 08:37
(50) по моему мнению, режим "По удержанному" изначально эпик фэйл
52. andrewks 13.03.12 08:38
(50) "она все ручные исправления обрабатывает" в штатной процедуре данные берутся не из той колонки, из какой надо, и вообще, как оказалось, по неправильному алгоритму. отсюда и проблемы при перемещениях сотрудника между разными ОКАТО/КПП и ручных корректировок регистра
53. JER MARK (JER_MARK) 13.03.12 08:56
(51) andrewks, а что такое эпик фэйл?
54. JER MARK (JER_MARK) 13.03.12 08:58
Мое предприятие использует по удержанному - и мы убедились, что ручные корректировки не берет. Этот момент я добавляла в модуль сама.
55. berezin berezin (berezin) 13.03.12 08:59
Взял Ваш алгоритм и запихнул его в обработку http://infostart.ru/public/120493/ , которая бежит по документам Перечисление НДФЛ в бюджет и правит суммы.
У меня порядка 40 бюджетных баз с кучей платежек (Оплата НДФЛ по КБК более десятка платежек за каждый месяц). Устал пробовать алгоритмы, чтобы свести концы с концами.
Спасибо за алгоритм. Всё более или менее срастается, кроме организации с 5 ОКАТО
56. Арутюн (harutyunb) 13.03.12 15:09
(55) berezin, я посмотрел обработку хорошая!
57. Александр Музыченко (sam41) 13.03.12 15:53
(55) berezin, вот за это спасибо, сам собирался сделать, но руки не дошли. А теперь уже и не буду :)
58. элла иванова (2011b11) 13.03.12 17:30
спасибо будем пробывать
59. andrewks 15.03.12 08:25
(47) выложил новую версию своего алгоритма, который как раз должен учитывать такие ситуации.
тестировал на большом предприятии, год закрылся нормально.

особое внимание нужно уделять контролю переходящих отпусков - видимо, в данных ситуациях ничего более правильного, как вручную разнести суммы по таким сотрудникам и разделить платёжки при перечислении (т.к. часть нужно перечислить за 2011 год, а часть - за 2012 год), не придумаешь без ощутимых вмешательств в конфу
60. Александр Музыченко (sam41) 15.03.12 08:45
(59) andrewks, про отпуска я с самого начала говорил. С них и надо начинать подготовку отчетности по НДФЛ.
61. andrewks 15.03.12 09:12
(60) всё гораздо хуже. начинать нужно уже при расчёте и перечислении НДФЛ с отпускных. тогда не надо будет "начинать" с них подготовку отчётности
62. Александр Музыченко (sam41) 15.03.12 10:00
(61) andrewks, Это как это??? Что именно можно сделать при расчете НДФЛ с переходящих отпусков?
63. Clod (Clod) 15.03.12 11:57
Кто-нибудь пробовал подобные обраобтки для 8-ки? Есть проверенные варианты?
64. Александр Музыченко (sam41) 15.03.12 12:48
(63) Clod, я слышал, что там все правильно считается, разве не так?
65. Clod (Clod) 15.03.12 13:28
(64) переходящие отпуска, выплата отпускных каждые 3 дня, возвраты ндфл - все эти события сильно мешают правильному распределению. Во всяком случае мне не удалось штатными средствами добиться "красоты".
66. andrewks 15.03.12 13:53
(62) ну смотри сам. давай для простоты представим такую картину с круглыми цифрами:

чел отправлен в отпуск с 15.12.11 по 15.01.12, отпускных всего 20000, в т.ч. за период декабрь 2011 г. 10000 (НДФЛ 1300), за период январь 2012 г. 10000 (НДФЛ 1300), но расчёт и выплата отпускных происходит в декабре 2011 г, и перечиление НДФЛ тоже нужно сделать не позднее дня выдачи, т.е. в декабре 2011 г.: 20000 (НДФЛ 1600)

радостный бух делает одну платёжку на 2600, указывая налоговый период - декабрь 2011 г.
а потом, когда приходит время сдавать отчётность по НДФЛ за 2011 год, с ужасом обнаруживает, что, оказывается, за декабрь 2011 г. она переплатила, а за январь 2012 - недоплатила, и никакими распределениями, никакими хитромудрыми алгоритмами это уже не исправишь. единственный вариант - за январь НДФЛ доплатить, а про декабрьский уведомить сотрудника, содрать с него заявление на возврат, вернуть НДФЛ сотруднику (только безналичным платежом!) самой написать заявление на возврат в налоговую, и только после камералки эти деньги, может быть, вернут фирме на счёт
67. andrewks 15.03.12 13:57
+(66) а как надо было сделать:
заплатить двумя разными платёжками, в одной на 1300 указать период - декабрь 2011, во второй на 1300 - указать январь 2012, и разносу в ЗиК, соответственно, делать тоже по разным периодам
69. Александр Музыченко (sam41) 15.03.12 18:03
(67) andrewks, понятно, все правильно говоришь. Я для себя несколько упрощаю эту ситуацию: пусть платежка будет одна, а в ЗиКе я делаю два документа перечисления, реквизиты платежки одинаковые, а периоды разные. Ну и суммы приходится вручную выставлять, конечно. Разумеется, это неправильно, и любая проверка докопается, если найдет. Но может не найдет, а?
70. Maxxi (Maxxi) 16.03.12 03:28
МИНИСТЕРСТВО ФИНАНСОВ РОССИЙСКОЙ ФЕДЕРАЦИИ
ФЕДЕРАЛЬНАЯ НАЛОГОВАЯ СЛУЖБА
ПИСЬМО
от 4 июля 2011 г. № ЕД-4-3/10764

Федеральная налоговая служба рассмотрела письмо о возврате суммы налога на доходы физических лиц, излишне перечисленной в бюджетную систему Российской Федерации, и сообщает.

Налоговые агенты согласно п. 6 ст. 226 Налогового кодекса Российской Федерации (далее - Кодекс) обязаны перечислять суммы исчисленного и удержанного налога не позднее дня фактического получения в банке наличных денежных средств на выплату дохода, а также дня перечисления дохода со счетов налоговых агентов в банке на счета налогоплательщика либо по его поручению на счета третьих лиц в банках.

При этом п. 9 ст. 226 Кодекса установлено, что уплата налога за счет средств налоговых агентов не допускается.

Статьей 231 Кодекса за счет предстоящих платежей по налогу предусмотрен только возврат налогоплательщику излишне удержанной суммы налога.

В данном случае перечисленная в бюджетную систему Российской Федерации сумма, превышающая сумму фактически удержанного из доходов физических лиц налога на доходы физических лиц, не является налогом на доходы физических лиц. Перечисление указанной суммы произведено неправомерно.
71. Александр Музыченко (sam41) 16.03.12 10:04
(70) Maxxi, так я и говорю, неправильно это! Но может не заметят...
72. andrewks 16.03.12 13:08
(71) что именно неправильно?
73. Mac RR (NewYork) 19.03.12 15:26
Если же перечисленная сумма больше удержанной суммы налога, то она полностью будет распределена между физическими лицами, в результате будет зарегистрирован тот факт, что по каждому физическому лицу налога перечислено больше, чем положено (удержано). В этом случае из учета не только будет полностью списана необходимость перечислить по каждому физическому лицу сумму налога, но и будет зарегистрирован излишне перечисленный налог, т.е. "необходимость со знаком минус". Такая необходимость на последующие месяцы налогового периода не переносится, т.е. не может быть зачтена при регистрации необходимости перечислить удержанный по этому физическому лицу налог за другой месяц налогового периода, по другой ставке налога, по другим кодам ОКАТО и КПП. Такой подход основывается на положениях НК РФ и подтверждается письмом ФНС от 19 октября 2011 г. N ЕД-3-3/3432@, в котором сказано:

"… ежемесячное перечисление в бюджет суммы, превышающей сумму фактически удержанного из доходов физических лиц налога на доходы физических лиц, не является налогом. В таком случае налоговому агенту следует обратиться в налоговый орган с заявлением о возврате на расчетный счет организации суммы, не являющейся налогом на доходы физических лиц и ошибочно перечисленной в бюджетную систему Российской Федерации."

Поэтому следует с осторожностью перечислять суммы НДФЛ в бюджет и соответственно отражать этот факт в программе. Если все-таки была перечислена сумма большая, чем полагается, то в программе этот факт регистрировать не следует, т.е. в качестве общей суммы следует указать сумму равную удержанной, а сумму, не являющуюся налогом, вернуть из ФНС. Автоматических средства контроля такой переплаты типовая конфигурация не содержит.
============================================================­====================
http://its.1c.ru/db/metod81#content:4701:1

т.е. 1С открыто признаётся, что реализовала распределение уплаты НДФЛ методологически неправильно, но, несмотря на это, видимо, не собирается это исправлять, а спихивает всё на бухов.

зато в ЗУП реализовали ведение и отслеживание переходящих сальдо в разрезе сотрудников, чего нет, и видимо, уже не будет в типовом ЗиК

это официальная позиция от какого числа??
для последнего релиза 1с зик имеет актуальность данная обработка?
74. Александр Музыченко (sam41) 19.03.12 16:00
(73) NewYork, на релизе 7.7.322 работает так же, как и на более ранних.
76. анка (анфиска) 21.03.12 23:38
Вот, интересно, если мы НДФЛ перечисляем, точно так как и происходят выплаты, а их по одному человеку может оказаться и две и три, то как тогда происходит закрытие НДФЛ??? А если человек уволен, то по нему уж точно он должен быть закрыт.
77. Александр Музыченко (sam41) 22.03.12 07:38
(76) анка, вот как раз для случая многократных перечислений за один месяц этот алгоритм и создавался. Уволенных никак не учитывает. Если перечислено больше, чем начислено, тогда они закроются, а если меньше - увы.
79. JER MARK (JER_MARK) 27.03.12 16:55
Добавлена новая проверка: в случае, если по строкам документа сумма получается больше суммы платежки, тогда, начиная с самых крупных налогоплательщиков, суммы сотрудников уменьшаются, выравниваясь с суммой платежа.

Вот это можно как-то отключать (на форме) или будет делаться по умолчанию? Мне кажется не все пригодная вещь
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа