gifts2017

Копирование табличной части документа, расширенное (управляемое приложение)

Опубликовал mxm2 mxm2 (mxm2) в раздел Обработки - Обработка документов

Развитие обработки http://infostart.ru/public/115007/, с расширенными возможностями, создавался для заполнения документа РаспределенияРасходовНаСебестоимостьТоваров в УТ11, но может использоваться с любыми другими документами.

Умеет брать часть информации для заполнения из Табличной части источника, а часть - просто заполнять указанным значением. Умеет создавать новый документ или дополнять существующий. Если объект приемник предварительно указан, то у него заполняется указанная ТЧ, если не указан, то создается новый и также заполняется указанная ТЧ, после заполнения объект приемник записывается, его можно открыть используя инструмент "Лупа" в строке формы "Приемник - Объект".

Скачать файлы

Наименование Файл Версия Размер
КопированиеТЧРасширенное.epf 185
.epf 9,14Kb
13.04.12
185
.epf 9,14Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Сергей (1C82) 28.03.12 04:15
Полезная обработка ! В УТ11 не хватает штатного механизма по копированию табличных частей между документами. Почему бы не сделать эту обработку стандартной и встраиваемой ? Тогда можно было бы претендовать на универсальность .
2. mxm2 mxm2 (mxm2) 28.03.12 14:52
Т.к. всеравно приходится "колбасить" УТ11, чтобы она работала как нужно, то сам включаю эту обработку непосредствеено в конфигурацию, а не использую механизм дополнительных отчетов и обработок.
3. mxm2 mxm2 (mxm2) 13.04.12 14:15
(1) 1C82, таки добавил регистарцию в доп обработках (проверено на УТ11)
4. Филипп (Филипп) 13.04.12 14:39
В ЗУП не работает, при запуске через Файл Открыть - просто промелькивает и все.
А при попытке подключить через "Заполнение табличных частей" сообщение об ошибке:
"Заполнение ТЧ не произведено!
Метод объекта не обнаружен (Инициализировать)
"
5. mxm2 mxm2 (mxm2) 13.04.12 15:08
(4) Филипп, ЗУП - использует обычные формы (не управляемые), поэтому возникает проблема. В свою очередь у меня сейчас нет возможности сделать универсальную обработку. Предлагаю искать подобную обработку для обычных форм, а она есть, причем очень древняя, проверенная-перепроверенная.
6. umka2008 (umka2008) 26.04.12 21:40
Спасибо за обработку - заточил немного под себя, бухи от счастья писают кипятком )))
7. юрий гулидов (gull22) 23.12.13 12:21
8. Константин Иванов (voyagerkonstantin) 24.06.15 10:57
Добрый день!
Спасибо за обработку, отлично работает.

Но есть одно неудобство. Копируем 95% случаев ТЧ одного определенного вида документа в другой определенный.
Можно как то заполнить значения полей в "Источнике" табличной части?
Т.е. чтобы поле приемника "Количество" всегда соответствовало поле источника "Количество" и т.д.

В коде разработки не могу понять где проставить. Это не значение по умолчанию, а "поля по умолчанию" если можно так назвать...

Помогите пожалуйста.
Прикрепленные файлы:
9. Константин Иванов (voyagerkonstantin) 29.06.15 07:41
Добрый день!
Спасибо за обработку, отлично работает.

Но есть одно неудобство. Копируем 95% случаев ТЧ одного определенного вида документа в другой определенный.
Можно как то заполнить значения полей в "Источнике" табличной части?
Т.е. чтобы поле приемника "Количество" всегда соответствовало поле источника "Количество" и т.д.

В коде разработки не могу понять где проставить. Это не значение по умолчанию, а "поля по умолчанию" если можно так назвать...

Помогите пожалуйста.


10. Константин Иванов (voyagerkonstantin) 29.06.15 08:53
Задача решена, привожу решение, возможно кому то пригодится. Для кнопки заполнения табличной части при копировании из накладной на внутреннее перемещение в документ ПересчетТовара:

Процедура ПоУмолчанию(Команда)
ТекСтрокаТаблЧасти = Элементы.КолонкиТЧОбъектов.ТекущиеДанные;
Для Каждого ТекСтрокаТаблЧасти Из КолонкиТЧОбъектов Цикл

Если ТекСтрокаТаблЧасти.КолонкаПриемника = "Количество" ИЛИ ТекСтрокаТаблЧасти.КолонкаПриемника = "КоличествоФакт" Тогда
ТекСтрокаТаблЧасти.Вкл = Истина;
ТекСтрокаТаблЧасти.КолонкаИсточника = "Количество";
КонецЕсли;
Если ТекСтрокаТаблЧасти.КолонкаПриемника = "КоличествоУпаковок" ИЛИ ТекСтрокаТаблЧасти.КолонкаПриемника = "КоличествоУпаковокФакт" Тогда
ТекСтрокаТаблЧасти.Вкл = Истина;
ТекСтрокаТаблЧасти.КолонкаИсточника = "КоличествоУпаковок";
КонецЕсли;
Если ТекСтрокаТаблЧасти.КолонкаПриемника = "Номенклатура" Тогда
ТекСтрокаТаблЧасти.Вкл = Истина;
ТекСтрокаТаблЧасти.КолонкаИсточника = "Номенклатура";
КонецЕсли;
КонецЦикла;

КонецПроцедуры
11. юрий гулидов (gull22) 30.12.15 09:37
Перестало работать на Бухгалтерия предприятия КОРП, редакция 3.0 (3.0.42.88) платформа 1С:Предприятие 8.3 (8.3.7.1805)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа