gifts2017

Настройка и сравнение прав

Опубликовал Денис Кожухов (imozg) в раздел Администрирование - Защита, права, пароли

Позволяет проверить настройку прав доступа не типовой конфигурации на соответствие правок внесенных внутренней службой сопровождения организации.

Основана на http://infostart.ru/public/19022/

Принцип работы обработки:

 

Для проверки прав необходимо указать базу эталон (например, последний релиз типовой конфигурации на которую производиться обновление) и внести в список настроек описание правок внутренней службы сопровождения. Права будут сверяться с базой эталоном, если обработка найдет правку прав в списке настроек, то эталонной будет считаться последняя. В виде дерева отображаются роли, под каждой из ролей отображаются объекты метаданных где права различаются, внутренние правки прав выделяются, при выделении этих записей, курсор в таблице настроек позиционируется на настройке соответствующей этой настройки. По этой таблице можно восстановить соответствие прав настройкам.

Доп. возможнсоти на 05.03.2012:

- Все настройки сохраняются в XML;

- Подсчет времени сравнения;

- При выполнении обработки высчитывается оставшее время до окончания сравления;

Видеобзор: (прошу прощения за "ээ... ууу... аа...", ну не диктор я, как мог, записал)

 

История обновления:

10.03.2012

- исправленны ошибки замеченные Рамзесом:

- Добавленна кнопка выбора файловой базы;

- Поле ввода пароля работает в "режиме пароля";

- Отлажена информация о подключении;

- Исправленны синтаксические ошибки;

Скачать файлы

Наименование Файл Версия Размер
Проверка настройки прав 149
.epf 41,29Kb
18.03.12
149
.epf 41,29Kb Скачать
Описание 34
.odt 16,29Kb
05.03.12
34
.odt 16,29Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Сергеев (Рамзес) 07.03.12 14:56
Отличная обработка, давно хотел сделать что-либо подобное, спасибо!
Есть ряд мелких замечаний:
1. В реквизите ПутьКФайловойБазе не хватает кнопки выбора (процедура есть - кнопки нет).
2. Для поля ввода "Пароль" хорошо бы установить режим "Ввод пароля".
3. Функцию ПодключитьсяКИнформационнойБазе лучше сделать так (чтобы понятней была информация об ошибках):
	БазаПодключена 	  = Ложь;		
	СтрокаПодключения = "";
	
	Попытка
		cntr = Новый COMObject("v82.COMConnector");		
		
		Если ПодключитьсяСервернойБазе = 1 Тогда
			Если ЗначениеЗаполнено(Сервер) И ЗначениеЗаполнено(БазаДанных) Тогда
				СтрокаПодключения =  "srvr='" + Сервер + "'; ref='" + БазаДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";	
			Иначе
				ВызватьИсключение "Не полностью указаны параметры подключения!";
			КонецЕсли;
		Иначе
			Если ЗначениеЗаполнено(ПутьКФайловойБазе) Тогда
				СтрокаПодключения = "File='" + ПутьКФайловойБазе + "'" + "; usr='" + Пользователь + "'; pwd='" + Пароль + "';";
			Иначе
				ВызватьИсключение "Не полностью указаны параметры подключения!";
			КонецЕсли;
		КонецЕсли;	
	Исключение
		Предупреждение("Не удалось создать COMObject! " + ОписаниеОшибки());
		Возврат Неопределено;
	КонецПопытки;
		
	Попытка
		Если НЕ ПустаяСтрока(СтрокаПодключения) Тогда
			//COMОбъект = COMПодключение.Connect(СтрокаПодключения);
			БазаСоединение = cntr.Connect(СтрокаПодключения);			
			БазаПодключена = Истина;
		КонецЕсли;
	Исключение		
		Предупреждение("Не удалось подключиться к базе!" + ОписаниеОшибки());
	КонецПопытки;
	//	
	Если НЕ БазаПодключена Тогда
		Предупреждение("Не удалось подключиться к базе!" + ОписаниеОшибки());
		Возврат Неопределено;
	КонецЕсли;
	
	Возврат БазаСоединение;
...Показать Скрыть

4. Надпись "База сравления" исправить на "База сравнения".
2. Денис Кожухов (imozg) 10.03.12 12:26
(1) Спасибо за замечания! Замеченные недочеты учтены, обработка перезалита.
3. Евгений Рачковский (eugen91) 08.06.12 18:17
хм, должно быть функционально и удобно!спасибо
4. Александр (zato1c) 27.09.12 11:49
С видио просто класс ясно, понятно, эффективно!
5. Анна Герасимова (Anna_G) 28.09.12 10:20
Наверно удобно. Спасибо.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа