Закрытие регистров в УПП

Администрирование - Сервисные утилиты

Данная обработка удобно закроет с нужным отбором регистры накопления и бухгалтерии в "ноль", создав документ "Корректировка записей регистров"

Данная обработка удобно закроет с нужным отбором регистры накопления и бухгалтерии в "ноль", создав документ "Корректировка записей регистров". Эта обработка предназначена для Платформы 1С 8.2 Конфигураций УПП, КА

Документ "Корректировка записей регистров", сразу не записывается. Просто открывается экранная форма, а дальше можно и отказаться от записи.

Отбор делается по всем измерениям регистров. 

Скачать файлы

Наименование Файл Версия Размер
Файл обработки
.epf 15,95Kb
21.03.12
183
.epf 15,95Kb 183 Скачать

См. также

Комментарии
0. Елена Смирнова (smielka) 128 03.04.12 11:16 Сейчас в теме
Данная обработка удобно закроет с нужным отбором регистры накопления и бухгалтерии в "ноль", создав документ "Корректировка записей регистров"

Перейти к публикации

1. cbr900 (cbr900) 148 03.04.12 11:16 Сейчас в теме
Хотелось бы выбор корреспондирующего счета для Регистров бухглатерии.
А то получаются проводки Дт 10 Кт??? - приходится вручную подставлять, а если тыщщщии строк?))
2. Александр Удалов (higs) 25.07.12 22:37 Сейчас в теме
А не так все шоколадно. Выбрал регистр ЗатратыНаВыпускПродукции, а в ответ

{ВнешняяОбработка.ЗакрытиеРегистров.МодульОбъекта(99)}: Ошибка при установке значения атрибута контекста (Текст)
ПостроительОтчета.Текст = ИтоговыйТекстЗапроса;
по причине:
{(1, 28)}: Таблица не найдена "РегистрНакопления.ЗатратыНаВыпускПродукции.Остатки"
ВЫБРАТЬ Разрешенные _.* ИЗ <<?>>РегистрНакопления.ЗатратыНаВыпускПродукции.Остатки(&ДатаКон, {Подразделение.*, НоменклатурнаяГруппа.*, Продукция.*, ХарактеристикаПродукции.*, СерияПродукции.*, Спецификация.*, Заказ.*, ДокументВыпуска.*, СтатьяЗатрат.*, Затрата.*, ХарактеристикаЗатраты.*, СерияЗатраты.*, НоменклатурнаяГруппаНЗП.*, ЗаказНЗП.*, ПодразделениеНЗП.*}) КАК _ {ГДЕ _.КоличествоОстаток, _.СуммаОстаток}

Я понимаю, что это означает - регистр-то оборотный. Но тогда надо список доступных регистров ограничить только регистрами остатков, ибо нафига тогда в списке оборотные?

Кстати, зачем упомянуты регистры сведений? Во-первых, они не выводятся в обработке, во-вторых, их тоже надо закрывать?
3. Алексей Т. (CratosX) 98 07.08.13 01:31 Сейчас в теме
очередная граната))
но думаю полезно сэкономит время...
а что с оборотными регистрами?
4. Александр Гончаров (aegoncharov) 3 04.06.15 07:50 Сейчас в теме
(2) higs,
Там ошибка, надо исправлять

//{{
			//Если ТипОбъектаМД = "РегистрыНакопления" Тогда
			Если ТипОбъектаМД.Ключ = "РегистрыНакопления" Тогда
			//gae}}

5. Александр Гончаров (aegoncharov) 3 04.06.15 08:04 Сейчас в теме
Еще в СоздатьДокумент() пришлось добавить
				// ресурсы
				Для каждого Ресурс из ОбъектМетаданных.Ресурсы Цикл
					Если Ресурс.Балансовый Тогда
						НоваяЗаписьДвижения[Ресурс.Имя] = -ВыборкаИзРезультатовЗапроса[Ресурс.Имя + "Остаток"];
					Иначе
						НоваяЗаписьДвижения[Ресурс.Имя + "Дт"] = -ВыборкаИзРезультатовЗапроса[Ресурс.Имя + "ОстатокДт"];
						НоваяЗаписьДвижения[Ресурс.Имя + "Кт"] = -ВыборкаИзРезультатовЗапроса[Ресурс.Имя + "ОстатокКт"];
					КонецЕсли;
				КонецЦикла;
				
				//{{GAE 150604
				// измерения
				Для каждого Измерение из ОбъектМетаданных.Измерения Цикл
					Если не Измерение.Балансовый Тогда
						НоваяЗаписьДвижения[Измерение.Имя + ПостФикс] = ВыборкаИзРезультатовЗапроса[Измерение.Имя];
					КонецЕсли;
				КонецЦикла;
				//gae}}
...Показать Скрыть


чтобы в налоговых проводка вид учета заполнялся
Оставьте свое сообщение