gifts2017

Справка 2-НДФЛ. Делаем удержанный и перечисленный равным исчисленному

Опубликовал CalvinK в раздел Обработки - Обработка документов

Простенькая обработка. Делает НДФЛ удержано и перечислено равным исчисленному в документах "Справка 2-НДФЛ для передачи в ИФНС" и "Справка о заработке (2-НДФЛ) сотрудникам".

Сначала была сделана просто доработка у клиента в конфигурации 1С Зарплата и кадры бюджетного учреждения 8 в виде кнопки в документах "Справка 2-НДФЛ для передачи в ИФНС" и "Справка о заработке (2-НДФЛ) сотрудникам", потом решил сделать внешнюю обработку. Думаю, что подойдет для др. конфигураций 1С 8, т.к. документы идентичны.

Если и у вас много сотрудников и полная неразбериха с регистрами НДФЛ, нужно срочно выдать на руки сотрудникам справки 2-НДФЛ и сдать 2-НДФЛ в ИФНС в виде налога Исчислено=Удержано=Перечислено, то эта обработка для вас :).

Инструкция: открыть обработку - выбрать документ - нажать Обработать. В выбранном документе у каждого сотрудника НДФЛ удержанный и перечисленный будет равен исчисленному.

10.03.2016 Обновление. Добавлена возможность править справки с 2015 года! 

Скачать файлы

Наименование Файл Версия Размер
Обработка 2-НДФЛ 298
.epf 6,67Kb
10.03.16
298
.epf 6,67Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Вячеслав (Slavez) 21.03.12 18:12
Спасибо. Актуально.
Зачем придумали этот "перечисленный"...
2. d d (rassss) 23.03.12 06:43
Спасибо. да конечно перечисленный налог это такое же извращение как ив пенссионном фонде тоже.Но что касаеться обработке,не всегда же удержанный должен быть равен начисленному?я бы сказал что наоборот в большинстве случаев он не должен быть равен исчисленному налогу,не понятно почему это так пугает и людей и налоговые органы .К нам приезжала проверка и тетя с налоговой незнала что такое НДФЛ удержанный))))))))))))))))))))))))
3. CalvinK 23.03.12 16:32
Согласен, что удержанный может быть не равен исчисленному даже при устан галочке в параметрах учета, например, при переходящем отпуске (Я своих клиентов приучаю отражать весь НДФЛ в мес начисления (законодат не нарушается, есть 2 позиции)). Большинство организаций предпочитают ставить галочку исч=удерж в параметрах учета и платят по исч, забывая про удержанный, а вот в программе пользователи то эту галочку в параметрах учета поперетыкивают, то исправления всякие повносят. Врезультате по факту всё ровно, а в программе неразбериха, отчёт на носу. Вот сначала отчёт ровненький сдаем, а потом разбираюсь с их ошибками:)
4. Антон Котов (Attest) 23.03.12 17:48
Спасибо за обработку! Нужна как воздух, бухи заставляют проверять перечисления НДФЛ по 600 сотрудником, у них не бьёт, а виноваты программисты! Надоело!
5. Михаил (capt_nemo) 24.03.12 19:39
Попал в четверг к клиенту, стоит ЗУП 8.2, расчетчик 2-ой день на работе, ей сказали сдаешь НДФЛ, работай дальше!!! Сотрудников 800. Обработка спасла человека, плюсую.
6. Алексей Старый (Alex Star) 29.03.12 09:51
Бухи тоже попросили, сделал, но как обработку заполнения табличных частей, я думаю так было-бы удобнее, без выбора документа, а непосредственно в сам документ подключить
Кстати вот:
Процедура Инициализировать(Объект, СотрудникиОрганизации, ТабличноеПоле = Неопределено) Экспорт
	//Объект = Документы.СправкаПоНДФЛВНалоговыйОрган.СоздатьДокумент();
	Табл = Объект.СотрудникиОрганизации;
	Для Каждого Стр Из Табл Цикл
		Стр.Перечислено = Стр.Исчислено;
	КонецЦикла;
	Табл = Объект.СуммыНалогов;
	Для Каждого Стр Из Табл Цикл
		Стр.Перечислено = Стр.Исчислено;
	КонецЦикла;
КонецПроцедуры
...Показать Скрыть
Abbra; Spirit11; elvis1917; +3 Ответить
7. CalvinK 29.03.12 15:24
Да, у меня тоже сначала кнопка в документе была. Программный код у меня не сложнее:)
9. Helen I (Bruk) 23.04.13 20:52
Спасибо Огромное!! Очень нужная обработка, а главное ко времени)
10. Наталья Недбальская (Seba) 23.02.14 17:23
Спасибо! Очень пригодилась обработка!
11. Михаил (Gasilin) 26.02.16 16:56
12. Вера Филимонова (FVK) 04.03.16 10:53
13. CalvinK 10.03.16 08:04
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа