gifts2017

Сторно любого документа УТ 10.3, Розница 1.0

Опубликовал Юрий Зайцев (Yury1001) в раздел Обработки - Обработка документов

Дополнительный документ для конфигураций Управление торговлей 10.3, Розница 1.0 и скорее всего любой конфигурации на регистрах накопления, обычный режим приложения.

Документ повторяет все движения основания по регистрам накопления с противоположным знаком.

Удивился, что не нашёл, вот выкладываю.

Установка: объединить конфигурацию, выбрать документ Сторно,

разрешить движения по всем регистрам накопления,

разрешить ввод на основании всех документов,

если нужно добавить права и интерфейсы, всё.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Сторно10-3
.cf 14,20Kb
12.04.12
48
.cf 14,20Kb 48 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Юрий Зайцев (Yury1001) 13.04.12 07:00
Дополнительный документ для конфигураций Управление торговлей 10.3, Розница 1.0 и скорее всего любой конфигурации на регистрах накопления, обычный режим приложения.

Перейти к публикации

1. Serj (Serj1C) 13.04.12 07:00
Может еще есть смысл добавить подписку на событие проведения документа, если по нему было сторно, то перепроводить сторно?
2. Роман Мишкин (smilejka) 13.04.12 09:38
А чем вас не устраивает типовой Корректировка записей регистров с галочкой "Использовать заполнение регистров" и выбором вида заполнения "Сторно движений документа" ?
По моему тоже самое и без доработки конфигурации...
Yury1001; sound; +2 Ответить 2
3. Юрий Зайцев (Yury1001) 13.04.12 11:56
(2) устраивает :)
клиент заказал, а я не стал впрягаться, подумал наверное знают чего просят.

У меня проще и ввод на основании, у клиента не редко возникает необходимость исправлений, а менять документы нельзя, там выгрузка куда то в центр – бонусов лишат.
В общем пусть будет.
4. Евгений L (laeg) 13.04.12 15:13
(3) Yury1001,
То что клиент заказал это конечно хорошо. Но смысл изобретать велосипед, делать то что уже давно сделано как написал человек в (2)

В основном УТ и розница запускается на типовом функционале, навешиваются внешние обработки и алю-лю. А снимать конфу с замков, что бы сделать аналог документа который уже есть в системе - имхо глупо. Плюс, корректировка записей регистров более универсальна, можно не только сторнировать но и именно корректировать. Может лучше всеже научить клиента пользоваться типовым функционалом да и самому разобраться не мешало бы.
5. Юрий Зайцев (Yury1001) 13.04.12 15:41
(4) только что приехал от этого клиента, по честному показал два варианта:
1. Документы / Дополнительные / Корректировка записей / Добавить / Использовать заполнение движений / Добавить / Действие / Выбрать Сторно движений / Документ / Выбрать тип данных / Ещё раз выбрать документ / Заполнить движения / ОК
2. Найти нужный документ в списке / Ввести на основании Сторно / ОК
Клиент сказал «не не не оставь свой вариант, нам нравиться, мы заплатим, 2 часа, да без проблем».
А конфигурация снята с поддержки в прошедшем Ноябре и вложено в неё, щас гляну чтоб не соврать, 368 часов.
Снимать с поддержки только из-за этого документа конечно не стОит.
P.S. Не встречал ни одной сколь ни будь серьёзной базы управленческого учёта на замках, но надеюсь ещё увижу – какие мои годы.
6. Вадим Matvienko (1cvirus) 13.06.12 15:19
Процедура ОбработкаПроведения(Отказ, РежимПроведения)
	Если ЗначениеЗаполнено(Документ) Тогда
		ДокументОбъект = Документ.ПолучитьОбъект();
		Для Каждого Регистр ИЗ Метаданные.РегистрыНакопления Цикл
			Если ДокументОбъект.Движения.Найти(Регистр.Имя) <> Неопределено Тогда
				ДокументОбъект.Движения[Регистр.Имя].Прочитать();
				ВремДвиж = ДокументОбъект.Движения[Регистр.Имя].Выгрузить();
				Для Каждого Элемент из ВремДвиж Цикл
					Элемент.Период = Дата;
					Для Каждого Ресурс ИЗ Регистр.Ресурсы Цикл
						Элемент[Ресурс.Имя] = - Элемент[Ресурс.Имя];
					КонецЦикла;
				КонецЦикла;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры
...Показать Скрыть


не качал, сделал док с таким модулем проведения - движений нет
непонимаю как оно могло работать
7. Юрий Зайцев (Yury1001) 13.06.12 15:24
(6) 1cvirus, ну всё так, а в чём вопрос?
8. Вадим Matvienko (1cvirus) 14.06.12 17:32
не работает, движений нет
ВремДвиж = ДокументОбъект.Движения[Регистр.Имя].Выгрузить(); - пусто
9. Юрий Зайцев (Yury1001) 14.06.12 17:43
(8) 1cvirus, значит нет движений или нет объекта, текст рабочий на 146%
10. Вадим Matvienko (1cvirus) 14.06.12 17:59
Блин я тупил - это у меня почему-то движения по регистрам не показывает, в отчете посмотрел - все работает
11. Юрий Зайцев (Yury1001) 14.06.12 18:09
(10) 1cvirus, плюсик в скобачках
12. Julia Galkina (lambert@inbox.ru) 24.03.14 10:22
Спасибо! У меня КА и было задание: переделать корр.записей рег., чтобы пользователь не заморачивался - заполнен регистр, или нет..., т.е. создать волшебную кнопку :) Ваша идея ОЧЕНЬ пригодилась, к тому же в ней легко реализовать др. задание: приходовать товар не туда, откуда он ушел с реализацией, а туда, куда хочет склад :) Спасибо!
13. Julia Galkina (lambert@inbox.ru) 24.03.14 11:05
У меня в модуле была ошибка(в конце цикла было):
Движения[Регистра.Имя].Загрузить(ВремДвиж)

надо исправить:

ДокументОбъект.Движения[Регистра.Имя].Загрузить(ВремДвиж)
14. Расул Кипкеев (rasulkipkeev) 25.09.14 10:59
А как сделать что бы сторно делалась по регистру, а не через документ
15. Юрий Зайцев (Yury1001) 25.09.14 11:10
(14) rasulkipkeev, не вопрос, а прям шедевр)))
Ну, никак - регистратором регистра накопления может быть только документ.
16. Расул Кипкеев (rasulkipkeev) 25.09.14 12:07
(15) Yury1001, ну а если регистратором будет документ тот же.
Я хочу сделать так что бы документ получил все записи из регистра и записал обратно так же только с заменой знака
17. Юрий Зайцев (Yury1001) 25.09.14 12:16
(16) rasulkipkeev, ну, можно и так, только запрос на заполнение движений переписать под эту цель
18. А В (Asenka) 13.08.16 22:57
Создаем документ Реализация товаров, услуг, затем через некоторое время документ Сторно. В Акте сверки что будет отражаться? УТ 10.3
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа