gifts2017

Включение (отключение) главного узла РИБ

Опубликовал Nitochka (Nitochka) в раздел Администрирование - Распределенная БД (УРИБ, УРБД)

Включение (отключение) главного узла для периферийной базы.

Для исправления ошибок баз данных, обновление которых происходит через обмен. Отключается главный узел, вносятся изменения, включается главный узел.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ОтменаРБД.epf
.epf 5,85Kb
13.04.12
581
.epf 5,85Kb 581 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. rasswet (rasswet) 18.04.12 11:58
вы сохраняете где-то значение главного узла при отключении? или как определяете к какому подключить?
2. Nitochka (Nitochka) 18.04.12 13:29
(1) rasswet,
Отношение главный - подчиненный определено для каждой пары связанных узлов распределенной системы. Обработка включает/отключает значение главный для подчиненного узла.
3. rasswet (rasswet) 18.04.12 15:20
(2) а если у 1го главного 10 подчиненных и планов обмена штук 6ть. как обработка определит какой именно узел был отвязан и какой у него главный?
4. Nitochka (Nitochka) 18.04.12 17:23
(3) rasswet,
специально для вас допишу выбор узла, как будет время :)
5. Галина Орехова (orehova123) 19.04.12 15:20
насколько помню, в периферийке в планах обмена только два узла, и какой из них главный, а какой подчиненный, определяется очень просто. а эта обработка ведь для периферийки и актуальна
6. Алексей (Alav) 24.04.12 20:12
7. Надежда Кутузова (Nadushka74) 05.05.12 10:55
гигантийское вам спасибо!!! " дня мучилась и сегодня все работает
8. Nitochka (Nitochka) 09.05.12 17:43
(7) Nadushka74,
пользуйтесь с удовольствием :)
9. i z (izz) 30.05.12 11:10
Спасибо за обработку! Пригодилась для восстановления РИБ на подразделении. Очень время съэкономии, используя ее.
10. Nitochka (Nitochka) 30.05.12 11:59
(9) izz,
пожалуйста, пользуйтесь :)
11. Сергей (il_abd@mail.ru) 17.06.12 10:00
Спасибо, как раз столкнулся сейчас с такой необходимостью, и вот очень пригодилось
12. Nitochka (Nitochka) 18.06.12 08:42
13. Аktrc Новоселецкий (kkprps) 06.03.13 21:56
Вот и нам пригодилась, спасибо
14. Pavel (PavelI) 28.03.13 15:18
Полазил в интернете нашел такой код, мне помогло.
Неважно какой параметр, хотя по умолчанию, параметр процедуры для кнопки командной панели
Процедура ОтключитьГлавныйУзелНажатиеКнопки(Кнопка)

будет проставляется как "Кнопка", а вставляемой через меню Форма --> Вставить элемент управления... получается "Элемент"
Процедура ОтключитьГлавныйУзелНажатиеКнопки(Элемент)

Ниже код внешней обработки отключение - восстановление подключения к УРБД:


Процедура ОтключитьГлавныйУзелНажатиеКнопки(Элемент)
   Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
       СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном",
           ПланыОбмена.ГлавныйУзел());
       ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
   КонецЕсли;
   Предупреждение("Главный узел отключен");
КонецПроцедуры

Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
   Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
   ПланыОбмена.УстановитьГлавныйУзел(
       ВосстановитьЗначение(
       "ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
   КонецЕсли;
Предупреждение("Главный узел восстановлен");
КонецПроцедуры
...Показать Скрыть
15. Виктор Темеров (ukasochi) 17.04.13 12:55
В Бухгалтерии предприятия 3.0 не работает! Открывается, но кнопок нет(((
16. Иван Титов (Ibrogim) 17.04.13 13:24
(0) чем вам не нравится обработка указанная в (6) ?
1. Не нашли (или не искали) перед тем как написать обработку
2. Не нашли (или не искали) перед тем как опубликовать
(7) Nadushka74,
" дня мучилась и сегодня все работает

Ну если не умеете гуглить, то тогда конечно остаётся только мучиться...
17. Надежда Кутузова (Nadushka74) 17.04.13 13:46
(16) Ibrogim, спасибо за оценку моих умственных способностей, особенно не зная меня.
Мучилась не с этим, а с проблемой, решить которую получилось этой обработкой. На нее попала случайно, и какая разница на эту или другую???
18. Иван Титов (Ibrogim) 17.04.13 14:06
(17) Nadushka74,
спасибо за оценку моих умственных способностей
Оценки как таковой не было.
Тот факт, что человек сначала "мучается" с некоторой проблемой, а лишь потом интересуется наличием готового решения, лишь косвенно его характеризует. Я только отметил, что если принцип не поменять, то и дальше придётся "мучиться"
19. Евгений Палагин (Jon2011) 13.05.13 18:50
А вот можно ли отключить гл.узел из конфигурации или какой-то сторонней обработкой , если база не запускается?
20. Den (Dvornik) 16.09.13 12:47
(15) ukasochi, Нужна управляемая форма, так как БУХ 3.0 на управляемом приложении. В ней вы увидите кнопки и всё прочее.
21. Никопол (N1k0p0l) 07.11.13 13:13
Автор, добавьте в описании обработки, что она не работает в режиме тонкого клиента (нет управляемой формы). А то я вижу, что не один такой - скачавший и запустивший ее в БП 3.0.
22. Сергей Сергеев (ksav1979) 18.12.13 15:44
Спасибо, очень пригодилась!
23. Марат Настоящий (rayastar) 28.02.14 13:46
Спасибооооо! очень пригодилось! автор - крут
24. Nikolay Agapov (Agapov_h) 27.05.15 14:01
25. Елена Пименова (Bukaska) 27.05.15 14:11
(24) Agapov_h, А почему? Может вы запускаете обработку не в той конфе и не на том релизе платформы?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа