Включение (отключение) главного узла РИБ

Опубликовал Nitochka в раздел Администрирование - Распределенная БД (УРИБ, УРБД)

Включение (отключение) главного узла для периферийной базы.

Для исправления ошибок баз данных, обновление которых происходит через обмен. Отключается главный узел, вносятся изменения, включается главный узел.

Файлы

Наименование Файл Дата Размер Кол. Скачив.
ОтменаРБД.epf
.epf 5,85Kb
13.04.12
558
.epf 13.04.12 5,85Kb 558 Скачать

См. также

Лучшие комментарии

15. ukasochi (файл скачал) 17.04.2013 12:55
В Бухгалтерии предприятия 3.0 не работает! Открывается, но кнопок нет(((
Ответили: (20)
+ 1 [ peterfil; ]
# Ответить
16. Ibrogim 17.04.2013 13:24
(0) чем вам не нравится обработка указанная в (6) ?
1. Не нашли (или не искали) перед тем как написать обработку
2. Не нашли (или не искали) перед тем как опубликовать
(7) Nadushka74,
" дня мучилась и сегодня все работает

Ну если не умеете гуглить, то тогда конечно остаётся только мучиться...
Ответили: (17)
+ 1 [ zoytsa; ]
# Ответить

Комментарии

1. rasswet 18.04.2012 11:58
вы сохраняете где-то значение главного узла при отключении? или как определяете к какому подключить?
Ответили: (2)
# Ответить
2. Nitochka 18.04.2012 13:29
(1) rasswet,
Отношение главный - подчиненный определено для каждой пары связанных узлов распределенной системы. Обработка включает/отключает значение главный для подчиненного узла.
Ответили: (3)
# Ответить
3. rasswet 18.04.2012 15:20
(2) а если у 1го главного 10 подчиненных и планов обмена штук 6ть. как обработка определит какой именно узел был отвязан и какой у него главный?
Ответили: (4)
# Ответить
4. Nitochka 18.04.2012 17:23
(3) rasswet,
специально для вас допишу выбор узла, как будет время :)
# Ответить
5. orehova123 19.04.2012 15:20
насколько помню, в периферийке в планах обмена только два узла, и какой из них главный, а какой подчиненный, определяется очень просто. а эта обработка ведь для периферийки и актуальна
# Ответить
6. Alav 24.04.2012 20:12
Очередной велосипед? http://infostart.ru/public/14814/
Ответили: (16)
# Ответить
7. Nadushka74 (файл скачал) 05.05.2012 10:55
гигантийское вам спасибо!!! " дня мучилась и сегодня все работает
Ответили: (8) (16)
# Ответить
8. Nitochka 09.05.2012 17:43
(7) Nadushka74,
пользуйтесь с удовольствием :)
# Ответить
9. izz 30.05.2012 11:10
Спасибо за обработку! Пригодилась для восстановления РИБ на подразделении. Очень время съэкономии, используя ее.
Ответили: (10)
# Ответить
10. Nitochka 30.05.2012 11:59
(9) izz,
пожалуйста, пользуйтесь :)
# Ответить
11. il_abd@mail.ru (файл скачал) 17.06.2012 10:00
Спасибо, как раз столкнулся сейчас с такой необходимостью, и вот очень пригодилось
# Ответить
12. Nitochka 18.06.2012 08:42
Пожалуйста :)
# Ответить
13. kkprps (файл скачал) 06.03.2013 21:56
Вот и нам пригодилась, спасибо
# Ответить
14. PavelI 28.03.2013 15:18
Полазил в интернете нашел такой код, мне помогло.
Неважно какой параметр, хотя по умолчанию, параметр процедуры для кнопки командной панели
Процедура ОтключитьГлавныйУзелНажатиеКнопки(Кнопка)

будет проставляется как "Кнопка", а вставляемой через меню Форма --> Вставить элемент управления... получается "Элемент"
Процедура ОтключитьГлавныйУзелНажатиеКнопки(Элемент)

Ниже код внешней обработки отключение - восстановление подключения к УРБД:


Процедура ОтключитьГлавныйУзелНажатиеКнопки(Элемент)
   Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
       СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном",
           ПланыОбмена.ГлавныйУзел());
       ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
   КонецЕсли;
   Предупреждение("Главный узел отключен");
КонецПроцедуры

Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
   Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
   ПланыОбмена.УстановитьГлавныйУзел(
       ВосстановитьЗначение(
       "ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
   КонецЕсли;
Предупреждение("Главный узел восстановлен");
КонецПроцедуры
...Показать Скрыть
# Ответить
15. ukasochi (файл скачал) 17.04.2013 12:55
В Бухгалтерии предприятия 3.0 не работает! Открывается, но кнопок нет(((
Ответили: (20)
+ 1 [ peterfil; ]
# Ответить
16. Ibrogim 17.04.2013 13:24
(0) чем вам не нравится обработка указанная в (6) ?
1. Не нашли (или не искали) перед тем как написать обработку
2. Не нашли (или не искали) перед тем как опубликовать
(7) Nadushka74,
" дня мучилась и сегодня все работает

Ну если не умеете гуглить, то тогда конечно остаётся только мучиться...
Ответили: (17)
+ 1 [ zoytsa; ]
# Ответить
17. Nadushka74 (файл скачал) 17.04.2013 13:46
(16) Ibrogim, спасибо за оценку моих умственных способностей, особенно не зная меня.
Мучилась не с этим, а с проблемой, решить которую получилось этой обработкой. На нее попала случайно, и какая разница на эту или другую???
Ответили: (18)
# Ответить
18. Ibrogim 17.04.2013 14:06
(17) Nadushka74,
спасибо за оценку моих умственных способностей
Оценки как таковой не было.
Тот факт, что человек сначала "мучается" с некоторой проблемой, а лишь потом интересуется наличием готового решения, лишь косвенно его характеризует. Я только отметил, что если принцип не поменять, то и дальше придётся "мучиться"
# Ответить
19. Jon2011 13.05.2013 18:50
А вот можно ли отключить гл.узел из конфигурации или какой-то сторонней обработкой , если база не запускается?
# Ответить
20. Dvornik 16.09.2013 12:47
(15) ukasochi, Нужна управляемая форма, так как БУХ 3.0 на управляемом приложении. В ней вы увидите кнопки и всё прочее.
# Ответить
21. N1k0p0l (файл скачал) 07.11.2013 13:13
Автор, добавьте в описании обработки, что она не работает в режиме тонкого клиента (нет управляемой формы). А то я вижу, что не один такой - скачавший и запустивший ее в БП 3.0.
# Ответить
22. ksav1979 (файл скачал) 18.12.2013 15:44
Спасибо, очень пригодилась!
# Ответить
23. rayastar (файл скачал) 28.02.2014 13:46
Спасибооооо! очень пригодилось! автор - крут
# Ответить
24. Agapov_h (файл скачал) 27.05.2015 14:01
Обработка хрень
Ответили: (25)
# Ответить
25. Bukaska 27.05.2015 14:11
(24) Agapov_h, А почему? Может вы запускаете обработку не в той конфе и не на том релизе платформы?
# Ответить
Внимание! За постинг в данном форуме $m не начисляются.
Внимание! Для написания сообщения необходимо авторизоваться
Текст сообщения*
Прикрепить файл