gifts2017

Печать прайс листа

Опубликовал Аля Свеженцева (Allechka) в раздел Обработки - Ценообразование, прайсы

Измененная обработка - Печать прайс-листа со свободными остатками.

В дополнение к выводу остатков, позволяет вывести резервы и свободные остатки.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Печать прайс-листа
.epf 50,06Kb
28.12.14
161
.epf 50,06Kb 161 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

0. Аля Свеженцева (Allechka) 15.07.12 18:46
Измененная обработка - Печать прайс-листа со свободными остатками.

Перейти к публикации

1. Кристина гаврилова (lediboss) 15.07.12 18:46
а у меня в Рознице 2.0.4.5 выдает ошибку {ВнешняяОбработка.ПечатьПрайсЛиста.МодульОбъекта(64,2)}: Переменная не определена (УправлениеОтчетами)
как быть?
2. Аля Свеженцева (Allechka) 16.07.12 07:43
Ну начнем с того, что данная обработка написана под другую конфигурацию нежели Розница. УправлениеОтчетами это общий модуль конфигурации УТ. Могу предложить лишь текст той функции, ссылка на которую вызвала Вашу ошибку, попробуйте добавить ее в модуль обработки и изменить в тексте модуля вызов этой функции с
УправлениеОтчетами.ЗадатьПараметрыОтбораПоКатегориям(ПостроительОтчета, ОбщийОтчет.мСтруктураДляОтбораПоКатегориям);

на
ЗадатьПараметрыОтбораПоКатегориям(ПостроительОтчета, ОбщийОтчет.мСтруктураДляОтбораПоКатегориям);
Но нет гарантий, что ссылки на другие процедуры не вызовут новых ошибок.

// Добавляет в параметры построителя отчета использованные в отборах категории
//
// Параметры:
//	ПостроительОтчета              - Построитель, отбор которого обрабатывается, и в Параметры 
//                                    которого добавляются категории
//	СтруктураДляОтбораПоКатегориям - структура, связывающая пути к данным Отборов Построителя и 
//                                    идентицфикаторы параметров
//
// Возвращаемое значение:
//	Истина, если добавление параметров произошло успешно
//	Ложь, если есть повторный отбор по одной и той же категории.
//
// Вообще-то, повторный отбор по одной и той же категории невозможен не всегда - 
//  можно отобрать два раза с видом сравнения "не равно". Контроль возвращаемого
//  этой функцией значения отключить можно, но нужно после этого понимать,
//  что два отбора по одной категории с видом сравнения "Равно" приведут к тому,
//  что отчет окажется пустым.
//
Функция ЗадатьПараметрыОтбораПоКатегориям(ПостроительОтчета, СтруктураДляОтбораПоКатегориям) Экспорт
	Если ТипЗнч(СтруктураДляОтбораПоКатегориям) = ТипЗнч(Новый Структура) Тогда
		Для Каждого ЭлементОтбора Из ПостроительОтчета.Отбор Цикл
			//Прочищаем все, независимо от использования элемента отбора
			НазваниеПараметра = "";
			Если Найти(ЭлементОтбора.ПутьКДанным, ".") = 0 Тогда
				Если СтруктураДляОтбораПоКатегориям.Свойство(ЭлементОтбора.ПутьКДанным, НазваниеПараметра) Тогда
					Если ПостроительОтчета.Параметры.Свойство(НазваниеПараметра) Тогда
						ПостроительОтчета.Параметры.Удалить(НазваниеПараметра);
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЦикла;
		Для Каждого ЭлементОтбора Из ПостроительОтчета.Отбор Цикл			
			Если Найти(ЭлементОтбора.ПутьКДанным, ".") > 0 Тогда
				Продолжить;
			КонецЕсли;
			Если ЭлементОтбора.Использование Тогда
				ИдентификаторПараметра = "";
				Если СтруктураДляОтбораПоКатегориям.Свойство(ЭлементОтбора.ПутьКДанным, ИдентификаторПараметра) Тогда
					МассивЗначенийКатегорий = НеОпределено;
					Если НЕ ПостроительОтчета.Параметры.Свойство(ИдентификаторПараметра, МассивЗначенийКатегорий) Тогда
						МассивЗначенийКатегорий = Новый Массив;
					Иначе
						Предупреждение("Нельзя использовать несколько отборов по одной и той же категории!");
						Возврат Ложь;
					КонецЕсли;

					Если ТипЗнч(ЭлементОтбора.Значение) = ТипЗнч(Новый СписокЗначений) Тогда
						Для Каждого ЗначениеКатегории Из ЭлементОтбора.Значение Цикл							МассивЗначенийКатегорий.Добавить(ЗначениеКатегории.Значение);
						КонецЦикла;
					Иначе
						МассивЗначенийКатегорий.Добавить(ЭлементОтбора.Значение);
					КонецЕсли;
					ПостроительОтчета.Параметры.Вставить(ИдентификаторПараметра, МассивЗначенийКатегорий);
				КонецЕсли;				
			КонецЕсли;				
		КонецЦикла;
	КонецЕсли;
	Возврат Истина;
КонецФункции // ЗадатьПараметрыОтбораПоКатегориям()
...Показать Скрыть
3. John Smith (AndrewAks) 25.08.12 18:14
При добавлении поля "Остаток" в прайс ничего не выводится, без остатка всё гут. При выборе "Свободный остаток" всё точно так же. Все склады оптовые. Конфигурация УТ 10.3.18.3. В чём может быть дело?
4. Аля Свеженцева (Allechka) 27.08.12 14:44
Поле остаток - это типовое поле данной обработки, работает ли у вас корректно стандартная обработка печати прайса при выборе данного поля? И проверяйте выбран ли тип цен, по умолчанию там установлена галочка, если его не выбирать - прайс будет выводиться пустым.
Если вы уверены, что все настройки при формировании прайса указаны верно, но прайс все равно пустой, то могу посоветовать только проверить работу обработки отладчиком.
5. Me Here (irbb) 31.08.12 19:02
Добрый день. А возможно ли добавить картинки к товарам? А под 8.1 пойдет?
6. Аля Свеженцева (Allechka) 31.08.12 20:33
Вероятно, Вам нужна эта обработка : http://infostart.ru/public/90508/
(Прайс-лист с возможностью вывода изображения и остатка
Платформа: 1C: Предприятие 8.1)
7. Me Here (irbb) 01.09.12 01:41
Спсибо за рекоментацию. По описанию то что нужно, но никак не могу найти этот файл для скачевания.
8. ProGramMoS ProGramMoS (ProGramMoS) 02.09.12 23:35
(6) Allechka, (7) irbb, Да кстати, весь прикольная ситуация тема есть, а вот файла нет((( П
ри добавлении поля "Остаток" в прайс ничего не выводится, без остатка всё гут. При выборе "Свободный остаток" всё точно так же. Все склады оптовые
У меня тоже самое((
9. Олег Владимирович (olezhe) 13.12.13 20:23
Немножко допилил, чтоб настройки сохранялись и видны были всем пользователям. Каждый манагер не будет же по-своему заново настраивать.
Большое спасибо, сэкономил время. Заменил штатный отчёт этим.
10. Олег Владимирович (olezhe) 20.12.13 19:10
(3) AndrewAks,
Ошибка в этом отчёте совсем маленькая:
- ***Обработка.ПечатьПрайсЛиста
- Модуль объекта - Различаются значения
Изменено: 697 - 699
< "·|" + ""
< "·//"
< " |СОЕДИНЕНИЕ"

> "·// |" + ""
> " |{ЛЕВОЕ СОЕДИНЕНИЕ"

Изменено: 730 - 730
< "·|";"

> "·|}";"

То есть, должно быть так:
	//  |" + "        // скобка Левое добавить
    |{ЛЕВОЕ СОЕДИНЕНИЕ
	|(ВЫБРАТЬ
	|	НесвернутыйРезерв.Номенклатура КАК НоменклатураСвободныеОст,
	|   НесвернутыйРезерв.ХарактеристикаНоменклатуры КАК ХарактеристикаНоменклатурыСвободныеОст,
	|   Сумма(НесвернутыйРезерв.Резерв) КАК Резерв 
	| ИЗ
...............
	|) КАК Резервы
	| ПО
	|	ЗапросПрайс.Номенклатура = Резервы.НоменклатураСвободныеОст
	|	И ЗапросПрайс.ХарактеристикаНоменклатуры = Резервы.ХарактеристикаНоменклатурыСвободныеОст
	|}";
// скобку закрыть
...Показать Скрыть
11. Олег Владимирович (olezhe) 20.12.13 19:19
Автору: Исправьте выборку резервов на ЛЕВОЕ СОЕДИНЕНИЕ, как я выше написал. Будет законченная годная обработка.
И ещё отбор по свободному остатку в прайсе легко прикручивается:
	
	СоответствиеДоступныхОтборов.Вставить("Склад", 0);
	СоответствиеДоступныхОтборов.Вставить("ВидСклада", 0);
	
	СоответствиеДоступныхОтборов.Вставить("Остаток", 0);     // добавлено
	СоответствиеДоступныхОтборов.Вставить("Резерв", 0);     // добавлено
	СоответствиеДоступныхОтборов.Вставить("СвободныйОстаток", 0);     // добавлено
...Показать Скрыть
dkonakov; llg_44; crashwork; +3 Ответить
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа