gifts2017

Проверка обновлений (1С: 7.7 и 1С: 8.2) версия 1.4.2 (бесплатная) на платформе 8.2

Опубликовал nirbolz в раздел Администрирование - Сервисные утилиты

Доработал конфигурацию проверки обновления 8ки http://infostart.ru/public/82308/. Добавлена возможность получения номеров последних версий конфигурации и отчетности по 1с 77.

Взял из обработки http://infostart.ru/public/80929/ адрес для получения последних номеров версии по 1с 77. Теперь вы можете получать обновления по 1с 8ке и получать номера актуальных релизов по 7ке и 8ке.

Скачивать обновления можно при наличии у вас логина и пароля на сайт users.v8.1c.ru.

Самое полезное конечно в этой конфигурации, что в ней есть регламентное задание, которое автоматически проверяет наличие обновлений и при нахождении их делает рассылку по электронной почте с описаниями обновлений.

Внес код пользователя YKT. Теперь все в порядке работает. Добавил константы портов smtp и pop серверов. С Mail.ru Все отлично рассылается.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ПроверкаОбновлений1.4.2.dt
.dt 171,98Kb
02.04.13
84
.dt 171,98Kb 84 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. A (Kochevnic) 08.06.12 23:35
2. Антон Руль (squeez) 09.06.12 07:11
Не пойму, а в чём фишка? Зачем такие сложности? Можно просто зайти на сайт и посмотреть номер версии. 82 сама умеет проверять обновления. Какая практическая польза данной разработки?
3. Иван Иванов (Famza) 09.06.12 08:41
(0)
Теперь вы можете получать обновления по 1с 8ке, и получать номера актуальных релизов по 7ке и 8ке.

Те реально скачивать релизы или получать номера обновлений?
4. Сергей Куликов (ksvd) 09.06.12 09:31
Присоединяюсь к вопросу - Зачем?
Сейчас я открываю сохраненную ссылку на последнии версии конфигураций и смотрю. Т.е. один щелчок мышью.
Я без претензий, просто интересно
5. nirbolz 09.06.12 09:36
(4) ksvd, (3) Famza, (2) squeez, так как я работаю во франчайзи, эта конфигурация умеет автоматически рассылать уведомления по электронной почте, очень удобно
6. Иван Иванов (Famza) 09.06.12 10:41
7. nirbolz 09.06.12 10:48
(6) Famza, у нас в офисе никто RSS не пользуется. Да и клиентам проще на почту отсылать.
8. Роман Хусяинов (rom-x) 09.06.12 11:05
Согласен, затея с почтой удобна.
9. Алексей Фурманов (Aleksey-29) 13.06.12 11:57
Если вы работаете во фрачайзи, то почему же не читали требования по именованию подсистем? Подсистема не должна называться "Переменные".
10. nirbolz 13.06.12 16:23
(9) Aleksey-29, Да, согласен неправильное название подсистемы, подсистема была создана исходным поставщиком конфигурации http://infostart.ru/profile/44871/. Его конфигурация вот она http://infostart.ru/public/82308/. Я же всего лишь сделал в ней проверку обновлений по 1с предприятию 7.7.
11. Павел Бараневский (WrongLane) 09.07.12 12:12
12. nirbolz 11.07.12 12:37
(11) WrongLane, БГУ тож работает надо всего лишь в справочник Продукты 1с добавить элемент БГУ, в кратком имени конфигурации надо написать stateaccounting, и версию программы поставить 10
13. Павел Бараневский (WrongLane) 06.08.12 09:25
На рабочем столе удаляю строчки - а они после перезапуска снова появляются
14. Павел Бараневский (WrongLane) 06.08.12 09:31
Еще было бы клево основную форму поделить на 2 части: 8,2 и 7,7
И сделать цветовые индикаторы (зеленый - актуально. Красный - надо скачать).
Так наглядней будет.
А FAQ по конфигурации есть?
Мне не надо проверять, соответствуют ли мои базы актуальным релизам.
Мне просто надо выкачивать недостающие релизы в определенную папку.
Это есть в конфигурации?
15. Павел Бараневский (WrongLane) 06.08.12 09:57
И платформу надо выкачивать
16. Елена Aндрюшкина (andryushkina) 20.08.12 18:02
А как бы не только шаблоны скачивать, а установщики обновлений?... Где бы ссылки взять?...
17. nirbolz 12.10.12 16:39
(16) andryushkina, Если вы имеети ввиду полные установщики или файл cf то такие файлы 1с в интернете не выкладывает, они есть только на нелегальных сайтах типа руборда.
18. nirbolz 12.10.12 16:44
(13) WrongLane, инструкции нет по конфигурации, когда нажимаете на кнопку загрузить то проверяется значения в справочнике продукты 1с, если там записана версия которая меньше чем та которая на сайте, то архивы с обновлениями закачиваются к вам в каталог, который указан в настройках.
19. Александр Потапов (tiniji) 19.11.12 18:22
Классная идея. Плюсую.
Немного полазил по конфигурации, из того что бросилось в глаза:
1. Зачем в справочниках коды ?
2. Там где есть путь к файлу или каталогу, неплохо было бы добавить кнопку выбора [...]
3. В адресах рассылки нужна кнопка подбор конфигураций 1с.
4. Можно замутить макет со списком конфигураций. И сделать удобное добавление тех конфигураций, которое нужно обновлять.
20. Александр (zato1c) 19.11.12 20:33
21. Leshka_m Мякишев (Leshka_m) 11.12.12 15:36
Привет, а ты только загрузку для релизов 77 дописал? Для меня там ничего нового интересного нету? :)
22. nirbolz 12.12.12 21:36
(21) Leshka_m, да только загрузку и рассылку оповещений о релизах написал..
23. LordMatrix (LordMatrix) 04.02.13 22:43
Классная конфа, только вот заметил одну странность запустил базу под 8.3 (режим совместимости: не использовать) и при скачке обновлений выдает теперь ошибку :
{Обработка.ПроверкаОбновлений.МодульОбъекта(160)}: Ошибка при вызове метода контекста (Получить): Файл не обнаружен '/tmplts/1c/Accounting/2_0_44_10/1cv8.zip': Ошибка работы с Интернет:  ресурс не найден (404). <html>
<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.2.6</center>
</body>
</html>
: Ошибка работы с Интернет:  ресурс не найден (404) 
...Показать Скрыть
24. Юрий Пихоцкий (pihy) 06.02.13 18:20
День добрый, nirbolz! Не могли бы выслать на ya.pihy@yandex.ru данную конфу - я новенький на инфостарте, и не имею достаточного количества баллов для скачивания. Спасибо
25. Александр Гладких (yku) 29.03.13 22:52
Всем кто использует данную конфу: 1С вчера выпустило обновление БП 3.0. Файл xml по последнему обновлению не содержит пункта "v8u:target".
вот такой он:
Код
<v8u:update configuration="БухгалтерияПредприятия">
 <v8u:vendor>Фирма "1С"</v8u:vendor>
 <v8u:file>1c/Accounting/3_0_19_29/1cv8.zip</v8u:file>
 <v8u:size>25 861 715</v8u:size>
 <v8u:version>3.0.19.29</v8u:version>
 <v8u:target>3.0.18.9</v8u:target>
 <v8u:target>3.0.19.15</v8u:target>
 <v8u:target>3.0.19.17</v8u:target>
 <v8u:target>3.0.19.25</v8u:target>
 <v8u:target>3.0.19.27</v8u:target>
</v8u:update>
<v8u:update configuration="БухгалтерияПредприятия">
 <v8u:vendor>Фирма "1С"</v8u:vendor>
 <v8u:file>1c/Accounting/3_0_19_31/1cv8.zip</v8u:file>
 <v8u:size>25 863 448</v8u:size>
 <v8u:version>3.0.19.31</v8u:version>
</v8u:update>
Показать полностью

в результате чего обновление не скачивается.

Предлагаю изменить модуль обработки "ПроверкаОбновлений" в процедуре "ВыполнитьЗагрузкуСпискаОбновлений"

		Пока ЧтениеXML.Прочитать() Цикл
			
			Если ЧтениеXML.Имя = "v8u:updateList" Тогда
				Прервать;					
			Иначе		
				
				Конфигурация = ЧтениеXML.ПолучитьАтрибут("configuration");
				
				Пока ЧтениеXML.Прочитать() Цикл
					
					Если ЧтениеXML.Имя = "v8u:update" Тогда
						Прервать;					
					Иначе		
						
						Если ЧтениеXML.Имя = "v8u:vendor" Тогда
							ЧтениеXML.Прочитать();
							Поставщик = ЧтениеXML.Значение;							
						ИначеЕсли ЧтениеXML.Имя = "v8u:version" Тогда
							ЧтениеXML.Прочитать();
							Версия = ЧтениеXML.Значение;
						ИначеЕсли ЧтениеXML.Имя = "v8u:file" Тогда
							ЧтениеXML.Прочитать();
							ПутьКФайлуОбновления = ЧтениеXML.Значение;
						ИначеЕсли ЧтениеXML.Имя = "v8u:size" Тогда
							ЧтениеXML.Прочитать();
							РазмерФайлаОбновления = ЧтениеXML.Значение;
						ИначеЕсли ЧтениеXML.Имя = "v8u:target" Тогда
							ЧтениеXML.Прочитать();
							НоваяСтрока = ТаблицаЗначений.Добавить();
							НоваяСтрока.Конфигурация          = Конфигурация;
							НоваяСтрока.Поставщик             = Поставщик;
							НоваяСтрока.Версия                = Версия;
							НоваяСтрока.ВерсияДляОбновления	  = ЧтениеXML.Значение;
							НоваяСтрока.ПутьКФайлуОбновления  = ПутьКФайлуОбновления;
							НоваяСтрока.РазмерФайлаОбновления = РазмерФайлаОбновления;
						КонецЕсли;
						
						ЧтениеXML.Прочитать();
						
					КонецЕсли;
					
				КонецЦикла;
				
			КонецЕсли;
			
		КонецЦикла;
...Показать Скрыть


на
Пока ЧтениеXML.Прочитать() Цикл
			
			Если ЧтениеXML.Имя = "v8u:updateList" Тогда
				Прервать;					
			Иначе		
				
				Конфигурация = ЧтениеXML.ПолучитьАтрибут("configuration");
				
				НоваяСтрока = ТаблицаЗначений.Добавить();
				НоваяСтрока.Конфигурация          = Конфигурация;			
				
				Пока ЧтениеXML.Прочитать() Цикл
					
					Если ЧтениеXML.Имя = "v8u:update" Тогда
						Прервать;					
					Иначе		
						
						Если ЧтениеXML.Имя = "v8u:vendor" Тогда
							ЧтениеXML.Прочитать();
							Поставщик = ЧтениеXML.Значение;							
							НоваяСтрока.Поставщик             = Поставщик;
						ИначеЕсли ЧтениеXML.Имя = "v8u:version" Тогда
							ЧтениеXML.Прочитать();
							Версия = ЧтениеXML.Значение;
							НоваяСтрока.Версия                = Версия;
						ИначеЕсли ЧтениеXML.Имя = "v8u:file" Тогда
							ЧтениеXML.Прочитать();
							ПутьКФайлуОбновления = ЧтениеXML.Значение;
							НоваяСтрока.ПутьКФайлуОбновления  = ПутьКФайлуОбновления;
						ИначеЕсли ЧтениеXML.Имя = "v8u:size" Тогда
							ЧтениеXML.Прочитать();
							РазмерФайлаОбновления = ЧтениеXML.Значение;
							НоваяСтрока.РазмерФайлаОбновления = РазмерФайлаОбновления;
						ИначеЕсли ЧтениеXML.Имя = "v8u:target" Тогда
							ЧтениеXML.Прочитать();
							НоваяСтрока.ВерсияДляОбновления	  = ЧтениеXML.Значение;							
						КонецЕсли;
						
						ЧтениеXML.Прочитать();
						
					КонецЕсли;
					
				КонецЦикла;
				
			КонецЕсли;
			
		КонецЦикла;
...Показать Скрыть
26. nirbolz 29.03.13 23:08
27. smaharbA (smaharbA) 29.03.13 23:21
28. nirbolz 29.03.13 23:42
29. Александр Гладких (yku) 02.04.13 20:25
Я до того обленился, что хочу теперь чтобы платформу тоже качала. А как сделать, ума не приложу. Может кто пинка даст в нужном направлении?
30. Вероника Гомзякова (Child45) 27.06.13 15:43
Подскажите, пожалуйста, как настроить рассылку на эл. почту?
31. Евгений Фамилия (internetname) 27.06.13 18:31
32. Константин Куликов (Светлый ум) 02.08.13 08:29
Хорошую работу проделал!
Главное, что теперь обновления скачиваются не с "intelav.ru", а с "downloads.1c.ru".

Щас докручу списки актуальных релизов, и установлю загрузку всего интервала релизов (сейчас грузится 1 последний актуальный) - и выложу свой вариант.
33. ddd ddd (alexsiswx) 07.08.13 10:39
О спасибо разработчику. Возьму за основу, сделаю регламентным заданием в своей конфе.
34. Shrek Shrek (Shrek2015) 07.08.13 11:21
спасибо автору. удобная штуковина
35. Вероника Гомзякова (Child45) 08.11.13 21:21
Почему не скачивается 1С;Учет в управляющих компаниях ЖКХ, ТСЖ и ЖСК 2.0.53.1?
36. nirbolz 08.11.13 23:50
не знаю, Child45. У меня доступа к этой конфе нету. Итс не подписана.
37. Александр Гладких (yku) 06.12.13 09:49
с надавнего времени у меня перестали скачиваться обновления. Пишет

{Обработка.ПроверкаОбновлений.МодульОбъекта(161)}: Ошибка при вызове метода контекста (Получить): Файл не обнаружен '/tmplts/1c/ARAutomation/1_1_41_1/1cv8.zip': Ошибка работы с Интернет:  ресурс не найден (404). <ht ml>
<head><title>404 Not Found</title></head>
<body bgcolor="white">
<center><h1>404 Not Found</h1></center>
<hr><center>nginx/1.4.4</center>
</body>
</html>
: Ошибка работы с Интернет:  ресурс не найден (404)
...Показать Скрыть


Куда копать, подскажите, пожалуйста.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа