Пакетная печать документов

Опубликовал Анатолий Ситников (acsent) в раздел Печать - Пакетная печать

Пакетная печать документов

v1.02 Поддержка БП 1.6.13

Скачать файлы

Наименование Файл Версия Размер
Пакетная печать v1.02
.1222082850 20,71Kb
13.02.13
731
.1222082850 20,71Kb 731 Скачать бесплатно

См. также

Комментарии
1. Den (Foxy) 30.10.06 15:35 Сейчас в теме
Господа....а есть ли такая-же обработка- но для версии 7.7 мне Очень срочно (точней нашей бухгалтерии) нужна она...конкретно-возможность печати документов пакетами, а именно - таких как:счет,счет фактура,акт
(желательно пономеру, в пределах даты)
заранее благодарен всем кто откликнется на мою "головную боль", т.к. я ток начинающий программист 1С..то прошу помощи у старших братьев!!
С ув. Денис!
Шлите сюда:Ichalovsky@mail.ru
3. Kandellaster (kandellaster) 30.01.07 07:20 Сейчас в теме
4. VasilyKushnir (vasilykushnir) 30.01.07 09:58 Сейчас в теме
Foxy, если не хочешь навеки остатся начинающим программистом - мой тебе дружеский совет: пиши сам. Чужие используй только как источник идей и методов "хитрого" программирования.
Пиши на мыло - скину образец для 7-ки. Но предупреждаю - писалась под себя: унификация и рядом не лежала. Подробности по мылу или ася - не хочется засорять чужие разработки не нужными комметами.
5. noname777 (noname777) 18.06.08 16:43 Сейчас в теме
А есть пакетная печать М-11 для 8.0???
6. Александр (Sedow) 24 05.10.08 21:30 Сейчас в теме
Немного запоздал но может надется время, сбросте пакетную печать для 7.7
sedowank@mail.ru
7. Наталья Семухина (NtS) 14.01.09 05:19 Сейчас в теме
в качестве пожелания - добавить пакетную печать счетов на оплату
8. 227405 (227405) 14.01.09 10:11 Сейчас в теме
Почему то выдает ошибку:
{Форма.Форма(23)}: Метод объекта не обнаружен (ПолучитьДеревоМакетовПечати)
9. Игорь Дмитрич (Igortid) 125 26.02.09 17:37 Сейчас в теме
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Объект.Ссылка, СтруктураВнутреннихПечатныхФорм);
=======================================================
Вот это поможет
10. 227405 (227405) 06.03.09 14:32 Сейчас в теме
Не помогает:
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(Объект.Ссылка, СтруктураВнутреннихПечатныхФорм);
При нажатии "Сформировать" просто ничего не присходит.
11. Владимир Тишунин (Tishu) 3 11.04.09 09:25 Сейчас в теме
Поправте в вызове НапечататьВнешнююФорму ссылку на общий модуль (надо УниверсальныеМеханизмы).
12. Рома Иванов (Romeo53) 27.01.11 12:24 Сейчас в теме
где тут ссылка на общий модуль, что исправить не понятно
-------------------
Функция НапечататьВнешнююФорму(Ссылка, ИсточникМакета) Экспорт

Перем ДополнительныеПараметры;

ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.Принадлежность[ИсточникМакета.НомерСтроки - 1].ХранилищеВнешнейОбработки.Получить();

// Получить дополнительные параметры внешней обработки
ИсточникМакета.Свойство("ДополнительныеПараметрыОбработки", ДополнительныеПараметры);

Если ДвоичныеДанные = Неопределено Тогда
ДвоичныеДанные = ИсточникМакета.СсылкаНаВнешнююОбработку.ХранилищеВнешнейОбработки.Получить();
КонецЕсли;

Если ДвоичныеДанные = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

ТабДокумент = Неопределено;

ИмяФайла = ПолучитьИмяВременногоФайла("epf");
Попытка
ДвоичныеДанные.Записать(ИмяФайла);
Обработка = ВнешниеОбработки.Создать(ИмяФайла);
Обработка.СсылкаНаОбъект = Ссылка;

// Передать внешней обработке дополнительные параметры
Если ДополнительныеПараметры <> Неопределено Тогда

// Если у внешней обработки есть реквизит для дополнительных параметров, присвоить ему значение
Если НЕ Обработка.Метаданные().Реквизиты.Найти("ДополнительныеПараметры") = Неопределено Тогда
Обработка.ДополнительныеПараметры = ДополнительныеПараметры;
КонецЕсли;

КонецЕсли;

ТабДокумент = Обработка.Печать();
УдалитьФайлы(ИмяФайла);
Исключение
ОбщегоНазначения.СообщитьОбОшибке(ОписаниеОшибки(),, "Не удалось сформировать внешнюю печатную форму!");
КонецПопытки;

Возврат ТабДокумент;

КонецФункции

------------------------------------
13. Svetlana_K (Svetlana_K) 05.10.11 15:43 Сейчас в теме
14. Alex Ivashechkin (ai000) 35 14.10.11 16:10 Сейчас в теме
Понадобилась печать одновременно нескольких печатных форм одного документа, немного переработал, выложил тут:
http://infostart.ru/public/94523/
Также добавил краткую печать реестра обработанных документов.
Версия для 8.2
15. Игорь Дмитрич (Igortid) 125 15.10.11 18:08 Сейчас в теме
16. mezonik (mezonik) 19.10.11 09:28 Сейчас в теме
без флуда теперь не обойтись, спасибо