gifts2017

Статистика по количеству данных в базе

Опубликовал Алексей Заболотнов (z-alexey) в раздел Администрирование - Статистика базы данных

Обновил. Время сборы статистики увеличено в ХХХ раз. Спасибо, anqro.

Обработка показывается информацию о количестве данных в информационной базе:
  - количество документов за период по каждому виду документа и общее;
  - количество строк в документе по каждому виду документа и общее;
  - среднее количество строк в документе;
  - можно собрать статистику только по проведенным, по не помеченным на удаление, по всем.

Если будет интересно, то добавлю статистику по справочникам :)
Чтобы прервать обработку нажимайте: Ctrl+Break (Pause)

P.S. отчет подходит для любой конфигурации 1С:Предприятие 8.0 и для 1С:Предприятие 8.1

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Версия 2.0. Для платформы 8.1
.epf 13,16Kb
19.02.13
149
.epf 13,16Kb 149 Бесплатно
Версия 1.1 Для платформы 8.0
.epf 10,51Kb
19.02.13
132
.epf 10,51Kb 132 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Maniac (Eugeneer) 23.10.06 16:56
2. Алексей Заболотнов (z-alexey) 23.10.06 17:26
Ту я смотрел как-то. Даже плюсанул :). В моей к сожалению нет статистика по пользователям. на все впереди :)
3. Роман (Unstoppable) 01.11.06 15:32
Мне понравилось! Удобно, однако....
4. angro (angro) 02.11.06 14:11
долго очень работает, просто кошмар какой-то. Зачем делать перебором ?
строчки в ТЧ можно посчитать например так
выбрать
count(*)
из
Документ.РеализацияТоваровУслуг
где проведен

видимо только начал 8-ку изучать ?
5. angro (angro) 02.11.06 14:11
6. Алексей Заболотнов (z-alexey) 02.11.06 16:53
amqro, через count(*) я так и не понял как получить количество во всех табличных частях документ. Может подскажешь?
7. angro (angro) 02.11.06 17:04
не то скопировал,
перебором по метаданным для всех ТЧ делаешь запрос

"выбрать
|count(*)
|из
|Документ.РеализацияТоваровУслуг. "+НаименованиеТЧ+"
|где проведен "
8. Алексей Заболотнов (z-alexey) 02.11.06 17:15
Это по одной табличной части. До этого дошел и сам. А одним запросом как получим количество строк в ТЧ ТОвары, Услуги, Тара?
или предлагаешь последовательно запросы на кажду табличную часть, а потом проссумировать все строки... А как тогда получить общее количество документов?
9. angro (angro) 02.11.06 17:33
да предлагаю последовательно запросы на кажду табличную часть, а количество документов
"выбрать
|count(*)
|из
|Документ.РеализацияТоваровУслуг
|где проведен"
10. angro (angro) 02.11.06 17:34
и наверное лучше будет не count(*) а count(ссылка)
11. angro (angro) 02.11.06 18:06
так примерно
Процедура ПолучитьСтатистикуПоДокументу(ВидДокумента) Экспорт

Запрос = Новый Запрос;
Запрос.Текст =
"выбрать
| count(ссылка) как всегодокументов
| из
| Документ."+ВидДокумента+"
| где проведен ";

Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() тогда
Счетчик = выборка.всегодокументов
иначе
Счетчик = 0;
КонецЕсли;


Запрос.Текст = " выбрать
| сумма(всегострок) как всегострок
| из ( ";

ТабличныеЧасти = Метаданные.Документы[ВидДокумента].ТабличныеЧасти;
естьТЧ = ложь;
Для каждого ТЧ Из ТабличныеЧасти Цикл
Запрос.Текст = Запрос.Текст +" выбрать
| count(ссылка) как всегострок
| из
| Документ."+ВидДокумента+"."+ТЧ.Имя+"
| где ссылка.проведен
| объединить все ";
естьТЧ = Истина;
КонецЦикла;

Запрос.Текст = Лев(Запрос.Текст,СтрДлина(Запрос.Текст )-15);

Запрос.Текст = Запрос.Текст +" ) как ттт ";

Если естьТЧ тогда
Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() тогда
КоличествоСтрок = выборка.всегострок
иначе
КоличествоСтрок = 0;
КонецЕсли;
иначе
КоличествоСтрок =0;
КонецЕсли;

Сообщить(Метаданные.Документы[ВидДокумента].Синоним, СтатусСообщения.Информация);
Сообщить(" Количество документов: " + Счетчик);
Сообщить(" Количество строк в документе: " + КоличествоСтрок);

СреднееКоличествоСтрок = Окр(?(Счетчик = 0, 0,КоличествоСтрок/Счетчик),2);

Сообщить(" Среднее количество строк в документе: " + СреднееКоличествоСтрок);

мОбщееКоличествоДокументов = мОбщееКоличествоДокументов + Счетчик;
мОбщееКоличествоСтрок = мОбщееКоличествоСтрок + КоличествоСтрок;

КонецПроцедуры
12. angro (angro) 02.11.06 18:07
время сбора статистики 44 секунды, в первом варианте я не дождался отключил минут через 5
13. Алексей Заболотнов (z-alexey) 02.11.06 18:19
anqro, сделал так же. что я могу - реально быстрее. Когда писал хотел одним запросом но так и не получилось. А получать несколькими запросами почему-то не допер :).

Выложу потом исправленную версию. Какой-то еще глюк вылез.
14. Алексей Заболотнов (z-alexey) 02.11.06 18:28
Выложил обновленный вариант.
15. гениталий 1с 19.02.07 19:14
= добавь справочники и статистику выводи в таблицу
= взял за основу твой код, бо надо на работе, поправлю - выложу.
16. гениталий 19.02.07 19:15
= добавь справочники и статистику выводи в таблицу
= взял за основу твой код, бо надо на работе, поправлю - выложу.
17. Klarisa (Klarisa) 07.12.08 16:58
ничего так :)
тока инфу такого плана желательно выводить в табличку, а не сообщениями
18. Станислав Турчинский (Istur) 14.04.10 17:23
(0) Вставь пожалуйста скриншоты.
19. Станислав Турчинский (Istur) 14.04.10 17:45
Пожелания: 1. выводить в табличку. 2.чтобы можно было выбирать данные за весь период, а не за ограниченный. конечно можно указать с 1990 по 2077, но это не айс.

Я бы сказал что идеал - это Статистика базы 8.1 (клиент-серверный вариант), но та обработка к сожалению тока для sql.
20. Алексей Заболотнов (z-alexey) 20.04.10 10:30
21. Алексей Заболотнов (z-alexey) 20.04.10 10:30
(19) сделал в табличку :)
и еще теперь работает на 8.1
22. евгения сон (Евгения Сон) 29.09.11 00:48
Плюсую однозначно.Выручала не раз, оч полезная штука. Побольше таких.
23. Илья (husky) 22.11.11 09:20
группировку по месяцам можно добавить?
24. Илья (husky) 22.11.11 09:22
группировку по месяцам можно добавить?
25. Виктор Гавриков (vitekryazan) 26.01.12 14:20
26. Namig Pirkuleiv (Namig) 14.02.15 13:44
Можно ли получить с справочником и с выводом в таблички для 8.0?
27. Илья (husky) 20.02.15 22:03
Конечно, надо добавить статистику по справочникам.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа