bdd2

Documents Browser

Опубликовал Андрей Скляров (coder1cv8) в раздел Обработки - Обработка документов

Универсальная форма списка документов.

Предоставляет следующие возможности:
* Выбор вида документов
* Просмотр табличных частей без открытия документов
* Просмотр не отображаемых на форме реквизитов/табличных частей
* Возможность установки отбора по любым реквизитам документа
* Установка реквизитов документа, не доступных для редактирования на форме.

Скачать файлы

Наименование Файл Версия Размер
DocumentsBrowser
.1184921315 9,36Kb
25.09.09
149
.1184921315 9,36Kb 149 Бесплатно
Documents Browser 8.1
.1190979299 9,15Kb
25.09.09
359
.1190979299 9,15Kb 359 Бесплатно

См. также

Добавить вознаграждение
Комментарии
1. Сhe Burashka (CheBurator) 20.07.07 21:37 Сейчас в теме
Ваппще! Паредлагаю суппорту все выкладываемые разработки без скриншотов отправлять в "отстойник". Люди сюда ходят (я так думаю) не для того чтобы качать 40 штук программ, а чтобы по возможности быстро и обосновано выбрать себе программу в помощь...
2. Андрей Скляров (coder1cv8) 3263 21.07.07 19:31 Сейчас в теме
Сhe Burashka: Извиняюсь. Изображение добавил. Я просто не посчитал эту обработку стоящей того, что бы писать подробное описание или добавлять скрины. Просто мне показалось удобным таким образом работать с документами и я посчитал, что возможно, это пригодиться кому-то ещё. Подчеркну, что сама по себе обработка не является, каким-то оригинальным решением или результатом длительного труда. Поэтому в свою очередь, предлагаю Суппорту удалить её совсем, если он посчитает её бесполезной.

Abadonna; +1 Ответить
3. Сhe Burashka (CheBurator) 22.07.07 23:21 Сейчас в теме
думаем об удобстве ищущих! положил обработку - не поленись описать поподробнее!!
4. Дмитрий Глух (IronDemon) 682 30.07.07 17:07 Сейчас в теме
Что-то под 8.1 табличные части пустые.
5. Андрей Скляров (coder1cv8) 3263 06.08.07 06:57 Сейчас в теме
(4) Не знаю, под 8.0 писал. Посмотрю...
6. Андрей Скляров (coder1cv8) 3263 13.08.07 16:52 Сейчас в теме
(4) В 8.1 столкнулся с таким же не понятным глюком как и в 8.0 - при смене страницы панели, исчезает табличное поле. В 8.0 удалось победить его вставив ПриОткрытии() очистку страниц панели: ЭлементыФормы.ПанельТабЧастей.Страницы.Очистить(); К сожалению, в 8.1 это не прокатывает... Буду очень признателен, если кто-то мне объяснит, в чем здесь дело?...
7. Андрей Скляров (coder1cv8) 3263 27.08.07 12:06 Сейчас в теме
Добавлена установка реквизитов для текущего документа.
8. Александр Окулов (PowerBoy) 2542 28.09.07 13:09 Сейчас в теме
(6) Это глюк 8.1 Исправляется так:
00091398 Программно создаваемые элементы управления на странице панели
Проблема:
При программном добавлении страниц в панель формы и элементов управления на новые страницы добавленные элементы управления будут невидимы, если для единственной существующей ранее в панели страницы свойство Видимость имело значение Ложь.
Способ обхода:
Сделать первую страницу панели невидимой только после добавления других страниц панели.
Дата публикации: 2007-08-31
9. Андрей Скляров (coder1cv8) 3263 28.09.07 15:38 Сейчас в теме
(8) БОЛЬШОЕ СПАСИБО!
Выложил версию для 8.1.
10. Максим Солдатов (Maxis) 30.01.08 21:56 Сейчас в теме
11. Андрей Скляров (coder1cv8) 3263 31.01.08 09:48 Сейчас в теме
12. Sergant500 (sergant500) 03.07.08 10:53 Сейчас в теме
Отлично. Печатной формы документа по реквизитам нехватает ...
13. angeliccare (angeliccare) 88 29.09.08 19:12 Сейчас в теме
В изменении реквизитов не хватило даты док.
Или - кнопкой по всем реквизитам открытой формы (после задержки т.к. приоткрытии задаёт их доступность) - проходиться и делать все доступными...
14. angeliccare (angeliccare) 88 29.09.08 19:38 Сейчас в теме
События следуют из названий процедур
Процедура КоманднаяПанельСпискаДействиеДоступность(Кнопка)
Если ФормаПоследнегоДок <> Неопределено Тогда
Если ФормаПоследнегоДок.Открыта() Тогда
Для Каждого ЭлементФормы Из ФормаПоследнегоДок.ЭлементыФормы Цикл
Попытка
ЭлементФормы.Доступность = Истина;
ЭлементФормы.ТолькоЧтение = 0;
Исключение
КонецПопытки;
КонецЦикла;
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Процедура ТабличноеПолеСписокВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
Если Элемент.ТекущиеДанные = Неопределено Тогда
Возврат;
КонецЕсли;
Если ПоследнийОткрытыйДокумент = Неопределено ИЛИ ПоследнийОткрытыйДокумент.Ссылка <> Элемент.ТекущиеДанные.Ссылка Тогда
ПоследнийОткрытыйДокумент = Элемент.ТекущиеДанные.Ссылка.ПолучитьОбъект();
ФормаПоследнегоДок = ПоследнийОткрытыйДокумент.ПолучитьФорму();
ФормаПоследнегоДок.Открыть();
СтандартнаяОбработка = 0;
КонецЕсли;
КонецПроцедуры
15. Андрей Скляров (coder1cv8) 3263 29.09.08 20:25 Сейчас в теме
(14) Спасибо! Отличная идея для редактирования значений недоступных элементов формы.
Но вообще-то "установку реквизитов" я задумывал для редактирования реквизитов для которых совсем нет элементов управления на форме.
16. Эстер Коган (e.kogan) 1814 08.12.08 14:39 Сейчас в теме
Развиваю предложенную концепцию, могу выложить. Добавлено отображение по желанию пользователя движений документа, автоматически заполняется панель списка документов, по клику на ячейке таблицы табчасти или движений открывается форма объекта, если это ссылка; планируется отображение движений как в Корректировке движений (пока простая таблица).
17. Андрей Скляров (coder1cv8) 3263 08.12.08 16:10 Сейчас в теме
(16) Выкладывай, конечно! Я ничего против не имею )
18. Эстер Коган (e.kogan) 1814 09.12.08 10:59 Сейчас в теме
Дорихтую отображение движений и выложу.
19. Yurii Trifan (Yurii463070) 28.02.09 18:11 Сейчас в теме
Прикольная обработка!!! ЗАчет :)
20. vasilijs vasiljevs (vasvas) 23.03.09 20:49 Сейчас в теме
21. Step (step_mc) 27.03.09 05:59 Сейчас в теме
Отлично.
Было бы неплохо добавить функционал просмотра свойств и категорий документов, да так чтобы документы можно было бы отбирать по значению свойства.
22. mishau У (mishau) 31.03.09 11:53 Сейчас в теме
Плюс. Жаль нету выбора нескольких видов документов, например, ПКО и РКО одновременно.
23. Виктор (victorustas) 24.07.09 16:58 Сейчас в теме
24. Андрей Мокров (AndreyKyiv07) 5 30.07.09 15:39 Сейчас в теме
Хорошая обработка.. Я, правда, искал редактор табличных частей документов.. может кто подскажет а?
25. Ярослав Тарарака (slaviksoft) 66 03.09.09 16:51 Сейчас в теме
Вещь конечно не хитрая , но шибко востребованная
спасибо
26. aga_aga (Збянтэжаны Саўка) 18.06.10 13:53 Сейчас в теме
(18) и хде оно дорихтовано :) ?
27. Эстер Коган (e.kogan) 1814 18.06.10 14:41 Сейчас в теме
(26) Решила не мелочиться - смотрите Универсальный журнал в моих разработках.
28. Андрей Краснокутский (Andry.Boris) 53 26.04.13 16:31 Сейчас в теме