gifts2017

Карточка учета материала М-17

Опубликовал Татьяна Ярокурцева (ivetta1C) в раздел Печать - Печатные формы документов

Формирование карточки учета материала (Типовая межотраслевая форма № М-17)

Скачать файлы

Наименование Файл Версия Размер
Карточка учета материала 247
.1187943333 58,50Kb
18.07.13
247
.1187943333 58,50Kb Бесплатно

См. также

Подписаться Добавить вознаграждение
Комментарии
1. solomonoff (Solomonoff) 02.04.08 10:24
Списание материалов (Передача в производство, складское перемещение) в карточку не попадает,
можно исправить например так"

Код
   Пока Ит.ПолучитьПериод() = 1 Цикл 
      Док=Ит.Операция.Документ;
      ВидДок=Док.Вид();
      Если ВидДок="ТребованиеНакладная" Тогда
         
         ДатаДок=Док.ДатаДок;
         НомерДок=Док.НомерДок;
         Цена = 0;
         
         ПорНом=ПорНом+1;
         Приход=Ит.ДО(3);
         Расход=Ит.КО(3);
         Остаток = Ит.СКД(3) - Ит.СКК(3);
         
         Если Док.ВидПеремещения = 0 Тогда 
            Контрагент = СокрЛП(Док.Субконто1.Наименование);
         Иначе
            Контрагент = СокрЛП(Док.МестоХраненияПриемник.Мол.Наименование);
            
         КонецЕсли;
         
      Иначе   
         ДатаДок=Док.ДатаДок;
         НомерДок=Док.НомерДок;
         Цена=Док.Цена;
         ПорНом=ПорНом+1;
         Приход=Ит.ДО(3);
         Расход=Ит.КО(3);
         Остаток = Ит.СКД(3) - Ит.СКК(3);
         Контрагент=СокрЛП(Док.Контрагент.Наименование);
      КонецЕсли;
      
      Если ПорНом=6+КолНаСтр Тогда
         КолНаСтр=КолНаСтр+18;
         Таб.ВывестиСекцию("СтрокаП");
         Таб.НоваяСтраница(); 
      Иначе
         Таб.ВывестиСекцию("Строка");
      КонецЕсли;
   КонецЦикла; 
Показать полностью
2. Ирина Венгловская (Iriska) 06.01.10 11:55
Доделали бы отчет. Нужная вещь, но как-то сыровато.
3. Галина Ивлева (galinka1c8) 19.02.12 16:06
спасибо, Iriska -главное основа то уже есть, можно и самим подправить.