gifts2017

Групповое проведение документов

Опубликовал Владислав Данилин (Legavaz) в раздел Администрирование - Сервисные утилиты

Проведение документов в различных режимах (установка задержки, восстановление последовательности, работа по таймеру)
Проведение документов в различных режимах (установка задержки, восстановление последовательности, работа по таймеру)

Скачать файлы

Наименование Файл Версия Размер
Групповое проведение документов(V2) 197
.1200379521 15,98Kb
25.09.09
197
.1200379521 15,98Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. cs25 (cs25) 15.01.08 09:58
После конвертации под 8.1.8.76 на УТ выдал:
{Форма.Форма(199,3)}: Процедура или функция с указанным именем не определена (ЗагрузитьВТаблицуЗначений)
<<?>>ЗагрузитьВТаблицуЗначений(ФормаОбработки.ТаблицаДанных,ТабличнаяЧастьДокументов);
hellf; about@list.ru; +2 Ответить
2. Владислав Данилин (Legavaz) 15.01.08 11:22
нужно просто дописать путь к типовой процедуре глобального модуля. она открыта поэтому правка для нужд только приветствуется!!!
3. Pavel_Lucenko (pavel_lucenko) 15.01.08 12:22
Сегодня собирался писать аналогичное, но решил покопать инет. И вот! То что надо. Ставим плюс, качаем, распаковываем. Не работает. Однако напильником тут работать и работать.
Если я не хочу по последовательности (которой у меня нет), то пробую конечно заполнить групповой обработкой. Вывело сообщение о необходимости заполнить групповую обработку и все. Смотрим код, видим что если форма обработки не открыта, тогда ... нет, не открываем, а только выводим сообщение :(. А понятно, автор не в курсе о возможностях форм "УстановитьДействие" и "ОповеститьОВыборе". Ладно, предварительно заполнив групповую обработку нажимаю "Получить из групповой обработки" и ... получаю набор строк (вне зависимости от "птичек" в исходном списке) НО с потерянными ссылками на документы. Лезем в код... канЭшно! Это работать не должно. Ну и третий вариант: загрузить из файла *.znc тоже не работоспособен, т.к. инструмент формирования такого файла не предоставлен. Вывод: очень сыро, плюсануть поторопился.
Хотя за старание и открытость автору спасибо. Теперь думаю писать "с нуля" или разбирать чужой код. Не известно что лучше :(
4. cs25 (cs25) 15.01.08 12:40
Окей ! Завелось ! Плюсуем !
5. Владислав Данилин (Legavaz) 15.01.08 14:10
Большое спасибо Павлу за критику, многое улыбнуло, кстати файл c расширением znc это не что иное как сохраненная таблица значений которая может быть сформированна моей же консолью запросов методом (Выполнить) для перечнья процедур
Интересно почему Павел не написал почему не должно работать в при передачи из группового обработке справочника, ведь не зря же ее добавил, и что интересно, я ведь этим пользуюсь поражает утверждение (Не должно работать!!!) Должно Паша обязательно должно, а если что не работает, я же оставил открытым код, и если есть ручки то надо дорабатывать.
Спасибо Паше за критику, често порадовался. Често!!!!
6. Владислав Данилин (Legavaz) 15.01.08 14:19
по поводу галочек, надо подумать, если нужно то сделаем.
7. Pavel_Lucenko (pavel_lucenko) 15.01.08 14:38
Не знаю как у Вас, а у нас в групповой обработке наименования граф с реквизитами шапки начинаются на Ш_, пришлось достать ручки и переделать:
Код
 
//ЗагрузитьВТаблицуЗначений(ФормаОбработки.ТаблицаДанных,ТабличнаяЧастьДокументов);
ТаблицаИсточник = ФормаОбработки.ТаблицаДанных;
ТаблицаПриемник = ТабличнаяЧастьДокументов;
Для каждого СтрокаТаблицыИсточника Из ТаблицаИсточник Цикл
   Если СтрокаТаблицыИсточника.Пометка Тогда
      СтрокаТаблицыПриемника = ТаблицаПриемник.Добавить();
      СтрокаТаблицыПриемника.Ссылка        = СтрокаТаблицыИсточника.Ш_Ссылка;
      СтрокаТаблицыПриемника.ДатаДокумента = СтрокаТаблицыИсточника.Ш_Дата;
      СтрокаТаблицыПриемника.Проведен      = СтрокаТаблицыИсточника.Ш_Проведен;
   КонецЕсли;
КонецЦикла;
Показать полностью

конечно это не "-" Legavaz, а скорее разработчикам моей типовой (как оказалось не совсем типовой). Так что решил "дорабатывать напильником" творение Legavaz а не писать "с нуля". За что ему еще раз отдельное спасибо.
ЗЫ. По поводу znc: "может быть сформированна моей же консолью запросов" :) а я о чем ? инструмент для формирования не приложен (хотя кое-что начинает проясняться).
8. Pavel_Lucenko (pavel_lucenko) 15.01.08 15:01
Буду тут дописывать свои исправления (может кому пригодится)
При установке ИнтрервалМеждуПроведением=0 вместо ожидаемого ускорения получаем полностью противоположный эффект (необходимость кликать "Да"). В модуле обработки исправил:
Код
 Если Не КолВремени=0 Тогда
   Если Вопрос("Продолжить выполнение действия над документом?", РежимДиалогаВопрос.ДаНет,КолВремени) = КодВозвратаДиалога.Нет Тогда
      Возврат "Остановить";
   КонецЕсли;
КонецЕсли;
Показать полностью
9. Александр Шишкин (Шёпот теней) 17.01.08 08:28
Позвольте выразить своё скромное мнение.

Что самое тяжёлое это щёлкать мышью... это серьёзно... чтобы выбрать 1 документ мне нужно совершить 5-9 действий с мышкой и клавиатурой... а если 10... а если 50... а если...?

Мне лично, тем и не нравятся, штатные отчёты в 8-ке, по сравнению с 7-ой, что только и "щёлкаешь мышью"...

Было бы проще предусмотреть множественный выбор документов и др. возможности выбора например, по периоду, реквизитам и т.д. ...

Вот... Такое мнение...
10. Владислав Данилин (Legavaz) 18.01.08 20:09
а кто мешает вам установить типы документо в типовой обработке и заполнить их в список проведения, к тому же в этом режиме происходит добавление документа, а не затирание.
если нужны все документы, то следует заполнить по последовательности.
и что самое хорошее в жизни (на все случае низя предусмотреть кнопку.)
Код открыт доработайте кто же запрещает, (хотя будет и обновление, нашел пару лишних проверок и задержек.)
8-)
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа