gifts2017

Автокопирование актов со сч-фактурами, выставление счетов за период + групповая печать

Опубликовал Виталий Глазунов (Altez) в раздел Обработки - Обработка документов

Автокопирование счетов на оплату, актов и счетов фактур за период
(для тех, у кого клиенты постоянные, напр. МКП "Горсвет")
Выставляет акты вып. работ (формирует таблицу, где можно открыжить нужные)
и вводит на их основании счета-фактуры автоматом за след.период на основании заданного,
есть групповая печать (сыровата весьма)
есть автокопирование (выставление) счетов

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Автоначисление+АвтоПечать+доп. Печ.Формы
.1204874766 110,53Kb
25.09.09
92
.1204874766 110,53Kb 92 Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Владимир Кравчук (Power Team) (krava_vlad) 03.02.08 23:36
Веждь нужная - иногда бывает нужно клиентам. Допиши, потестируй, еще сыровато...
2. AlteZ (Altez) 11.02.08 18:28
сабжем не пользуюсь, опиши, плз, каких не хватает деталей
3. Дмитрий Павлик (DimaP) 11.09.09 15:59
В модуле счета от 1С есть такой код:

Если Константа.ВсеДокументыВЖурналОпераций = Да Тогда
СуществуетОперация(1);
ЦеныВДоговоре = 1; // в рублях
Если Договор.Выбран() = 1 Тогда
Если ПустоеЗначение(Договор.ВалютаДоговора) = 0 Тогда
ЦеныВДоговоре = 2; // в валюте
КонецЕсли;
КонецЕсли;

Если ЦеныВДоговоре = 2 Тогда
Валюта = Договор.ВалютаДоговора;
Кратность = Валюта.Кратность.Получить(ДатаДок);
Курс = Валюта.Курс.Получить(ДатаДок);
Кратность = ?(Кратность=0, 1, Кратность);
Операция.СуммаОперации = Окр(Итог("Всего")*Курс/Кратность, 2, 1);
Иначе
Операция.СуммаОперации = Итог("Всего");
КонецЕсли;
Операция.Содержание = "Счет заказчику: "+Контрагент;
Иначе
СуществуетОперация(0);
КонецЕсли;

В данной обработке момент с операциями не учитывается.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа