gifts2017

"Аналоговые часы" - ActiveX-компонента для 1С

Опубликовал Василий Демидов (Душелов) в раздел Программирование - Внешние компоненты

"Аналоговые часы" - ActiveX-компонента для 1С 8.х

Небольшое "украшательство" для форм 1С.  

*** Для работы компоненты потребуется установленный Microsoft .NET Framework 2.0, который можно скачать отсюда.
http://www.microsoft.com/downloads/details.aspx?displaylang=ru&FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5

и зарегистрировать компоненту в Windows - запустить reg.bat
(для удаления информации о компоненте в Windows - запустить unreg.bat)
или использовать совместно с хранилищем внешних компонент: http://infostart.ru/projects/2863/

*** Добавление на форму 1С:

v7: Использовать 1С++:

Перем Часы;

Процедура ПослеОткрытия()
    Часы = СоздатьОбъект("АктивИкс");
    Часы.УстановитьАтрибут(Форма, "АктХ");
    //"АктХ" - идентификатор элемента диалога, на месте которого будет создан элемент ActiveX.
    //только для реквизитов диалога типа "Текст".
    Часы.СоздатьЭУ("Душелов.АналоговыеЧасы");
    Часы.УстановитьФокус();
КонецПроцедуры

Процедура АктХ_ПриАктивацииНапоминания(Время, Сообщение)
    Сообщить(Строка(Время) + ": " + Сообщение);
КонецПроцедуры

Процедура АктХ_ПриДвойномЩелчкеМышки()
    Сообщить("Двойной щелчок мышкой");
КонецПроцедуры

v8: Меню "Форма" - "Вставить ActiveX..." - Выбрать элемент "Душелов.АналоговыеЧасы"

*** Параметры

  • ЦветЧасовойСтрелки
  • ЦветМинутнойСтрелки
  • ЦветСекунднойСтрелки
  • ЦветДелений
  • Показывать1МинутныеДеления //булево
  • Показывать5МинутныеДеления //булево

*** Методы:

//ЗАПУСТИТЬ ЧАСЫ:
Старт();

//ОСТАНОВИТЬ ЧАСЫ:
Стоп();

//ДОБАВИТЬ НАПОМИНАНИЯ:
ДобавитьНапоминание(Время, Сообщение);

//УДАЛИТЬ НАПОМИНАНИЯ:
УдалитьНапоминания();

//ПОЛУЧИТЬ НАПОМИНАНИЯ
ПолучитьНапоминания(); //возвращает массив строк с напоминаниями

*** События:

  • ПриАктивацииНапоминания(Время, Сообщение)
  • ПриДвойномЩелчкеМышки()

*** ИСТОРИЯ:

20.05.2008:

- первая пробная версия

21.05.2008:

- добавлена работа с напоминаниями (будильник)
- добавлены события
- добавлено контекстное меню

Скачать файлы

Наименование Файл Версия Размер
Часы 171
.1236857681 16,82Kb
25.09.09
171
.1236857681 16,82Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Василий Демидов (Душелов) 20.05.08 17:26
Пробую себя в визуальных компонентах для 1С...
Вообщем, просто украшательно, хотя можно сделать в дальнейшем и будильник или что-то подобное...
2. zyto (zyto) 20.05.08 18:34
Забавная штука, но пока не представляю где использовать, хотя намётки есть...
+1
Душелов; +1 Ответить
3. Василий Демидов (Душелов) 20.05.08 19:40
Ну в целом можно сделать аналог ОбработкиОжидания с событиями по времени... Или что-то вроде того...
4. artem666 Bogomaz (artem666) 20.05.08 20:36
Можно сделать что то типа напоминаний на определенное время...
5. Василий Демидов (Душелов) 21.05.08 13:16
- добавлена работа с напоминаниями (будильник)
- добавлены события
- добавлено контекстное меню
6. Олег Пономаренко (O-Planet) 21.05.08 23:06
Зачем часы и напоминания, если их модно остановить кнопкой "Стоп"?
7. Василий Демидов (Душелов) 22.05.08 10:00
Зачем работать в 1С, если ее можно закрыть кнопочкой "Х" ?
8. Аркадий Кучер (Abadonna) 23.05.08 13:53
чем бы дитя не тешилось....
9. Molot (molot) 30.05.08 04:16
10. Василий Демидов (Душелов) 30.05.08 17:41
Добавил пример для 1С 7.7 (использую 1С++)
11. air777 (Air777) 21.11.08 12:25
12. arjuna (arjuna) 07.01.09 03:05
А почему может несрабатывать напоминание в 1с8???
13. Василий Демидов (Душелов) 07.01.09 03:12
События срабатывают? Двойной щелчок мышки?
14. Василий Демидов (Душелов) 13.02.09 19:37
Для получения демо-версии или покупки обращайтесь по контактам, указанным в профиле.
15. Алексей Братко (macalex) 12.03.09 14:31
16. Василий Демидов (Душелов) 12.03.09 14:37
17. Алексей Братко (macalex) 12.03.09 17:28
Приятная штуковина. Обязательно буду использовать. Спасибо. +
18. quest (quest) 19.03.09 08:50
а можно как-то для типа Дата с квалификатором время вместо существующего элемента ввода использовать этот? или это нереально?
19. Василий Демидов (Душелов) 19.03.09 09:30
В смысле стрелки крутить что ли? :)
20. Olga (Джиневра) 09.02.10 13:13
А у меня тоже в 8.0 не работает: ни напоминания не срабатывают, ни двойной щелчок...
21. dushelov (Душелов) 09.02.10 13:19
(20) Фреймворк нужно обновить со всеми сервис-паками.
22. Dima Dima (bayce) 16.03.14 01:53
На управляемых формах работать будет?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа