gifts2017

XLS2MXL

Опубликовал Дмитрий Бухалов (Re:аниматор) в раздел Обмен - Загрузка и выгрузка в Excel

Преобразование таблицы XLS в MXL

Конвертер файлов XLS в макеты MXL.

Скачать файлы

Наименование Файл Версия Размер
XLS2MXL.epf 1721
.1212626641 11,01Kb
08.01.10
1721
.1212626641 11,01Kb Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. BDE30 (Re:аниматор) 04.06.08 08:04
Выкладываю функцию по переводу цвета из десятичной системы (котррый возвращает Excel) в RGB до делать не сложно, кому если надо:

Function mColorRGB(Color10) Export

B = Цел(Color10 / 65536);
G = Цел((Color10 - B * 65536) / 256);
R = Color10 - B * 65536 - G * 256;

Return New Color(R, G, B);

EndFunction
2. Михаил (ILM) 31.07.08 10:32
Хорошая обработка, еще бы отступы из Excel можно было бы брать, вообще хорошо было бы...
3. BDE30 (Re:аниматор) 21.08.08 10:37
4. AgressiveRest (AgressiveRest) 09.09.08 19:06
5. BDE30 (Re:аниматор) 16.09.08 10:47
netserfer

я так понимаю в тебе живет злоба, помнится или ошибаюсь минусанул твой "блог", месть? хотя на обиженных х ложат =)


6. Сергѣй Батанов (baton_pk) 18.12.08 18:34
определённо плюс... осталось только совместными усилиями сделать сие творение более быстродейственным... а то перегонял я путевой лист, дык чаю попить успел :)
7. BDE30 (Re:аниматор) 13.01.09 11:44
(6) Дак и так обрабатывается только ячейки заполненные т.е. по области данных. Если сделать всю таблицу обрабатывать, ох как долго будет)
8. Владимир Пушин (vladnet) 28.01.09 09:41
блин плюс хотел поставить и кликнул не туда (((
9. Владимир Пушин (vladnet) 28.01.09 09:43
Сейчас попробую поправить...
10. Сергей (seermak) 28.01.09 10:00
11. Сергей (seermak) 28.01.09 10:01
+(10) Try
ExcelApplication = GetCOMObject(FileName); // Excel.Application
Except
DoMessageBox("Ошибка чтения файла: " + FileName + " возможно защищен паролем.");
Return;

вываливается в ошибку
12. Stopxaker Stopxaker (stopxaker) 09.02.09 15:52
Люди не бейте сильно и не пинайте , уже и автору отписал , подскажите как его юзать ??? вот открыл конфигуратор и сижу смотрю на эти два файла XLS2MXL.epf и Пример.xls , пожалуйста поясните как им воспользоваться ....

сам я работаю в компании сисадмином , то есть с Windows & Linux & FreeBSD я полностью на ты ! но блин с 1С только начинаю работать и то не по своей воле ((( замучал меня начальник " вот найди ему этот конвертор , узнай сколько стоит и полноценный ли это конвертор и как им пользоваться тд и тп "

Хоть увольняйся ... ((((( будьте добро подскажите как им пользоваться ?
у меня ОS W2k, 1С Предприятие v 8.0 и 8.1

за рание благодарен !
13. Владимир Пушин (vladnet) 09.02.09 16:12
Открывать надо в режиме предприятия, вот и все.
14. Stopxaker Stopxaker (stopxaker) 09.02.09 16:27
2 vladnet , спасибо , спасибо большое !!!!!!!!!!!!!!!!!!!!!!! и автору BDE30 и тебе vladnet , кароче всем кто откликнулся ! я наверное тут теперь часто буду бывать ! :)))))
15. Михаил Иванов (MikeI) 04.03.09 22:13
16. Михаил Иванов (MikeI) 04.03.09 22:15
А кто нибудь пробовал сделать тоже для Ворда
17. Vital prog (Vitalk) 17.03.09 18:27
Премного благодарен, очень полезная вещь оказалась)))!!!!!
18. Александр Маляев (maljaev) 21.04.09 15:20
Спасибо, помогло! С шириной столбцов и строк портачит правда.
20. Sheridan (WKBAPKA) 18.05.09 13:46
ставлю жирный плюс, лучшего в инете не видел...
22. Римма Фролова (Уфимская) 01.06.09 21:52
Лениво было искать для 7.7, поэтому конвертила в 8, потом через буфер тащила в 7 (сохранять оказысч бесполезно, у 8 и 7.7 разное понимание mxl). Маленько с размером шрифта перебарщивало при вставке, но решается банальным уменьшением оного через свойства.
Целюлю в нос автора!
23. Александр Шишкин (Шёпот теней) 24.06.09 22:28
BDE30 ... ОГРОМНОЕ спа-си-бо ... воооооооот...
24. Андрей Хван (gelion) 28.06.09 15:07
Автор, Большое спасибо! Не представляешь как на сколько сильно ты мне упростил мою работу! Ставлю "+"!
25. EvgeniuXP EvgeniuXP (EvgeniuXP) 10.07.09 23:26
Здравствуйте!
А наоборот можно сделать обработку? Нужно отчеты 1С-овские (7.7, 8.1) записывать в Excel, при этом чтобы сохранялся вертикальный текст, а также можно было устанавливать параметры страницы (отступы, содержимое колонтитулов, портрет/ландшафт). В mxl-е это всё есть, а вот сохранить в Excel - этого уже нет, только через OLE нужно делать.... а так бы внешней компонентой, было бы очень удобно.
26. Ужас бухгалтера (Ужас бухгалтера) 14.07.09 08:42
(25) http://yoksel.net.ru/HomePage
Есть все, кроме колонтитулов.
Скачивать лучше отсюда: http://yoksel.net.ru/Hotfixes

Вообще, там есть ВК для 7.7, самостоятельное приложение и COM-сервер для 8.1. Конвертирует не только mxl в xls, но и из xls в mxl (при этом поддерживает внедренные объекты: картинки и прочее). Демо-конфы для 7.7 и 8.1 смотрите там же.

Проект существует уже несколько лет - так что можете больше не изобретать велосипеды :)
27. Андрей Куканов (KukA.5) 11.09.09 11:37
Русское имя Английское имя
Если If
Тогда Then
ИначеЕсли Elsif
Иначе Else
КонецЕсли End If
Для For
Каждого Each
Из In
По To
Пока While
Цикл Do
КонецЦикла End Do
Процедура Procedure
Функция Function
КонецПроцедуры End Procedure
КонецФункции EndFunction
Перем Var
Перейти Goto
Возврат Return
Продолжить Continue
Прервать Break
И And
Или Or
Не Not
Попытка Try
Исключение Except
ВызватьИсключение Raise
КонецПопытки EndTry
Новый New
Выполнить Execute
-----
После просмотра (качественного) кода обработки вспомнил фразу: "Учите английский язык..." :(
Учить родной язык :)
28. Андрей Куканов (KukA.5) 11.09.09 11:45
Функционал работает СУПЕР! Однозначный огромный плюс!
...вот такие программисты и заставляют учить английский язык!
29. иван иванов (five_seven) 24.09.10 15:41
Большое спасибо автору.
30. mosAdm (mosAdm) 17.11.10 11:06
Спасибо. Экономит кучу времени.
31. AntiDot (kurator1C) 18.07.11 13:10
Можно в пару строчек скопировать в буфер обмена и вставить в табличный документ,
а там уже сохранять в xml, хоть в любой формат экселя
32. Наталья Павлова (Летяга) 10.09.11 23:35
Большое спасибо - отличная обработка! Как правило, все "хотелки" клиентов (в части "нужен вот такой отчет") присылаются как раз в виде Excel-файлов (раскрашенных в разные цвета и написанных разными шрифтами). Рисовать такое "чудо" в Мокселе - занятие не для слабонервных.
33. Игорь (i_konnov) 28.09.11 22:10
Спасибо большое часто пользую эту обработку
34. Сергей П (SerebanSK) 10.10.11 11:28
35. Lena G (ihthus) 13.10.11 12:12
Отличная обработка, единственный недостаток это время работы. Но наверное быстрее нельзя
36. Денис (KrakoZyabl) 03.11.11 15:31
Спасибо большущее!!!!! , уже лет 8 програмлю в 1С и не знал что сие есть, до сих пор руками перерисовывал таблички EXCEL'я из консультанта и т.д ..СПАСИБО..безусловно +++.
чингачгук; +1 Ответить
37. klen17 (klen17) 03.11.11 16:10
У меня не совсем корректно, наверное дело в пределе возможностей м-х-эля, но помогло здорово!
38. Dima (ch1mera) 15.11.11 13:41
Большое спасибо автору.
39. Олег Иванов (ogeniv) 26.12.11 18:34
Спасибо большее, существенно экономит время
40. fasdf fds (zog) 28.12.11 14:54
41. Vladimir Vladimir (VladimirVladimir) 03.08.12 10:59
Спасибо, сэкономил время, но картинки пришлось вручную добавлять. От меня плюс
42. Мария Очкина (marishka60632) 05.03.14 18:28
Огромное спасибо автору! Обработка очень помогла! Макеты теперь делаются гораздо быстрее!
Прикрепленные файлы:
43. Никита Журавлёв (LLIKIPER) 11.07.14 10:58
Огромное спасибо! выручили!
44. Данил Абдулгафаров (diso) 19.11.14 13:22
45. Сергей Любезнов (sergathome) 06.02.15 15:23
46. anna3388 (anna3388) 02.04.15 16:13
спасибо..классная штука))) тоже мучилась-рисовала...а тут - красотищааа
47. sanches (sanches) 22.06.15 15:44
Обработка полезная!
Но как использовать результат после консультанта, когда выходят сотни слепленных колонок...
48. Сергей Петров (user628834_snb2006) 24.10.16 20:11
(13) vladnet,

добрый вечер

не могу открыть все равно


что значит в режиме предприятия

помогите

целый вечер убил

результат 0(((
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа