gifts2017

Удаление помеченных объектов в 7.7

Опубликовал Саид Абушев (Абушев) в раздел Администрирование - Чистка базы

Удаление  помеченных объектов  в 7.7
Аналог стандартного удаления объектов с разницей в том, что можно и не монопольно удалять, в прочем занятная вещь. Для организаций, которые работают, а вам нужно удалить мусор, а всех выгонять из 1С проблемная ситуации, то это может пригодиться!

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
v002
.1215249771 16,13Kb
25.09.09
545
.1215249771 16,13Kb 545 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Kapitan911 Юрий (Kapitan911) 06.07.08 10:58
2. Аркадий Кучер (Abadonna) 06.07.08 11:35
А не стыдно?
http://infostart.ru/profile/4246/projects/1281/
тебе до poppy как до Луны пешком
4rtehouse; +1 Ответить
3. Аркадий Кучер (Abadonna) 06.07.08 11:43
Да еще и ВК, блин. всё там ШТАТНО запросто делается
lomok; 4rtehouse; +2 Ответить
4. Meatgrinder (4rtehouse) 07.07.08 06:12
А нет ли ВК для поиска ссылок без блокировки?
5. Абазов Вячеслав ABAZOV (abazow) 07.07.08 07:48
довольно давно пользуюсь обработкой у которой в окне написано:
"Продвинутое удаление помеченных объектов (с) Евстигнеев С.К. 2002"
вобщем могу смело утверждать что никто еще лучше не сделал. брал кажется на 1c.proclub.ru. но как давно это было... :-) а вот это... да еще за деньги... с паролем... для чайников, да?
6. Lomok (lomok) 07.07.08 07:51
7. Саид Абушев (Абушев) 07.07.08 10:26
Друзья, ну зачем же так строго, во-первых, я тут новенький, и деньги это как-то само собой получилось, т.е. случайным образом. Adadonna, прежде чем кого-то стыдить подумай за, что. Отправленная тобой ссылка не чего не значить, нет у нас с ним схожего ни чего, и я тебя уверяю это полностью моя идея и взята она из типовой конфы, так же как и им самим. Открой его код программы и мой и сверь.
Abadonna; +1 Ответить
8. Аркадий Кучер (Abadonna) 07.07.08 11:41
Если "и деньги это как-то само собой получилось, т.е. случайным образом." - беру слова обратно :)
Минус компенсирую плюсом на комментарий
9. Аркадий Кучер (Abadonna) 07.07.08 11:42
10. Саид Абушев (Абушев) 07.07.08 12:12
Ой ссори, я подумал что она
11. Лев Селиверстов (Mordens) 07.07.08 16:11
Бываю не часто...в основном открываю те разработки у которых много коментарием...и что интересно попадаю второй раз на обработку "Удаление помеченных обьектов", где так рьяно обсуждается цена...
По разработке poppy сначала читал почти все коменты...затем скачал, потестил, нашел ошибку...написал...и даже как ее поправить.

Ради интераса потестил и эту...конфа "бюджетная бухгалтерия" ...было 129 помеченных обьектов...при первом прогоне написало что нельзя удалить 29...и что странно попробовал прогнать второй раз...осталось 24 а 5 стало возможным удалить.

Не уподобляйтесь "Мелкомягким"...почему должны тестить конечные пользователи? Обкатайте , а уж потом торгуйте...
Без обид просто может день такой...
Ziggurat; lomok; +2 Ответить
12. Саид Абушев (Абушев) 07.07.08 16:45
О торге нет и речи, мною уже ранее было сказано, что эта обработка не на продажу. Скинул я ее, чтоб может народу как то помочь и чтоб они её оценили, и само собой я знаю её слабые стороны, и что она еще сырая, но я всегда рад тому, если её под нуль выведут, и определят все её слабые стороны!
13. comper (COMPER) 10.07.08 15:58
14. Ruzel (ruzelka) 30.10.08 14:21
Извите, может я что-нибудь не понимаю, но как я понял алгоритм программы следующий:
1. Сначала идет построение списка помеченых
2. Потом(после нажатия клавиши КОНТРОЛЬ) идет поиск ссылок и определение возможности удаления объектов
3. И при нажатии по клавише Удалить идет поиск ссылок на каждый объект.

Так зачем искать ссылки в пункте 3 если это выполнено в пункте 2?...
Дело в том, что если количество помеченых около 2000, то процесс оочень затягивается))

P.S. Может автор опубликует пароль обработки ))
15. Альтаир (Altair777) 30.10.08 14:30
(14) > P.S. Может автор опубликует пароль обработки ))
юзайте плагины для Тотал Коммандера или для Фара :-)
16. Саид Абушев (Абушев) 30.10.08 14:46
Дело в том что при первой проверки галочки снимаются на тех у кого есть ссылки на объект, но до того как еще не удалили можно галочки поставить вновь, ну и поэтому опять проверяются
17. Саид Абушев (Абушев) 30.10.08 14:47
А пароль я уже не помню. Я полностью изменил код и скоро выложу 3 вариант
18. Альтаир (Altair777) 30.10.08 14:50
19. Аркадий Кучер (Abadonna) 30.10.08 14:52
(17)>А пароль я уже не помню.
Да че там помнить!? ;) Восемь звездочек :)))
20. Аркадий Кучер (Abadonna) 30.10.08 14:59
Вот смотри, как красиво сделать, чтобы не заставлять пользователя лупиться на отсутствующую форму во время поиска:
Код
Процедура Сформировать()
   Форма.ОбработкаОжидания("Сформировать",0);//хлоп! только разок сработали и выключили
   НайтиПомеченныеНаУдаление(СпсУдл);
   СтатусСтрока=""; 
   Форма.Обновить(); 
   Если СпсУдл.РазмерСписка()=0 Тогда
      СтатусСтрока="Объектов, помеченных на удаление, не обнаружено!";
      Форма.Кн1.Доступность(0);                                                              
      Форма.Обновить();
      Возврат;
   КонецЕсли;   
КонецПроцедуры
      
Процедура ПриОткрытии()
   Форма.ОбработкаОжидания("Сформировать",1);  
   СтатусСтрока="Идет поиск объектов, помеченных на удаление..."; 
   Форма.Обновить();   
   Форма.ИспользоватьЗакладки(1); 
   Форма.Закладки.ДобавитьЗначение("Основная");
   Форма.Закладки.ДобавитьЗначение("Ссылки");  
   ПриВыбореЗакладки(1,"Основная"); 
КонецПроцедуры
Показать полностью
21. Саид Абушев (Абушев) 31.10.08 13:23
Спасибо, учту на будущее!!!
22. Виктория (vika64) 18.07.11 12:52
В обработке ошибки, у меня не удаляется номенклатура, т.к. ссылается на ед изм, а единица - ссылается на эту номенклатуру так не должно быть!!!! типовой - монопольно - все удаляется- а исправить я это не могу, т.к. пароль стоит.
23. Евген (evg300183) 27.09.11 13:02
А нельзя сделать чтоб и связанные документы удалялись - мне нужно свернуть базу
24. Дмитрий Русских (dimon_tb) 28.10.11 12:15
Спасибо большое! стандартная обработка работает как то медленней
25. Елена Васильева (VasilevaHelen) 07.11.11 17:02
Спасибо, даже не пришлось пользователей выгонять для установки монопольного режима.
26. MyLoginXXX 1212 (MyLoginXXX) 27.12.11 09:24
Спасибо за отсутствие монопольного доступа!
27. Ольга Доги (olgadogi) 08.01.12 16:28
жалко, что 7.7 ушла из обслуживания, в ней все было проще, без заморочек
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа