gifts2017

Проверка на ввод символов

Опубликовал Лёша Авто (Lesha1C) в раздел Программирование - Универсальные функции

Проверка на ввод символов

Вводимые символы проверяются на
- количество символов
- на англ. буквы
- на цифры

p.s.: вдруг кому пригодится...

Скачать файлы

Наименование Файл Версия Размер
- 29
.1217421357 34,50Kb
21.10.14
29
.1217421357 34,50Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Алексей Плутенко (Noy) 30.07.08 17:45
Можно проще:

Функция ЭтоБукваИнглиш(Знач Символ)
Если КодСимв(Символ)>64 Тогда
Если КодСимв(Символ)<91 Тогда
Возврат 1;
КонецЕсли;
КонецЕсли;
Возврат 0;
КонецФункции


Функция ЭтоЦифра(Знач Символ)
Если КодСимв(Символ)>47 Тогда
Если КодСимв(Символ)<58 Тогда
Возврат 1;
КонецЕсли;
КонецЕсли;
Возврат 0;
КонецФункции

А символ проверяешь так:
Если ЭтоЦифра(НашСимвол)+ЭтоБукваИнглиш(Врег(НашСимвол))=0 тогда
Сообщить("Неверный символ: "+НашСимвол);
КонецЕсли;
2. Дмитрий (Mitay) 13.08.08 11:27
а вот еще немного более быстрый вариант:

Функция ЭтоБукваИнглиш(Знач Символ)
Код = КодСимвола(Символ);
Если (Код > 64 и Код < 91) или (Код > 96 и Код < 123) Тогда
Возврат Истина;
КонецЕсли;
Возврат Ложь;
КонецФункции

Функция ЭтоБукваРус(Знач Символ)
Код = КодСимвола(Символ);
Если Код > 1039 и Код < 1104 Тогда
Возврат Истина;
КонецЕсли;
Возврат Ложь;
КонецФункции


Функция ЭтоЦифра(Знач Символ)
Код = КодСимвола(Символ);
Если Код > 47 и Код < 58 Тогда
Возврат Истина;
КонецЕсли;
Возврат Ложь;
КонецФункции


тогда и Врег при вызове не нужен
NittenRenegade; +1 Ответить