gifts2017

XML Browser

Опубликовал Алексей Семенец (sh4d0w) в раздел Администрирование - Сервисные утилиты

XML Browser для 1С
XML Browser для 1С. Позволяет просматривать XML файлы, а также редактировать значения реквизитов файла. Может, кому-то будет полезно

Скачать файлы

Наименование Файл Версия Размер
XMLBrowser 904
.1221486680 9,60Kb
25.09.09
904
.1221486680 9,60Kb Бесплатно

См. также

Подписаться Добавить вознаграждение

Комментарии

1. belegnar (belegnar) 17.09.08 10:53
Неплохо, но очень не хватает поиска.
2. nickVZ (nickVZ) 18.09.08 23:30
Хм... Есть на свете утила akXMLEdit.exe
Справляется с этим делом неплохо.
3. Pavlo (pavlo) 19.09.08 06:54
а еще бы такое же на 7.7. :(
4. Алексей Семенец (sh4d0w) 19.09.08 10:33
На 7.7 так красиво не получится. Там нет дерева значений
5. АЛьФ (АЛьФ) 19.09.08 12:35
2(4) Можно использовать, например, FormEx.
6. NoMAx (NoMax) 22.09.08 09:38
Типа XML Notepad 2007 от мелкософта не канает?
7. Алексей Семенец (sh4d0w) 22.09.08 10:43
(6, 2)
Это понятно, что утилит для работы с XML дофига, и все они канают. Просто эта обработка удобна тем, что написана на 1С. Код открыт. То есть кому чего в ней не хватает - каждый может дописать себе чего захочет
8. angeliccare (angeliccare) 26.09.08 06:25
Вместо
Запись.ОткрытьФайл(Файл, Чтение.КодировкаXML);
лучше поставить:
Запись.ОткрытьФайл(Файл, ?(ЗначениеЗаполнено(Чтение.КодировкаXML),Чтение.КодировкаXML,Чтение.КодировкаИсточника));

Не во всех XML файлах явно указана кодировка
9. Алексей Семенец (sh4d0w) 26.09.08 09:46
(8) Спасибо, поправил, файло обновил
10. Buran_ (Yasen) 01.10.08 23:51
Не работало на других локалях.
Подправил:
Код
Если ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
         НоваяСтрока = НоваяСтрока.Строки.Добавить();
         НоваяСтрока.Реквизит = Реквизит;
         НоваяСтрока.Тип = "Узел";
         Если Чтение.КоличествоАтрибутов() <> 0 Тогда
            Строки = НоваяСтрока.Строки;
            Пока Чтение.ПрочитатьАтрибут() Цикл
               Атрибут = Строки.Добавить();
               Атрибут.Реквизит = Чтение.Имя;
               Атрибут.Значение = Чтение.Значение;
               Атрибут.Тип = "Атрибут";
            КонецЦикла;
         КонецЕсли;
      ИначеЕсли ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
         НоваяСтрока = НоваяСтрока.Родитель;
      Иначе
         НоваяСтрока.Значение = Значение;
      КонецЕсли
Показать полностью
11. Алексей Семенец (sh4d0w) 02.10.08 11:14
(10) Спасибо, поправил, файло обновил
12. Иван Сидоров (itit) 26.10.11 11:56
отличная обработка, то что надо для меня
13. Андрей (andrewPt) 24.12.11 23:22
Типа XML Notepad 2007 от мелкософта не канает?
14. Модератор раздела Артур Аюханов (artbear) 19.02.12 18:34
Хорошая обработка.
Простой и удобный код.
15. Станислав Турчинский (Istur) 19.03.13 11:43
16. юрий гулидов (gull22) 22.01.15 14:01
Спасибо за обработку, конвертировал под 8.2. Тестировал на Комплексной автоматизации.
17. Гайк Аракелян (arakelyan) 21.03.16 17:24
Хорошая обработка, ставлю лайк
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа