gifts2017

ЗначениеВСтрокуВнутр(....ПолучитьФорму()) и немного СтрЗаменить

Опубликовал brix8x (brix8x) в раздел Программирование - Практика программирования

Может кто и знает этот фокус, но я был приятно удивлен.
Задача стояла такая - разобраться в структуре описания формы объекта метаданных.
Я взялся за форму списка справочника ...

строка = ЗначениеВСтрокуВнутр(Справочники.Справочник1.ПолучитьФормуСписка());
 
Около часа извращался в сдвижке скобочек "{" и "}" по уровням, чтобы было удобнее выявлять структуру.
 
А потом просто взял и написал вот такой код
Функция ЗаписатьВХМЛ2(вхСтрока)
Перем стр;
стр = "";
//{ Замена символов { и }
Для ном = 1 По СтрЧислоСтрок(вхСтрока) Цикл

тмп = СтрПолучитьСтроку(вхСтрока,ном);

Сообщить(тмп); тмп = СтрЗаменить(тмп,"{","<elem>"); тмп = СтрЗаменить(тмп,"}","</elem>"); стр = стр + тмп КонецЦикла; //} //{ Создание файла XML

Запись =Новый ЗаписьXML();
Запись.ОткрытьФайл("O:\СтруктураФормы.xml");
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьБезОбработки(стр);
	

Запись.Закрыть();
//} Возврат "";
КонецФункции

Дополнительно код и комментировать код не буду. Он прост.
И самое приятное, что созданный файл прекрасно открывается и смотрится в XML редакторе.

Удачи тем, кому интересно.

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Герман (German) 27.02.08 11:52
Я тоже вначале об этом думал... но все сделал немного проше .. просто запихал все во вложенный массив
Получить нужную структур не фокус .. куда сложнее данную структуру отредактировать. И преобразовать обратно.. в текст.

По твоему коду .. возникнет конфликт в случае "Опа а это комментарии {" Так что считай скобки """;
Так же описание типов не удастся преобразовать... {Parent,
{"S"}
не изобретай велосипед .. код я могу тебе дать .. уже проработанный в обоих направлениях
2. Герман (German) 27.02.08 11:55
хотя к xml можно и запрос прикрутить .. так что тут еще и вопрос что лучше ..

Как удалось нащупать флаги?
3. Аркадий Кучер (Abadonna) 27.02.08 13:04
А чем Dialog Stream не устроил?
4. brix8x (brix8x) 27.02.08 13:13
(2) До флагов пока не дошел, сейчас планировал утилиту, на вход которой можно закинуть ИБ, на выходе получить кучу xml-ей, и обобщенную статистику.
Код будет кстати (велосипед изобретать, действительно, будет не очень умно), только оговори, пожалуйста, условия распространения или нераспространения кода, а то у меня "по умолчанию" включен режим "отдай тому, кто попросит".

(3) Поясни, пожалуйста, термин "Dialog Stream", это из какой области (сходу не ухватил идею)?
5. Аркадий Кучер (Abadonna) 27.02.08 14:16
(4) это я не въехал сразу, что речь о 8-ке ;)
6. Герман (German) 27.02.08 14:31
по утилите все есть в пятой версии Ei данная задача решается достаточно просто..
про статистику не понял ? нафиг ..
7. Влад Косилов (kosilov) 05.03.08 02:13
Поделитесь идеями как выгрузку и загрузку в строку можно практически использовать.
Вроде бы фича, но практическое применение что-то в голову не приходит.
Одна мысль только возникает. Делал как-то управление правами через управление видимостью и доступностью любого элемента любой формы (в УПП). Так вот надо было добавить во все модули форм строчку в процедуры ПриОткрытии() и ПриЗаписи(). У УПП оказалось около 1200!!! таких модулей. Пришлось выгрузить все модули в файлы и специально написаной программой обработать. Программа отобрала нужные модули, нашла нужное место в нужных процедурах и добавила нужную строчку с уникальным для каждого модуля параметром.
Все было хорошо, но только осталась одна нерешенная проблема - там где процедур ПриОткрытии или ПриЗаписи не было, я создавал новые процедуры. Таким образом в тексте они появились, а в соответсткующих свойствах формы нет. Т.е. в свойствах всё равно пришлось прописывать руками по мере надобности.
Так вот к чему я это всё рассказывал. Если бы можно было и свойства форм выгрузить, скорректировать, а потом обработно втянуть, то ...
Но что-то похоже и это реализовать через этот механизм не ососбо удасться. Только если в файле обмена (например) между распределенками при полной выгрузке корректировать. Но синтаксис там такой же.
8. Алексей (a.v.petuhov) 05.03.08 12:08
Отстойный код. Думаю что так будет лучше:

Функция ЗаписатьВХМЛ2(ЗНАЧ вхСтрока)

вхСтрока = СтрЗаменить(вхСтрока,"{","<elem>");
вхСтрока = СтрЗаменить(вхСтрока,"}","</elem>");

Запись = Новый ЗаписьXML();
Запись.ОткрытьФайл("O:СтруктураФормы.xml");
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьБезОбработки(вхСтрока);
Запись.Закрыть();

КонецФункции
9. brix8x (brix8x) 06.03.08 09:13
(8) Приведенный ниже код, действительно, лучше. Оставив в покое блок сохранения строки в ХМЛ, можно выделить четыре возможных сценария работы со значением вхСтрока.

Варианты <elem> и запятушки
Первые два (0) и (8) малополезны. Разница только в том, что в варианте (8) мы получаем многострочный текст, а в варианте (0), текст "склеен" в одну строку. При этом с точки зрения скорости вариант (8) лучше. О результате: ХМЛ редактор покажет нам в итоге дерево <elem>, в котором в качестве значения текста будут выступать примитывные типы данных, разделенных запятыми. Как в этом случае документировать структуру описания формы неясно.

Вариант <elem> как папка <data> как файл (попытка 1)
Используя следующий код мы можем разделить каждый элемент описания метаданных в отдельный тэг.

Код
   //   Пусть каждая запятая - это признак окончания данных
   //   Пусть скобки { и } признаки папки данных
   
   //   Каждую запятую превращаем в признак конца предыдущего данного - <\data>
   //   и признак начала следующего данного <data>
   выхХМЛТело = СтрЗаменить(вхСтрока,",","</data><data>");
   
   //   Каждая начало блока превращаем в признак начала элемента
   //   и последующим началом блока данных
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"{","<elem><data>");
   
   //   Каждое завершение блока требует признака завершения блока данных
   //   и последующим завершением элемента
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"}","</data></elem>");

Показать полностью


Но при этом получается некрасивая картина в плане того, что каждый <elem> оказывается вложенным в <data> ж-)

Вариант <elem> как папка <data> как файл (окончательный вариант)
Лишь в случае, описанном ниже мы получаем то, что нужно - <elem> как папка, <data> как файл

Код
   
   //{ Получение одной длинной строки
   выхХМЛТело = СтрЗаменить(вхСтрока,СИМВОЛЫ.ПС,"");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,СИМВОЛЫ.ВК,"");
   //}
   
   //{ Замена одинарных символов
   выхХМЛТело = СтрЗаменить(выхХМЛТело,",","</data><data>");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"{","<elem><data>");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"}","</data></elem>");
   //}
   
   //{ Удаляем лишние блоки <data><elem> и </data></elem>
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"<data><elem>","<elem>");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"</elem></data>","</elem>");
   //}

Показать полностью


Теперь мы можем при желании работать с полученными элементами как с объектами файловой системы.
Частично это ответ kosilov-у о практической пользе этого знания.

НО, прошу принять во внимание, то, что в своем первом ответе подсказал German.
Данный прием не дает 100 процентного правильного результата. У меня в HRM из 900 форм, 100 оказались некорректно разобранными. И это совершенно правильно, ибо

1. На данном этапе стоит задача документировать формат описания форм, а не создать парсер.
2. Теперь мы можем создать файл XML Schemа, который и будет окончательным документом о формате описания форм.

И уже после этого. Умные головы смогут, имея на руках, описание формата создать безошибочный сборщик-разборщик.

10. brix8x (brix8x) 06.03.08 12:33
(6) Про статистику и нафига ;-) В тот момент я делал обработку, которую хотел применить как основной инструмент документирования структуры описания метаданных.
http://infostart.ru/profile/16971/projects/1745/
11. brix8x (brix8x) 10.03.08 12:28
В завершении темы предлагаю внимание код, который в ЗиуПе дал мне 100 корректное преобразование предстваления 1С в формат XML.
Код
Функция СтрокаВнутрВХМЛТело4(вхСтрока, выхХМЛТело) Экспорт
   //{ Получение одной длинной строки
   выхХМЛТело = СтрЗаменить(вхСтрока,СИМВОЛЫ.ПС,"");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,СИМВОЛЫ.ВК,"");
   //}
   
   //{ Заменяем символы, критичные для XML
   //   & на &amp;
   //   < на &lt;
   //   > на &gt;
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"&","&amp;");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"<","&lt;");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,">","&gt;");
   //}
   
   //{ Замена одинарных символов
   выхХМЛТело = СтрЗаменить(выхХМЛТело,",","</data><data>");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"{","<elem><data>");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"}","</data></elem>");
   //}
   
   //{ Удаляем лишние блоки <data><elem> и </data></elem>
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"<data><elem>","<elem>");
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"</elem></data>","</elem>");
   //}
   
   //{ Добавляем перенос строки к </data> и к </elem> для удобства поиска различий
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"</elem>","</elem>"+СИМВОЛЫ.ПС);
   выхХМЛТело = СтрЗаменить(выхХМЛТело,"</data>","</data>"+СИМВОЛЫ.ПС);
   //}
   
   Возврат "";   
КонецФункции
Показать полностью


Тестировался на ЗиУП в результате получено:
5 минут на преобразование 961 формы, все формы - корректны.

bambr1975; +1 Ответить
12. Алекс Ю (AlexO) 28.12.11 23:25
(1) а где код от Германа?
И зачем фигурные скобки в комментариях?