gifts2017

Дополнительный журнал регистрации (управляемые формы), сравнение реквизитов и табличных частей

Опубликовал Максим Кузнецов (Makushimo) в раздел Администрирование - Журнал регистрации

Дополнительный журнал регистрации (управляемые формы), сравнение реквизитов и табличных частей
Регистрирует изменения реквизитов и их табличных частей следующих типов объектов:
  1. Справочники
  2. Документы
  3. Планы видов расчета
  4. Планы видов характеристик
  5. Бизнес процессы
  6. Задачи
  7. Регистры сведений (независимые)
Форма списка журнала позволяет просмотреть все изменения в объекте в виде дерева и в отдельном окне.Ограничения:Форма отображения изменений объекта может показать максимум 4 табличные части и максимум 20 колонок в одной табличной части, кроме постоянных колонок.  Мне больше и не встречалось. Хранятся же изменения по любому количеству табличных частей и и любому количеству колонок.Для работы механизма сравнения табличных частей должен быть заполнен регистр «Ключевые колонки табличных частей», открывается по кнопке «Настройки» формы списка журнала. По умолчанию (если регистр не заполнен) система считает ключевыми колонки, у которых в свойстве «Проверка заполнения» стоит «Выдавать ошибку».Строки неограниченной длинны в табличных частях преобразует в строки ограниченной длинны (300), чтобы запрос сравнения работал. По желанию можно изменить в коде.Как устанавливать.Решение оформлено как файл конфигурации с одной подсистемой.Объединяем его со своей конфигурацией. При этом нужно снять флаги с раздела «Свойства» конфигурации и справочника «Пользователи» (предполагается, что он у вас уже есть).Всем пользователям включаем роль «ЗаписьВДополнительныйЖурналРегистрации»Решение выкладываю с открытым кодом. Буду исправлять только грубые ошибки, которые мешают адекватной работе подсистемы (пишите в каментах). Дальнейшее развитие не предполагаю ввиду сильной нехватки времени.Некоторые идеи подглядел в скриншотах других публикаций на эту тему, например: http://infostart.ru/public/18588/

Дополнено 22.03.2013

Если на ваших конфигурациях выдает ошибку, связанную с определением текущего пользователя, исправьте способ определения текущего пользователя на тот, который реализован у вас. Делать это нужно в процедуре ОбработатьСобытиеПередЗаписьюОбъекта() в строке

ТекПользователь = ОбщегоНазначения.ТекущийПользователь();

 

Исправлены ошибки:

 

Выдавал ошибку при записи набора в регистре сведений без ресурсов и реквизитов.

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
ДополнительныйЖурналРегистрации82УФ
.cf 75,82Kb
22.03.13
62
.cf 75,82Kb 62 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. WellMaster (WellMaster) 20.03.13 09:55
Изменения в журнал записываются при записи/проведении? Как это влияет на скорость работы БД?
2. Андрей А. (Amras) 20.03.13 10:04
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
Попытка передачи с клиента на сервер мутабельного значения 1-го параметра метода СделатьЗаписьВДополнительныйЖурналРегистрацииДокументПередЗа­писью ().

ЗУП 2.5.6.3 - При записи документа "Начисление зарплаты работникам организации"
3. Максим Кузнецов (Makushimo) 20.03.13 10:16
4. Максим Кузнецов (Makushimo) 20.03.13 10:17
(1) WellMaster,
предположительно незначительное, не замерял.
5. WellMaster (WellMaster) 20.03.13 11:02
Это довольно важный момент. Если производительность упадет, хорошего мало.
6. Ловыгин Антон (wunderland) 21.03.13 19:22
(1) это первый вопрос, который у меня возник, про скорость
7. Максим Кузнецов (Makushimo) 22.03.13 09:18
(2) Amras,
потестил на ЗУП 2.5.63.1 (демо) запись ведется без проблем. Возможно у вас доработанная конфа.
Подробности в студию, будем разбираться.

Кстати эта ЗУП на обычных формах, поэтому интерфейс для просмотра результатов записи в журнал не доступен.
Все сделано для управляемых форм.
8. Андрей А. (Amras) 22.03.13 10:50
Попробую описать (Документ "Прием на работу в организацию" - не проведен, делаем перезапись):

Функция ПолучитьТекстЗапросаСравненияТаблиц(Колонки)
...


При сборке запроса по:
ТекстВТ_УдаленоИзмененоСекцияГДЕ = "ГДЕ
	   |	ВТ_ТаблицаПосле.НомерСтрокиПосле ЕСТЬ NULL
	   |			ИЛИ (";

ТекстВТ_ДобавленоИзмененоСекцияГДЕ = "ГДЕ
	   |	ВТ_ТаблицаДо.НомерСтрокиДо ЕСТЬ NULL
	   |			ИЛИ (";
...Показать Скрыть


С дальнейшим соединением запроса в данном модуле:

Если Колонка.Ключевая Тогда
(всегда попадает в это место, в Иначе не попал ни разу)
...

А теперь вот эти моменты:
ТекстВТ_УдаленоИзменено = ТекстВТ_УдаленоИзмененоСекцияВыбрать+Символы.ПС+ТекстВТ_УдаленоИзмененоСекцияИЗ+ТекстВТ_УдаленоИзмененоСе­кцияГДЕ+");"+Символы.ПС;



ТекстВТ_ДобавленоИзменено = ТекстВТ_ДобавленоИзмененоСекцияВыбрать+Символы.ПС+ТекстВТ_ДобавленоИзмененоСекцияИЗ+ТекстВТ_ДобавленоИзмене­ноСекцияГДЕ+");"+Символы.ПС;


Ну и формируется примерно такой кусок в запросе:

...
ГДЕ
   ВТ_ТаблицаДо.НомерСтрокиДо ЕСТЬ NULL
	ИЛИ ();
...Показать Скрыть

...

При выполнение запроса он начинает ругаться на это неопределенное состояние ИЛИ ()

П.С.
Про управляемые формы, точно... не сообразил сразу, немного изменил правила работы для общего модуля ДополнительныйЖурналРегистрации
9. Максим Кузнецов (Makushimo) 22.03.13 11:13
(8) Amras,
описанную вами ошибку исправил
файл перезалил
10. Андрей А. (Amras) 22.03.13 14:32
(9) Makushimo,
Вот теперь все работает хорошо. Пока глубоко не копал, но показывает изменения верно. Только почему-то в разных строчках. Или это правильная логика? При более подробном рассмотрении, старое и новое отображается в двух таблицах напротив.
Прикрепленные файлы:
11. Андрей А. (Amras) 22.03.13 14:57
Решил поиграться с отпусками организаций (доработана ТЧ Сотрудники). Читаем измения более развернуто, выдается сообщение:

{РегистрСведений.ДополнительныйЖурналРегистрации.Форма.ФормаПросмотраИзмененияОбъекта.Форма(338)}: Поле объекта не обнаружено (ТабличнаяЧасть1ДоКолонка21)
Элементы["ТабличнаяЧасть"+НомерТч+"ДоКолонка"+НомерКолонки].Заголовок = ИмяКолонки;

Вероятнее всего это произошло из за наличия в ТЧ 22 колонок. А если взять типовой расчет зарплаты (Начисление зарплаты работникам организации), то там колонок и того больше (порядка 32).
12. dskull86 Алексеев (dskull86) 13.06.13 15:25
счето у меня вообще ниче не показывает, кнопки настроить нету, толи файл старый, хотя только вчера скачал
13. Максим Кузнецов (Makushimo) 14.06.13 05:37
(10) Amras,
Это логика работы такая.
Таблицы до и после сравниваются по ключевым полям.
Ключевые поля по умолчанию - это поля, обязательные для заполнения (свойство поля)
Судя по вашему скриншоту, поле "должность" и есть ключевое поле таблицы.
Вы просто поменяли должность, а журнал воспринял это как удаление текущей строки и последующее ее добавление новой строки.
Переопределить ключевые колонки для табличных частей можно по кнопке "Настройка" в форме списка журнала.
14. Максим Кузнецов (Makushimo) 14.06.13 05:42
Коллеги, обнаружил что текущая версия "Дополнительного журнала регистрации" не дружит с подсистемой БСП "Обновление версии ИБ". Когда при смене версии ИБ в конфигураторе запускаются процедуры подсистемы БСП, журнал вылетает с ошибкой при попытке зафиксировать изменения в служебных регистрах сведений.

Временное решение - заглушить выполнение обработчика подписки СделатьЗаписьВДополнительныйЖурналРегистрацииРегистрСведений­ПередЗаписью на время работы обработчиков обновления ИБ.

Над постоянным решением этой проблемы работаю. Выложу результат и новый файл по готовности.
15. Максим Кузнецов (Makushimo) 25.06.13 07:58
(14) Makushimo,
Проблема решена, журнал ругался на ресурсы и реквизиты с типом "Хранилище значения"
Решение заменить текст функции ДополнительныйЖурналРегистрации.ОпределитьКлючевыеКолонкиТабличнойЧасти на следующий текст:

Функция ОпределитьКлючевыеКолонкиТабличнойЧасти(МетаданныеОбъекта,ТабличнаяЧасть,ЕстьКлючевые,НаборЗаписей = Неопределено)//да
	
	//исключим колонки с несравнимыми типами данных, например, хранилище значения
	ИсключаемыеКолонки = Новый СписокЗначений;
	Если ТабличнаяЧасть = "НаборЗаписей" Тогда
		Для каждого Ресурс из МетаданныеОбъекта.Ресурсы Цикл
			Если Ресурс.Тип = Новый ОписаниеТипов("ХранилищеЗначения") Тогда
				ИсключаемыеКолонки.Добавить(Ресурс.Имя);
			КонецЕсли;
		КонецЦикла;
		
		Для каждого Реквизит из МетаданныеОбъекта.Реквизиты Цикл
			Если Реквизит.Тип = Новый ОписаниеТипов("ХранилищеЗначения") Тогда
				ИсключаемыеКолонки.Добавить(Реквизит.Имя);
			КонецЕсли;
		КонецЦикла;
	Иначе
		Если не МетаданныеОбъекта.Табличныечасти.Найти(ТабличнаяЧасть) = Неопределено Тогда //если такая ТЧ есть в метаданных
			Для каждого Колонка из МетаданныеОбъекта.ТабличныеЧасти[ТабличнаяЧасть].Реквизиты Цикл
				Если Колонка.Тип = Новый ОписаниеТипов("ХранилищеЗначения") Тогда
					ИсключаемыеКолонки.Добавить(Колонка.Имя);
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
	КонецЕсли;
	
	
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	               |	КлючевыеКолонкиТабличныхЧастей.ИмяКолонки,
	               |	КлючевыеКолонкиТабличныхЧастей.Ключевая КАК Ключевая
	               |ИЗ
	               |	РегистрСведений.КлючевыеКолонкиТабличныхЧастей КАК КлючевыеКолонкиТабличныхЧастей
	               |ГДЕ
	               |	КлючевыеКолонкиТабличныхЧастей.ИмяОбъектаМетаданных = &ИмяОбъектаМетаданных
	               |	И КлючевыеКолонкиТабличныхЧастей.ТабличнаяЧасть = &ТабличнаяЧасть
				   |    И КлючевыеКолонкиТабличныхЧастей.ИмяКолонки не в(&ИсключаемыеКолонки)
	               |
	               |УПОРЯДОЧИТЬ ПО
	               |	Ключевая УБЫВ";
	Запрос.УстановитьПараметр("ИмяОбъектаМетаданных",МетаданныеОбъекта.Имя);
	Запрос.УстановитьПараметр("ТабличнаяЧасть",ТабличнаяЧасть);
	Запрос.УстановитьПараметр("ИсключаемыеКолонки",ИсключаемыеКолонки);
	                                                         
	ТаблицаРезультат = Запрос.Выполнить().Выгрузить();
	
	Если ТаблицаРезультат.Количество() = 0 Тогда
		
		ТаблицаРезультат = Новый ТаблицаЗначений;
		ТаблицаРезультат.Колонки.Добавить("ИмяКолонки");
		ТаблицаРезультат.Колонки.Добавить("Ключевая",Новый ОписаниеТипов("Булево"));
		
		Если ТабличнаяЧасть = "НаборЗаписей" Тогда
			
			// все измерения регистра сведений являются ключевыми колонками
			Для каждого Измерение из МетаданныеОбъекта.Измерения Цикл
				НоваяСтрока = ТаблицаРезультат.Добавить();
				НоваяСтрока.ИмяКолонки = Измерение.Имя;
				НоваяСтрока.Ключевая = Истина;
			КонецЦикла;
					
			//Проверим на периодичность, если да, то Период тоже ключевое поле
			Если не Строка(МетаданныеОбъекта.ПериодичностьРегистраСведений) = "Непериодический" Тогда
				НоваяСтрока = ТаблицаРезультат.Добавить();
				НоваяСтрока.ИмяКолонки = "Период";
				НоваяСтрока.Ключевая = Истина;
			КонецЕсли;
			
			// получим структуру полей таблицы набора записей
			ТаблицаНабора = НаборЗаписей.Выгрузить();
			ТаблицаНабора.Очистить();
			
			// добьавим ресурсы и реквизиты в таблицу результат, они не ключевые
			Для каждого Колонка из ТаблицаНабора.Колонки Цикл
				ИмяКолонки = Колонка.Имя;
				
				//проигнорим исключаемые ресурсы и реквизиты
				Если не ИсключаемыеКолонки.НайтиПоЗначению(ИмяКолонки) = Неопределено Тогда
					Продолжить;
				КонецЕсли;
				
				Если ТаблицаРезультат.Найти(ИмяКолонки,"ИмяКолонки") = Неопределено Тогда //раньше не добавляли
					НоваяСтрока = ТаблицаРезультат.Добавить();
					НоваяСтрока.ИмяКолонки = ИмяКолонки;
					НоваяСтрока.Ключевая = Ложь;
				КонецЕсли;
			КонецЦикла;
			
			//Возврат ТаблицаРезультат;
			
		Иначе // не "НаборЗаписей"
			Если не МетаданныеОбъекта.Табличныечасти.Найти(ТабличнаяЧасть) = Неопределено Тогда //если такая ТЧ есть в метаданных
				Для каждого Колонка из МетаданныеОбъекта.ТабличныеЧасти[ТабличнаяЧасть].Реквизиты Цикл
					ИмяКолонки = Колонка.Имя;
					
					//проигнорим исключаемые колонки
					Если не ИсключаемыеКолонки.НайтиПоЗначению(ИмяКолонки) = Неопределено Тогда
						Продолжить;
					КонецЕсли;
					
					НоваяСтрока = ТаблицаРезультат.Добавить();
					НоваяСтрока.ИмяКолонки = ИмяКолонки;
					НоваяСтрока.Ключевая   = Колонка.ПроверкаЗаполнения  = ПроверкаЗаполнения.ВыдаватьОшибку;
					Если не ЕстьКлючевые Тогда
						ЕстьКлючевые = Колонка.ПроверкаЗаполнения  = ПроверкаЗаполнения.ВыдаватьОшибку;
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
			
		КонецЕсли;
	Иначе // запрос по ключевым колонкам дал результат
		Для каждого СтрокаРезультат из ТаблицаРезультат Цикл
			Если СтрокаРезультат.Ключевая Тогда //если есть хоть одна ключевая колонка, тогда все ОК
				ЕстьКлючевые = Истина ;
				Прервать;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;
	
	ТаблицаРезультат.Сортировать("Ключевая Убыв");
			
	Возврат ТаблицаРезультат;
	
КонецФункции // ОпределитьКлючевыеКолонкиТабличнойЧасти()
...Показать Скрыть
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа