gifts2017

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

Опубликовал Роман Г (Stradivari) в раздел Печать - Универсальные печатные формы

Создание внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11)

Публикация предназначена в первую очередь для тех, кто впервые сталкивается с написанием внешних печатных форм  под управляемое приложение.

Здесь будет рассмотрен один из способов создания внешней печатной формы под Управляемое Приложение (Управление Торговлей 11.1.1.11).

Во-первых, регистрация внешней обработки, отчета, печатной формы под УТ 11 отличается от регистрации таких же отчетов, печатных форм, обработок под обычное приложение.

Первое, что необходимо сделать, в модуле обработки прописать функцию СведенияОВнешнейОбработке

Функция СведенияОВнешнейОбработке() Экспорт

ПараметрыРегистрации = Новый Структура;

МассивНазначений = Новый Массив;
МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг");

ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //возможны варианты - ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов,
ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
ПараметрыРегистрации.Вставить("Наименование", "Акт приема-передачи"); //имя под kt обработка зарегистрирована будет в справочнике внешних обработок
ПараметрыРегистрации.Вставить("Версия", "1.1");
ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
ПараметрыРегистрации.Вставить("Информация", "Дополнительная печатная форма к документу РеализацияТоваровУслуг ");

//команды
ТаблицаКоманд = Новый ТаблицаЗначений;
ТаблицаКоманд.Колонки.Добавить("Представление"); //как будет выглядеть описание печ.формы для пользователя
ТаблицаКоманд.Колонки.Добавить("Идентификатор"); //имя нашего макета
ТаблицаКоманд.Колонки.Добавить("Использование"); //ВызовСерверногоМетода
ТаблицаКоманд.Колонки.Добавить("ПоказыватьОповещение"); //Истина
ТаблицаКоманд.Колонки.Добавить("Модификатор"); //ПечатьМХL

НоваяКоманда = ТаблицаКоманд.Добавить();
НоваяКоманда.Представление = "Акт приема-передачи";
НоваяКоманда.Идентификатор = "МакетАкт"; //Внешняя печатная форма
НоваяКоманда.Использование = "ВызовКлиентскогоМетода"; //здесь можно прописать использование как серверного так и клиентского, отличие в том, что серверный метод будет обращаться к экспортной процедуре из модуля объекта, клиентский - к экспортной процедуре из модуля формы объекта
НоваяКоманда.ПоказыватьОповещение = Истина;
НоваяКоманда.Модификатор = "ПечатьMXL";

ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);

Возврат
ПараметрыРегистрации;

КонецФункции


Далее, если используем вызов серверного метода, то в модуле обработки добавляем процедуру печати

Процедура Печать(МассивОбъектов, ПараметрыПечати,КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт


//здесь объект, который будет распечатан содержится в параметре МассивОбъектов, можно либо перебрать массив и распечатать каждый:

Для Каждого ТекущийДокумент Из МассивОбъектов Цикл

КонецЦикла

//либо воспользоваться запросом:

//это пример запроса, не использовать

Запрос = Новый Запрос();
Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
Запрос.Текст ="ВЫБРАТЬ
| *
|ИЗ
| Документ.РасходнаяНакладная КАК РасходнаяНакладная
|ГДЕ
| РасходнаяНакладная.Ссылка В (&МассивОбъектов)

//Или, если всегда будет распечатывать только один объект, можно прописать:

СсылкаНаОбъект = МассивОбъектов[0];

///////Далее Свой код


КонецПроцедуры


Если используется клиентский метод то создаем форму обработки и соответсвующую процедуру

&НаКлиенте
Процедура Печать(ИдентификаторКоманды,ОбъектыНазначения) Экспорт
//здесь объект, который будет распечатан содержится в параметре ОбъектыНазначения, соответственно для распечатки надо перебрать все что там содержится, можно сделать банально, если всегда печатается один объект

СсылкаНаОбъект = ОбъектыНазначения[0];

//Далее либо процедуру печати пишем здесь, при необходимости можно прописать обращение к серверной процедуре

///////Далее Свой код

КонецПроцедуры

Лично я столкнулся с такой штукой,  у меня есть печатная форма, которая использует шаблон Word, в обычном приложении труда не составит написать соответствующую процедурку, которая выгрузит шаблон в соответствующее приложение и заполнит его. В УП это должно происходить на клиенте,  соответственно я в процедуре Печать прописываю запуск нужного мне приложения, а шаблон, который хранится в макете, можно вытащить на сервере.

&НаКлиенте
Процедура Печать(ИдентификаторКоманды,ОбъектыНазначения) Экспорт

СсылкаНаОбъект = ОбъектыНазначения[0];
НазваниеФайла = ПолучитьИмяВременногоФайла("doc");
Макет = ВернутьМакет();
Макет.Записать(НазваниеФайла);
mWordObject = Новый COMObject("Word.Application");
Попытка
WordDoc = mWordObject.Documents.Add(НазваниеФайла);
Исключение

КонецПопытки;

///////Далее Свой код

КонецПроцедуры

&НаСервере
Функция ВернутьМакет()
СсылкаНаОбъект = РеквизитФормыВЗначение("Объект");
Макет = СсылкаНаОбъект.ПолучитьМакет("МакетАкт");
Возврат
Макет;
КонецФункции

В довесок выкладываю несколько внешних печатных форм, форм для заполнения ТЧ документов под управляемое приложение (УТ11.1.1.11), т.к предприятие на котором работую, специфичное, обработки содержат минимальный необходимый код.


Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
Obrabotk.rar
.rar 32,10Kb
28.03.13
483
.rar 32,10Kb 483 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Сергей Ожерельев (Поручик) 28.03.13 20:17
(0) Ничего особенного, всё уже давно описано и разжёвано.
ljubasia; +1 Ответить
2. Vladimir (C0oLZ3r0) 05.04.13 10:56
Как пример можно глянуть реализацию внешней печатной формы ТОРГ-12 под УТ 11.1 здесь: http://cheapepf.ru/goods.php?idd=1490114
Adept; Stradivari; +2 2 Ответить
3. Ловыгин Антон (wunderland) 06.04.13 11:52
а дополнительные внешние обработчики табличных частей по такой схеме можно прикрутить?
4. Роман Г (Stradivari) 08.04.13 08:38
(3) wunderland, Да, практически!
В функции СведенияОВнешнейОбработке надо вместо строки ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); написать - СведенияОбОбработке.Вставить("Вид", "ЗаполнениеОбъекта");
Ну и дальше либо вызов серверного метода, либо клиентского, в зависимости от того, что хотите делать с ТЧ.
5. Юрий Зайцев (Yury1001) 07.06.13 11:12
И тут вдруг опа и вышла 11.1.2.Х и всё отвалилось :)))
6. Андрей Волин (kser87) 11.06.13 14:00
Это не внешняя обработка для "Управляемого приложения", а внешняя обработка для БСП 2.*.

Вся информация есть на сайте ИТС http://its.1c.ru/db/bspdoc#content:22:1:

Раздел ИТС "Разработка и Администрирование",
Стандартные библиотеки
Настройка и использование подсистем при разработке конфигурации

там есть все: Виды внешних отчетов и обработок, как внедрять подсистему в свою конфигурацию, как создавать отчеты и обработки.

Если есть доступ, или диск ИТС, то можно скачать Демо конфигурацию БСП и посмотреть конкретные примеры.
7. Serge Popoff (WildFire) 24.10.13 15:18
(6) Спасибо за ссылку, ознакомился :)
Но эта публикация - для тех, кому надо по-быстрому, по-простому. Потом будет обязательно использовать УправлениеПечатью.НужноПечататьМакет и прочее, но для начала - познавательно.
8. Александр Жерздев (Al777) 06.11.13 12:54
Статья помогла, но только один момент не сработал. Почему-то так и не смог получить одиночный объект:

Ссылка = МассивОбъектов[0];

Возвращает пустое значение.
А вот перебор всего массива, то есть

Для Каждого Ссылка Из МассивОбъектов Цикл
...
КонецЦикла

сработал. Я так и не понял, почему. Причём, если назвать не Ссылка, тогда возвращается пустое значение.
serjik777; st-ty@ngs.ru; Анатолий50; WildFire; +4 Ответить
9. Анянов Михаил (insurgut) 25.12.13 08:59
А как сделать так, чтобы добавленная ПФ в списке печатных форм документов сразу отображалась, а не приходилось проваливаться в Печать -> Дополнительные печатные формы. Или это принципиальный подход такой в УТ11 (в УТ 10.3 внешнюю ПФ можно было назначить легко ПФ по умолчанию)?
10. Роман Г (Stradivari) 25.12.13 09:35
(9) insurgut, не разбирался, но так понял что это такой подход.
11. Сергей Ожерельев (Поручик) 25.12.13 10:19
(9) (10) Дождаться, когда УТ 11.1 переведут на БСП 2.1.6.19 или позднее. В БП 3.0, начиная с релиза примерно 25, внешние формы показываются вместе со штатными.
Stradivari; +1 Ответить
12. Yan (polyakovyan) 15.01.14 17:56
Столкнулся в БП 3.0 вот с чем: нашел внешную печатную форму счет-фактуры, подключил. Из документа сч/ф печатается нормально, а вот из документа "Реализация товаров и услуг" пишет что печатная форма недоступна. В функции СведенияОВнешнейОбработке()дописал в Назначении документ реализации, но ничего не выходит. На форумах везде примеры только для печати из одного документа, а как быть когда одна форма нужна в нескольких документаз?
13. Роман Г (Stradivari) 20.01.14 15:47
(12) Странно, что у вас так. У нас в УТ 11 печатная форма счет-фактуры прекрасно печатается как из "реализации" так и из "Счет-фактура выданный", помимо функции СведенияОВнешнейОбработке() еще и в окне регистрации внешней печатной формы есть возможность указать объекты назначения, там тоже выбраны и документ "Счет-Фактура" и "Реализация"....может с этим что-то связано, может особенности БП 3.0, ее к сожалению (может быть к счастью) еще не смотрел.
14. Анянов Михаил (insurgut) 04.04.14 15:10
Создал ПФ для клиентов. Сведения об обработке заполнил корректно. Создал форму. Далее не понятно, как получить ссылку на объект, для которого была вызвана ПФ.
Для формы необходимо создать параметр ОбъектыНазначения? С каким типом? На форме вывел реквизит клиент, при открытии делаю что-то вроде:
Клиент = ОбъектыНазначения[0];
Соответственно ничего не получается. Запутался. Насколько понимаю реквизит для обработки "СсылкаНаОбъект" для УФ не актуален? Потому что он при открытии формы - пустой тоже.
15. Анянов Михаил (insurgut) 05.04.14 17:05
Разобрался. Если кому интересно, в качестве примера: http://infostart.ru/public/270761/
16. Sasha User (BAE1234567) 10.05.14 01:33
17. Алексей Шарапов (Isperator) 13.05.14 10:36
Спасибо, помогла статья.
18. Ловыгин Антон (wunderland) 16.05.14 17:34
Подскажите, а можно в обработке вн. печ. формі добраться до строки табличной части, которую перед этим кликнули мышкой?
Смотрел в БСП, в форме документа есть такая проц.

&НаКлиенте
Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтаФорма, Объект);

КонецПроцедуры

То, что мне нужно, можно достать из "ЭтаФорма", но до обработки, это не передается....

Буду благодарен за любой ответ.
19. Владислав Козак (vkozak) 22.07.14 17:54
Сделал все как написано, но в бухгалтерии 3.0 не сработало. Выдает вот что.

{ОбщийМодуль.ДополнительныеОтчетыИОбработки.Модуль(233)}: В обработчике печати не был сформирован табличный документ для: ИмяИдентификатор
ВызватьИсключение(ТекстСообщенияОбОшибке);

Подскажите где ошибся!

Вот Код

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "")
	
	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = Представление; 
	НоваяКоманда.Идентификатор = Идентификатор;
	НоваяКоманда.Использование = Использование;
	НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
	НоваяКоманда.Модификатор = Модификатор;
	
КонецПроцедуры

Функция ПолучитьТаблицуКоманд()
	
	Команды = Новый ТаблицаЗначений;
	Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));//как будет выглядеть описание печ.формы для пользователя
	Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка")); //имя макета печ.формы
	Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка")); //ВызовСерверногоМетода
	Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
	Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
	Возврат Команды;
	
КонецФункции

Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = Новый Структура;
	МассивНазначений = Новый Массив;
	МассивНазначений.Добавить("Документ.РеализацияТоваровУслуг"); //Указываем документ к которому делаем внешнюю печ. форму
	ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //может быть – ПечатнаяФорма, ЗаполнениеОбъекта, ДополнительныйОтчет, СозданиеСвязанныхОбъектов… 
	ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
	ПараметрыРегистрации.Вставить("Наименование", "Наименовение"); //имя под которым обработка будет зарегестрирована в справочнике внешних обработок
	ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ);
	ПараметрыРегистрации.Вставить("Версия", "1.0"); 
	ПараметрыРегистрации.Вставить("Информация", "Это шаблон для облегчения жизни"); 
	ТаблицаКоманд = ПолучитьТаблицуКоманд();
	ДобавитьКоманду(ТаблицаКоманд, "Имя печатной формы Как будет наисанно в меню", "ИмяИдентификатор", "ВызовСерверногоМетода", Истина, "ПечатьMXL");
	ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
	
	Возврат ПараметрыРегистрации;
	
КонецФункции    // СведенияОВнешнейОбработке

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "СчетНаОплатуВРТУ", "Счет на оплату (шаблон)", СформироватьПечатнуюФорму(МассивОбъектов[0], ОбъектыПечати));
	
КонецПроцедуры // Печать()

Функция СформироватьПечатнуюФорму(СсылкаНаДокумент, ОбъектыПечати)
	ТабличныйДокумент = Новый ТабличныйДокумент;
	ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_Торг_12_ОЗК";
	
	МакетОбработки = ПолучитьМакет("Торг12_ОЗК");
	
	//заполняем шапку
	ОбластьШапка = МакетОбработки.ПолучитьОбласть("Шапка");
	ОбластьШапка.Параметры.НомерДокумента = СсылкаНаДокумент.Номер;
	ОбластьШапка.Параметры.ДатаДокумента = СсылкаНаДокумент.Дата;
	ОбластьШапка.Параметры.НазваниеОрганизации = СсылкаНаДокумент.Организация.Наименование;
	//выводим шапку в табличный документ
	ТабличныйДокумент.Вывести(ОбластьШапка);
	
	ТабличныйДокумент.АвтоМасштаб = Истина;
	ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;
	ТабличныйДокумент.ПолеСверху = 13;
	ТабличныйДокумент.ПолеСлева  = 0;
	ТабличныйДокумент.ПолеСнизу  = 0;
	ТабличныйДокумент.ПолеСправа = 0;

	ТабличныйДокумент.ВерхнийКолонтитул.Выводить          = Истина;
	ТабличныйДокумент.ВерхнийКолонтитул.НачальнаяСтраница = 2;
	ТабличныйДокумент.ВерхнийКолонтитул.ВертикальноеПоложение = ВертикальноеПоложение.Низ;
	ТабличныйДокумент.ВерхнийКолонтитул.ТекстСлева   = "ЗаголовокДляПечати";
	ТабличныйДокумент.ВерхнийКолонтитул.ТекстСправа  = "Лист [&НомерСтраницы]";
	
	Возврат ТабличныйДокумент;
	
КонецФункции
...Показать Скрыть
20. delay OO (delay) 28.07.14 14:33
21. Владислав Козак (vkozak) 06.08.14 09:56
Разобрался где ошибка: просто невнимательность.
22. Виталий Жиляев (VitRu) 28.11.14 10:50
Спасибо, статья помогла. В УП только начал писать и Ваша статья и примеры оказались очень кстати.
23. Иван Phoenix (Phoenix4565) 13.12.14 14:52
24. Александр Сидоров (sansanih) 02.03.15 23:24
Почему не выводиться макет, а открывается пуствя форма?
25. cmd_vasec (cmd_vasec) 26.03.15 10:27
(12) polyakovyan,
У меня была такая же проблема. Установил, что нет данных для печати.
Ujine1313; Manoshkin; +2 Ответить
26. Ильдар Тимганов (timgan) 17.04.15 10:21
27. Stepan Tyumentsev (st-ty@ngs.ru) 16.01.16 11:33
ссылка на объект
Док = Документы.РеализацияТоваровУслуг.ПолучитьСсылку(ОбъектыНазначения[0].УникальныйИдентификатор());
28. Дмитрий Гусев (Информаудитсервис) 11.07.16 19:25
(12) polyakovyan,
Решил данный вопрос?
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа