gifts2017

Групповое создание справок о заработке для расчета пособий

Опубликовал Денис Каминский (ubper) в раздел Обработки - Обработка документов

Обработка для группового создания и печати справок о заработке для расчета пособий в конфигурации Зарплата и Управление персоналом, ред. 2.5

В конфигурации Зарплата и Управление персоналом, ред. 2.5 есть документ Справка о заработке для расчета пособий, предназначенный для формирования справок о заработке по форме, утвержденной Приказом Минздравсоцразвития России от 17 января 2011 г. №4н. Периодически может возникает необходимость распечатать эти справки для списка сотрудников.

Данная обработка позволяет создать, заполнить, и распечатать документы Справка о заработке для расчета пособий для указанного списка сотрудников. На закладке Сотрудники указывается список сотрудников организации, для которых необходимо сформировать справки. На закладке Справки при нажатии на кнопку Создать справки создаются документы  Справка о заработке для расчета пособий для каждого сотрудника из списка. При этом, если в информационной базе уже есть документ по данному сотруднику за указанный период, то новый документ создан не будет, а в список справок попадет существующий документ из информационной базы, и пользователю будет выведено сообщение об этом.

Кроме этого, на закладке справок есть возможность с помощью кнопки Подбор справок выбрать произвольные документы справок для последующей печати.

С помощью меню Печать можно будет распечатать все справки из списка.

Скачать файлы

Наименование Файл Версия Размер
Обработка группового создания справок о заработке 51
.epf 28,73Kb
18.07.13
51
.epf 28,73Kb Скачать

См. также

Подписаться Добавить вознаграждение
Комментарии
1. Maxim Kolkin (the1) 18.07.13 16:34
Хэй, уже действует приказ N 182н!
2. Роман Хусяинов (rom-x) 26.08.13 13:03
Спасибо за обработку! N 182н форма уже есть. Не работает лишь массовая печать справок, когда на закладке справки выбрано несколько документов, печатает только первую справку, но если поправить код, то все заработает:
Процедура Печать(ИмяМакета)
	
	Для Каждого стрСправка из Справки Цикл
		ТабДокумент = Новый ТабличныйДокумент;
		ТабДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_СправкаОЗаработкеДляРасчетаПособий";
		ТабДокумент.ПолеСлева = 0;
		ТабДокумент.ПолеСправа = 0;
		
		ДокОбъект = стрСправка.Документ.ПолучитьОбъект();
		ДокСсылка = стрСправка.Документ;
		Если ИмяМакета = "Справка" Тогда
			ПечатьСправки(ИмяМакета,ТабДокумент,ДокСсылка);
		ИначеЕсли ИмяМакета = "СправкаРасширенная" Тогда
			ПечатьСправки2013(ИмяМакета,ТабДокумент,ДокСсылка);
		КонецЕсли;	
				
		ТабДокумент.ВывестиГоризонтальныйРазделительСтраниц();
		ТабДокумент.Показать("Справки о заработке для расчета пособий");
	КонецЦикла;
	
КонецПроцедуры	
...Показать Скрыть
3. Елена К (for-elenak) 29.01.14 02:46
Обработка хорошая. Очень пригодилась. Спасибо!
Правда пришлось немного подкорректировать.
Видимо автор создавал ее для старой формы. Для новой формы потребовались дополнительные данные.
Здесь не заполняется табличная часть "Дни болезни, ухода за детьми".
В процедуре СоздатьСправки() нужно заменить 2 строки НовСправка.Автозаполнение("ДанныеСтрахователя") и НовСправка.Автозаполнение("ДанныеСотрудника" на одну: НовСправка.Автозаполнение() - без параметров. Тогда заполнятся все табличные части.