gifts2017

Подготовка сведений для ПФР с распределением сумм уплаченных взносов без учета ранее переданных данных

Опубликовал Виктор Илютин (vik80111) в раздел Печать - Регламентированная отчетность

С 2013 года 1С решила полностью распределять уплаченные взносы по ранее переданным данным в ПФР. А что делать пользователям, которые не сохранили эти файлы? Сформировать их заново, загрузить их в базу и радоваться жизни, заполняя сведения в ПФР, нажатием одной кнопки. И это будет правильно!!!

С 2013 года 1С решила полностью распределять уплаченные взносы по ранее переданным данным в ПФР. А что делать пользователям, которые не сохранили эти файлы? Сформировать их заново, загрузить их в базу и радоваться жизни, заполняя сведения в ПФР, нажатием одной кнопки. И это будет правильно!!!

Эта обработка для тех, кто не может этого сделать по каким-либо причинам и у кого встретилась ситуация, когда было уплачено за прошедший и текущий период больше, чем начислено за текущий (т.к. в этом случае программа уплату поставит равной начислению). Обработка – переделанная типовая обработка из Бухгалтерия 77 (7.70.557)

Копируем скаченные файлы в папку «ExtForms» каталога базы.  Запускаем обработку «_Подготовка сведений для ПФР 2013 без учета файлов ПФР», снимаем галочку «Распределение сумм уплаченных взносов …», и далее, как обычно.

Дополнительно вставил проверку на заполнение номеров ПФР у работающих сотрудников, для исключения случаев невключения сотрудников в сведения по причине отсутствия номера ПФР.

Но еще раз утверждаю, что правильней будет пользоваться типовым механизмом распределения, для избегания дальнейшей запутки  данных!!!

Скачать файлы

Наименование Файл Версия Размер Кол. Скачив.
файл ERT
.ert 481,00Kb
14.05.13
57
.ert 481,00Kb 57 Скачать
описание EFD
.EFD 0,06Kb
14.05.13
4
.EFD 0,06Kb 4 Скачать

См. также

Подписаться Добавить вознаграждение

Комментарии

1. Елена Королева (bearcat) 26.05.13 13:43
{D:\1С7.7 \1S МШ\EXTFORMS\7.7 РАСПЕД ВЗНОСОВ.ERT(696)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПолучитьКорректирующиеОтменяющиеПачки)
<<?>>КонецЦикла;
{D:\1С7.7 \1S МШ\EXTFORMS\7.7 РАСПЕД ВЗНОСОВ.ERT (696)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПолучитьПачкиСЗВ63)
<<?>>КонецЦикла;
{D:\1С7.7 \1S МШ\EXTFORMS\7.7 РАСПЕД ВЗНОСОВ.ERT (696)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПолучитьТаблицуУплатыВзносов)
<<?>>КонецЦикла;
{D:\1С7.7 \1S МШ\EXTFORMS\7.7 РАСПЕД ВЗНОСОВ.ERT (696)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПолучитьТаблицуИсчисленоВзносов)
<<?>>КонецЦикла;
{D:\1С7.7 \1S МШ\EXTFORMS\7.7 РАСПЕД ВЗНОСОВ.ERT (696)}: Процедура или функция с указанным именем объявлена, но не определена в текущем модуле (ПолучитьКоэффициентыУплатыВзносов)

Что нужно сделать?
2. Елена Королева (bearcat) 26.05.13 13:44
нельзя ли более подробно описать действия, чтобы ваша обработка работала?
3. Виктор Илютин (vik80111) 27.05.13 11:54
Данная процедура, в которой показывает ошибку (стр. 696) (Функция ПолучитьТаблицуПринятыхДанных()) вызывается, если установлен типовой механизм распределения с учетом переданных данных.

Если при открытии это говорит, то проверь в какой конфе запускаешь (сделано для БУ 7.70.557).
Если при формировании сведений, то сними "галочку" "Распределять с учетом переданных данных". Хотя у клиентов в типовых и не очень конфах работает и с ней и без нее.
Если и это не помогает, то запусти 1С от имени администратора (в Vista, Win7, Win8), может с конфой проблемы.

Если и это не помогает, то пиши, будем разбираться!!!

А порядок простой.
Сначала пробуешь работать в 1С через Файл-Открыть.
Потом регистрируешь в дополнительных возможностях 1С.
Для написания сообщения необходимо авторизоваться
Прикрепить файл
Дополнительные параметры ответа